[solved] SSL not functioning at the moment, I'm on it.

General Announcements about Unreal Tournament and UT99.org
User avatar
Darkelarious
Skilled
Posts: 167
Joined: Sat Feb 08, 2014 12:02 pm
Location: Phobos Moon

Re: SSL not functioning at the moment, I'm on it.

Post by Darkelarious » Mon Oct 05, 2015 10:33 am

Yay, it's back!

Thanks, Shade!




Pssst, want a new certificate? https://letsencrypt.org/ is coming soon.
--Darkelarious
Image
Master Server | Discord Channel
Oh, and we still are ready to receive donations. The url works, right? It doesn't seem to be doing anything...

User avatar
Shade
Site Admin
Posts: 1426
Joined: Sun Jan 27, 2008 12:03 pm
Personal rank: Founder of UT99.org
Location: Germany

Re: SSL not functioning at the moment, I'm on it.

Post by Shade » Mon Oct 05, 2015 1:08 pm

Darkelarious wrote:Pssst, want a new certificate? https://letsencrypt.org/ is coming soon.
:mrgreen: Cool!

User avatar
papercoffee
Godlike
Posts: 9988
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.

Re: SSL not functioning at the moment, I'm on it.

Post by papercoffee » Mon Oct 05, 2015 1:26 pm

Let's celebrate!!!

:minigun1: :tele2: :tele2: :tele2: :minigun2:

Red_Fist
Godlike
Posts: 1936
Joined: Sun Oct 05, 2008 3:31 am

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by Red_Fist » Mon Oct 05, 2015 6:20 pm

Yep, is fixed. :thuup:
Binary Space Partitioning

User avatar
Dr.Flay
Godlike
Posts: 3323
Joined: Thu Aug 04, 2011 9:26 pm
Personal rank: Chaos Evangelist
Location: Kernow, UK

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by Dr.Flay » Mon Oct 05, 2015 8:38 pm

The EFF LetsEncrypt project is what I was recommending here https://www.ut99.org/viewtopic.php?t=59 ... 393#p76393
What I meant by "regular certificates" is the fact that it is automated, and should update regularly (and for free) without you needing to worry.

User avatar
Metalfist
Masterful
Posts: 627
Joined: Sun Jan 03, 2010 3:54 pm
Personal rank: ^,..,^ rawr

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by Metalfist » Wed Oct 07, 2015 2:56 pm

Yay it's back! Thanks for fixing it :)
Image

User avatar
Barbie
Godlike
Posts: 2153
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by Barbie » Tue Oct 04, 2016 1:22 am

Groundhog Year: certificate expired...
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

Red_Fist
Godlike
Posts: 1936
Joined: Sun Oct 05, 2008 3:31 am

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by Red_Fist » Tue Oct 04, 2016 4:10 am

I get complaint, just now., cookies ?
Binary Space Partitioning

User avatar
Chamberly
Godlike
Posts: 1963
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by Chamberly » Tue Oct 04, 2016 5:00 am

Firefox wouldn't let me in here unless I add exception for the expired certificate. O.o
Image
Image
Image Edit: Why does my sig not work anymore?

User avatar
EvilGrins
Godlike
Posts: 8253
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by EvilGrins » Tue Oct 04, 2016 5:44 am

I'm home (for once) and when I tried coming to this forum, and only this forum, my security settings keep going off.

I gotta keep saying I want to be here, proceeding past multiple "may not be safe" warnings.

Did somebody do something bad?
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
Wormbo
Adept
Posts: 258
Joined: Sat Aug 24, 2013 6:04 pm

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by Wormbo » Tue Oct 04, 2016 5:48 am

Nothing exceptionally bad, just an expired SSL certificate again. Somebody forgot to put a reminder into their calendar. ;)

User avatar
Shade
Site Admin
Posts: 1426
Joined: Sun Jan 27, 2008 12:03 pm
Personal rank: Founder of UT99.org
Location: Germany

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by Shade » Tue Oct 04, 2016 7:38 am

The funny thing is, I renewed it like 2 weeks ago! I will investigate.

User avatar
Dr.Flay
Godlike
Posts: 3323
Joined: Thu Aug 04, 2011 9:26 pm
Personal rank: Chaos Evangelist
Location: Kernow, UK

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by Dr.Flay » Tue Oct 04, 2016 10:49 am

As noted by Wormbo there is no need to worry.
You can safely force the use of the certificate, as it is still secure and not compromised.

Shade has had a poke around and thinks he has found the problem, but it may need for us to wait for the change.

User avatar
rjmno1
Masterful
Posts: 676
Joined: Fri Aug 12, 2011 9:38 pm
Personal rank: masterfull

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by rjmno1 » Tue Oct 04, 2016 1:16 pm

yes i,m getting a security certevicate error.

User avatar
Shade
Site Admin
Posts: 1426
Joined: Sun Jan 27, 2008 12:03 pm
Personal rank: Founder of UT99.org
Location: Germany

Re: [solved] SSL not functioning at the moment, I'm on it.

Post by Shade » Tue Oct 04, 2016 1:54 pm

Problem solved. If you still get a warning page, delete your browser history and reload the site.