default UT menu music instead of umx track?

Discussions about UT99

default UT menu music instead of umx track?

Postby gattovicentino » Wed Mar 13, 2019 11:39 pm

Hello,

many maps I play have their own .umx music file, so I suppose that if I run a multiplayer game I should hear this music track as background music...but I tried many maps and i always hear only the default UT interface/menu music. All umx files are properly in /unreal tournament/music folder. So, what's wrong?
User avatar
gattovicentino
Average
 
Posts: 55
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)

Re: default UT menu music instead of umx track?

Postby EvilGrins » Thu Mar 14, 2019 2:57 am

For instances where a particular map doesn't have a specific music file setup for it, usually you hear nothing until you open a menu... then the default music starts.

Odds are the maps you're using that're having this issue weren't setup with music.

Can you list the names of the maps you're experiencing this with?
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
User avatar
EvilGrins
Godlike
 
Posts: 6175
Joined: Thu Jun 30, 2011 8:12 pm
Location: Palo Alto, CA
Personal rank: God of Fudge

Re: default UT menu music instead of umx track?

Postby gattovicentino » Thu Mar 14, 2019 10:22 am

EvilGrins wrote:For instances where a particular map doesn't have a specific music file setup for it, usually you hear nothing until you open a menu... then the default music starts.

Odds are the maps you're using that're having this issue weren't setup with music.

Can you list the names of the maps you're experiencing this with?


For example CTF-EternalCave (its music should be Foregone.umx, as indicated by UnrealEd, but when I play I only hear the interface menu music)... or DM-(SUF)Psycho_City]EMB[ , but it happens on any map, stock and custom ones. It seems that their umx files are ignored, but they are there and are in the right folder. Whatever map I start, the background music is always the default ut menu interface music.
User avatar
gattovicentino
Average
 
Posts: 55
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)

Re: default UT menu music instead of umx track?

Postby UnrealGGecko » Thu Mar 14, 2019 10:52 am

A wild guess, but I think this might be due to the Use CD audio option in the advanced options, check if that's on.

Otherwise try reinstalling the game, maybe something got corrupted or something :?
"NHL Rock The Rink" (PS1) announcer wrote:...And there are no stunt doubles in this game, folks!

My work for UT99: Counter-Strike VP, MaleOne+ & FemaleOne+ voicepacks (NEW!), DM-XC-NaliTreeV2 (from the ut99.org Xmas Contest mappack), my small spec of files at Google Drive

List of console converted maps, models & more!
User avatar
UnrealGGecko
Site Staff
 
Posts: 2149
Joined: Wed Feb 01, 2012 11:26 am
Location: Kaunas, Lithuania
Personal rank: GEx the Gecko

Re: default UT menu music instead of umx track?

Postby gattovicentino » Thu Mar 14, 2019 12:59 pm

I discovered the cause of the problem mentioned above. It's Oldskool Amp'd . I have to disable Oldskool Amp'd into UT Menu, exit the game (back to Windows desktop), start again unrealtournament.exe and so if I start a map I can hear the right umx music. So, I don't know if it's a Oldskool issue but I can't hear the proper music of DM/CTF multiplayer maps if OldSkool is enabled.
If anyone has a suggestion to solve this issue without disabling OldSkool Amp'd... if not, I will leave OldSkool disabled when I launch multiplayer games and I'll use it only when I play singleplayer game sessions...
User avatar
gattovicentino
Average
 
Posts: 55
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)

Re: default UT menu music instead of umx track?

Postby OjitroC » Thu Mar 14, 2019 1:41 pm

gattovicentino wrote:I discovered the cause of the problem mentioned above. It's Oldskool Amp'd . I have to disable Oldskool Amp'd into UT Menu, exit the game (back to Windows desktop), start again unrealtournament.exe and so if I start a map I can hear the right umx music. So, I don't know if it's a Oldskool issue but I can't hear the proper music of DM/CTF multiplayer maps if OldSkool is enabled.
If anyone has a suggestion to solve this issue without disabling OldSkool Amp'd... if not, I will leave OldSkool disabled when I launch multiplayer games and I'll use it only when I play singleplayer game sessions...

Have a look in your OldSkool.ini for these
Spoiler: show
[olroot.oldskoolRootwindow]
Backround=olroot.utbackround
musicclass=utmenu23.utmenu23
force=True {TO FALSE}
and alter 'force'; this should solve the problem.

OR in the Oldskool menu, under the Music tab, make sure Force Music is unticked (I tested this and, for me, the music of the map plays rather than the song selected in the OldSkool menu).
User avatar
OjitroC
Godlike
 
Posts: 1052
Joined: Sat Sep 12, 2015 8:46 pm

Re: default UT menu music instead of umx track?

Postby gattovicentino » Thu Mar 14, 2019 2:27 pm

OjitroC wrote:
gattovicentino wrote:I discovered the cause of the problem mentioned above. It's Oldskool Amp'd . I have to disable Oldskool Amp'd into UT Menu, exit the game (back to Windows desktop), start again unrealtournament.exe and so if I start a map I can hear the right umx music. So, I don't know if it's a Oldskool issue but I can't hear the proper music of DM/CTF multiplayer maps if OldSkool is enabled.
If anyone has a suggestion to solve this issue without disabling OldSkool Amp'd... if not, I will leave OldSkool disabled when I launch multiplayer games and I'll use it only when I play singleplayer game sessions...

Have a look in your OldSkool.ini for these
Spoiler: show
[olroot.oldskoolRootwindow]
Backround=olroot.utbackround
musicclass=utmenu23.utmenu23
force=True {TO FALSE}
and alter 'force'; this should solve the problem.

OR in the Oldskool menu, under the Music tab, make sure Force Music is unticked (I tested this and, for me, the music of the map plays rather than the song selected in the OldSkool menu).


Fantastic!
It worked and now everything is OK.
Thank you :D
User avatar
gattovicentino
Average
 
Posts: 55
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)


Return to General Discussions

Who is online

Users browsing this forum: No registered users and 3 guests

cron