Weapon mutators issue

Discussions about UT99

Weapon mutators issue

Postby JimmyCognitti » Wed Jan 16, 2019 3:22 am

Recently, whenever I use any of the weapon mutators I have installed (Night's Edge & CSS Weapons) I notice that I cannot switch to the next weapon (nor the previous one I was using) after starting a match, I just get stuck and can only use a single weapon. For the record, the default mutators that I always use are: "XMaps, XPickUps, and UltraGore".
Any ideas?
Image
User avatar
JimmyCognitti
Experienced
 
Posts: 81
Joined: Sat Mar 29, 2014 11:48 pm

Re: Weapon mutators issue

Postby Aldebaran » Wed Jan 16, 2019 2:50 pm

I never used XMaps but can it be that it has stored some configuration you don't like? Perhaps it is using an Arena mode?
Can you choose all weapons directly with the number keys ontop of the keyboard after you have taken them, so are they really available in the game?
Aldebaran
Masterful
 
Posts: 642
Joined: Thu Jan 28, 2016 7:30 pm

Re: Weapon mutators issue

Postby OjitroC » Wed Jan 16, 2019 3:18 pm

I've tried to reproduce the issue using combinations of xPickups, NightsEdge, CSSWeapons and UltraGore but failed - everything works fine during and after using them - I can switch weapons normally (I use the mouse wheel to do that).

The only thing I can thing of is that something has altered the keys (or whatever) you use to switch weapons, so have you checked under Options -> Preferences -> Controls?
User avatar
OjitroC
Godlike
 
Posts: 1045
Joined: Sat Sep 12, 2015 8:46 pm

Re: Weapon mutators issue

Postby PrinceOfFunky » Wed Jan 16, 2019 5:04 pm

JimmyCognitti wrote:Recently, whenever I use any of the weapon mutators I have installed (Night's Edge & CSS Weapons) I notice that I cannot switch to the next weapon (nor the previous one I was using) after starting a match, I just get stuck and can only use a single weapon. For the record, the default mutators that I always use are: "XMaps, XPickUps, and UltraGore".
Any ideas?

Does it happen only if you use those mutators?
Image
User avatar
PrinceOfFunky
Godlike
 
Posts: 1005
Joined: Mon Aug 31, 2015 10:31 pm

Re: Weapon mutators issue

Postby JimmyCognitti » Wed Jan 16, 2019 6:29 pm

It only happens when I use these mutators (forgot to mention Oldskool weapon mutator, it's bugged as well).
Default weapons work perfectly, I find no issues there, it's kinda weird.
Image
User avatar
JimmyCognitti
Experienced
 
Posts: 81
Joined: Sat Mar 29, 2014 11:48 pm

Re: Weapon mutators issue

Postby OjitroC » Wed Jan 16, 2019 7:53 pm

Does it happen when you use just one of the weapons mutators by itself and no other mutators? If not, then try adding the mutators you use back in one by one and see if the issues arises (that way you can identify which mutator is causing a conflict, should that be the case).
User avatar
OjitroC
Godlike
 
Posts: 1045
Joined: Sat Sep 12, 2015 8:46 pm

Re: Weapon mutators issue

Postby JimmyCognitti » Thu Jan 17, 2019 5:00 am

OjitroC wrote:Does it happen when you use just one of the weapons mutators by itself and no other mutators? If not, then try adding the mutators you use back in one by one and see if the issues arises (that way you can identify which mutator is causing a conflict, should that be the case).


Tried what you said, tested each weapon mutator one at a time and they worked, though UltraGore effects were still active, even though the mutator had not been selected. I also noticed that OldSkool Amp'd was still buggy (it locked the game twice), perhaps this mutator is the one causing conflict, not really sure though.

EDIT:
Seems like XMaps is the one causing trouble every time I want to use any weapon mutator (it does work flawlessly with default weapons though).
Kind of a shame, it's a pretty useful addon that lets you organize and play up to 250 maps. By the way, thanks for your suggestions.
Image
User avatar
JimmyCognitti
Experienced
 
Posts: 81
Joined: Sat Mar 29, 2014 11:48 pm


Return to General Discussions

Who is online

Users browsing this forum: No registered users and 1 guest