"Unreal vs Doom" and more SinglePlayer issues

Discussions about UT99

"Unreal vs Doom" and more SinglePlayer issues

Postby gattovicentino » Wed Mar 20, 2019 5:02 pm

Hello,

here it is a list of issues I have in single player mode (UT 451b version + Oldskool Amp'd):

(1) I'm trying to run "Unreal vs Doom" mod. It doesn't appear in "map pack" list inside "new single game" menu, so I tried to start it manually, launching "UMDintro.unr" inside "custom maps" submenu, but it gives me an error, saying that the file for the packet "emitter" is missing. (all files are installed in proper folders, but, since this mod was created for Unreal Gold, I don't know if I have to do something specific to make it work in UT99).

(2) If I launch UT and immediately start some single player "custom map", as for example "13 mutants", it gives an error: "URL failed to start, file Index.unr not found" ... but if I start a mappack first (maybe Return to Napali, Shimigami, French Level or any other on the list), and THEN I start the custom map (13 mutants in this case), it starts without any problem and the "index.unr not found" error no longer appears.
So i can easily bypass this issue starting a mappack before the custom map... I'm only curious about it.

(3) In mappack list of single player campaigns there is "One Day" (by Chris Burgess). When I start it, gives this error: "object Level None.My Level not found". I tried to manually start its first map (should be "dawn.unr") but, although the map is inside Maps folder, it doesn't appear in "custom maps" of oldskool single player submenu (I yet tried to do a refresh). In this case, as for "Unreal vs Doom", I have doubts about the right installation in UT and in fact I can't make it work.

I hope someone can help me, especially for points 1 and 3. Thanks!
User avatar
gattovicentino
Average
 
Posts: 53
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby OjitroC » Thu Mar 21, 2019 12:56 am

(1) The map won't run in UT99, only in Unreal.
(3) 'One Day' runs fine for me in UT using Oldskool Amp'd - shows up in the map pack and in the custom map lists and runs fine with no errors. Dawn.unr runs OK and the next map starts up OK as well - didn't go any further. Can't really help with your problem - it's possible that Oldskool can't find the map for some reason. What happens if you start UT, press 'esc' to get rid of the menus, hit TAB and, at the prompt, type 'open dawn.unr'? It should open as a DM.
User avatar
OjitroC
Godlike
 
Posts: 1041
Joined: Sat Sep 12, 2015 8:46 pm

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby gattovicentino » Thu Mar 21, 2019 1:15 am

OjitroC wrote:(1) The map won't run in UT99, only in Unreal.
(3) 'One Day' runs fine for me in UT using Oldskool Amp'd - shows up in the map pack and in the custom map lists and runs fine with no errors. Dawn.unr runs OK and the next map starts up OK as well - didn't go any further. Can't really help with your problem - it's possible that Oldskool can't find the map for some reason.


About point (1), I imagined it would be difficult or impossible... I'd like to see that stuff in UT (I frequently play Doom/Doom II and their expansions on DoomsDay Engine) but if it won't run, I'll stop trying :)

And about point (3), could you tell me which files of "One Day" you have? And if there is, in your Oldskool configuration file, any particular line concerning One Day mappack.

Thank you
User avatar
gattovicentino
Average
 
Posts: 53
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby JackGriffin » Thu Mar 21, 2019 2:17 am

Why go to all this trouble? Just play them in Unreal.
"You damn kids, back in my time we made the items, maps and games ourselves with an unwieldy engine using counter-intuitive crash-prone tools and we liked it so much we built communities around this which nowadays look like cults because they're quasi-parallel societies based on the same old games." -Hellkeeper
User avatar
JackGriffin
Godlike
 
Posts: 3739
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: Hack coder

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby gattovicentino » Thu Mar 21, 2019 10:04 am

JackGriffin wrote:Why go to all this trouble? Just play them in Unreal.


Yes, for "Unreal vs Doom" it's the solution of course, but "One Day" should work in UT, as OjitroC confirmed, and I'd like to understand why it doesn't.
User avatar
gattovicentino
Average
 
Posts: 53
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby UnrealGGecko » Thu Mar 21, 2019 1:14 pm

For #3 you might wanna try to redownload the campaign? Either you got an older version or something's up.
https://unrealarchives.com/project-xenome-first-day/
"NHL Rock The Rink" (PS1) announcer wrote:...And there are no stunt doubles in this game, folks!

My work for UT99: Counter-Strike VP, MaleOne+ & FemaleOne+ voicepacks (NEW!), DM-XC-NaliTreeV2 (from the ut99.org Xmas Contest mappack), my small spec of files at Google Drive

List of console converted maps, models & more!
User avatar
UnrealGGecko
Site Staff
 
Posts: 2137
Joined: Wed Feb 01, 2012 11:26 am
Location: Kaunas, Lithuania
Personal rank: GEx the Gecko

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby gattovicentino » Thu Mar 21, 2019 2:54 pm

UnrealGGecko wrote:For #3 you might wanna try to redownload the campaign? Either you got an older version or something's up.
https://unrealarchives.com/project-xenome-first-day/


They are different campaigns, both of them appear in SP mappack list menu, even if actually the authors have the same surname (Jarodd Burgess and Chris Burgess... I don't know if it's the same person or relative or coincidence...).
"Project Xenome First Day" works fine, the problem is "One Day" https://unrealarchives.com/one-day/ (I yet tried both the original and the fixed one), the error launching it from Oldskool mappacks submenu is: "object Level none. My level not found"; same error if I try to manually run via console: "open dawn.unr" (dawn.unr is the first map of the campaign).
User avatar
gattovicentino
Average
 
Posts: 53
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby JackGriffin » Thu Mar 21, 2019 3:45 pm

gattovicentino wrote: I'd like to understand why it doesn't.

I respect that answer a very great deal. :tu:
"You damn kids, back in my time we made the items, maps and games ourselves with an unwieldy engine using counter-intuitive crash-prone tools and we liked it so much we built communities around this which nowadays look like cults because they're quasi-parallel societies based on the same old games." -Hellkeeper
User avatar
JackGriffin
Godlike
 
Posts: 3739
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: Hack coder

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby TheDane » Thu Mar 21, 2019 8:17 pm

JackGriffin wrote:
gattovicentino wrote: I'd like to understand why it doesn't.

I respect that answer a very great deal. :tu:


Understanding the "WHY" is a good way to learn and change things for the better - generally speaking, it's universal :tu:
Semi-Retired UT fan(atic).
User avatar
TheDane
Masterful
 
Posts: 592
Joined: Tue Feb 12, 2008 2:47 pm
Personal rank: *censored*

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby OjitroC » Thu Mar 21, 2019 8:26 pm

I have to revise my "'One Day' runs fine for me in UT using Oldskool Amp'd" comment - that was yesterday! Today I get the "object Level none. My level not found" error! 'One Day' shows up in the Oldskool Map Pack menu (with a screenshot) but trying to open it results in that error, as does starting the first map (DAWN.unr) from the console.

However, I can open it by starting UT and playing a DM, then starting DAWN.unr from the console and, once it's running, turning Oldskool Amp'd on - then it works OK. It's a mystery to me :noidea

One thing that interests me is where Oldskool Amp'd gets the information on the map pack from - is it from the first map as there is no int or u file with the map pack as there is with some of the other SP campaigns?

gattovicentino wrote: could you tell me which files of "One Day" you have? And if there is, in your Oldskool configuration file, any particular line concerning One Day mappack.

Got the maps from the same source as you so I have the same files. All the maps appear is the list of LoadedMaps (under [olroot.OldSkoolmapsClientWindow]) but don't show up in the custom map menu and the other entry in the ini is
[olroot.oldskoolnewgameclientwindow]
MutatorList=
Map=dawn
SelectedPackType=oldskool.oneday

EDIT "One thing that interests me is where Oldskool Amp'd gets the information on the map pack from" - from the Oldskool.int, along with a number of other map packs I don't have!!! :loool:
User avatar
OjitroC
Godlike
 
Posts: 1041
Joined: Sat Sep 12, 2015 8:46 pm

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby gattovicentino » Thu Mar 21, 2019 11:19 pm

OjitroC wrote:I have to revise my "'One Day' runs fine for me in UT using Oldskool Amp'd" comment - that was yesterday! Today I get the "object Level none. My level not found" error! 'One Day' shows up in the Oldskool Map Pack menu (with a screenshot) but trying to open it results in that error, as does starting the first map (DAWN.unr) from the console.


The same error here, this "object Level none. My level not found".

OjitroC wrote:One thing that interests me is where Oldskool Amp'd gets the information on the map pack from - is it from the first map as there is no int or u file with the map pack as there is with some of the other SP campaigns?

Got the maps from the same source as you so I have the same files. All the maps appear is the list of LoadedMaps (under [olroot.OldSkoolmapsClientWindow]) but don't show up in the custom map menu.

EDIT "One thing that interests me is where Oldskool Amp'd gets the information on the map pack from" - from the Oldskool.int, along with a number of other map packs I don't have!!! :loool:


Same issue too... One Day files don't show up in custom map submenu.
But I'll tell you more: I tried to open Oldskool Map Menu in one of my UT installations where One Day is not installed (none of its files). And... OIdskool shows One Day in the list, with its screenshot! So it seems to be a predefined Oldskool configuration, even if the campaign is not installed (and installing it, copying the files in Maps folder, nothing changes!). So really It's a strange issue.
User avatar
gattovicentino
Average
 
Posts: 53
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby OjitroC » Thu Mar 21, 2019 11:57 pm

gattovicentino wrote: OIdskool shows One Day in the list, with its screenshot! So it seems to be a predefined Oldskool configuration, even if the campaign is not installed (and installing it, copying the files in Maps folder, nothing changes!). So really It's a strange issue.

As I said, that's because One Day is in a list of map packs in the OldSkool.int - check out your int file and you'll see what I mean - you can safely delete any map packs you don't have (unless you might install them in future).

I had another go at trying to play One Day - Dawn didn't appear in the Oldskool custom map menu but Dusk2 did and that played OK. Odd, very odd!!
User avatar
OjitroC
Godlike
 
Posts: 1041
Joined: Sat Sep 12, 2015 8:46 pm

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby gattovicentino » Fri Mar 22, 2019 12:32 am

OjitroC wrote:I had another go at trying to play One Day - Dawn didn't appear in the Oldskool custom map menu but Dusk2 did and that played OK. Odd, very odd!!


Yes I can confirm it: dawn doesn't appear in custom maps list but dusk2 appears and plays ok...
User avatar
gattovicentino
Average
 
Posts: 53
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby OjitroC » Fri Mar 22, 2019 12:48 am

It gets odder and odder - just tried it again and DAWN does appear now in the custom maps menu - still can't start it though!! It does run though if I start a DM in UT, go to the console and type 'open dawn.unr'. This starts in UT and I then enable OldSkool Amp'd and open DAWN in the menu - this works OK and the map runs.

I did open the map in UEd and in the LevelInfo -> Screenshot I deleted NONE.
User avatar
OjitroC
Godlike
 
Posts: 1041
Joined: Sat Sep 12, 2015 8:46 pm

Re: "Unreal vs Doom" and more SinglePlayer issues

Postby gattovicentino » Fri Mar 22, 2019 1:07 am

OjitroC wrote:It gets odder and odder - just tried it again and DAWN does appear now in the custom maps menu - still can't start it though!! It does run though if I start a DM in UT, go to the console and type 'open dawn.unr'. This starts in UT and I then enable OldSkool Amp'd and open DAWN in the menu - this works OK and the map runs.

I did open the map in UEd and in the LevelInfo -> Screenshot I deleted NONE.


It's crazy and interesting at the same time... one of the strangest issues I've seen. Tomorrow I'll try to analyze it more too.
User avatar
gattovicentino
Average
 
Posts: 53
Joined: Sat Feb 16, 2019 4:07 pm
Location: Vicenza (Veneto - Italia) / Santa Catarina (Brasil)

Next

Return to General Discussions

Who is online

Users browsing this forum: No registered users and 2 guests