Terrain brush issues

Discussions about UT99
Post Reply
hee
Average
Posts: 68
Joined: Wed Jan 16, 2019 2:11 am

Terrain brush issues

Post by hee » Wed Jun 17, 2020 4:42 am

As you may have noticed, I have asked a lot of questions. I am trying to create a map (the finished product to be released and you all will be the first to know).
However, I have run into problems. My map is a little over medium size, but not huge. I am using some terrain brushes ADDED not SUBTRACTED using the idea from Rime Island.
When I try to subtract tunnels into the mountains of the terrain, errors appear on the map far from the changes. The terrain I am tunneling is 18 by 18 so I don't feel like I am stressing out the engine. Is this a common problem or am I doing something wrong?

User avatar
TexasGtar
Skilled
Posts: 210
Joined: Sun Feb 16, 2020 5:52 pm

Re: Terrain brush issues

Post by TexasGtar » Wed Jun 17, 2020 5:18 am

From my memory the terrain brush was tricky to prevent hom's. I tried to intersect only on vertices. Try not to intersect at some random point along the plane.

That seemed to work pretty good for me. How many segments do you have (sometimes too complex terrain brushes didn't work too well for me....and when you made your terrain brush ...Did you keep all the vertices on a grid point (even if the scale is 1 instead of 16. Just on a grid point somewhere?
I just tried to always keep cuts on the unreal unit grid. There are other people here who probably have better insight as to why these happen etc. It's been a while for me.

Also i think zone portals sometimes cause these. I'll let the better mappers chime in from here. I'm just trying to remember things as best i can. Best of luck to you and I'm sure the good people here will help you figure it out.

User avatar
Hellkeeper
Inhuman
Posts: 812
Joined: Tue Feb 25, 2014 12:32 pm
Personal rank: Soulless Automaton
Location: France
Contact:

Re: Terrain brush issues

Post by Hellkeeper » Wed Jun 17, 2020 12:58 pm

Could we have a screenshot or a link to download the map?
The problem you have could be caused by a number of things? Terrains are usually complex so there's a chance yours is causing this issue, but BSP holes can be caused by any brush, even normal ones in a bad place. It's impossible to diagnose the cause of your trouble.

I don't know what's your skill level but in any case, here's an explanation of what's going on:
What you have is probably a BSP Hole, a hole in your geometry caused by a combination of complex or erroneous geometry (more on that later) and the way the engine builds the map as a series of triangles. You can learn about them here (your hole would fall under the 5th category listed in the beginning).
We really need a definitive document on holes and their fixes.
You must construct additional pylons.

hee
Average
Posts: 68
Joined: Wed Jan 16, 2019 2:11 am

Re: Terrain brush issues

Post by hee » Thu Jun 18, 2020 9:00 pm

Thanks for the suggestions and links. I will try these and see how it comes out.

Post Reply