TeamDeathMatch Players not dying after warmup. *Solved*

Discussions about UT99
User avatar
Que
Adept
Posts: 376
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

TeamDeathMatch Players not dying after warmup. *Solved*

Post by Que » Sat Jan 09, 2021 4:06 am

Hi there , Iam having a problem whereby after players have clicked to start , the game starts straight away but players still have all weapons because of warmup mode. on other servers with TDM the players both Die after warmup and start with enforcers after respawning.

here is my settings;

Code: Select all

CustomGame[1]=(bUse=True,MapFolder="Maps/DM",DefaultMap="DM-Deck16][v3a",GameName="1.TeamDeathMatch+",GameClass="Botpack.TeamGamePlus",mutators="UN1e.DoubleJump,UTToolbox.CustomizePickups",Settings="MinPlayers=2,bTournament=True,bWeaponStay=False",ServerPackages="",ServerActors="<newnet>",ServerName="Gibblets.com | USA - Multi #3 | TeamDeathMatch+")
EDIT:
Solution:
setting MinPlayers=0,MaxPlayers=2 Solved the Problem.

also using nexgen hud... and cant see the green warmup flags on players in warmup mode.
Last edited by Que on Sun Jan 10, 2021 1:24 am, edited 1 time in total.
Image Image Image
*Join our Discord Here.*

User avatar
EvilGrins
Godlike
Posts: 8007
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: TeamDeathMatch Players not dying after warmup.

Post by EvilGrins » Sat Jan 09, 2021 8:02 am

I may need some clarification here, as I've played Team Deathmatch before but I don't recall any flags and I'm not sure what you mean by "warm up".
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
sektor2111
Godlike
Posts: 5340
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: TeamDeathMatch Players not dying after warmup.

Post by sektor2111 » Sat Jan 09, 2021 11:28 am

I don't get that "bTournament=True", and what is for in a Net Game environment I have never used it. As for that "WarmUp" I cannot speak more without extra information.

User avatar
asosed
Experienced
Posts: 95
Joined: Fri May 15, 2020 2:36 pm
Location: Russia

Re: TeamDeathMatch Players not dying after warmup.

Post by asosed » Sat Jan 09, 2021 12:45 pm

Que,
1. MinPlayers=2 - wrong. This implies that there will be a bot. Bot should not be in warm-up mode. I think it should be - MinPlayers=0. If the duel is designed for two players, then you need to add MaxPlayers=2.
2. I see that you are using UltimateNewNet. BWarmup=True must be in un.ini settings
Image
Image

User avatar
esnesi
Inhuman
Posts: 792
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: Dialed in.

Re: TeamDeathMatch Players not dying after warmup.

Post by esnesi » Sat Jan 09, 2021 1:01 pm

EvilGrins wrote:
Sat Jan 09, 2021 8:02 am
I may need some clarification here, as I've played Team Deathmatch before but I don't recall any flags and I'm not sure what you mean by "warm up".
You are in serious need of some online experiences bud! ;)
Que wrote:
Sat Jan 09, 2021 4:06 am
Hi there , Iam having a problem whereby after players have clicked to start
Isn't this also bound to bUseClickboard=True on the UN ini ?

User avatar
Que
Adept
Posts: 376
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

Re: TeamDeathMatch Players not dying after warmup.

Post by Que » Sun Jan 10, 2021 1:32 am

asosed wrote:
Sat Jan 09, 2021 12:45 pm
Que,
1. MinPlayers=2 - wrong. This implies that there will be a bot. Bot should not be in warm-up mode. I think it should be - MinPlayers=0. If the duel is designed for two players, then you need to add MaxPlayers=2.
2. I see that you are using UltimateNewNet. BWarmup=True must be in un.ini settings
the MaxPlayers=2 Solved the problem and the game now correctly kills players before starting the countdown timer.
Still can't get green flags to show in Warmup Mode but I can live with that.

Code: Select all

// UN.ini
bUseclickBoard=True
bwarmUp=True
Much appreciated :tu:
Image Image Image
*Join our Discord Here.*

User avatar
asosed
Experienced
Posts: 95
Joined: Fri May 15, 2020 2:36 pm
Location: Russia

Re: TeamDeathMatch Players not dying after warmup. *Solved*

Post by asosed » Sun Jan 10, 2021 10:22 am

Still can't get green flags to show in Warmup Mode but I can live with that.
If you use the classic scoreboard together with the NexGen, then there is a fix.
You do not have the required permissions to view the files attached to this post.
Image
Image