NwUltraGore Settings not having effect on server

Discussions about UT99
User avatar
Que
Adept
Posts: 376
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

NwUltraGore Settings not having effect on server

Post by Que » Wed Mar 10, 2021 1:00 am

Hi Ferali,
I have been trying to minimize the Gore Settings NWUltraGore without much success.

Code: Select all

[NWUltraGoreSSEb.NWBloodyMess_UGSSE]
enableHeadshotFX=True
enableHeadshotShake=True
enableBodyshotFX=False
enableBodyshotShake=False
enableBodyCarcassDetection=True
enableBodySkeleton=False
enableFullNetworkRelevancy=False
BloodFogLifespanMultiplier=1.000000
MaxCordIterations=3
bCordCollideWithActors=True
GoreLifeSpanMultiplier=1.000000
GorePartsMultiplier=0.010000
GoreScaleMultiplier=0.025000
enableSlideBloodDecals=True
BloodDecalsMinLifespan=0.000000
BloodDecalsMaxLifespan=0.000000
UseClientGoreMultSettings=False
UseClientGoreDecalSettings=False
WaterSplashDetail=3
enableBodyshotFX=False
enableBodyshotShake=False
enableBodyCarcassDetection=True
enableBodySkeleton=False

here I have tried to disable all gore except for HeadShots... but still the fullgore and skeleton remains.
I reduced the GorePartsMultiplier and other settings to fractions of what their presets were and nothing seems to change.

what Iam trying to achieve is a somewhat minimal GORE enhancement (not too Bloody) but still bloody to some degree.

seems no matter what settings I use , the mutator ignores them and gives me the default gore levels.
Image Image Image
*Join our Discord Here.*

User avatar
Feralidragon
Godlike
Posts: 5307
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: NwUltraGore Settings not having effect on server

Post by Feralidragon » Wed Mar 10, 2021 2:38 am

Just checked the source code (since at this point that's the only way I will be able to answer any questions about my mods :lol2: ).

For the body FX, you should also set enableBodyCarcassDetection=False, given that in some cases when a player dies it immediately spawns a "carcass" which is a complete intact copy of the player but as a corpse, and if you use a Flak Cannon, for example, which one of its fire modes is pretty much a shotgun, then the first projectile to hit may kill the player, make it spawn this intact carcass (since one small projectile is usually not enough to "gib"), and then the other projectiles may hit the carcass right afterwards, accumulating enough damage to gib the carcass (instead of the player) in a similar fashion as the body gibing.

Having that said, as for the rest of the settings, they should work without issues, being something I remember testing at length at the time.
That is... as long as they are being changed in the right context: many of those settings are server-side only, others are client-side only, and some are mixed (with other settings to decide whether to use server or client settings).

So my first question(s) to you is: what is the context exactly here? Are you trying to set up a server with this and changing these settings in the server? Or are you changing them locally and playing against bots?

If you're doing the former, I would suggest you to first try the latter: install the mod on your side, tweak it like you want, and test against bots in a practice session to see if your changes are working.
This is meant to rule out a bunch of basic problems first, to narrow down what the problem could be.

I could give it a go and test it on a server environment myself to test your changes (if that's you're trying to do), but I will only be able to do that over the weekend.

User avatar
Que
Adept
Posts: 376
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

Re: NwUltraGore Settings not having effect on server

Post by Que » Wed Mar 10, 2021 5:06 am

Ferali wrote: So my first question(s) to you is: what is the context exactly here? Are you trying to set up a server with this and changing these settings in the server? Or are you changing them locally and playing against bots?
ServerSide please.

i see the ini is both client/server settings as detailed above.
here is my serverside config.
Image

here is my .ini attached.
You do not have the required permissions to view the files attached to this post.
Last edited by Que on Wed Mar 10, 2021 5:22 am, edited 1 time in total.
Image Image Image
*Join our Discord Here.*

User avatar
sektor2111
Godlike
Posts: 5340
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: NwUltraGore Settings not having effect on server

Post by sektor2111 » Wed Mar 10, 2021 5:10 am

Like I said already in forum this MOD needs another INI file and NOT what is provided with Mod.
viewtopic.php?f=34&t=4844&p=112693
Either way here
viewtopic.php?f=34&t=4844&start=165#p112690

Mod also will save the right INI file IF INT file is completed, exactly from preferences menu by UT itself.

Code: Select all

[Public]
Object=(Name=NWUltraGoreSSEb.NWBloodyMess_UGSSE,Class=Class,MetaClass=Engine.Mutator,Description="NW3 SSE - Ultra Gore,Nali Weapons 3 Ultra Gore Special Standalone Edition")
Preferences=(Caption="Mutators",Parent="Advanced Options")
Preferences=(Caption="NWUltraGoreSSE",Parent="Mutators",Class=NWUltraGoreSSEb.NWBloodyMess_UGSSE,Immediate=True)
Object=(Name=NWUltraGoreSSEb.NWMainModMenuItem_UGSSE,Class=Class,MetaClass=UMenu.UMenuModMenuItem)
Object=(Name=NWUltraGoreSSEb.NWClientGoreSettingsMenuPageInfo_UGSSE,Class=Class,MetaClass=NWUltraGoreSSEb.NWMenuPageInfo_UGSSE)
Object=(Name=NWUltraGoreSSEb.NWServerGoreSettingsMenuPageInfo_UGSSE,Class=Class,MetaClass=NWUltraGoreSSEb.NWMenuPageInfo_UGSSE)
Said file it's called NWConfig.ini and not NWUltraGoreSSE.ini.

User avatar
Que
Adept
Posts: 376
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

Re: NwUltraGore Settings not having effect on server

Post by Que » Wed Mar 10, 2021 5:40 am

Iam running NWUltraGoreSSEb I looked in NWConfig.ini but the relevant class for the mod was not in there.
this is from NWUltraGoreSSE.ini;

Code: Select all

[NWUltraGoreSSEb.NWBloodyMess_UGSSE]
Image Image Image
*Join our Discord Here.*

User avatar
sektor2111
Godlike
Posts: 5340
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: NwUltraGore Settings not having effect on server

Post by sektor2111 » Wed Mar 10, 2021 6:11 am

Of course it's not there, it has to be copied or letting UT to generate section from Preferences. I got a functional INI file using that way, working guaranteed.

Off-topic
I needed access at this configuration for decreasing gore level and adding green blood to my creatures - original file did not work because configuration is read from elsewhere and that file had no data for this mod - Shortly INI is Wrong.
sektor2111 wrote:
Wed Mar 10, 2021 5:10 am
Said file it's called NWConfig.ini and not NWUltraGoreSSE.ini.

User avatar
Que
Adept
Posts: 376
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

Re: NwUltraGore Settings not having effect on server

Post by Que » Wed Mar 10, 2021 9:56 am

I copied over the relevant info from NWUltraGoreSSE.ini to NWConfig.ini and it now works thanks Sektor
unfortunately theres no way to dumb down the gore ServerSide... :/
I managed to get it working just for HeadShots though which is pretty cool.
Image Image Image
*Join our Discord Here.*

User avatar
Feralidragon
Godlike
Posts: 5307
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: NwUltraGore Settings not having effect on server

Post by Feralidragon » Wed Mar 10, 2021 3:34 pm

Yep, that's the problem, at the time I forgot to change this:
class NWBloodyMess_UGSSE expands Mutator config(NWConfig);
to this:
class NWBloodyMess_UGSSE expands Mutator config(NWUltraGoreSSE);
in the code.

The main issue is that this package is a standalone version of the same feature in NW3 itself.
In NW3 the configuration is meant to be NWConfig, but in this one it was meant to be NWUltraGoreSSE instead, but I messed that up.

I vaguely remember this being brought up once in the past.
I would do another release to fix this, but being a fairly used mod these days in some servers, and one without updates since 2013, it may send the wrong message (especially in moddb), plus if I do it, I would likely do some more fixing in there since the code is not exactly stellar, it has some flaws (not in the sense of "bugs", but just certain definitions that may lead anyone reading the code the wrong impression, like simulated functions which shouldn't be simulated, unused functions, etc).

As for tweaking the gore down server-side, it IS possible, I designed it for that to be possible.
However, the client (player) has always the option to override that on their end, but by default they will use the server settings.

Let me know what you aren't able to do from here.

User avatar
sektor2111
Godlike
Posts: 5340
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: NwUltraGore Settings not having effect on server

Post by sektor2111 » Wed Mar 10, 2021 6:46 pm

Mod itself it's updating any needed ini file if it's used that menu activated by a god INT file - it works, tested. Either way can be conformed another version and all are going normal. NsMonster uses other Sliths, Mercs for which I changed green blood and I did a few changes at configuration - no coding is even needed. I think I have already mod installed from around two years - it has no flaws. As far as I remember I keep settings for server...

Code: Select all

BloodDecalsMinLifespan=5.000000
BloodDecalsMaxLifespan=10.000000
UseClientGoreMultSettings=False
UseClientGoreDecalSettings=False

User avatar
Que
Adept
Posts: 376
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

Re: NwUltraGore Settings not having effect on server

Post by Que » Thu Mar 11, 2021 3:27 am

ok I think that ive managed to dumb down the gore levels which is awesome.

next question is.. I would like Mecenary's player skins to have GREEN Blood ... like is already set in the .ini?

Code: Select all

GoreBloodTypes[6]=(VictClassName="Mercenary",VictModel="*",VictSkin="*",VictSkinID=0,BloodType="GREEN")
however when I set myself to Male Soldier > Mercenary Skin , my blood is still RED.
is there something I need to edit in order for this to work (GREEN BLOOD) for players with Mercenary Skins?
Image Image Image
*Join our Discord Here.*

User avatar
sektor2111
Godlike
Posts: 5340
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: NwUltraGore Settings not having effect on server

Post by sektor2111 » Thu Mar 11, 2021 7:17 am

It's about "VictClassName" definition and whatever "soldier" is not a child of Mercenary nor a Mercenary, then completing skin and model-name.

User avatar
Que
Adept
Posts: 376
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

Re: NwUltraGore Settings not having effect on server

Post by Que » Thu Mar 11, 2021 9:40 am

Ok , so what would I enter into that string to make it so that the mercenary players have GREEN blood?
Image Image Image
*Join our Discord Here.*

User avatar
Feralidragon
Godlike
Posts: 5307
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: NwUltraGore Settings not having effect on server

Post by Feralidragon » Thu Mar 11, 2021 1:33 pm

If by "Mercenary", you really mean players using the Unreal 1 mercenary pawn model and such, then it should work if you add:
GoreBloodTypes[7]=(VictClassName="Bot",VictModel="UnrealI.Merc",VictSkin="*",VictSkinID=0,BloodType="GREEN")

If it doesn't work, you will need to find out which mesh exactly the mercenary uses, since that's what you need to put in VictModel.

User avatar
OjitroC
Godlike
Posts: 2427
Joined: Sat Sep 12, 2015 8:46 pm

Re: NwUltraGore Settings not having effect on server

Post by OjitroC » Thu Mar 11, 2021 1:40 pm

Que wrote:
Thu Mar 11, 2021 3:27 am
however when I set myself to Male Soldier > Mercenary Skin , my blood is still RED.
is there something I need to edit in order for this to work (GREEN BLOOD) for players with Mercenary Skins?
Ok - so you mean you are playing as a Player using the MaleSoldier mesh/skins and the skin you are using is called Mercenary?

If so then taking this line as an example

Code: Select all

GoreBloodTypes[3]=(VictClassName=Bot,VictModel="*",VictSkin="Soldierskins.HKil*",VictSkinID=3,BloodType=Silver)
for VictClassName you need =TMale2
VictModel you can leave with the wildcard *
VictSkin - insert the name of the skin SoldierSkins.whatever
VictSkinID no idea possibly 0
BloodType =Green

Obviously you know what you are playing as but is there a SoldierSkin called Mercenary? One of the default Commando skins is Mercenary, is that what you mean? If so, VictClassName =TMale1 and VictSkin = CommandoSkins.daco*

If it's the skin in your avatar, isn't that SoldierSkins.blkt (Marine)?

User avatar
Que
Adept
Posts: 376
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

Re: NwUltraGore Settings not having effect on server

Post by Que » Fri Mar 12, 2021 12:54 am

Thanks for replies. Just wandering .. what is the easiest way to get this Information , VictClasses , models , skins ,(Names).. some kinda UT Skin editor?

For example let's say I wanted the XAN Green Skin (Player) to have GREEN Blood but not the other XAN Skins?..

How would I get the relevant information to enter into the .ini? Unrealed? UTSkin maker?

Also interested as to what VictSkinID is? Is this a team thing red , blue , green , yellow? 0~3
Can this be * for all teams if this is the case?
Image Image Image
*Join our Discord Here.*