My server isn't showing up in server list from ~2 weeks

Discussions about UT99
Killeroid
Novice
Posts: 6
Joined: Wed Feb 16, 2022 12:32 pm
Personal rank: -

My server isn't showing up in server list from ~2 weeks

Post by Killeroid » Wed Feb 16, 2022 12:59 pm

Hi folks
Using the official patch v436 for almost a decade now it always worked hosting games for my friends to play online, but in the past 2 weeks can't see my game in the UT server list anymore, but I still see a couple of people (28 servers) still managing to host their v436 games...

So if there is any PRO that could help me what are the requirements to make the v436 work again that would be awesome
Thank you
You do not have the required permissions to view the files attached to this post.

User avatar
esnesi
Inhuman
Posts: 931
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: Dialed in.

Re: My server isn't showing up in server list from ~2 weeks

Post by esnesi » Wed Feb 16, 2022 1:09 pm

Welcome to the forums.

I got no explanation why this happened since 2 weeks.
This could be due to a network related change as well. (New IP / Firewall issue)

But first rule out that you are using the right MasterServers:
https://333networks.com/instructions
Check the section: Server Side Configuration

*You could also try to make a copy of your UT Server folder, and copy the files from the 469b patch in there.
This patch already generates the right entries in the ini.
Players with higher ping will enjoy the optimized player movement.

If the issue persists, we need some more info about the environment of the host.
Where are you hosting this ?
Locally or on a VPS, or a service like Gameservers?
If local/VPS, make sure the portforwarding > firewall exclusions are still setup correctly.

Killeroid
Novice
Posts: 6
Joined: Wed Feb 16, 2022 12:32 pm
Personal rank: -

Re: My server isn't showing up in server list from ~2 weeks

Post by Killeroid » Wed Feb 16, 2022 1:27 pm

esnesi wrote:
Wed Feb 16, 2022 1:09 pm
Welcome to the forums.

I got no explanation why this happened since 2 weeks.
This could be due to a network related change as well. (New IP / Firewall issue)

But first rule out that you are using the right MasterServers:
https://333networks.com/instructions
Check the section: Server Side Configuration

*You could also try to make a copy of your UT Server folder, and copy the files from the 469b patch in there.
This patch already generates the right entries in the ini.
Players with higher ping will enjoy the optimized player movement.

If the issue persists, we need some more info about the environment of the host.
Where are you hosting this ?
Locally or on a VPS, or a service like Gameservers?
If local/VPS, make sure the portforwarding > firewall exclusions are still setup correctly.
Ofcourse, all my ports are correctly forwarded and checked with PortForward tool in the router never modified which all worked before the issue started, host locally on my PC, no special server made for an occasional playing with friends,
no other IP or firewall or anything were changed, I even disabled all AV firewalls and everything, all other games programs are working fine,
so on my end is everything untouched unchanged even verified, even router restarted, it is on the other end, somewhere at the UT99 servers
(i'm not into using forums as I have never been helped from forums, but this time it's beyond my grasp... and I taught some may have the correct answer)
You do not have the required permissions to view the files attached to this post.

User avatar
esnesi
Inhuman
Posts: 931
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: Dialed in.

Re: My server isn't showing up in server list from ~2 weeks

Post by esnesi » Wed Feb 16, 2022 1:59 pm

I assume you host this locally then > from home.

Could you verify if your Masterservers contain any Gamespy entries?
If so, change them to:

Code: Select all

ServerActors=IpServer.UdpServerUplink MasterServerAddress=utmaster.epicgames.com MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerAddress=master.333networks.com MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerAddress=master.newbiesplayground.net MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerAddress=master.errorist.eu MasterServerPort=27900

Killeroid
Novice
Posts: 6
Joined: Wed Feb 16, 2022 12:32 pm
Personal rank: -

Re: My server isn't showing up in server list from ~2 weeks

Post by Killeroid » Wed Feb 16, 2022 2:15 pm

esnesi wrote:
Wed Feb 16, 2022 1:59 pm
I assume you host this locally then > from home.

Could you verify if your Masterservers contain any Gamespy entries?
If so, change them to:

Code: Select all

ServerActors=IpServer.UdpServerUplink MasterServerAddress=utmaster.epicgames.com MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerAddress=master.333networks.com MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerAddress=master.newbiesplayground.net MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerAddress=master.errorist.eu MasterServerPort=27900
I'm now verifying ammending the possible modifications in unrealtournament.ini
although I see a port that is not configured in my router, is this new for UT99 ? port nr 28900
You do not have the required permissions to view the files attached to this post.

User avatar
esnesi
Inhuman
Posts: 931
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: Dialed in.

Re: My server isn't showing up in server list from ~2 weeks

Post by esnesi » Wed Feb 16, 2022 2:24 pm

Killeroid wrote:
Wed Feb 16, 2022 2:15 pm
I'm now verifying ammending the possible modifications in unrealtournament.ini
although I see a port that is not configured in my router, is this new for UT99 ? port nr 28900
7777-7781 on only UDP protocol is sufficient.
27900 should not be needed.

Killeroid
Novice
Posts: 6
Joined: Wed Feb 16, 2022 12:32 pm
Personal rank: -

Re: My server isn't showing up in server list from ~2 weeks

Post by Killeroid » Wed Feb 16, 2022 2:43 pm

esnesi wrote:
Wed Feb 16, 2022 2:24 pm
Killeroid wrote:
Wed Feb 16, 2022 2:15 pm
I'm now verifying ammending the possible modifications in unrealtournament.ini
although I see a port that is not configured in my router, is this new for UT99 ? port nr 28900
7777-7781 on only UDP protocol is sufficient.
27900 should not be needed.
ok, done all the modification, same problem, public servers show up but mine doesn't :???:
You do not have the required permissions to view the files attached to this post.

User avatar
esnesi
Inhuman
Posts: 931
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: Dialed in.

Re: My server isn't showing up in server list from ~2 weeks

Post by esnesi » Wed Feb 16, 2022 2:51 pm

Could you also post/verify the [Engine.GameEngine] section?
Thanks in advance.

Killeroid
Novice
Posts: 6
Joined: Wed Feb 16, 2022 12:32 pm
Personal rank: -

Re: My server isn't showing up in server list from ~2 weeks

Post by Killeroid » Wed Feb 16, 2022 3:08 pm

FINALLY DONE ! :tu:
NOW my locally hosted games appear again in the public server list... thanx to esnesi for help much appreciation !!!
the problem was to ADD the gamespy IP 81.205.81.173 master0.gamespy.com to the hosts file in C:\Windows\System32\drivers\etc\hosts
then restart the PC
...Now to fix my friend's problems too !

Automatically merged

esnesi wrote:
Wed Feb 16, 2022 2:51 pm
Could you also post/verify the [Engine.GameEngine] section?
Thanks in advance.
updating now these as well
You do not have the required permissions to view the files attached to this post.

User avatar
esnesi
Inhuman
Posts: 931
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: Dialed in.

Re: My server isn't showing up in server list from ~2 weeks

Post by esnesi » Wed Feb 16, 2022 3:36 pm

You're welcome.
Glad the issue is resolved.
:tu:

It should be sufficient though to only change the ServerActors on the [Engine.GameEngine] section.

User avatar
Barbie
Godlike
Posts: 2317
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: My server isn't showing up in server list from ~2 weeks

Post by Barbie » Wed Feb 16, 2022 5:38 pm

Killeroid wrote:
Wed Feb 16, 2022 3:36 pm
the problem was to ADD the gamespy IP 81.205.81.173 master0.gamespy.com to the hosts file in C:\Windows\System32\drivers\etc\hosts
then restart the PC
Hmm, AFAIK the host "master0.gamespy.com" does not exist any more, and I'd remove that line from UnrealTournament.ini instead of screwing up Windows.

The IP 81.205.81.173 resolves to "81-205-81-173.fixed.kpn.net", located in Netherlands. I'd use the IP or this hostname in UnrealTournament.ini then.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

User avatar
f7r
Average
Posts: 66
Joined: Mon Oct 19, 2020 6:53 pm

Re: My server isn't showing up in server list from ~2 weeks

Post by f7r » Wed Feb 16, 2022 9:27 pm

SS_2022-02-16_23-17-46.png
:loool:
You do not have the required permissions to view the files attached to this post.