Video Renderer Issues

Discussions about UT99
shakka
Novice
Posts: 4
Joined: Wed Jul 30, 2008 8:18 pm

Video Renderer Issues

Post by shakka » Sun Feb 20, 2022 1:40 am

Installing UT99 again and having issues getting decent video performance.

Intel i7-11700k
Nvidia RTX 3070
Windows 10
Patch v436 from Steam

D3D9r13 runs good performance wise, but getting what looks like terrible screen tearing when moving mouse horizontally.
D3D10v29 is better with the screen tearing issue, but it feels like frame rate drops frequently.

Put the OpenGL.dll from utglr37 in my system folder, but when I run the video renderer selection, it doesn't even show up as a compatible device.
When I click "Show all devices" I get:
3dfx Glide for Windows
Direct3D 10 Support
Direct3D Support
Direct3D9 Support
S3 MeTaL for Windows
Software Rendering

....but no OpenGL! OpenGL Viewer shows OpenGL driver installed is 4.6.0.

Any suggestions?

User avatar
OjitroC
Godlike
Posts: 2842
Joined: Sat Sep 12, 2015 8:46 pm

Re: Video Renderer Issues

Post by OjitroC » Sun Feb 20, 2022 1:54 am

Have you put the .int and .ini files for OpenGL in your system folder? The renderer should show up if there is an .int for it.

You can also put the following in your UnrealTournament.ini under [Engine.Engine]

Code: Select all

GameRenderDevice=OpenGLDrv.OpenGLRenderDevice

shakka
Novice
Posts: 4
Joined: Wed Jul 30, 2008 8:18 pm

Re: Video Renderer Issues

Post by shakka » Sun Feb 20, 2022 3:10 am

.ini and .int?

I have .dll and .int for the D3D renderers.
But utglr37 only comes with a .dll. Is OpenGLDrv.dll supposed to come with a .int too?

I will try forcing it in the UT.ini like you suggested too

EDIT: Tried forcing it in UT.ini and it seems to take, but there's no OpenGL settings in console -> preferences, and when I add settings in the UT.ini under [OpenGLDrv.OpenGLRenderDevice] section, they don't seem to take. So it doesn't seem like forcing OpenGL via UT.ini is working for me.

Buggie
Godlike
Posts: 1313
Joined: Sat Mar 21, 2020 5:32 am

Re: Video Renderer Issues

Post by Buggie » Sun Feb 20, 2022 5:42 am

install v469b patch and use D3D9 render.
https://github.com/OldUnreal/UnrealTour ... ses/latest

User avatar
rjmno1
Masterful
Posts: 698
Joined: Fri Aug 12, 2011 9:38 pm
Personal rank: masterfull
Location: https://sites.google.com/view/unrealtou ... oject/home

Re: Video Renderer Issues

Post by rjmno1 » Wed Feb 23, 2022 4:58 pm

first of all you must download the opengl driver from tip trick and tuturials section on this forum.
Download the opengl driver 3.7 and copy that rar or zip file in your unrealtournament\system folder.
Choose to extracted here and your driver must overwrite the existing opengl driver becouse you have a updated driver wich is newer and bether.

much more information in this page:

viewtopic.php?f=6&t=373

unreal tournament .ini file:download and overide unrealtournament.ini because of the opengl setting wich are chanched to updated settings.!

download/file.php?id=2520

opengl driver:

download/file.php?id=2637

dutch blog about settings

https://richardmoust105.blogspot.com/20 ... ef-in.html

much plesure with it
unreal tournament 99
®
Image
Image
ImageImage
https://sites.google.com/view/unrealtou ... oject/home mine home ut99 website.
https://richardmoust105.blogspot.com/20 ... ef-in.html dutch blog page about ut99 settings.

User avatar
esnesi
Inhuman
Posts: 931
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: Dialed in.

Re: Video Renderer Issues

Post by esnesi » Wed Feb 23, 2022 5:39 pm

shakka wrote:
Sun Feb 20, 2022 1:40 am
D3D9r13 runs good performance wise, but getting what looks like terrible screen tearing when moving mouse horizontally.
Could you confirm if the variable under d3d9 UseVSync=True ?
If it's not there, try adding it manual.
Also make sure your driver (nvidia/amdcatalyst) is not overriding this setting.
For sharper edges also make sure that UseAA=True (AntiAliasing) and NumAASamples=8 at minimal.