ut99 can't make the server to listen anymore, but some other games can

Discussions about UT99
User avatar
PrinceOfFunky
Godlike
Posts: 1192
Joined: Mon Aug 31, 2015 10:31 pm

ut99 can't make the server to listen anymore, but some other games can

Post by PrinceOfFunky » Sun Mar 13, 2022 8:03 pm

It looks like WinSock can't listen to new connections anymore, I tried binding the port 7777 (TCP) on Python and Java and it works fine, but with games written in C, C++, like ut99 or Wolfenstein: Enemy Territory, the ports are not accessible outside of my network.

These past days everything worked fine until I updated XLink Kai + installed ZeroTier to play LAN games over the internet, then I noticed I couldn't access my ut99 home server like I did before using my public IP. I also noticed that a new network adapter was created called "Local Area Connection* n" (where "n" is whatever number) which is a "Microsoft Wi-Fi Direct Virtual Adapter", every software was opening ports on that adapter instead of the one I used since forever (over ethernet), I was able to hide those adapters and kind of uninstalling some of them... So now ut99 shows it opens the port on the correct IP so I believe it uses the correct adapter now, yet it doesn't listen, I think it doesn't because I've checked the ports:
UCC (7777)
ucc_7777_7778_8777.png
Enemy Territory (27690)
etl_27960.png
Python (7777)
python_7777.png
Minecraft (Java, 25565)
java_25565.png
I doubt it's the router because I've formatted it twice already and there were no differences.

So, does anybody have an idea of what the hell is happening?
You do not have the required permissions to view the files attached to this post.
"Your stuff is known to be buggy and unfinished/not properly tested"