UT99 won't go into fullscreen

Discussions about UT99

UT99 won't go into fullscreen

Postby maximdymok » Mon May 30, 2011 5:38 am

So I had UT99 installed for about 4 years now and I've never encountered this problem...
Just yesterday everything was fine. Now when I go to play UT99 it starts in full screen, and after a second or so goes into windowed mode. I have tried deleting the unrealtournament.ini file, but it didn't help. I downloaded a new D3D driver and it didn't help. It however works fine in software mode, but, really, the quality is shit. If i try OpenGL it gives me some weird error. I'm running Vista x86 with 1.6 GHz intel core 2 duo, intel express 965 chipset (it sucks), 2 GB DDR2 RAM, 220 GB 5400RPM HDD. Help?
maximdymok
Experienced
 
Posts: 84
Joined: Mon May 30, 2011 5:28 am

Re: UT99 won't go into fullscreen

Postby JackGriffin » Mon May 30, 2011 1:30 pm

Did you try reinstalling your video driver? This sounds like a problem outside UT itself.
"You damn kids, back in my time we made the items, maps and games ourselves with an unwieldy engine using counter-intuitive crash-prone tools and we liked it so much we built communities around this which nowadays look like cults because they're quasi-parallel societies based on the same old games." -Hellkeeper
User avatar
JackGriffin
Godlike
 
Posts: 3723
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: Hack coder

Re: UT99 won't go into fullscreen

Postby anth » Mon May 30, 2011 1:48 pm

This happens when your fullscreen renderdevice is not supported by your graphics card/settings. Open your UT\System\UnrealTournament.ini file and go to the [Engine.Engine] section. Your WindowRenderDevice is probably SoftDrv.SoftwareRenderDevice. What is your GameRenderDevice set to right now? You should try changing it to GameRenderDevice=D3DDrv.D3DRenderDevice. If that doesn't work, it's probably due to hardware acceleration being disabled for your graphics card.
anth
Skilled
 
Posts: 160
Joined: Thu May 13, 2010 2:23 am

Re: UT99 won't go into fullscreen

Postby Raynor » Mon May 30, 2011 5:34 pm

Update your DirectX (http://www.microsoft.com/downloads/en/d ... 6652cd92a3) AND video drivers. What's the specific OpenGL error you get and what version did you used?
User avatar
Raynor
Adept
 
Posts: 417
Joined: Sun Jan 27, 2008 5:09 pm

Re: UT99 won't go into fullscreen

Postby maximdymok » Mon May 30, 2011 10:43 pm

Yes, I installed new video card drivers and it didn't help. I have DX11, as DXdiag tells me at least. And its definitely not that my video card doesn't support acceleration since it worked just fine 2 days ago but now it has this problem. I didn't change any video card settings either, so I don't know what could've caused this. Yes, in the ini file WindowRenderDevice is software, but i think (not sure) it was always like this.. not that I've ever changed that at least. GameRenderDevice is D3Ddrv.d3drenderdevice, and it won't go fullscreen like this, but if i change gamerenderdevice to software it does. If I set it to OpenGL it errors out with some extremely long error, and I can't copy it. But even if i did get OGL to work I would rather want D3D because OGL looks weird and lags on this computer (plays in slomo basically, and no, VSync doesn't help, or setting the CPU speed). I think maybe reinstalling the game might help, but I don't know where your progress is stored, and I wouldn't want to start from scratch. So anyone know what the problem might be?
maximdymok
Experienced
 
Posts: 84
Joined: Mon May 30, 2011 5:28 am

Re: UT99 won't go into fullscreen

Postby JackGriffin » Mon May 30, 2011 11:27 pm

We can fix your progress through the single-player. I'd do a reinstall and see where that gets you, saving your current install to a DVD or jump drive if you want to have a backup to restore. Be sure to completely delete the UT folder before reinstalling, don't try a "fix" reimaging.
"You damn kids, back in my time we made the items, maps and games ourselves with an unwieldy engine using counter-intuitive crash-prone tools and we liked it so much we built communities around this which nowadays look like cults because they're quasi-parallel societies based on the same old games." -Hellkeeper
User avatar
JackGriffin
Godlike
 
Posts: 3723
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: Hack coder

Re: UT99 won't go into fullscreen

Postby Raynor » Mon May 30, 2011 11:32 pm

DirectX gets additional updates over time so it is good practice to keep it recent. With modern systems (multi-core CPU's alongside with Windows Vista and Windows 7) it is NOT recommanded to use default video renderers, because they are horribly outdated and occasionally will cause different issues. You should definitely use updated Direct3D9 or OpenGL renderer and see if it helps with your issue. For more details peale refer to this link: viewtopic.php?f=6&t=373
User avatar
Raynor
Adept
 
Posts: 417
Joined: Sun Jan 27, 2008 5:09 pm

Re: UT99 won't go into fullscreen

Postby maximdymok » Tue May 31, 2011 2:53 am

Ok, i downloaded the OpenGL driver and confirgured the settings in the ini and now it runs in opegl, but it still has this slo-mo effect whenever there's not much to render. There doesn't seem to be an option for VSync or anything similar in opegl though, so how do I fix this? It still doesn't run in D3D, even with the updated driver I DL'd from the opengl page.
maximdymok
Experienced
 
Posts: 84
Joined: Mon May 30, 2011 5:28 am

Re: UT99 won't go into fullscreen

Postby JackGriffin » Tue May 31, 2011 3:10 am

Did you disable speed stepping in your processor (is this a laptop)?
"You damn kids, back in my time we made the items, maps and games ourselves with an unwieldy engine using counter-intuitive crash-prone tools and we liked it so much we built communities around this which nowadays look like cults because they're quasi-parallel societies based on the same old games." -Hellkeeper
User avatar
JackGriffin
Godlike
 
Posts: 3723
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: Hack coder

Re: UT99 won't go into fullscreen

Postby maximdymok » Tue May 31, 2011 3:48 am

Yes, its a laptop but.. sorry for stupid question, what is speed stepping? Is it when you make a shortcut for UT99 exe and type CPUSPEED=1600 or something like that?
maximdymok
Experienced
 
Posts: 84
Joined: Mon May 30, 2011 5:28 am

Re: UT99 won't go into fullscreen

Postby UT99.org » Tue May 31, 2011 1:00 pm

medor wrote:You have directx11 take Video_Render D3D11 for UT http://unrealtournament.99.free.fr/utfi ... o_Renders/

add in
UnrealTournament.ini
[D3D11Drv.D3D11RenderDevice]
UseVSync=False
SwapInterval=0
ZRangeHack=False
NoAATiles=False
NumAASamples=0
UseAA=False
RequestHighResolutionZ=True
UseSoftwareVertexProcessing=False
UsePureDevice=True
UseTripleBuffering=False
MaskedTextureHack=False
SmoothMaskedTextures=False
FrameRateLimit=150
UseVertexProgram=True
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=False
UseTexPool=True
UseTexIdPool=True
UseSSE2=True
UseSSE=True
BufferTileQuads=True
BufferClippedActorTris=True
SinglePassDetail=False
SinglePassFog=False
ColorizeDetailTextures=False
DetailClipping=False
UseDetailAlpha=True
DetailMax=0
RefreshRate=0
MaxTMUnits=0
NoFiltering=False
MaxAnisotropy=0
Use565Textures=False
Use16BitTextures=False
UseS3TC=False
UseAlphaPalette=False
UseTrilinear=False
UsePrecache=False
UsePalette=False
UseMultiTexture=True
MaxLogTextureSize=8
MinLogTextureSize=0
MaxLogVOverU=8
MaxLogUOverV=8
OneXBlending=True
GammaCorrectScreenshots=False
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.100000
LODBias=0.000000
DetailTextures=False
DescFlags=0
Description=
HighDetailActors=False
Coronas=False
ShinySurfaces=False
VolumetricLighting=False


select d3d11 render in UT

If you whant use d3d9 in ut you ned to d9d9dll comme with directx9 ...go install on windows


easy path for install opengl use a UT all ready patched with default opengl render full optimised http://unrealtournament.99.free.fr/foru ... hp?f=4&t=7 it have to d3d9 but ou must have directx9 for all right C:WINDOWSsystem32
UT99.org
 

Re: UT99 won't go into fullscreen

Postby Raynor » Tue May 31, 2011 1:07 pm

In Unreal Tournament, VSync is SwapInterval - to turn VSync on, set SwapInterval=1 and when off then set SwapInterval=0 (that's located under [OpenGLDrv.OpenGLRenderDevice])
SpeedStep is CPU feature that automatically lowers clock speeds when there isn't much load on your PC to improve battery life. You can disable this from your computer BIOS.

But before you do that try that make sure you have framerate limiter turned on, it often resolves speed issue without turning off Speedstepping etc.

[OpenGLDrv.OpenGLRenderDevice]
FrameRateLimit=62

---------------

@medor - you don't have to use DX11 renderer because Vista or 7 supports DX11. That one is highly experimental and I found Chris Dohnal's OpenGL to be more stable and customizable (options wise).
User avatar
Raynor
Adept
 
Posts: 417
Joined: Sun Jan 27, 2008 5:09 pm

Re: UT99 won't go into fullscreen

Postby maximdymok » Thu Jun 02, 2011 11:53 am

Alright guys thanks for the help, it now works! I used the DX11 driver and it runs very good. Now I'm gonna go frag some noobish bots.
maximdymok
Experienced
 
Posts: 84
Joined: Mon May 30, 2011 5:28 am

Re: UT99 won't go into fullscreen

Postby bannmannutt » Sat Mar 04, 2017 9:39 pm

switch to software rendering. don't use direct3d. it slows it down and doesn't allow you to go into fullscreen mode.
bannmannutt
 
Posts: 1
Joined: Sat Mar 04, 2017 9:35 pm

Re: UT99 won't go into fullscreen

Postby Carbon » Sun Mar 05, 2017 7:47 am

bannmannutt wrote:switch to software rendering. don't use direct3d. it slows it down and doesn't allow you to go into fullscreen mode.


Welcome and thanks for needlessly necro-bumping a 6 year-old thread which was resolved. :gj:
User avatar
Carbon
Inhuman
 
Posts: 822
Joined: Thu Jan 17, 2013 1:52 pm
Personal rank: Hoarder.

Next

Return to General Discussions

Who is online

Users browsing this forum: No registered users and 1 guest