answer to this may be obvious [how to disable hit-sound]

Discussions about UT99
User avatar
EvilGrins
Godlike
Posts: 7393
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

answer to this may be obvious [how to disable hit-sound]

Post by EvilGrins » Mon Jul 18, 2011 5:50 pm

I currently have two versions of UT99 on my system. In order to figure out why my server issues weren't resolving themselves as they should, Hermskii suggested I reinstall. Now, while I do still have the original CDs for UT99...I decided to go another way.

A couple years back, before my computer had room or could handle it, I bought the UA (Unreal Anthology) set. It's a 2 CD set. 1st CD has Unreal, UT99, Unreal 2, & UT2k4 on it. 2nd just has Unreal music selections. So as suggested, I installed UT99 from there to a different directory and everything else along with it.

Start menu looks like this:
Image
You just click the one you wanna play.

In the original UT99 there was a mutator that provided a hit sound when you shot... well, that's kinda obvious. It was annoying and I stopped using it pretty quick. Apparently the UT99 of UA has it as an automatic feature.

So far I can't figure out how to turn it off. Can't find it in any of the setup menus.

Suggestions? :help:
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

JackGriffin
Godlike
Posts: 3766
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: -Retired-

Re: answer to this may be obvious

Post by JackGriffin » Mon Jul 18, 2011 6:21 pm

EvilGrins wrote:Hermskii suggested I reinstall
I read the thread. You made the right call, he's wrong. Reinstalling when you haven't corrupted anything doesn't solve the problem, it just makes you start over. You see that a lot though, people don't really understand what they are trying to help on so they just tell you to just erase the entire thing. Unless you are experiencing crashing or errors you can almost always fix things.

About the hitsounds, I don't really understand what you mean. I've included hitsounds mods into several things I've done but I don't know of any default hitsounds mutators that are native to the UT disk. Can you elaborate?
So long, and thanks for all the fish

User avatar
Hook
Masterful
Posts: 745
Joined: Tue Apr 22, 2008 11:21 pm
Personal rank: UT99 Promoter/Admin
Location: Minnesota USA
Contact:

Re: answer to this may be obvious

Post by Hook » Mon Jul 18, 2011 6:52 pm

JackGriffin wrote:
EvilGrins wrote:Hermskii suggested I reinstall
Reinstalling when you haven't corrupted anything doesn't solve the problem, it just makes you start over. You see that a lot though, people don't really understand what they are trying to help on so they just tell you to just erase the entire thing. Unless you are experiencing crashing or errors you can almost always fix things.
Actually, Hermskii didn't say to "erase" anything.
He said do a Separate New install and for some good reasons, and because the original has been tinkered with a lot.
He was just getting EG back to square one is all with a base line install that hasn't been altered to use as a test, and this was before he found out that the problem is the router that is not the users so he cannot redo the port settings. (no access to the router)
That was the problem and Hermskii said that also. (case figured out and closed) :wink:

EvilGrins - JackGriffen is correct though about the hit sounds.
JG has incorporated stand alone "HitSounds" mutators into some of his mods, and I agree also with him that there are no Stock hit sounds that come with UT99 at all, any of them that I know of.
=Hook=(Member# 626)
Active Forums: http://hooksutplace.freeforums.net
UT99 Server -> CROSSBONES Missile Madness {CMM}

* Newest Versions of: PRO-Redeemers | PRO-SNIPER-Redeemers | PRO-SEEKER-Redeemers <-(the Original)
and Now with FOOD FIGHT and Frying Pan arena !!!
IP: 68.232.181.236:7777
{CMH} CROSSBONES Monster Hunt (MH) by Mars007 (The Original) - IP: 108.61.238.93:7777

User avatar
EvilGrins
Godlike
Posts: 7393
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: answer to this may be obvious

Post by EvilGrins » Mon Jul 18, 2011 6:54 pm

Well, I didn't reinstall exactly. At least not in the sense that I installed over what I have. I've got UT99 in 2 separate directories, one being the one I've been playing for years and this other that only been on my system for about a week.

As stated, this isn't from the UT disk. Unreal Anthology is 1 disk with UT99 on it plus Unreal, Unreal 2, & UT2k4 as well.

Near as I can determine, as I certainly didn't select it as an option, the hitsound mutator is incorporated into the game automatically. I haven't started poking around in the .ini files just yet, hoping maybe somebody else had experience with Unreal Anthology and might be able to give me the heads up on how to deactivate it.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
EvilGrins
Godlike
Posts: 7393
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: answer to this may be obvious

Post by EvilGrins » Mon Jul 18, 2011 7:44 pm

Hook wrote:EvilGrins - JackGriffen is correct though about the hit sounds.
JG has incorporated stand alone "HitSounds" mutators into some of his mods, and I agree also with him that there are no Stock hit sounds that come with UT99 at all, any of them that I know of.
Well, Unreal Anthology's UT99 is a little different than they standard UT99.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
EvilGrins
Godlike
Posts: 7393
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: answer to this may be obvious

Post by EvilGrins » Mon Jul 18, 2011 8:39 pm

Found it.

Image

We all have our favorite health/ammo regenerators. I've always been partial to excessive, which is why I copied it over to this newer UT99 directory. What I didn't realize is that it has 'hitsound' in as a standard feature. I either turned it off or never chose it years ago and, for whatever reason, it started automatically working in this new directory.

It's set, or was until I edited UnrealTournament.ini a couple minutes ago, for every gametype. Oddly, apparently it kept the hitsound active even if it wasn't selected as a mutator.

Weird.

Anyway, problem solved. Thanks for the help.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

JackGriffin
Godlike
Posts: 3766
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: -Retired-

Re: answer to this may be obvious

Post by JackGriffin » Mon Jul 18, 2011 8:47 pm

Hook wrote:Actually, Hermskii didn't say to "erase" anything.
He said do a Separate New install and for some good reasons, and because the original has been tinkered with a lot.
He was just getting EG back to square one is all with a base line install that hasn't been altered to use as a test, and this was before he found out that the problem is the router that is not the users so he cannot redo the port settings. (no access to the router)
That was the problem and Hermskii said that also. (case figured out and closed) :wink:
Someone who runs servers should know immediately that you don't need to reinstall if your server isn't accessible. He told you in the first post he wants to use the computer he surfs from so you know it has outside access. An unseen server is a router issue, pure and simple. Telling someone to double their installation footprint to test (what exactly you are looking for? port assignment isn't ever messed with) is redundant and wasteful. If you don't really know what you are doing, let someone else that does so people don't waste their time chasing ghosts.

@Grin: UA is different only in that it installs into a different folder than the default. Otherwise your installation is the same patched 432. You'll still need to update to the 436 one. Your excessive mod probably wasn't directly loading but you were loading the gametype instead (ExcessiveDeathmatchPlus) and getting the mod that way.
So long, and thanks for all the fish

User avatar
EvilGrins
Godlike
Posts: 7393
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: answer to this may be obvious

Post by EvilGrins » Mon Jul 18, 2011 9:42 pm

UA actually is 436, at least mine is.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
Hook
Masterful
Posts: 745
Joined: Tue Apr 22, 2008 11:21 pm
Personal rank: UT99 Promoter/Admin
Location: Minnesota USA
Contact:

Re: answer to this may be obvious

Post by Hook » Mon Jul 18, 2011 9:55 pm

JackGriffen wrote:An unseen server is a router issue, pure and simple.
I believe that is what we concluded, as I said above, just as soon as we found out the router was not available to adjust.
Sorry you mis-understood. :|
EvilGrins wrote:UA actually is 436, at least mine is.
You are correct EG! :tu:
=Hook=(Member# 626)
Active Forums: http://hooksutplace.freeforums.net
UT99 Server -> CROSSBONES Missile Madness {CMM}

* Newest Versions of: PRO-Redeemers | PRO-SNIPER-Redeemers | PRO-SEEKER-Redeemers <-(the Original)
and Now with FOOD FIGHT and Frying Pan arena !!!
IP: 68.232.181.236:7777
{CMH} CROSSBONES Monster Hunt (MH) by Mars007 (The Original) - IP: 108.61.238.93:7777

Hermskii
Average
Posts: 70
Joined: Fri May 23, 2008 3:33 am
Personal rank: Secret Administrator
Location: Houston, TX.
Contact:

Re: answer to this may be obvious

Post by Hermskii » Tue Jul 19, 2011 5:42 am

Hi Jack. It sounds like you are implying that I don't know how to run a server or trouble shoot one. You may want to take a really good look at this link I have provided. It concerns you and a certain server called "MEAT's Redeemer Screamer"

There are some funny things about that server. I'll go ahead and let you research it further by going to this link:

hxxp://hermskii.com/Forum/viewtopic.php?f=3&t=2774

I'll go ahead and spill the beans though for those who don't feel like reading everything about this: That server I mentioned, the one that you host now starting last December, the one that MEAT 'owns", the one that you and MEAT have been working so hard on all of this 6 months or so, the one you are so proud of...

I built that server! It is basically a near copy of my "Curious Georges Redeemer Insanity" server except I built it the way MEAT asked me to way back since he didn't know how to build a server. I never claimed to be the best at anything. I challenge you to find any place where I ever did claim to be really good at anything. I have never attacked another administrator or forum ever but this will be my first post where I will have counter attacked and on a forum that was not my own. You better hurry and read that link I put there. You'll have lots of questions coming at you real soon and I haven't even posted about you yet! That part that is there so far is just about why I BANNED you and MEAT from my forum and then I posted the special section all about MEAT. Your section is coming soon so everybody keep your eyes open and if this gets deleted somehow, worry not. It will be posted on every forum where I find an attack on me.

User avatar
papercoffee
Godlike
Posts: 9693
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.
Contact:

Re: answer to this may be obvious

Post by papercoffee » Tue Jul 19, 2011 8:24 am

Nothing will be deleted ... But I advice both of you to leave the drama out of this Forum. If I see another drama thread or a discussion went to a drama talk I will lock it.
And you can explain the thread owner why you started the drama there.

So please calm down or we whack you with the basting ladle.

Hermskii
Average
Posts: 70
Joined: Fri May 23, 2008 3:33 am
Personal rank: Secret Administrator
Location: Houston, TX.
Contact:

Re: answer to this may be obvious

Post by Hermskii » Tue Jul 19, 2011 12:38 pm

Thank you papercoffee and all other forum staff memebers here! Have a great day!

JackGriffin
Godlike
Posts: 3766
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: -Retired-

Re: answer to this may be obvious

Post by JackGriffin » Tue Jul 19, 2011 11:29 pm

Wow, all that because I said it was wasteful to tell people to double their installation to troubleshoot? Jesus, how did Meat and his server even get involved in this anyway?

Look I know you are this 'hugely respected member of all things Unreal' but coming in here blasting away like that is going to make you an extremely short career posting here. If you have an ax to grind with me personally then leave it off this board, and if you can't handle a little criticism when you are wrong about something you ought to not try to help people. I never defamed you, I simply gave my opinion of your troubleshooting abilities there Mr. Overreaction. Mappers get far worse when posting crap maps to be discussed. Someone should change into big-boy pants.

Yes, everyone knows I've been trouble before but you'll not draw me into anything here. I enjoy posting and discussing at UT99 so why don't you stop trying to drag me into a fight. It's just not going to happen. I'll choose when and where I fight anyone and you can't change that no matter how much you try to stir the 'pots'.

You know, I'll let you in on something (Ferali is welcome to back this up if you need confirmation, we just discussed this a couple of days back). I had planned on taking the rest of the summer off from computer gaming and maybe looking at returning in the fall.

My plans just changed.
So long, and thanks for all the fish

Skillz

Re: answer to this may be obvious

Post by Skillz » Wed Jul 20, 2011 1:18 am

Image

Hermskii
Average
Posts: 70
Joined: Fri May 23, 2008 3:33 am
Personal rank: Secret Administrator
Location: Houston, TX.
Contact:

Re: answer to this may be obvious

Post by Hermskii » Wed Jul 20, 2011 7:10 am

Yes, this is not the place for this discussion. I'd like to apologize to the Forum Administrators here for this behavior.

I have updated the topic on my forum and not here to respect this forum's Administrator's wishes. I see that my link above has been broken by being edited but only the http has been changed to hxxp as near as I can tell. I appreciate that it wasn't completely removed!

I'd like to invite you Jack Griffin, A.K.A. Kelly A.K.A GOPOSTAL to my forum as a "guest" so that you and "only you" can enjoy the genuinely felt nice words I wrote about you in one of the last few of paragraphs I posted there tonight about this topic! Since my almost functional link no longer works for you JACK Griffin, please feel free to do a search on my forum for a topic called:

"A short time ago in a forum you're reading right now..."

I'm sure you remember where my forum is. You'll see that "among other things" I have credited you with being one of the greatest things to ever happen to the Monster Hunt Mod! Congrats on that!

I hope I phrased everything here in a proper manner and respectfully enough for the Forum Administrators. Thank you for your continued support!

Locked