Anybody run into this before?

Discussions about UT99
Post Reply
User avatar
EvilGrins
Godlike
Posts: 7307
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Anybody run into this before?

Post by EvilGrins » Thu Feb 28, 2013 10:19 am

The thing that makes UT slow down or go really fast when you play can be fixed any number of ways. I usually just exit out of the game and go back in, tend to work pretty good for the most part.

Something different happened the last time and so far, it seems to have stayed that way. Unless I'm imagining it. Could be I'm just old, perception is one of the first things to go.

Image

Looking at myself, in behindview, or the other players in the game... it looks like we're all smaller. Rest of the game looks fine but all the players, myself included, looks like we've all shrunk a little bit.

Is this even possible?
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
Hitman
Skilled
Posts: 164
Joined: Mon Aug 16, 2010 11:01 am
Location: Sweden
Contact:

Re: Anybody run into this before?

Post by Hitman » Thu Feb 28, 2013 10:29 am

Problem: Unreal, UT and old Unreal-engine games run 'erratically' - the game speeds up and slows down at random, seemingly independent of the framerate. And this is most common for AMD-cores

Cause: This is caused by the way the Unreal engine calculates time, which is a little archaic has a number of issues with modern hardware - primarily because it is based on the CPUs clock speed, which on modern CPUs is automatically varied to save power, but it also has issues when the framerate is particularly high.

Quick Fix: Sorry, you're out of luck - this can be caused by a range of issues, so go through the solution step-by-step and see which ones actually fix the problem.

Solutions: Try the following in order - generally the first few tend to fix the problem for most people, and the latter are more extreme measures for problematic systems (dual-core laptops running Vista are particularly awkward).

* If you have an AMD multi-core processor, install the AMD Dual-Core Optimizer (5th down). This is needed because of a bug with some AMD processors which means that the timers on the CPU cores aren't synchronised with each other.

* UT has a built-in flag you can use to tell it the CPUs clock speed if it doesn't detect the speed correctly (it shows the detected speed in UT.log). Create a shortcut to UnrealTournament.exe and add ' -cpuspeed=X' to the end - without the quotes, and replacing X with you CPUs clock speed in Mhz.

* As stated above, UT has issues with very high framerates (200+), you need to put a limit on it. The best way to do this is to install one of Chris Dohnal's updated renderers (OpenGL, D3D8 or D3D9) - this is worth doing anyway. Try OpenGL first, and if you have issues use D3D9 or 8.
o Copy the .dll (and .int if present) to UT\System
o Run the game in safe mode (create a shortcut to UnrealTournament.exe and add ' -safe' to the end)
o When it asks to select a render device, click on 'show all' at the bottom and select the appropriate device
o After the game starts up, open the console (normally the ~ key if I remember correctly), go to Render Devices > OpenGL (or D3Dx as appropriate), find the FrameRateLimit entry and set the value to 200.
o While you're there, find the SwapInterval entry and set it to 0 - see the section on VSync for an explanation.
Alternatively you can edit your UnrealTournament.ini directly to make these changes but you're on your own doing this, unless I update this guide that is.

* The next step is to disable the CPU's power saving features before running UT. There are a number of ways to go about this depending on which operating system you use, so I'll list the easiest first.
o On Windows XP, go to Control Panel > Power Options, and in the Power Schemes tab select 'Always On'. This can be done automatically in a batch file, as explained by Blitzschlag on the Infiltration forums.
o In Windows Vista, go to Control Panel > Power Options and select the 'High Performance' profile.
o In a modern Linux distro e.g. Ubuntu, the easiest thing to do is to use the EMIFreq applet - simply select either 'Performance' or a fixed speed.
Failing this there are three ways to go about this, none perfect but all fairly fool-proof.
o The first, and in my opinion the easiest, is to run a CPU-hungry process in the background. Prime95 is a good one to use as it defaults to running in the background, so won't interfere with UT at all.
+ Download Prime95 from the link above and extract it to any location
+ Run the application, and if nothing happens go to Options > Torture Test
+ Select 'Small FFTs' as it uses the least amount of memory
+ To start off, tell it to run only one thread - no need to waste any more power than is needed
+ Click OK and leave it to it
o The second is to use a 3rd-party utility to manually set the CPU speed. These tend to vary in effectiveness though - I use RMClock on Windows XP but don't know if it supports Vista yet. Feel free to suggest any others.
o The third is a little more involved, but if you aren't worried about power-saving you'll only have to do it once. Disabling power saving in the BIOS is a fairly fail-safe method, but the exact option to look for can vary depending on the CPU and BIOS type. Either way, you'll usually find the settings in something like Advanced Options or CPU Features. For AMD processors, look for Cool & Quiet and disable it. For Intel CPUs look for something like EIST Function, Thermal Control and C1E Function.

* VSync (or Vertical Synchronisation) is a bit of a contentious issue - some people claim that enabling it solves the problem, while in my experience it can hinder things - try it both ways (0=off, 1=on). In a nutshell, it forces the video card to synchronise the swapping of buffers (i.e. outputting the picture) with each refresh of the monitor, in order to prevent 'tearing' effects where the monitor displays the upper part of one frame and the lower part of the next. On most modern flat panel monitors this is 60Hz, giving at most 60 updates per second, and in my experience a 60fps limit doesn't put enough load on a modern CPU to make it run at full clock speed all the time, meaning power saving will cut in and mess up the game speed.

Written by Crowze
Image
Image
Image
Image

User avatar
EvilGrins
Godlike
Posts: 7307
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: Anybody run into this before?

Post by EvilGrins » Thu Feb 28, 2013 8:46 pm

Okay, you seem to have missed the speed thing wasn't the focus of my post. That was just a lead up.

I want to know about the other thing. Is it possible that the players in the game could have shrunk?

They really do look smaller to me.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
Feralidragon
Godlike
Posts: 5212
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: Anybody run into this before?

Post by Feralidragon » Thu Feb 28, 2013 8:54 pm

EvilGrins wrote:Is this even possible?
Unless you're running a mod that specifically does that (which I doubt)... no.
I guess the best explanation is:
EvilGrins wrote:Unless I'm imagining it. Could be I'm just old, perception is one of the first things to go.

Image
:tongue:

It could be that you may tend to get too close to other players/bots, so up close they look bigger, but when you play with behind-view your camera never goes as close, hence perhaps making them appearing smaller to your eyes, when in fact they are the same.

User avatar
EvilGrins
Godlike
Posts: 7307
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: Anybody run into this before?

Post by EvilGrins » Fri Mar 01, 2013 1:35 am

It sounds reasonable but it turns out it isn't me.

I keep 2 versions of ut99 on my system. They're basically identical, the newer install I was hoping to host my own games from. Anyway, I took screenshots from both of them of the same model on the same map.

This is the one I think shrunk:
Image

This is the other version that's been uneffected:
Image

So, somehow the player view settings have shifted and caused the players to look smaller.

Again, I ask.... how?
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

Hermskii
Average
Posts: 70
Joined: Fri May 23, 2008 3:33 am
Personal rank: Secret Administrator
Location: Houston, TX.
Contact:

Re: Anybody run into this before?

Post by Hermskii » Fri Mar 01, 2013 6:39 am

I replied to your same question on one of my other favorite forums! Good luck!

User avatar
Chamberly
Godlike
Posts: 1907
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA
Contact:

Re: Anybody run into this before?

Post by Chamberly » Fri Mar 01, 2013 6:57 am

Probably fov changes. You could try typing fov 90 for default fov and see if that make any differences.

The fast/slow effect (client side) players... from what I've investigated myself, it have to do something with CPU. So I set it in task manager > set affinity > and only use 1 cpu.

These are what some things I thought of to answer.

User avatar
EvilGrins
Godlike
Posts: 7307
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: Anybody run into this before?

Post by EvilGrins » Fri Mar 01, 2013 9:18 am

Chamberly wrote:Probably fov changes. You could try typing fov 90 for default fov and see if that make any differences.
Type it where? In command console??

Sorry, playing a long time aside... I am somewhat dense on certain points.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

Pileyrei
Masterful
Posts: 734
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Re: Anybody run into this before?

Post by Pileyrei » Fri Mar 01, 2013 1:39 pm

I had a similar issue where my screen look stretched.
Deleted and re-added a backed up user.ini file
Image

Our Server
Image

[donate][/donate]
Donate to UT99.org!

User avatar
Chamberly
Godlike
Posts: 1907
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA
Contact:

Re: Anybody run into this before?

Post by Chamberly » Fri Mar 01, 2013 5:18 pm

EvilGrins wrote:
Chamberly wrote:Probably fov changes. You could try typing fov 90 for default fov and see if that make any differences.
Type it where? In command console??

Sorry, playing a long time aside... I am somewhat dense on certain points.
Yes in console.

Edit: You can change it like 85 for closer view. 110 for far view. Or 360 or 30 for wacky to laugh about view. lol. But the default is 90 FOV.
Last edited by Chamberly on Sat Mar 02, 2013 1:19 am, edited 1 time in total.

User avatar
papercoffee
Godlike
Posts: 9675
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.
Contact:

Re: Anybody run into this before?

Post by papercoffee » Sat Mar 02, 2013 12:59 am

EvilGrins wrote:It sounds reasonable but it turns out it isn't me.

I keep 2 versions of ut99 on my system. They're basically identical, the newer install I was hoping to host my own games from. Anyway, I took screenshots from both of them of the same model on the same map.

This is the one I think shrunk:
http://ic.pics.livejournal.com/evilgrin ... iginal.png

This is the other version that's been uneffected:
http://ic.pics.livejournal.com/evilgrin ... iginal.png

So, somehow the player view settings have shifted and caused the players to look smaller.

Again, I ask.... how?
Just check the texture on the ground
...in both pictures has the model the same step length therefore also the same height.
Your "camera" is farther away in the first picture compared to the second picture. Your POV is different.
Did you change this somehow in the past?

User avatar
EvilGrins
Godlike
Posts: 7307
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: Anybody run into this before?

Post by EvilGrins » Sat Mar 02, 2013 2:19 am

papercoffee wrote:Your "camera" is farther away in the first picture compared to the second picture. Your POV is different.
Did you change this somehow in the past?
Naw, always went with whatever the automatic/default setting was. This recent switch kinda happened all by itself.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

Post Reply