Is it possible to have smooth gameplay with no mouse lag??

Discussions about UT99
User avatar
Carbon
Inhuman
Posts: 841
Joined: Thu Jan 17, 2013 1:52 pm
Personal rank: Hoarder.

Re: Is it possible to have smooth gameplay with no mouse lag

Post by Carbon » Mon Sep 15, 2014 12:59 pm

SwapInterval=-1

This took away the tearing issue I was having. If I set it to 0, it comes back.

Phuckphucker
Novice
Posts: 16
Joined: Tue Sep 02, 2014 12:26 am

Re: Is it possible to have smooth gameplay with no mouse lag

Post by Phuckphucker » Tue Sep 16, 2014 12:19 am

Imho best way is to deactivate vsync and limit frames. You need to play around a bit but sooner or later you will find a frame limit which hardly produces any Tearing.

User avatar
{S.o.W}DeathMask
Skilled
Posts: 161
Joined: Sun Feb 09, 2014 7:42 pm

Re: Is it possible to have smooth gameplay with no mouse lag

Post by {S.o.W}DeathMask » Thu Oct 02, 2014 1:30 am

Carbon wrote:SwapInterval=-1

This took away the tearing issue I was having. If I set it to 0, it comes back.
I tried this, but thie led me to have a "rubber-band-around-my-mouse" effect (like in VSync). Other than that, it does remove the tearing indeed. But how do I fix the above stated effect?
{S.o.W}DeathMask, 9 times CWC UT2003, 1 time EMKTC.

Image

Image

User avatar
Carbon
Inhuman
Posts: 841
Joined: Thu Jan 17, 2013 1:52 pm
Personal rank: Hoarder.

Re: Is it possible to have smooth gameplay with no mouse lag

Post by Carbon » Thu Oct 02, 2014 1:08 pm

{S.o.W}DeathMask wrote:
Carbon wrote:SwapInterval=-1

This took away the tearing issue I was having. If I set it to 0, it comes back.
I tried this, but thie led me to have a "rubber-band-around-my-mouse" effect (like in VSync). Other than that, it does remove the tearing indeed. But how do I fix the above stated effect?
Here is my .ini (the relevant parts):

Code: Select all

[Engine.Engine]
GameRenderDevice=OpenGLDrv.OpenGLRenderDevice

Code: Select all

[WinDrv.WindowsClient]
WindowedViewportX=1264
WindowedViewportY=975
WindowedColorBits=32
FullscreenViewportX=1920
FullscreenViewportY=1200
FullscreenColorBits=32
Brightness=0.500000
MipFactor=1.000000
UseDirectDraw=True
UseJoystick=False
CaptureMouse=True
StartupFullscreen=True
CurvedSurfaces=True
LowDetailTextures=False
ScreenFlashes=False
NoLighting=False
SlowVideoBuffering=True
DeadZoneXYZ=True
DeadZoneRUV=False
InvertVertical=False
ScaleXYZ=1000.000000
ScaleRUV=2000.000000
MinDesiredFrameRate=1.000000
Decals=True
NoDynamicLights=False
UseDirectInput=False
ParticleDensity=0
NoFractalAnim=False
SkinDetail=High
TextureDetail=High

Code: Select all

[OpenGLDrv.OpenGLRenderDevice]
TruFormMinVertices=0
TruFormTessellation=3
UseTruForm=False
ZRangeHack=True
AAFilterHint=0
NumAASamples=24
UseAA=True
RequestHighResolutionZ=True
MaskedTextureHack=True
FrameRateLimit=200
SwapInterval=-1
UseVertexProgram=True
UseCVA=False
UseMultiDrawArrays=True
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=True
UseTexPool=True
UseTexIdPool=True
UseSSE=True
BufferTileQuads=True
BufferClippedActorTris=True
SinglePassDetail=False
SinglePassFog=True
ColorizeDetailTextures=False
DetailClipping=False
UseDetailAlpha=True
DetailMax=3
RefreshRate=75
MaxTMUnits=0
NoFiltering=False
NoMaskedS3TC=False
MaxAnisotropy=16
UseTNT=False
Use16BitTextures=False
UseS3TC=True
UseAlphaPalette=True
AutoGenerateMipmaps=True
UseTrilinear=True
UsePrecache=True
AlwaysMipmap=True
ShareLists=False
UsePalette=True
UseMultiTexture=True
UseBGRATextures=True
UseZTrick=False
MaxLogTextureSize=14
MinLogTextureSize=2
MaxLogVOverU=12
MaxLogUOverV=12
OneXBlending=False
GammaCorrectScreenshots=True
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.000000
LODBias=-1.000000
DetailTextures=True
DescFlags=0
Description=AMD R9 280x Series
HighDetailActors=True
Coronas=True
ShinySurfaces=True
VolumetricLighting=True
SmoothMaskedTextures=True
UseSSE2=True
NoAATiles=True
SceneNodeHack=True
UseFragmentProgram=True

[D3DDrv.D3DRenderDevice]
Translucency=True
VolumetricLighting=False
ShinySurfaces=True
Coronas=True
HighDetailActors=True
UseMipmapping=True
UseTrilinear=False
UseMultitexture=True
UsePageFlipping=True
UsePalettes=True
UseFullscreen=True
UseGammaCorrection=True
DetailTextures=False
Use3dfx=False
UseTripleBuffering=True
UsePrecache=True
Use32BitTextures=False
DescFlags=1
dwDeviceId=38149
dwVendorId=4098
Use32BitZBuffer=False
UseVertexFog=False
UseAGPTextures=False
UseVideoMemoryVB=False
UseVSync=True
Description=ATI Radeon HD 3850
It has been a long time since I ran UT in D3D, so I cannot vouch for those settings.

Post Reply