[INFO] Development Journal

User avatar
Shadow
Masterful
Posts: 719
Joined: Tue Jan 29, 2008 12:00 am
Personal rank: mad scientist
Location: Halle (Saale), Germany
Contact:

Re: [INFO] Development Journal

Post by Shadow » Wed Oct 19, 2011 6:50 pm

AH okay. Well as I said, it's untested online and it depends on the admin which packages are allowed. Now back to work..
Image

User avatar
Shadow
Masterful
Posts: 719
Joined: Tue Jan 29, 2008 12:00 am
Personal rank: mad scientist
Location: Halle (Saale), Germany
Contact:

Re: [INFO] Development Journal

Post by Shadow » Sun Oct 23, 2011 3:15 pm

October Beta Update/Preview

Since time between both updates was just 2 weeks I didn't manage to implement THAT much as in Build 250, but I think a Material System is still a nice new feature, especially for Mappers.

New Features
  • Material System: supports Texture Combiners, Texture Panners, Texture Oscillators, Texture Scalers, Emissive Materials - works both on BSP and Meshes! this also means: Macro and Detail Textures on Meshes!
  • New Trigger System
  • New extended Timer Scripting Feature, allows multiple Timer Events to be called by their individual Names (supports Infinite Loop, Counted Loop and Once Only sequences)
Fixes/Updates
  • Occlusion Checks for Static Meshes (improves Performance)
  • Particle Engine Documentation
Media

Image Image

New Video:
Image
Image

User avatar
Creavion
Godlike
Posts: 4497
Joined: Sun Feb 17, 2008 7:23 pm
Personal rank: About to be non-act.
Location: Germany, Lower Saxony

Re: [INFO] Development Journal

Post by Creavion » Mon Oct 24, 2011 9:32 pm

*speechless*, the screenshots alone are just freaking awesome.

For me you are one of the best coders I have ever meet beside dots and Smirf. :mrgreen:
About to be non-active
My very last UT map project: CTF-FacePalm (tropical CTF-Face remake)
Why do I leave? click here
What I want to do next: Joining an UDK team (uncertain however) and improve 3D modelling and texture editing skills
Thanks to those who visibly supported me until/at the end!
My reactivated account on indiedb.com.

User avatar
Dr.Flay
Godlike
Posts: 3274
Joined: Thu Aug 04, 2011 9:26 pm
Personal rank: Chaos Evangelist
Location: Kernow, UK
Contact:

Re: [INFO] Development Journal

Post by Dr.Flay » Tue Oct 25, 2011 3:13 am

Updated to the new SDK to try primarily from a stability test rather than from the editing point of view.
I've only being playing with the editor properly since I recently downgraded from the 451b patch :what:

It crashes when I open the player or bot roster windows.
I have noticed a clash with Wormo's Enhanced Items mutator. I'm pretty sure it's a clash with the overlay systems used by both.
I will make a posting on the forum there tomorrow, and suggest that he checks out the SDK himself.
http://www.koehler-homepage.de/Wormbo/E ... Items.html
Hopefully I will be able to attach a log file.
I removed all extra mutators, and the only extra thing adjusting my UT should be OldSkool Amp'd and standard fixes + the SDK

Maps I have previously edited seem to work with both Enhanced Items and X-Pickups, but maps with the Xreplacer in from the "UTR" collection in the CMP2 map pack now crash when I use the Enhanced Items mutator.
Except for DM-UTR-Kamah ! :omfg:
Which I have added squid, fish, and birds inc. song-birds, sparrows, sea gulls, for a bit of life (gotta put the snakes and scorpions in next).
The SDK, X Pickups, and Enhanced Items are all in the editor package list, but I have not manually added anything relating to them. Just animals.
Attachments
UT-logs.rar
(4.6 KiB) Downloaded 134 times

User avatar
Shadow
Masterful
Posts: 719
Joined: Tue Jan 29, 2008 12:00 am
Personal rank: mad scientist
Location: Halle (Saale), Germany
Contact:

Re: [INFO] Development Journal

Post by Shadow » Tue Oct 25, 2011 9:25 am

Glad there're users like rooting out bugs :)

The SDK currently uses no such Overlay System like the Enhanced Items does.
Well I have taken a look into the Log files you provided with your post, from what I can see the error in UT-SDK.log (do you have a UT-SDK.exe or something?) the sdkLevelInfo seams to cause half of the problem, next error deals with the RenderOverlays Function, which the SDK is currently not using in any class since Screen-Rendering is done directly with new Canvas class, have you set the Canvas to the SDK's Canvas (Canvas=sdkCanvas) in UnrealTournament.ini?

It could possibly be that there're some issues when dealing with the sdkLevelInfo since it's AutoPlaced when using the new Base Render, on the other hand it's ALWAYS difficult to run many mutators and mods simultaneously, no matter of a native Mod like the SDK or not

Hm well when we look closer we can see that half of the errors occure before the problem with the sdkLevelInfo, originating in the line:

Code: Select all

Critical: Assertion failed: Actor->Role==ROLE_Authority [File:C:\UTDev\Engine\Src\UnLevAct.cpp] [Line: 79]
So this could be a network issue when dealing with many mutators/mods, unfortunetely I can't say what's in Line 79 of UnLevAct.cpp ... we all know why.

From guessing I would say it's the ULevel's C++ SpawnActor Function and the Engine is checking here for initial Role settings and that setting failed at that time (Actor->Role==ROLE_Authority)
Image

User avatar
Dr.Flay
Godlike
Posts: 3274
Joined: Thu Aug 04, 2011 9:26 pm
Personal rank: Chaos Evangelist
Location: Kernow, UK
Contact:

Re: [INFO] Development Journal

Post by Dr.Flay » Tue Oct 25, 2011 2:21 pm

:mrgreen: Hehe, Believe me, I test things to hell and back!

My UT is as standard as I can make it at the moment.
I did not submit any bug reports before, because I was using the 451b patch, and I was waiting for the new SDK.
BTW. Last years SDK worked well with 451 :wink:

I have not renamed my UT. I just renamed the log files based on what I was testing at the time. The "UT-SDK" log is me trying to run a map, and the "UTPlayer" log is me opening the player config panel.
When opening the Player or Bot config panel, it crashes immediately.
Running a map with the SDK and Enhanced Items, UT will load the map and crashes only when I press fire to start the game.

The render and canvas lines in the ini file are set correctly (you should see them bound in the log files) and I removed the sdkWindows line from the editor config.

I should also list what versions of system files I am using.
UT 436 (No delta patch)
Enhanced OpenGL v3.6 and DirectX9 v1.3 renderers from http://www.cwdohnal.com/utglr/
OMP multimedia pack from http://www.oldunreal.com, plus the EAX patched galaxy.dll (no idea of the dll version numbers)
I do also have the DirectX10 and 11 renderers installed, but I am not using them (I can get some programs to use DX10 in XP but not UT) http://kentie.net/article/d3d10drv/ http://kentie.net/article/d3d11drv/
OldSkool Amp'd 2.39 (Full)
Paradox's UT enhancements www.pseudorandom.co.uk/2003/paradox/ut/
ENB series bloom v0.075e (works well with the new SDK so far)

NOTE:
For bug testing I change to the OpenGL renderer, remove all mutators (except the ones I am testing and the Chaos GOTY mutator). Also I change back to the Galaxy audio as ALaudio driver fills the log files with stupid amounts of data.

User avatar
Shadow
Masterful
Posts: 719
Joined: Tue Jan 29, 2008 12:00 am
Personal rank: mad scientist
Location: Halle (Saale), Germany
Contact:

Re: [INFO] Development Journal

Post by Shadow » Fri Oct 28, 2011 10:09 am

Okay... now I experienced the bug myself. When starting UT as normal with the exe I got the same error like you. I have an idea in mind how to fix it: creating a List of Maps where to add the LevelInfo and were not. Actually I can't imagine why it's such a problem adding that new LevelInfo. It gets even more weird when you load the Cityintro.unr Map seperatly: No errors, no bugs. It appears only when starting with the exe...

The November Beta will hopefully fix that issue, for the coming October Release it's just too late. I'm already writing documentation and no changes are applied from this point on. Additionally I'm focussing on Food Fight again, so November Beta will only be a bugfix and update release.

Well but I have good news too: Lately I added Distance Fog Support, on a Level and Zone setup basis. It also works well with transparent and modulated surfaces and smoothly blends behind them. It's the last feature added to this month's release.

Image
Image

User avatar
>@tack!<
Adept
Posts: 338
Joined: Sat Apr 17, 2010 4:51 pm
Personal rank: lol?

Re: [INFO] Development Journal

Post by >@tack!< » Fri Oct 28, 2011 11:23 am

DOPE distance fog :)

User avatar
Dr.Flay
Godlike
Posts: 3274
Joined: Thu Aug 04, 2011 9:26 pm
Personal rank: Chaos Evangelist
Location: Kernow, UK
Contact:

Re: [INFO] Development Journal

Post by Dr.Flay » Tue Nov 01, 2011 12:46 am

Any one else unable to access the player and/or bot selection window?
I've tried with the standard, Enhanced and Xbots bot config, but they all bomb the SDK for me.

User avatar
Shadow
Masterful
Posts: 719
Joined: Tue Jan 29, 2008 12:00 am
Personal rank: mad scientist
Location: Halle (Saale), Germany
Contact:

Re: [INFO] Development Journal

Post by Shadow » Wed Nov 02, 2011 12:24 am

Dr.Flay wrote: Any one else unable to access the player and/or bot selection window?
I've tried with the standard, Enhanced and Xbots bot config, but they all bomb the SDK for me.
Flay, please give a more detailed explaination of the error


October Beta Release

Only two weeks after the September release the October release is available. Thus I only implement 2 new major features and some minor features. Some fixes and improvements here and there.

New Features
  • Distance Fog Support (per-Level Setup, per-Zone Setup, Vertex/Pixel Rendering, Dynamic Color, Dynamic Distance, 3 Fog Modes)
  • Material Support (Texture Combiners, Texture Oscillators, Texture Panners, Emissive Materials, Emissive Panners), works currently only on BSP
  • New Trigger System
  • New Timer System, allows for multiple unique timer function calls

Fixes/Updates
  • Decoration Layer, supports Copy & Paste Mode
  • Static Meshes, supports Occlusion Checks and Simple Collision
  • improved Base Render and Sprite Render
  • new OpenGL Render Driver, based on UTGLR by Chris Dohnal

Download

UTSDK October 2011 Beta (Build 271) - 19,8 MB
Image

User avatar
Dr.Flay
Godlike
Posts: 3274
Joined: Thu Aug 04, 2011 9:26 pm
Personal rank: Chaos Evangelist
Location: Kernow, UK
Contact:

Re: [INFO] Development Journal

Post by Dr.Flay » Wed Nov 02, 2011 9:04 pm

I included a log file of me opening the player selection window in the zip with the 2 logs.
As soon as I open either the player and bot selection windows, UT immediately crashes. Can't think of much more to say.
Could a menu enhancement like OldSkool or Enhanced Menus cause something like this?
Let me know of any other info I can gather for you (would my UT.ini file be usefull to look at).

User avatar
Shadow
Masterful
Posts: 719
Joined: Tue Jan 29, 2008 12:00 am
Personal rank: mad scientist
Location: Halle (Saale), Germany
Contact:

Re: [INFO] Development Journal

Post by Shadow » Wed Nov 02, 2011 11:43 pm

I finally managed to really fix that bug concerning the LevelInfo, when starting the game or loading a map in the menu.

Code: Select all

Critical: Assertion failed: Actor->Role==ROLE_Authority [File:C:\UTDev\Engine\Src\UnLevAct.cpp] [Line: 79]
No matter how I tried to change the class or using different classes to spawn at the beginning (testing) by the Render the error persisted, but strangely it worked flawless for some actors like sdkActor. Well I wrote an own specialized spawn function just for the LevelInfo, now everything works fine. Thanks for your assistance!
Image

User avatar
Dr.Flay
Godlike
Posts: 3274
Joined: Thu Aug 04, 2011 9:26 pm
Personal rank: Chaos Evangelist
Location: Kernow, UK
Contact:

Re: [INFO] Development Journal

Post by Dr.Flay » Wed Nov 02, 2011 11:56 pm

:idea: As a matter of curiosity, and in a vain hope it would fix/bypass the prob with opening the player config, I have replaced the core UT files with the files from the (don't shout at me) 451b patch!
:cry: No, it didn't work.

...But I can tell you (& I know you don't want to hear this) so far the SDK also works fine with the UTPG patch.

...Sorry :wink:

UT99.org

Re: [INFO] Development Journal

Post by UT99.org » Thu Nov 03, 2011 3:31 pm

medor wrote:Download

UTSDK October 2011 Beta (Build 271) - 19,8 MB

corupt file :(

User avatar
Shadow
Masterful
Posts: 719
Joined: Tue Jan 29, 2008 12:00 am
Personal rank: mad scientist
Location: Halle (Saale), Germany
Contact:

Re: [INFO] Development Journal

Post by Shadow » Thu Nov 03, 2011 4:54 pm

medor wrote:Download

UTSDK October 2011 Beta (Build 271) - 19,8 MB

corupt file :(
You need a good zip program, use WinRAR or 7zip. I compressed it with 7zip this time (ultra compression), it saved 10 MB for me, so upload was faster and smaller.
Image

Post Reply