Nexgen Server Controller

Discussions about Servers
User avatar
Barbie
Godlike
Posts: 2478
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: Nexgen Server Controller

Post by Barbie » Tue Jun 07, 2022 7:48 pm

Letylove49 wrote:
Tue Jun 07, 2022 7:12 pm
i dont know what do this bug sorry
See event Nexgen112N.NexgenHUDWrapperT.postRender(): There a loop over all class'NexgenClient' is done with the implicit thought that a matching one is found. But if none is found, "client" stays NONE, and the access to it in line 94 and 104 causes the Access Nones.

Probably a matching class'NexgenClient' does not exist, because the login was denied and further initializations by Nexgen have not been done.
I suspect the same for the other error messages.
You do not have the required permissions to view the files attached to this post.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

User avatar
Barbie
Godlike
Posts: 2478
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: Nexgen Server Controller

Post by Barbie » Sat Jun 25, 2022 8:11 pm

I'm interested in disabling the "Game > Map Switch" tab in Nexgen. Is it possible by changing something in Nexgen.ini?
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

Letylove49
Skilled
Posts: 173
Joined: Tue Feb 28, 2012 7:47 pm
Personal rank: <[MHA]> /UK Admin
Location: suisse

Re: Nexgen Server Controller

Post by Letylove49 » Mon Jun 27, 2022 5:25 pm

Barbie wrote:
Sat Jun 25, 2022 8:11 pm
I'm interested in disabling the "Game > Map Switch" tab in Nexgen. Is it possible by changing something in Nexgen.ini?
why do you want tor disable it ? this option is for match admin on nexgenplus

Automatically merged

somone know Why: Server performance optimizer. has been removed from NexgenPlus ?
<[MHA]>Letylove49 aka -=]UK[=-Shado

User avatar
Berserker
Experienced
Posts: 89
Joined: Fri Sep 27, 2019 5:08 pm

Re: Nexgen Server Controller

Post by Berserker » Mon Jun 27, 2022 8:58 pm

I made a clean lan server for testing with Nexgen112N and no plugins. I noticed when the game starts, I can use !red !blue !spec !play three times and after that these commands stop working. Any suggestions what could be the issue?
Visit us on Discord:
https://discord.gg/fcRakgNCjR Image

User avatar
Barbie
Godlike
Posts: 2478
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: Nexgen Server Controller

Post by Barbie » Mon Jun 27, 2022 10:47 pm

Berserker wrote:
Mon Jun 27, 2022 8:58 pm
Any suggestions what could be the issue?
Any hints in the log?
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

Letylove49
Skilled
Posts: 173
Joined: Tue Feb 28, 2012 7:47 pm
Personal rank: <[MHA]> /UK Admin
Location: suisse

Re: Nexgen Server Controller

Post by Letylove49 » Mon Jun 27, 2022 11:19 pm

have you this onb your unrealtournent or server.ini
ServerActors=Nexgen112NNexgenActor
ServerPackages=NexgenCC
ServerPackages=Nexgen112N
<[MHA]>Letylove49 aka -=]UK[=-Shado

User avatar
Berserker
Experienced
Posts: 89
Joined: Fri Sep 27, 2019 5:08 pm

Re: Nexgen Server Controller

Post by Berserker » Tue Jun 28, 2022 6:45 am

Barbie wrote:
Mon Jun 27, 2022 10:47 pm
Any hints in the log?
From where should I set up logs to troubleshoot this? Perhaps its "logEvents" under Nexgen.ini? Here are the full log lines in Nexgen.ini:
logEvents=False
logSystemMessages=False
logChatMessages=False
logPrivateMessages=False
logAdminActions=True
logToConsole=False
logToFile=False

Letylove49 wrote:
Mon Jun 27, 2022 11:19 pm
have you this onb your unrealtournent or server.ini
ServerActors=Nexgen112NNexgenActor
ServerPackages=NexgenCC
ServerPackages=Nexgen112N
Yes, already set
Visit us on Discord:
https://discord.gg/fcRakgNCjR Image

User avatar
Barbie
Godlike
Posts: 2478
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: Nexgen Server Controller

Post by Barbie » Tue Jun 28, 2022 11:05 am

Berserker wrote:
Tue Jun 28, 2022 6:45 am
Barbie wrote:
Mon Jun 27, 2022 10:47 pm
Any hints in the log?
Here are the full log lines in Nexgen.ini:
No, with these you can decide what kind of things should be logged, for example:
[ EVENT ] The game has started.
Instead have a look into the SYSTEM folder of the UT installation. There you can find a file name "UnrealTounament.log" (assuming a Windows installation). Have a look into this and have an eye on lines with WARNING or ERROR in it.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

User avatar
Berserker
Experienced
Posts: 89
Joined: Fri Sep 27, 2019 5:08 pm

Re: Nexgen Server Controller

Post by Berserker » Tue Jun 28, 2022 3:09 pm

Barbie wrote:
Tue Jun 28, 2022 11:05 am
Berserker wrote:
Tue Jun 28, 2022 6:45 am
Barbie wrote:
Mon Jun 27, 2022 10:47 pm
Any hints in the log?
Here are the full log lines in Nexgen.ini:
No, with these you can decide what kind of things should be logged, for example:
[ EVENT ] The game has started.
Instead have a look into the SYSTEM folder of the UT installation. There you can find a file name "UnrealTounament.log" (assuming a Windows installation). Have a look into this and have an eye on lines with WARNING or ERROR in it.
I see, its pretty clean with no errors or warnings. I also had the server cmd console opened to monitor any errors there as well but no signs. When I spam !s !p !s !p quickly it breaks on the second try and you cant use ! commands anymore. I then joined the server with a clean UT and ! commands dont work on this client as well, which means the ! commands are broken for everyone. Do you happen to have a bit of time to run the server on LAN yourself, so you can check it out? It's a fairly small windows server.
Visit us on Discord:
https://discord.gg/fcRakgNCjR Image

User avatar
Barbie
Godlike
Posts: 2478
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: Nexgen Server Controller

Post by Barbie » Tue Jun 28, 2022 3:40 pm

What about the long !-commands like "!play" equal to "mutate nsc play" or "!blue" equal to "mutate nsc setteam 1"? Do they work?
all (?) nexgen commands
Show
Mutate nsc start or "!l" or "!start": Starts a match.
mutate nsc pause: Toggles pause of game. Admin rights required.
mutate nsc openrcp or "!o" or "!open": Opens the Nexgen window.
mutate nsc play or "!p" or "!play": Rejoins you as a player.
mutate nsc spectate or "!s" or "!spec": Rejoins you as a spectator.
mutate nsc exit or "!exit" or "!quit": Terminates your UT client.
mutate nsc bye or "!bye" or "!leave": Disconnects you from the server.
mutate nsc setteam 0 or "!r" or "!red": Sets skin and HUD colours to red.
mutate nsc setteam 1 or "!b" or "!blue": Sets skin and HUD colours to blue.
mutate nsc setteam 2 or "!g" or "!green": Sets skin and HUD colours to green.
mutate nsc setteam 3 or "!y" or "!yellow" or "!gold": Sets skin and HUD colours to yellow.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

User avatar
Berserker
Experienced
Posts: 89
Joined: Fri Sep 27, 2019 5:08 pm

Re: Nexgen Server Controller

Post by Berserker » Tue Jun 28, 2022 4:13 pm

Barbie wrote:
Tue Jun 28, 2022 3:40 pm
What about the long !-commands like "!play" equal to "mutate nsc play" or "!blue" equal to "mutate nsc setteam 1"? Do they work?
all (?) nexgen commands
Show
Mutate nsc start or "!l" or "!start": Starts a match.
mutate nsc pause: Toggles pause of game. Admin rights required.
mutate nsc openrcp or "!o" or "!open": Opens the Nexgen window.
mutate nsc play or "!p" or "!play": Rejoins you as a player.
mutate nsc spectate or "!s" or "!spec": Rejoins you as a spectator.
mutate nsc exit or "!exit" or "!quit": Terminates your UT client.
mutate nsc bye or "!bye" or "!leave": Disconnects you from the server.
mutate nsc setteam 0 or "!r" or "!red": Sets skin and HUD colours to red.
mutate nsc setteam 1 or "!b" or "!blue": Sets skin and HUD colours to blue.
mutate nsc setteam 2 or "!g" or "!green": Sets skin and HUD colours to green.
mutate nsc setteam 3 or "!y" or "!yellow" or "!gold": Sets skin and HUD colours to yellow.
Yes, the console commands work. Could it be some kind of a chat mute? Altho im not using any mutators that would handle that, I guess it should be something in nexgen.
Visit us on Discord:
https://discord.gg/fcRakgNCjR Image

User avatar
Barbie
Godlike
Posts: 2478
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: Nexgen Server Controller

Post by Barbie » Tue Jun 28, 2022 8:21 pm

What about the long !-commands like "!play"?
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

User avatar
Berserker
Experienced
Posts: 89
Joined: Fri Sep 27, 2019 5:08 pm

Re: Nexgen Server Controller

Post by Berserker » Tue Jun 28, 2022 9:26 pm

Barbie wrote:
Tue Jun 28, 2022 8:21 pm
What about the long !-commands like "!play"?
No, they don't work. Only console commands work.

Visit us on Discord:
https://discord.gg/fcRakgNCjR Image

User avatar
Barbie
Godlike
Posts: 2478
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: Nexgen Server Controller

Post by Barbie » Wed Jun 29, 2022 12:13 am

I noticed some other, unusual messages in the chat. Have you tried disabling all other ServerActors and Mutators?
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

User avatar
Berserker
Experienced
Posts: 89
Joined: Fri Sep 27, 2019 5:08 pm

Re: Nexgen Server Controller

Post by Berserker » Wed Jun 29, 2022 2:13 am

Barbie wrote:
Wed Jun 29, 2022 12:13 am
I noticed some other, unusual messages in the chat. Have you tried disabling all other ServerActors and Mutators?
Great suggestion, that allowed me to pinpoint to the issue. It seems like for whatever reason ServerActors=2k4Sounds24.SoundsActor seems to be making this issue, i tested many combinations to finally confirm, but I wasnt able to make the mutator run without the !commands issue. It's strange, because it is a known mutator and I am also using it without any issues on my main server. My 2k4Sounds24.u package seems to be fine, everything should be in order. I will try to resolve this maybe by loading the mutator trough mapvote and not trough server actors, I have doubts it would actually work and if it doesnt I guess I will ditch the mutator.
Visit us on Discord:
https://discord.gg/fcRakgNCjR Image