469 Server questions

Discussions about Servers
Casual Gamer
Novice
Posts: 3
Joined: Mon Sep 28, 2020 9:52 pm
Personal rank: Casual Gamer

469 Server questions

Post by Casual Gamer » Mon Sep 28, 2020 10:05 pm

Hi there,
Quick questions regarding 469a.


1. How do I change a rented server from 451 to 469a? I have tried moving all the files and selecting every exe file I see. But nothing changes. Maybe its the server company blocking it? (I use NFO)
2. With this new patch do I need as much Anti-Cheat or mods? I currently use ACE 1.2E, AntiTweak v52, No 16 Bit, Pure from Ultimate Newnet, and Tickfix 2.
3. When I installed 469a on my pc I couldn't join some 469 servers as it said my engine.u wasn't approved by md5. I tried a different engine.u file from beta 469 but no luck. So I rolled everything back to beta and I then I could connect.
So I guess those servers must update to 469a?

Thanks for your help.

User avatar
papercoffee
Godlike
Posts: 9940
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.

Re: 469 Server questions

Post by papercoffee » Mon Sep 28, 2020 10:15 pm

Moved the thread to the right section.

SC]-[WARTZ_{HoF}
Adept
Posts: 425
Joined: Tue Feb 21, 2012 7:29 pm

Re: 469 Server questions

Post by SC]-[WARTZ_{HoF} » Mon Sep 28, 2020 10:36 pm

If you ask NFO to use your files they will end up changing everybody's servers and this is what we want to avoid. Best thing would be just rent a virtual dedicated server from NFO. This way you will have total control over your gameserver.
Image
Image
Image

User avatar
OjitroC
Godlike
Posts: 2476
Joined: Sat Sep 12, 2015 8:46 pm

Re: 469 Server questions

Post by OjitroC » Mon Sep 28, 2020 11:02 pm

Casual Gamer wrote:
Mon Sep 28, 2020 10:05 pm
3. When I installed 469a on my pc I couldn't join some 469 servers as it said my engine.u wasn't approved by md5. I tried a different engine.u file from beta 469 but no luck. So I rolled everything back to beta and I then I could connect.
So I guess those servers must update to 469a?
That question was asked in the OldUnreal 469 release thread (https://www.oldunreal.com/cgi-bin/yabb2 ... 6518/10#10) and the answer was YES - those servers would be running earlier releases of 469.

User avatar
sektor2111
Godlike
Posts: 5379
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: 469 Server questions

Post by sektor2111 » Tue Sep 29, 2020 5:26 am

Cough, I rolled back a 469 server to 451b at NfoServers because they rammed my previous XC install. I've executed a few PC operating specific tasks getting over "protections" which look hard-coded and addicted to certain names - but nothing happens if you are changing names... lol, and switch folders. Using a smarty commander VIA FTP for making changes, nothing exploded and server could start after copying a few required things specific to their services in newer System folder - required for external server control. The rest of folders can have the same deal. They did not allow me to remove Assault maps and then I renamed them for not being loaded by any MapVote - I'm not using Assault there only MH MA DM CTF. System folder having 469 junks I renamed it to System_Trash0. Things are easy over there... except when you want another run-line - that's doable only by one of their service OPs.
I think you might try to do the same from 451 to 469 but... taking those two new textures in account too and properly using another folder declared in UT Paths.

User avatar
Gustavo6046
Godlike
Posts: 1218
Joined: Mon Jun 01, 2015 7:08 pm
Personal rank: Zeta Group leader
Location: Brazil

Re: 469 Server questions

Post by Gustavo6046 » Wed Sep 30, 2020 1:03 am

I branched my copy of UT99 in Git, and updated it with v469. I had to comment XC_Engine out, because it is incompatible with the current alpha of v469. To be fair, XC_Engine existed primarily to remedy the lack of official patches a little. I like XC_Engine myself, but it is important to realize that XC_Engine is an unofficial community patch, and an addon pack that unfortunately depends on the former and is not forwards-compatible (future-proof) with newer versions. v469 is basically official, even if OldUnreal is developing it - it is overseen by Epic themselves, unlike XC_Engine.

I really wish Higor had released all the other addons separately, maybe refactor XC_Engine a bit so only a bit of glue code would have to change between UT versions. This way, among other much needed reliefs, sektor and other lunatics would stop incessantly bitching about this all

User avatar
Deepu
Skilled
Posts: 238
Joined: Mon Nov 11, 2013 7:56 am
Personal rank: Average
Location: India

Re: 469 Server questions

Post by Deepu » Wed Sep 30, 2020 2:18 am

Installed new patch in my cloud server, it seems everything working fine 😉

User avatar
sektor2111
Godlike
Posts: 5379
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: 469 Server questions

Post by sektor2111 » Wed Sep 30, 2020 6:12 am

Gustavo6046 wrote:
Wed Sep 30, 2020 1:03 am
This way, among other much needed reliefs, sektor and other lunatics would stop incessantly bitching about this all
Like it can be seen, even in past posting, YOU are The Lunatic in stage demonstrating this in your mainly OFF TOPIC type replies - even here you say nothing about Servers subject - NfoServers, but you did not forgot mentioning ME, attacking constantly - no worries, it will be my turn - unexpectedly.

My crashes are happening WITHOUT XC_Engine or WITH XC_Engine exactly in the Same SITUATION and logs are Identical. You are bitching at XC for no reason as long as you did not made anything with it but for me it helps in running more borked maps and I have no plans to remove X maps as lunatics are thinking and also not removing other helping XC tools because you have no clue what I'm using after all - specific to a lunatic and bugs free. If these are not going to be fixed I have no reason to do any update at my server as long as there I run things which 469 won't run very soon and then I'm not going to remove mods just because of UT469 - I can ignore it in end.

NfoServers did a wrong thing with that Non-Public 469 version and I had to screw up what they did for recovering server.
AND THEN, because a server is not using render and audio stuff shown on GUI as in client, perhaps is running solid like a rock as long as audio bugs and changes are no longer executed so it's probably good for servers, if not even perfect. But... NOPE, UT469 it's not ready as other lunatics are thinking. Yesterday I witnessed another issue in Editor at rendering chapter, this coming nearby Audio things and the only ZERO crusher is a beta older OpenAL working but it sounds screwed. Render issue was similar to what Diego was posting but not in XOpenGL which for me doesn't even starts - Perhaps Diego and others are lunatics too because 469 needs another hardware which has to be bought first, suuuure...

In mean time - I've configured a 469 RX server - yes, it works perfectly - out of render, audio, and all those client interfaces.

User avatar
Gustavo6046
Godlike
Posts: 1218
Joined: Mon Jun 01, 2015 7:08 pm
Personal rank: Zeta Group leader
Location: Brazil

Re: 469 Server questions

Post by Gustavo6046 » Wed Sep 30, 2020 7:07 pm

I never stated v469 was already ready for production. In fact, if anything I don't commend people already trying to host servers with those pre-release versions. It's unstable, unsafe, and just generally unsound.

Casual Gamer
Novice
Posts: 3
Joined: Mon Sep 28, 2020 9:52 pm
Personal rank: Casual Gamer

Re: 469 Server questions

Post by Casual Gamer » Wed Sep 30, 2020 8:57 pm

Okay, I think I will keep my current server 451 version for now. But I will look into a virtual server, just out of curiosity. Thanks for the help.

User avatar
esnesi
Inhuman
Posts: 801
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: Dialed in.

Re: 469 Server questions

Post by esnesi » Wed Sep 30, 2020 9:08 pm

Deepu wrote:
Wed Sep 30, 2020 2:18 am
cloud
Image

User avatar
sektor2111
Godlike
Posts: 5379
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: 469 Server questions

Post by sektor2111 » Thu Oct 01, 2020 6:26 am

Casual Gamer wrote:
Wed Sep 30, 2020 8:57 pm
Okay, I think I will keep my current server 451 version for now. But I will look into a virtual server, just out of curiosity. Thanks for the help.
But definitely you can do some checks as long as a dedicated server won't use all sort of client assets and so far I did not see any damage.
By example you can look for EUTSource mods, there you can find INI samples for a dedicated server. I wasn't really surprised to see those Display/Render/Audio things commented out. Even Browsing Servers section in a dedicated server INI file has no purpose. Dedicated servers won't join to any game anywhere neither browsing other servers...

Casual Gamer
Novice
Posts: 3
Joined: Mon Sep 28, 2020 9:52 pm
Personal rank: Casual Gamer

Re: 469 Server questions

Post by Casual Gamer » Fri Oct 02, 2020 5:03 am

Thanks for the help everyone. Lots of quick answers here. Have a good night!