I need a little help with my new UT99 CTF server

Discussions about Servers
User avatar
[NBK]DxTrEm3Fx
Experienced
Posts: 113
Joined: Wed May 09, 2012 5:56 pm
Location: Glendale, AZ

I need a little help with my new UT99 CTF server

Post by [NBK]DxTrEm3Fx » Thu May 12, 2022 4:11 pm

What's Up? Is it possible for someone to help me get my UT99 CTF server working correctly?
I have edited the UT.INI and the Bots will not spawn in a Multiplayer game along with the Team Balance isn't working and adding bots as needed. The Botpack.CTFMapList isn't working. It keeps starting with CTF-Face map and that map isn't even listed in the CTF map list. Below is what I have added to my UT.INI. I do not have any mods or map vote running, it is just a stock server so far with a few custom maps. When I reboot the server it always starts on CTF-Face and no bots are added to play against me.

[Botpack.CTFGame]
bUseTranslocator=True
bCoopWeaponMode=True
GoalTeamScore=10.000000
bNoTeamChanges=False
FriendlyFireScale=0.000000
MinPlayers=16
AirControl=0.550000
MaxTeams=2
MaxTeamSize=16
FragLimit=0
TimeLimit=0
bMultiWeaponStay=True
bForceRespawn=False
MaxCommanders=2
bNoMonsters=False
bHumansOnly=False
bClassicDeathMessages=False
MinFOV=80.000000
MaxFOV=130.000000
MaxNameChanges=0

[Botpack.TeamGamePlus]
bBalanceTeams=True
GoalTeamScore=30.000000
bPlayersBalanceTeams=False
bNoTeamChanges=False
FriendlyFireScale=0.000000
MaxTeams=2
MaxTeamSize=10
FragLimit=30
TimeLimit=0
bMultiWeaponStay=True
bForceRespawn=False
bUseTranslocator=True
MaxCommanders=0
bNoMonsters=False
bHumansOnly=False
bCoopWeaponMode=False
bClassicDeathMessages=False
MinFOV=80.000000
MaxFOV=130.000000
MaxNameChanges=0

[Botpack.CTFMapList]
Maps[0]=CTF-FSW-Hotel-FreakShow2021.unr
Maps[1]=CTF-NBK-NaliTemple-Dx2021][.unr
Maps[2]=CTF-NBK-pillars-Dx-2021.unr
Maps[3]=CTF-Gauntlet.unr
Maps[4]=CTF-Dreary.unr
Maps[5]=CTF-LavaGiant.unr
Maps[6]=CTF-November.unr
Maps[7]=CTF-Gauntlet.unr
Maps[8]=CTF-Command.unr
Maps[9]=CTF-Coret.unr
Image

User avatar
sektor2111
Godlike
Posts: 5810
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: I need a little help with my new UT99 CTF server

Post by sektor2111 » Thu May 12, 2022 7:46 pm

Server is probably using another INI file such as Server.ini - you have to investigate server.log file for figuring what is being used/read. In other hand, without to know more details I cannot talk what else might be wrong or not.

Buggie
Godlike
Posts: 1313
Joined: Sat Mar 21, 2020 5:32 am

Re: I need a little help with my new UT99 CTF server

Post by Buggie » Thu May 12, 2022 9:12 pm

1. Server always start on map which you specify in start line AFAIK.

2. For bot spawn need set
[Botpack.DeathMatchPlus]
MinPlayers=8

Best use for this mutator DynamicBotCount: viewtopic.php?f=7&t=14446

3. bPlayersBalanceTeams=False mean players never balanced. Only bots if bBalanceTeams=True

User avatar
[NBK]DxTrEm3Fx
Experienced
Posts: 113
Joined: Wed May 09, 2012 5:56 pm
Location: Glendale, AZ

Re: I need a little help with my new UT99 CTF server

Post by [NBK]DxTrEm3Fx » Thu May 12, 2022 9:35 pm

As far as I know, there is no server.ini file in the system folder for UT99. Not sure if this needs to be created from scratch. I have a backup folder of my old CTF server that was running back in 2016 and there is no server.ini in my archive of files. The console log is posted below and I see CTF-Face is being loaded and not sure why.
This is a search of my files for the word Server in the UT99 system folder. No server.ini
Image




Server Log:

Code: Select all

[OVERLORD] DEBUG    AppDir: /usr/local/games/ut/1083073/68.232.164.232:7777/System
[OVERLORD] DEBUG    Executable: ./ucc-bin
[OVERLORD] DEBUG    Parameters: server CTF-Face?game=Botpack.CTFGame?MaxPlayers=10 ini=UnrealTournament.ini multihome=68.232.164.232 port=7777 -nohomedir
[OVERLORD] INFO     Starting server
WARNING: Not using preference directory
Executing Class Engine.ServerCommandlet
Unreal engine initialized
Browse: CTF-Face?Name=Player?Class=Botpack.TMale2?team=0?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?game=Botpack.CTFGame?MaxPlayers=10
LoadMap: CTF-Face?Name=Player?Class=Botpack.TMale2?team=0?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?game=Botpack.CTFGame?MaxPlayers=10
Bound to Fire.so
Case-insensitive search: Botpack -> ../System/BotPack.u
Bound to IpDrv.so
Case-insensitive search: utcrypt -> ../Textures/UTcrypt.utx
Case-insensitive search: genfluid -> ../Textures/GenFluid.utx
Collecting garbage
Purging garbage
Garbage: objects: 17119->17118; refs: 226768
Game class is 'CTFGame'
Sockets: Socket queue 262144 / 262144
TcpNetDriver on port 7777
Server Package: SoldierSkins
Case-insensitive search: SoldierSkins -> ../Textures/Soldierskins.utx
Server Package: CommandoSkins
Server Package: FCommandoSkins
Server Package: SGirlSkins
Server Package: BossSkins
Server Package: BossSkin_DxFx
Server Package: BossSkins_Dxtre
Server Package: BossSkins_BDCDigitHead
Server Package: BossSkins_TeamNBK
Server Package: BossSkins_NTBDX
Server Package: BossNBK_CLAN
Server Package: Boss_NBKKiller
Server Package: BossSkins_DIGIT
Server Package: SoldierSkins_DxSoldier
Server Package: Botpack
Case-insensitive search: Botpack -> ../System/BotPack.u
Server Package: swJumpPad
Spawning: IpDrv.UdpBeacon
Spawning: IpServer.UdpServerQuery
Spawning: IpServer.UdpServerUplink
Spawning: IpServer.UdpServerUplink
Spawning: IpServer.UdpServerUplink
Spawning: UWeb.WebServer
Bound to UWeb.so
Level is Level CTF-Face.MyLevel
Bringing Level CTF-Face.MyLevel up for play (20)...
InitGame: ?Name=Player?Class=Botpack.TMale2?team=0?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?game=Botpack.CTFGame?MaxPlayers=10
MaxPlayers 10
Base Mutator is CTF-Face.DMMutator0
UdpServerQuery(crt): Port 7778 successfully bound.
DoUplink is not set.  Not connecting to Master Server.
DoUplink is not set.  Not connecting to Master Server.
DoUplink is not set.  Not connecting to Master Server.
Initiating local logging...
Initiating world logging...
Game engine initialized
UDP recvfrom error: 11 from 0.0.0.0:0

Automatically merged

@buggie thank you that fixed my bot issue they are now loading into the server. I will look into the mutator
[Botpack.DeathMatchPlus]
MinPlayers=8
Image

User avatar
sektor2111
Godlike
Posts: 5810
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: I need a little help with my new UT99 CTF server

Post by sektor2111 » Thu May 12, 2022 9:56 pm

Yes, it starts with CTF-Face and it uses UnrealTournament.ini as configuration. First time when I configured such a server I used loved* settings from my local practice (and non-dedicated server) game where I had Bots as I wanted. From game's menu you can check what options you need and these are saved in INI file which later can be future configuration template for a server. The only future editing is concerning ServerPackages - in your case swJumpPad doesn't need to be added there because is mapped automatically by Engine for maps which are using it.

User avatar
[NBK]DxTrEm3Fx
Experienced
Posts: 113
Joined: Wed May 09, 2012 5:56 pm
Location: Glendale, AZ

Re: I need a little help with my new UT99 CTF server

Post by [NBK]DxTrEm3Fx » Thu May 12, 2022 11:22 pm

@ sektor2111 Thank you for the info I will remove swJumpPad from the server packages in the UT.ini
Image

Buggie
Godlike
Posts: 1313
Joined: Sat Mar 21, 2020 5:32 am

Re: I need a little help with my new UT99 CTF server

Post by Buggie » Thu May 12, 2022 11:29 pm

[NBK]DxTrEm3Fx wrote:
Thu May 12, 2022 9:40 pm
I see CTF-Face is being loaded and not sure why.

Code: Select all

[OVERLORD] DEBUG    Executable: ./ucc-bin
[OVERLORD] DEBUG    Parameters: server CTF-Face?game=Botpack.CTFGame?MaxPlayers=10 ini=UnrealTournament.ini multihome=68.232.164.232 port=7777 -nohomedir
Because you call from command line it. Look at .sh file.

User avatar
[NBK]DxTrEm3Fx
Experienced
Posts: 113
Joined: Wed May 09, 2012 5:56 pm
Location: Glendale, AZ

Re: I need a little help with my new UT99 CTF server

Post by [NBK]DxTrEm3Fx » Sat May 14, 2022 7:47 pm

@biggie Thank you for your help. I forgot there was a command line, all issues have been resolved.
Image