[solved] XServerQuery - Server missing in Browser list

Discussions about Servers
User avatar
Barbie
Godlike
Posts: 2480
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

[solved] XServerQuery - Server missing in Browser list

Post by Barbie » Mon Nov 14, 2022 3:43 pm

EDIT 24 Nov 2022: Problem solved: only ports 9999 and 10000 were open in firewall. But port 10001 was needed also.
Same configuration for a server as in a working one:

UnrealTournament.ini
Show

Code: Select all

[XServerQuery.XServerQuery]
netAddress=
homepage=https://forum.barbies.world/
bSendMailURL=true
bShowProtection=hidden
bShowSpectators=true
bShowPlayerCountry=true
iMaxConnPerIPPerSec=2
iNumPacketsBeforBlock=8
iNumSecToBlockIP=5
bLogSpecialQuerys=true
bLogUnknownQuerys=true
bShowTimeStamp=true
bShowAdvancedTimeStamp=false



Engine.GameEngine]
CacheSizeMegs=4
UseSound=True
ServerActors=IpDrv.UdpBeacon

ServerActors=XServerQuery.XServerQuery
ServerActors=XServerQuery.XServerUplink MasterServerAddress=unreal.epicgames.com MasterServerPort=27900
ServerActors=XServerQuery.XServerUplink MasterServerAddress=utmaster.epicgames.com MasterServerPort=27900
ServerActors=XServerQuery.XServerUplink MasterServerAddress=master.mplayer.com MasterServerPort=27900
ServerActors=XServerQuery.XServerUplink MasterServerAddress=master.333networks.com MasterServerPort=27900
ServerActors=XServerQuery.XServerUplink MasterServerAddress=master.oldunreal.com MasterServerPort=27900
ServerActors=XServerQuery.XServerUplink MasterServerAddress=master.errorist.eu MasterServerPort=27900
ServerActors=XServerQuery.XServerUplink MasterServerAddress=master.qtracker.com MasterServerPort=27900
ServerActors=XServerQuery.XServerUplink MasterServerAddress=master.telefragged.com MasterServerPort=27500
ServerActors=XServerQuery.XServerUplink MasterServerAddress=master.newbiesplayground.net MasterServerPort=27900
But the Monsterhunt Tank Server does not show up in client's server browser. :???:
Last edited by Barbie on Sun Nov 27, 2022 10:21 am, edited 2 times in total.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

Buggie
Godlike
Posts: 1773
Joined: Sat Mar 21, 2020 5:32 am

Re: XServerQuery - Server missing in Browser list

Post by Buggie » Mon Nov 14, 2022 6:36 pm

You do not have the required permissions to view the files attached to this post.

User avatar
Barbie
Godlike
Posts: 2480
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: XServerQuery - Server missing in Browser list

Post by Barbie » Tue Nov 15, 2022 12:26 pm

Buggie wrote:
Mon Nov 14, 2022 6:36 pm
In-Game too:
Strange, even days after starting, the server "Barbies Monsterhunt Tank World" at port 9999 does not appear here:
UTBrowserList.jpg
(Ofc I tried different sort orders by Map, by Game type.)
UBrowserAll-Section in client's UnrealTournament.ini
Show

Code: Select all

[UBrowserAll]
ListFactories[0]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.333networks.com,MasterServerTCPPort=28900,Region=0,GameName=ut
ListFactories[1]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.noccer.de,MasterServerTCPPort=28900,Region=0,GameName=ut
ListFactories[2]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.errorist.tk,MasterServerTCPPort=28900,Region=0,GameName=ut
ListFactories[3]=UBrowser.UBrowserGSpyFact,MasterServerAddress=utmaster.epicgames.com,MasterServerTCPPort=28900,Region=0,GameName=ut
bHidden=True
bFallbackFactories=False
ServerListTitle=
ListFactories[3]=
ListFactories[4]=
ListFactories[5]=
ListFactories[6]=
ListFactories[7]=
ListFactories[8]=
ListFactories[9]=
URLAppend=
AutoRefreshTime=0
bNoAutoSort=False
You do not have the required permissions to view the files attached to this post.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

User avatar
OjitroC
Godlike
Posts: 3095
Joined: Sat Sep 12, 2015 8:46 pm

Re: XServerQuery - Server missing in Browser list

Post by OjitroC » Tue Nov 15, 2022 12:34 pm

Barbie wrote:
Tue Nov 15, 2022 12:26 pm

Strange, even days after starting, the server "Barbies Monsterhunt Tank World" at port 9999 does not appear here: UTBrowserList.jpg
(Ofc I tried different sort orders by Map, by Game type.)
No idea really but the screenshot shows the XBrowser window whilst the UT ini extract show the UBrowser settings - would need to look at the XBrowser settings (in XBrowser.ini)?

Buggie
Godlike
Posts: 1773
Joined: Sat Mar 21, 2020 5:32 am

Re: XServerQuery - Server missing in Browser list

Post by Buggie » Tue Nov 15, 2022 12:52 pm

IDK. My settings near same:

Code: Select all

[UBrowserAll]
ListFactories[0]=UBrowser.UBrowserGSpyFact,MasterServerAddress=utmaster.epicgames.com,MasterServerTCPPort=28900,Region=0,GameName=ut
ListFactories[1]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.333networks.com,MasterServerTCPPort=28900,GameName=ut
ListFactories[2]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.hlkclan.net,MasterServerTCPPort=28900,GameName=ut
ListFactories[3]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.oldunreal.com,MasterServerTCPPort=28900,GameName=ut
ListFactories[4]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.errorist.eu,MasterServerTCPPort=28900,GameName=ut
ListFactories[5]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.hypercoop.tk,MasterServerTCPPort=28900,GameName=ut
ListFactories[6]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.openspy.net,MasterServerTCPPort=28900,GameName=ut
ListFactories[7]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master2.oldunreal.com,MasterServerTCPPort=28900,GameName=ut
ListFactories[8]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.telefragged.com,MasterServerTCPPort=28900,GameName=ut
ListFactories[9]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.qtracker.com,MasterServerTCPPort=28900,GameName=ut
ListFactories[10]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.newbiesplayground.net,MasterServerTCPPort=28900,GameName=ut
ListFactories[11]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master.gonespy.com,MasterServerTCPPort=28900,GameName=ut
ListFactories[12]=UBrowser.UBrowserGSpyFact,MasterServerAddress=darkelarious.blicky.net,MasterServerTCPPort=28900,GameName=ut
bHidden=True
bFallbackFactories=False
ServerListTitle=
URLAppend=
AutoRefreshTime=0
bNoAutoSort=False

User avatar
Barbie
Godlike
Posts: 2480
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: XServerQuery - Server missing in Browser list

Post by Barbie » Tue Nov 15, 2022 12:56 pm

OjitroC wrote:
Tue Nov 15, 2022 12:34 pm
the UT ini extract show the UBrowser settings
Ups. :oops:
Parts of client's XBrowser.ini
Show

Code: Select all

[XBrowser.XBrowserTabInternet]
bKeepMasterServer=True
bFallbackFactories=True
MasterServer[0]=XBrowser.XBrowserFactInternet,MasterServerAddress=utmaster.epicgames.com,MasterServerTCPPort=28900,GameName=ut
MasterServer[1]=XBrowser.XBrowserFactInternet,MasterServerAddress=333networks.com,MasterServerTCPPort=28900,GameName=ut
MasterServer[2]=XBrowser.XBrowserFactInternet,MasterServerAddress=unreal.epicgames.com,MasterServerTCPPort=28900,GameName=ut
MasterServer[3]=XBrowser.XBrowserFactInternet,MasterServerAddress=master.errorist.tk,MasterServerTCPPort=28900,GameName=ut
MasterServer[4]=XBrowser.XBrowserFactInternet,MasterServerAddress=master.oldunreal.com,MasterServerTCPPort=28900,GameName=ut
MasterServer[5]=
MasterServer[6]=
MasterServer[7]=
MasterServer[8]=
MasterServer[9]=

[XBrowser.XBrowserSettings]
bHideLanTab=False
bHideHistoryTab=False
bHidePlayerList=False
bHideServerDetails=False
bHidePopupNotify=True
bHideBlacklistedServers=False
bHideEmptyServers=False
bHideFullServers=False
bHideLockedServers=False
bCleanHostName=False
FilterList[0]=UT Servers,bCompatibleServersOnly=True,bHideTOServers=True
FilterList[1]=Deathmatch,GameType=DeathMatchPlus,bCompatibleServersOnly=True
FilterList[2]=Team Deathmatch,GameType=TeamGamePlus,bCompatibleServersOnly=True
FilterList[3]=Capture the Flag,GameType=CTFGame,MapName=CTF-*,bCompatibleServersOnly=True
FilterList[4]=BunnyTrack,GameType=BunnyTrackGame,bCompatibleServersOnly=True
FilterList[5]=Monster Hunt,MapName=MH-*,bCompatibleServersOnly=True
FilterList[6]=Assault,MapName=AS-*,bCompatibleServersOnly=True
FilterList[7]=Last Man Standing,GameType=LastManStanding,bCompatibleServersOnly=True
FilterList[8]=Residual,GameType=:residual:
bShowSearchBar=False
(all other entries are empty)
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

Buggie
Godlike
Posts: 1773
Joined: Sat Mar 21, 2020 5:32 am

Re: XServerQuery - Server missing in Browser list

Post by Buggie » Tue Nov 15, 2022 12:57 pm

In XBrowser.ini I see next settings:

Code: Select all

[XBrowser.XBrowserTabInternet]
bKeepMasterServer=True
bFallbackFactories=True
MasterServer[0]=XBrowser.XBrowserFactInternet,MasterServerAddress=utmaster.epicgames.com,MasterServerTCPPort=28900,Region=0,GameName=ut
MasterServer[1]=XBrowser.XBrowserFactInternet,MasterServerAddress=333networks.com,MasterServerTCPPort=28900,Region=0,GameName=ut
MasterServer[2]=XBrowser.XBrowserFactInternet,MasterServerAddress=unreal.epicgames.com,MasterServerTCPPort=28900,Region=0,GameName=ut
MasterServer[3]=XBrowser.XBrowserFactInternet,MasterServerAddress=master.errorist.tk,MasterServerTCPPort=28900,Region=0,GameName=ut
MasterServer[4]=XBrowser.XBrowserFactInternet,MasterServerAddress=master.oldunreal.com,MasterServerTCPPort=28900,Region=0,GameName=ut
Which is not good. bFallbackFactories must be false. And list of master servers must be wider.

Look like you need check this file.

Automatically merged

bFallbackFactories=True
MasterServer[0]=XBrowser.XBrowserFactInternet,MasterServerAddress=utmaster.epicgames.com,MasterServerTCPPort=28900,GameName=ut

This mean - use only one master servers - other use as fallbacks. So it connect only in first one and only if fail, to second and so on.
If false - it connect to all masters ervers.

So effectively you query only epic master server. On which (look like) your server not registered somehow.
So because of that you not see server, when I see it, since i query ALL master servers and some of them (333) send your server, since server registered on it.

User avatar
Barbie
Godlike
Posts: 2480
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: XServerQuery - Server missing in Browser list

Post by Barbie » Fri Nov 18, 2022 3:55 pm

Apart from original question, because this is the situation at a 469c client:
It does not matter what combination of TRUE/FALSE for bKeepMasterServer and bFallbackFactories I use: the "Barbies Monsterhunt Tank Server" is only shown up is server browser if "333networks.com" is in front of "utmaster.epicgames.com" inlist. So I suspect that if MasterServer[0] is reachable, other MasterServers are not connected regardless of bFallbackFactories.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

User avatar
OjitroC
Godlike
Posts: 3095
Joined: Sat Sep 12, 2015 8:46 pm

Re: XServerQuery - Server missing in Browser list

Post by OjitroC » Fri Nov 18, 2022 4:55 pm

Barbie wrote:
Fri Nov 18, 2022 3:55 pm
Apart from original question, because this is the situation at a 469c client:
It does not matter what combination of TRUE/FALSE for bKeepMasterServer and bFallbackFactories I use: the "Barbies Monsterhunt Tank Server" is only shown up is server browser if "333networks.com" is in front of "utmaster.epicgames.com" inlist. So I suspect that if MasterServer[0] is reachable, other MasterServers are not connected regardless of bFallbackFactories.
That is indeed the case with 451 as well - interestingly I get more servers showing up if I have "utmaster.epicgames.com" rather than "333networks.com" as MasterServer[0] - nothing in the log suggests an attempt is made to connect to my second MasterServer "333networks.com".

Buggie
Godlike
Posts: 1773
Joined: Sat Mar 21, 2020 5:32 am

Re: XServerQuery - Server missing in Browser list

Post by Buggie » Fri Nov 18, 2022 5:24 pm

Weird. Sounds as XBrowser bug, since stock server browser respect this options AFAIK.

User avatar
Barbie
Godlike
Posts: 2480
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: XServerQuery - Server missing in Browser list

Post by Barbie » Fri Nov 18, 2022 9:41 pm

Buggie wrote:
Fri Nov 18, 2022 5:24 pm
Weird. Sounds as XBrowser bug, since stock server browser respect this options AFAIK.
I switched back to stock server browser and can confirm that toggling bFallbackFactories works then as described.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

Buggie
Godlike
Posts: 1773
Joined: Sat Mar 21, 2020 5:32 am

Re: XServerQuery - Server missing in Browser list

Post by Buggie » Fri Nov 18, 2022 9:57 pm

I look into XBrowser code and can confirm - it use only one source always. And bFallbackFactories only serve as flag for use (or not) next source if and only if previous failed.
So this is make XBrowser completely useless if you need use few master servers at same time, like stock browser do.

Which is super weird. Possible it based on very outdated code. I can not see another rational explanation for such great regression.

Automatically merged

I check v436 sources and it is multi-source capable. So I really no idea why XBrowser (which developed in 2014 if believe source comments) single-sourced.

User avatar
Barbie
Godlike
Posts: 2480
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: XServerQuery - Server missing in Browser list

Post by Barbie » Fri Nov 18, 2022 10:35 pm

Maybe the author of XBrowser has misunderstood bFallbackFactories as I did: only if TRUE, use MasterServer[i+1] if MasterServer[i] fails (regardless if this makes sense or not).
A name like bUseFirstFactoryOnly would have been more descriptive.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

User avatar
Barbie
Godlike
Posts: 2480
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: XServerQuery - Server missing in Browser list

Post by Barbie » Thu Nov 24, 2022 12:59 am

I found the reason: In the firewall only ports 9999 and 10000 were enabled. But for some of the master servers port 10001 is needed for queries also.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

Eternity
Experienced
Posts: 121
Joined: Sat Nov 30, 2019 10:56 pm

Re: XServerQuery - Server missing in Browser list

Post by Eternity » Sun Nov 27, 2022 6:00 am

Buggie wrote:
Fri Nov 18, 2022 10:03 pm
I look into XBrowser code and can confirm - it use only one source always. And bFallbackFactories only serve as flag for use (or not) next source if and only if previous failed.
So this is make XBrowser completely useless if you need use few master servers at same time, like stock browser do.

Which is super weird. Possible it based on very outdated code. I can not see another rational explanation for such great regression.

Automatically merged

I check v436 sources and it is multi-source capable. So I really no idea why XBrowser (which developed in 2014 if believe source comments) single-sourced.
There is some chance it might be redesigned in the next version ( viewtopic.php?f=34&t=3284&p=135966&hili ... er#p135767 ).
I take it as a serious disadvantage. But very few users have mentioned this issue so far, which indicates it is not important that much overall. So i estimate that chance is quite small...