XVehicles (Network play) (VCTF, VMH for UT99)

Need some nice Mods? Here, you are right!
User avatar
OjitroC
Godlike
Posts: 3252
Joined: Sat Sep 12, 2015 8:46 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by OjitroC »

EvilGrins wrote: Thu Jun 09, 2022 11:04 pm
OjitroC wrote: Thu Jun 09, 2022 8:50 pmI see - that does indeed stop people rushing to the end!
Had a chat about that on Fuzzy's forum. Apparently they still do...they just can't do much of anything when they get down there.
Seems pretty pointless to try to 'beat' a map without actually playing through it.

Played through to the end in a tank - good fun - got through without taking much damage. Some more observations:

1 The HellDemon, Ghost, Teleporting Zombi and the Zombi Mother (I think) do not cause any damage to a tank;

2 The log reports that 3 Ghosts 'flew out of the world' - not sure what can be done about that;

3 Lots of

Code: Select all

ScriptLog: MH-XV-GardenOfDeath_Hell.HellDemon5 Error - PlayRangedAttack should be implemented in subclass
lines in the log;

4 Also got

Code: Select all

Log: BFG9KBall MH-XV-GardenOfDeath_Hell.BFG9KBall0 (Function UDoom.BFG9KBall.Flying.BeginState:003B) PlayAnim: No mesh
in the log - not sure what the effect of this is;

5 Several of the CreatureFactories seem to spawn creatures from only one spawnpoint - that is, if one positioned the tank where only one spawnpoint was visible one could take out the majority of the monster type set to be spawned by firing at that one spawnpoint;

6 Most of the Counters seemed to be off by 10 - 12 so that a monster 'group' was stated to be completed when there were about 12 of that type still alive in the map - not sure that this is an issue though.
User avatar
EvilGrins
Godlike
Posts: 9064
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by EvilGrins »

OjitroC wrote: Fri Jun 10, 2022 12:04 amThe log reports that 3 Ghosts 'flew out of the world' - not sure what can be done about that
Not much, that's why they're not on a counter.

Already decided to opt with 1 or 2 different edits, one with the Gods monsters and the other with the Gauntlet ones. Both maps were completed over a year ago, but never setup for downloads.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758
User avatar
OjitroC
Godlike
Posts: 3252
Joined: Sat Sep 12, 2015 8:46 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by OjitroC »

Buggie wrote: Fri May 27, 2022 5:40 am v32
- Add XVehiclesHUD mutator for show in HUD who inside vehicle.
I'm not sure if it started with this version or not but Relics no longer show up in the HUD when playing with XVehicles (that is, when picking up a Relic outside a vehicle). I've only played with XVehicles in MH so not sure if it is related to the XVehicles MH mutator or not.

The Relics work (not when in a vehicle of course) but just don't show up in the HUD.
Buggie
Godlike
Posts: 1926
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

Original Relics broke HUD mutators, so quite possible it is stop work after use some HUD mutator.

But in fact, HUD mutator for XV work all time. Even if you not in vehicle. So I think problem not in it.

In upcoming v469c Relics must be almost fixed:
https://github.com/OldUnreal/UnrealTour ... issues/325

Automatically merged

I check with latest v469c beta and relics in local play draw in HUD all time, doesnot matter inside you vehicle or outside.

Automatically merged

scr_1654852161.jpg
scr_1654852144.jpg
You do not have the required permissions to view the files attached to this post.
User avatar
darkbarrage99
Experienced
Posts: 95
Joined: Fri Jan 02, 2009 12:41 am
Personal rank: Silent Lurker
Location: VA, USA

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by darkbarrage99 »

Sorry if this is the wrong place to ask. Are there any tutorials or instructions on how to properly path for the helico? I'm not seeing my sky path nodes link up in the editor.

Also I've noticed that in some maps the alt fire of the pulse gun heals vehicles and in others it does not. How is this enabled/disabled?
Buggie
Godlike
Posts: 1926
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

darkbarrage99 wrote: Sat Jun 11, 2022 10:19 pm Sorry if this is the wrong place to ask. Are there any tutorials or instructions on how to properly path for the helico? I'm not seeing my sky path nodes link up in the editor.
Unfortunately, air paths not able link in UnrealEd as for now. Maybe in v469c this be possible (but not sure, since all depends from @Anthrax decision).
But bots inside heli able travel above ground paths, but less effective. So make path on ground, as usual, and ensure there is enough space above it for ride on heli.
darkbarrage99 wrote: Sat Jun 11, 2022 10:19 pm Also I've noticed that in some maps the alt fire of the pulse gun heals vehicles and in others it does not. How is this enabled/disabled?
By default, pulse heal vehicle only if no FixGun or FixGunMutator on map.
And it heal only vehicles of your team.
You can control that heal in XVehiclesCTF mutator placed on map:

Code: Select all

enum EPulseForHeal
{
	PFH_Auto,				// Detect by presence FixGun on map, or by use FixGunMutator
	PFH_Yes,				// Pulse Heal vehicles
	PFH_No,					// Pulse not heal vehicles
};
var() EPulseForHeal PulseForHeal;
Eternity
Experienced
Posts: 136
Joined: Sat Nov 30, 2019 10:56 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Eternity »

What could be wrong in the server setup if projectiles velocity vector is always directed straight vertically either in top or in bottom direction when vehicle's Rotation has Pitch==0 and Roll==0?
I try to compare the server where this problem exists with another one where it does not, but still have not found any differences that might seem to be related... It occurs with all vehicles, except CybotHelico.
Buggie
Godlike
Posts: 1926
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

Hard to say. Possible messed defaults values for base Projectile class. Need make dump of projectile on bugged server and good one and compare.
use playersonly + editactor + v469c preview, for get and compare actors dumps.

Automatically merged

v36

- fix rotate trail rotor for heli over net.
- Make flag on roof transparent for net owner inside vehicle.
- Fix display flag on vehicle roof.
- Add hit sound for vehicle with enemy for UTPure compatible controllers.
- Fix fake idle movement vehicles on slopes.
- Fix Initial position of vehicles.
- Try fix stuck in ground for NewNet+ controllers.

Updated in first post: viewtopic.php?f=34&t=14936

Automatically merged

v37

- Fix move treads on slopes and bugs in tank movement near zero speed on change direction.
- Fix bugs in jeeps movement near zero speed on change direction.
- Fix move treads on net.
- Fix detect vehicle on ground for v436.
- Fix track movement for v436.
- Fix bugs with tanks movement and display position.

Updated in first post: viewtopic.php?f=34&t=14936
Buggie
Godlike
Posts: 1926
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

Eternity
Experienced
Posts: 136
Joined: Sat Nov 30, 2019 10:56 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Eternity »

Buggie wrote: Sun Jun 12, 2022 7:07 pm Hard to say. Possible messed defaults values for base Projectile class. Need make dump of projectile on bugged server and good one and compare.
use playersonly + editactor + v469c preview, for get and compare actors dumps.
Interesting is that if a copy of "bugged" server is running in Windows OS, this problem doesn't occur.
And opposite, a copy of another server that worked in Windows OS and didn't have this problem, begin to have this problem if running in Linux OS.
In both OS same version used - v469c-Test45.

Something similar happened with NWModifiersVIII.ModifCharger in v451 Linux build - so far i have never seen any information what exactly was causing this problem and why it doesn't occur in v469 Linux build anymore (was it tracked down and fixed, or, by occasion, just doesn't appear anymore in this specific case). It still can be seen, for example, in dU NWIII server that matches this criteria - v451 running in Linux OS.
Buggie
Godlike
Posts: 1926
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

v38

- Reduce CPU usage.
- Fix flood in the log.

Updated in first post: viewtopic.php?f=34&t=14936
User avatar
EvilGrins
Godlike
Posts: 9064
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by EvilGrins »

Hmmmm...
You do not have the required permissions to view the files attached to this post.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758
Eternity
Experienced
Posts: 136
Joined: Sat Nov 30, 2019 10:56 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Eternity »

Eternity wrote: Sun Jun 12, 2022 7:14 am What could be wrong in the server setup if projectiles velocity vector is always directed straight vertically either in top or in bottom direction when vehicle's Rotation has Pitch==0 and Roll==0?
I try to compare the server where this problem exists with another one where it does not, but still have not found any differences that might seem to be related... It occurs with all vehicles, except CybotHelico.
Something is completely wrong with VActor Rotation when Roll is equal to 0... Yaw then becomes 0, and Pitch - either 0 or 16383/-16383.
Though, Rotation replicated to client is correct, only Projectile velocity Vector indicated that issue exists.
It affects Vehicle, VehicleAttachment and WeaponAttachment subclasses...
You do not have the required permissions to view the files attached to this post.
Buggie
Godlike
Posts: 1926
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

Need more info and way for reproduce.
User avatar
EvilGrins
Godlike
Posts: 9064
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by EvilGrins »

That awkward moment where you're testing an XV map and in order to do the full thing you have to get to the end... and you discover one of the monsters on the map is too powerful to beat with XV.
You do not have the required permissions to view the files attached to this post.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758