NW3 Ultra Gore SSE

Need some nice Mods? Here, you are right!
User avatar
Feralidragon
Godlike
Posts: 5431
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: NW3 Ultra Gore SSE

Post by Feralidragon » Sat Jun 08, 2013 10:50 am

So basically, it was working before, but when you added something more it stopped working, right? By looking at your .ini I can't spot the problem, it should work.
Which exact line(s) did you add that made it stop working?

Either ways spotted a small detail on it:
The entry: GoreBloodTypes[7]=(VictClassName="Bot",VictModel="BotPack.*",VictSkin="*",VictSkinID=0,BloodType="Red")
Should be switched with the first: GoreBloodTypes[0]=(VictClassName="Bot",VictModel="BotPack.TBossBot",VictSkin="*",VictSkinID=0,BloodType="Silver")

Otherwise the Boss model gore will be red, this since those lists work like CSS (Cascading Style Sheets), so more detailed settings come last, and more generic stay on top, since I evaluate it backwards (from the end of the list to the beginning).

User avatar
EvilGrins
Godlike
Posts: 8723
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: NW3 Ultra Gore SSE

Post by EvilGrins » Mon Jun 10, 2013 9:42 am

Finally tried it, extensive screenshots later, and it was working fine for a few maps until this:
Image

Translation please?

Other than that, great! Gore sliding down walls. Didn't seem to ultra-gib always, normal gibbing of players had them falls down as always. Ultragore only seemed to kick in with BIG explosions.

Those blood coronas, blood mist, really like to linger:
Image

Image

Image
It's from those last 2 screenshots the error message posted above came from. May or may not've had something to do with the map having 2 instagibs on it, one for each team... so multiple gorey blasts in a compressed timeframe.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
Feralidragon
Godlike
Posts: 5431
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: NW3 Ultra Gore SSE

Post by Feralidragon » Mon Jun 10, 2013 12:18 pm

Probably it's the amount of decals. In most maps it shouldn't be problem, but in a few (generally big ones or ones that have something messed up which triggers that) the excessive rendering of decals together with other effects going on results in a crash.
This is also why the current nukes crash sometimes in big maps but only at the client (the server never does), the decals have some sort of bug which leads the rendering part of the engine to crash sometimes.

User avatar
Hitman
Skilled
Posts: 202
Joined: Mon Aug 16, 2010 11:01 am
Location: Sweden

Re: NW3 Ultra Gore SSE

Post by Hitman » Mon Jun 10, 2013 4:21 pm

Ok now I had done a lot of trial/error tests and found out that its the same issue as on my MH-NW3 server, Its the Actor IpToCountry, I thought it was ACE since the start-log breaks in the middle Of ace-start, when I disable IpToCountry all work fine.

User avatar
EvilGrins
Godlike
Posts: 8723
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: NW3 Ultra Gore SSE

Post by EvilGrins » Mon Jun 10, 2013 6:16 pm

Random notion, only as I have player models of the Sktrooper and a Skeletal released Mercenary player model...

...are you aware of the Ultra-Gore not working on Unreal1 models?

The old MoreGore mutator didn't work on them, but I haven't been playing enough with yours yet to see any real difference.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
Feralidragon
Godlike
Posts: 5431
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: NW3 Ultra Gore SSE

Post by Feralidragon » Tue Jun 11, 2013 7:53 pm

Hitman wrote:Ok now I had done a lot of trial/error tests and found out that its the same issue as on my MH-NW3 server, Its the Actor IpToCountry, I thought it was ACE since the start-log breaks in the middle Of ace-start, when I disable IpToCountry all work fine.
That IpToCountry... it certainly doesn't like my mods at all for some wicked reason... thanks for reporting back the root of the problem. :)
EvilGrins wrote:Random notion, only as I have player models of the Sktrooper and a Skeletal released Mercenary player model...

...are you aware of the Ultra-Gore not working on Unreal1 models?

The old MoreGore mutator didn't work on them, but I haven't been playing enough with yours yet to see any real difference.
The gore only works with the pawns setup in the .ini file that comes with the mod (and their subclasses, like the Skaarj work, therefore all the variations/descendents of them work too). The standard pawns are supported, now when it comes to U1, if you're using custom ones or upgraded ones in some way, the mod may not work with them, unless you add them to the .ini file.

User avatar
Sp0ngeb0b
Adept
Posts: 374
Joined: Wed Feb 13, 2008 9:16 pm
Location: Cologne

Re: NW3 Ultra Gore SSE

Post by Sp0ngeb0b » Tue Jun 11, 2013 10:37 pm

Feralidragon wrote:
Hitman wrote:Ok now I had done a lot of trial/error tests and found out that its the same issue as on my MH-NW3 server, Its the Actor IpToCountry, I thought it was ACE since the start-log breaks in the middle Of ace-start, when I disable IpToCountry all work fine.
That IpToCountry... it certainly doesn't like my mods at all for some wicked reason... thanks for reporting back the root of the problem. :)
Don't forget that I had a similiar issue with NW3 Ferali, where it turned out that it wasn't IpToCountry, but more a general engine issue which prevented the server to start (to many Mods/Actors).
Website, Forum & UTStats

Image
******************************************************************************
Nexgen Server Controller || My plugins & mods on GitHub
******************************************************************************

User avatar
Feralidragon
Godlike
Posts: 5431
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: NW3 Ultra Gore SSE

Post by Feralidragon » Tue Jun 11, 2013 11:22 pm

True, and it was fixed with a 451 upgrade iirc.
The thing is afaik Hitman upgraded to 451 as well if I am not mistaken.
Fluke had the same problem, but I don't remember if he ever confirmed to also have 451, but I think he did too.

Mods that admins claimed to break themselves or NW3 whenever NW3 was on: BTPlus, ACE Manager, IPtoCountry and there was another little something I don't remember.
UTPure doesn't work at all afaik (unless there's an updated version out there), but that's because it tries to disable or at least severally crippling every client-side feature of it and only has 8 configurable whitelisting entries for whatever reason afaik.

Either these admins have something in common in their servers that breaks everything when NW3 (or NW3 derivatives like this mod) are mixed in, or something more wacky is going on.
It would be nice if everyone with a similar problem (and already upgraded to 451) could post or PM me a simple list of your entire set of mods running (with version number if possible), so I can compare and see the common denominators, and perhaps compare them with Sponge's listing (since it's the one that works with no problems afaik).

User avatar
Sp0ngeb0b
Adept
Posts: 374
Joined: Wed Feb 13, 2008 9:16 pm
Location: Cologne

Re: NW3 Ultra Gore SSE

Post by Sp0ngeb0b » Wed Jun 12, 2013 12:02 am

Feralidragon wrote:True, and it was fixed with a 451 upgrade iirc.
Indeed, after my server provider updated to 451, everything was fine. Probably interesting to note that it was a linux server.
Feralidragon wrote: Mods that admins claimed to break themselves or NW3 whenever NW3 was on: BTPlus, ACE Manager, IPtoCountry and there was another little something I don't remember.
UTPure doesn't work at all afaik (unless there's an updated version out there), but that's because it tries to disable or at least severally crippling every client-side feature of it and only has 8 configurable whitelisting entries for whatever reason afaik.

[...], and perhaps compare them with Sponge's listing (since it's the one that works with no problems afaik).
Completely right that (and also why) UTPure is not compatible. My NW3 server has been running without issues with the following mods:

Code: Select all

AntiTweakV52
IpToCountry
Nexgen112 + Plugins
ACE v08h
SmartDM
HostnameBan

Interesting thing: I just helped a guy at unrealadmin who ran into a similar problem, with the server simply aborting the starting procedure with cutting of the log. Can be found here. He's also running 451, but a windows server. I got the small intuition that this might be a common issue with UT servers, which are unable to boot if a specific amount/size of packages/actors is loaded on startup ...
Website, Forum & UTStats

Image
******************************************************************************
Nexgen Server Controller || My plugins & mods on GitHub
******************************************************************************

User avatar
Wises
Godlike
Posts: 1089
Joined: Sun Sep 07, 2008 10:59 am
Personal rank: ...

Re: NW3 Ultra Gore SSE

Post by Wises » Wed Jun 12, 2013 2:49 am

FeraliDragon wrote:UTPure doesn't work at all afaik (unless there's an updated version out there), but that's because it tries to disable or at least severally crippling every client-side feature of it and only has 8 configurable whitelisting entries for whatever reason afaik.
I don't know what/where you find the whitelist?.. if you are talking about PlayerPacks[x]= , ok this is likely to be what you are talking about , as there are indeed [8] Slots , how interesting..

so I wonder how would we utilize these extra slots to exclude certain mods (if indeed this is possible)?..

Interesting.

*afaik , that whitelisting is for custom skins and the likes?..

however , if not ... can we simple add perhaps ; PlayerPacks[x]=NWCoreV3 or similar?

anyone ever test this kind of thing with pure?

User avatar
EvilGrins
Godlike
Posts: 8723
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: NW3 Ultra Gore SSE

Post by EvilGrins » Wed Jun 12, 2013 6:06 am

How did you pick the noise made when the bodies ultra-gib?

It sounds a lot like a water balloon splashing.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
Feralidragon
Godlike
Posts: 5431
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: NW3 Ultra Gore SSE

Post by Feralidragon » Wed Jun 12, 2013 10:41 am

@Wises: It's possible, the problem it's the fact that it has only 8 slots whereas NW3 have over 20 files. If UTPure checked the origin of the calls (since they are mostly from NWCoreV3 functions), then only the NWCoreV3 could be added, but iirc correctly that was tried and the other files would need to be added as well.
Perhaps someone needs to release a new version of UTPure with a wider range for such slots, until then while it may be useful to other mods, for the entire NW3 pack it's rather useless.

@EvilGrins: I used 2 actual gib sounds from another Unreal/UT (either from Unreal 2 or UT2k4, one of the two), and I modified them to be more apparent and to have a better kick in.

User avatar
Wises
Godlike
Posts: 1089
Joined: Sun Sep 07, 2008 10:59 am
Personal rank: ...

Re: NW3 Ultra Gore SSE

Post by Wises » Wed Jun 12, 2013 11:13 am

Feralidragon wrote:@Wises: It's possible, the problem it's the fact that it has only 8 slots whereas NW3 have over 20 files. If UTPure checked the origin of the calls (since they are mostly from NWCoreV3 functions), then only the NWCoreV3 could be added, but iirc correctly that was tried and the other files would need to be added as well.
Perhaps someone needs to release a new version of UTPure with a wider range for such slots, until then while it may be useful to other mods, for the entire NW3 pack it's rather useless.
perhaps you could do a small modification to Pure7e which is the last version released with sources.. I think the authors lost the source for pure7g :\

or we could modify that one.. you would be doing the community a favour by extending the array from 8 to 32 even 64 I am sure its just a small patch to do so however I am not experienced myself to do such things.

here is the source packages for pure <=7e: http://unrealtournament.99.free.fr/utfi ... ources.rar

I will also see if timtim can extend it in his newnet which is also ironically enough based on pure.

cheers.

User avatar
Feralidragon
Godlike
Posts: 5431
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: NW3 Ultra Gore SSE

Post by Feralidragon » Wed Jun 12, 2013 12:02 pm

Just checked, those PlayerPacks aren't whitelisting at all.
They're custom login handlers for pure, and need to have a very specific naming to them in order to work.

@Sponge: were these you were referring about back then? Because if it were these, forget it, there's no whitelisting in Pure, but there should be.

Anyway, 7E because of lack of 7G? As far as I see there's an unreleased 7H and a 7F before the 7G one. Aren't still developers working on this (given the unreleased 7F dating back to April 2012)?
Either ways, I gave a quick look through the whole thing, and it's possible to add whitelisted packages.
I probably could work on Pure to add these, it looks like it wouldn't be too hard, but I am not even sure if you are allowed to post those sources publicly? Or are they free for anyone to modify at will?

User avatar
Sp0ngeb0b
Adept
Posts: 374
Joined: Wed Feb 13, 2008 9:16 pm
Location: Cologne

Re: NW3 Ultra Gore SSE

Post by Sp0ngeb0b » Wed Jun 12, 2013 12:32 pm

Feralidragon wrote: @Sponge: were these you were referring about back then? Because if it were these, forget it, there's no whitelisting in Pure, but there should be.
I didn't really looked into Pure back then, but ye, I believed these entries are considered as a 'whitelist'. Good to know I was wrong, lol
Feralidragon wrote: I probably could work on Pure to add these, it looks like it wouldn't be too hard, but I am not even sure if you are allowed to post those sources publicly? Or are they free for anyone to modify at will?
TNSe, who was involved in the development of UTPure, just posted this on ua.org: Click - You can find all sources (even of UTPure7H) on page 2.
I would say you are basically allowed to do whatever you want with it since he threwed out the source.
Website, Forum & UTStats

Image
******************************************************************************
Nexgen Server Controller || My plugins & mods on GitHub
******************************************************************************