Big Ugly CTF map needs feedback !!!!

Tutorials and discussions about Mapping - Introduce your own ones!

Re: Big Ugly CTF map needs feedback !!!!

Postby FraGnBraG » Mon Nov 19, 2018 3:56 pm

OjitroC wrote:... Mac logs ...

So, are you running UT on a MacBook or Macintosh? Maybe what's happening has to do with that (or my map doesn't like "Apple" stuff :P )

Barbie wrote: ... XPickups.u ...

afaik I'm using the last released version of XPickups... (i'll get the details)

Barbie wrote: ... swjumppad0: ERROR: Could not calculate JumpSpeed U=[kickout200] PN=[Barbie] N=[swjumppad0] D=[swjumppad86] ...

man, I hate these jumppads things - some adjustments required i guess

Barbie wrote: ... bWaterZone=True for the tubes ...

iirc, same settings as used in ctf-HAllOfGiants - I'm not sure why pancho did that - i never questioned it.
I remember way back trying to set up fluid type settings for various situations without 100% success :(
I ended up just using the same actors and properties as HoG for these tubes - except used swJumpPads instead
(remember HoG uses traditional LE+Lc+JumpPad+Kicker setup, which was always a pain to get working)

Example: This very early (c.2001) unreleased FraGnBraG map has a massive zoomer that propels/transports players/BOTs from a floor trap door through
a long winding tube/pipe way up to the top of a giant cone where it spit the player out to fall down through several increasing gravity zones...
players/BOTs had to land on large "ring" platforms on the way down or go splat (unless the trap door at the bottom was open - then they would loop :-)
interestingly, several players/bots could wind up in the tubes, shooting each other during the trip, lol! lots of fun :P

FYI: Conical, heh (as in "cone")

EDIT: This is a better depiction of the zoomer tube:
020602 UT DM-FNB-Conical-BETA-2.jpg


Cheers
Last edited by FraGnBraG on Tue Nov 20, 2018 1:21 am, edited 1 time in total.
User avatar
FraGnBraG
Inhuman
 
Posts: 761
Joined: Sun Jun 13, 2010 5:13 pm
Location: Canada
Personal rank: Good news everyone!

Re: Big Ugly CTF map needs feedback !!!!

Postby JackGriffin » Mon Nov 19, 2018 5:16 pm

@Ojit: I had to fix several errors in CS weapons RenderOverlay but I don't think that's the problem here. Something in your renderer doesn't like that tube at all. Can you switch renderers and test?
All mazes should have a minotaur.

-Marisa Kirisame
User avatar
JackGriffin
Godlike
 
Posts: 3585
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: Hack coder

Re: Big Ugly CTF map needs feedback !!!!

Postby OjitroC » Mon Nov 19, 2018 7:02 pm

FraGnBraG wrote: So, are you running UT on a MacBook or Macintosh? Maybe what's happening has to do with that (or my map doesn't like "Apple" stuff :P )

Yes, my UT runs on an iMac within Wineskin (this provides a Windows environment).
JackGriffin wrote:@Ojit: ... Can you switch renderers and test?

Using OpenGL or D3D9 the result is the same - 'falling out of the world' or the game freezing, though the precise result on any one occasion does vary and I can't pinpoint what causes this difference.
User avatar
OjitroC
Inhuman
 
Posts: 919
Joined: Sat Sep 12, 2015 8:46 pm

Re: Big Ugly CTF map needs feedback !!!!

Postby JackGriffin » Mon Nov 19, 2018 7:33 pm

It's kind of a shot in the dark but are you using a default player model?
All mazes should have a minotaur.

-Marisa Kirisame
User avatar
JackGriffin
Godlike
 
Posts: 3585
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: Hack coder

Re: Big Ugly CTF map needs feedback !!!!

Postby OjitroC » Mon Nov 19, 2018 9:15 pm

JackGriffin wrote:It's kind of a shot in the dark but are you using a default player model?

No, I'm not - I thought of that and tried it with the TFemale1 but the result was the same. I'll try it again though with a different default model (Edit - I did and the result is the same, though it seems that with the default models I just get the 'falling out of the world' and not the freezing).

Thanks for the suggestions, much appreciated.
User avatar
OjitroC
Inhuman
 
Posts: 919
Joined: Sat Sep 12, 2015 8:46 pm

Re: Big Ugly CTF map needs feedback !!!!

Postby FraGnBraG » Tue Nov 20, 2018 1:35 am

Okay here is the info regarding XPickups ... The version I send out with maps is the last release from CMP2 v1.3

xpickup_versions1.jpg


Note - both zips are official afaik - I believe Creavion instructed me to replace the mappack xpickups files with the v1.3 ones.

Perhaps Ferali can remember specifics of that time period :)

EDIT: UPDATE ON ALT-PATHS

I made a little test map just to remind myself how they work.
There are three routes between flags, as shown:
Alt-path-test-Image1.jpg


1. When no alt paths in map - just path nodes - the only route used is 1.
by both teams - unless a fight took the FC bot into route#2, in which case he kept going.

2. Next added normal alt-paths to route 2 and 3 (selection weight of 5 and 10 respectively) which
actually caused the attackers and flag bot to randomly and regularly choose 2 or 3 instead of 1.
This is the ideal situation. IMHO.

3. Next replaced the alt paths with SmartAltPath actors. Added these to route 1 as well (this is what is
shown in the image). Selection weight was set to 0, 2, and 4 for routes 1, 2 and 3. When a bot runs through
a SAP actor then all the other SAP selection weight grow by increment of 0.5. So they should "balance out"
after a while time and allow the bot to choose the "least used" paths by making them appear more desireable.
I was believing what sektor said for a while because the buggers were only using route#1. But they did start
using route 2 and 3 more often as the match progressed. Took a while for that to happen.

My thinking is the normal old Alt paths are really the way to go and adjusting the selection weight on each by trial
and error (well observation as well) is the easiest way to go. I would _guess_ the bot already has some kind of
randomizing built in because he was just choosing from the 3 routes with no particular order or preference.

And I did not change collide actor property for any of this.

I'll probably change out the SmartAltPath for regular ones...

Cheers
User avatar
FraGnBraG
Inhuman
 
Posts: 761
Joined: Sun Jun 13, 2010 5:13 pm
Location: Canada
Personal rank: Good news everyone!

Re: Big Ugly CTF map needs feedback !!!!

Postby sektor2111 » Tue Nov 20, 2018 7:07 am

FraGnBraG wrote:3. Next replaced the alt paths with SmartAltPath actors. Added these to route 1 as well (this is what is
shown in the image). Selection weight was set to 0, 2, and 4 for routes 1, 2 and 3. When a bot runs through
a SAP actor then all the other SAP selection weight grow by increment of 0.5. So they should "balance out"
after a while time and allow the bot to choose the "least used" paths by making them appear more desireable.
I was believing what sektor said for a while because the buggers were only using route#1. But they did start
using route 2 and 3 more often as the match progressed. Took a while for that to happen.

Not really, they use these AlternatePath routes based on random sorting from CTFGame controller - they might be useful here, but not 100%. Touch is not even called if they have bCollideActors=False, just add a log line with a string in function touch and see if it does a log - if not, they are wrong set. If you want more hints check out Teleporters. Teleporter has bCollideActors=True else it won't teleport anything because it uses the same function "Touch" for teleporting pawns, it's very simple, I don't get what is the problem at setting up a bool value correctly.
I was playing a map with these SmartAlternatePath and it do works nice if actor has the right setup. Then only problem is the code growing weight without any limitation which won't help at a moment (after playing more time).
Such a debug session would be using this:
Code: Select all
function Touch( actor Other )
{
   local SmartAlternatePath A;
   if ( Level.TimeSeconds - ReTouchTime >= 4 )
   {
      log (Self.Name@call touching by@Other.Name); //Add remark slashes after debugging like in this remark to entire line after full testing
      ReTouchTime = Level.TimeSeconds;
      foreach AllActors( class 'SmartAlternatePath', A )
      {
         if (A != Self)
            A.SelectionWeight += 0.5;
         if (A.SelectionWeight > 8) //If too big might be useless
            A.SelectionWeight = 0.5; //and then get back to default letting it to grow again at next touches
      }
   }
}

Of course in age of XC_Engine I can manage to screw such a map in run-time, making it to work properly in my server - probably people will never know why do works different here and why not over there. Changes are capping that Touch by replacing execution and also making it to Collide properly.
Note:
Because of crapped forum syntax rules, you will want to put quotes for text call touching by because I could not put quotes in the code and copy pasting it directly won't compile. Sharing an UScript code in forum it's not always a solution at this point because forum will remove the two quotes showing a borked code. Also fixed code posted above by adding all required brackets. It has to be tested with logs...
User avatar
sektor2111
Godlike
 
Posts: 3609
Joined: Sun May 09, 2010 6:15 pm
Location: vect(1,1,1)

Re: Big Ugly CTF map needs feedback !!!!

Postby JackGriffin » Tue Nov 20, 2018 1:40 pm

FnB, I'm sorry I haven't kept up with things. I was sick for a bit and I'm trying to get caught up. Anyway I got around to checking server logs and your map poured out a lot into the server:

Code: Select all
Log: Possessed PlayerPawn: TMale2 CTF-BigAndUgly-BETA1.TMale4
DevNet: Join succeeded: XXXXXXX
swjumppad0: ERROR: Could not calculate JumpSpeed U=[kickout200] PN=[KingJosh] N=[swjumppad0] D=[swjumppad86]
swjumppad0: ERROR: Could not calculate JumpSpeed U=[kickout200] PN=[Dessloch] N=[swjumppad0] D=[swjumppad86]
DevPath: 1000 navigation nodes searched from DefensePoint7!
DevPath: 1000 navigation nodes searched from InventorySpot1215!
DevPath: 1000 navigation nodes searched from DefensePoint7!
DevPath: 1000 navigation nodes searched from InventorySpot1395!
DevPath: 1000 navigation nodes searched from DefensePoint7!
DevPath: 1000 navigation nodes searched from InventorySpot1223!
DevPath: 1000 navigation nodes searched from DefensePoint7!
DevPath: 1000 navigation nodes searched from InventorySpot1218!
DevPath: 1000 navigation nodes searched from DefensePoint6!
DevPath: 1000 navigation nodes searched from InventorySpot1237!
DevPath: 1000 navigation nodes searched from PathNode433!
DevPath: 1000 navigation nodes searched from FlagBase0!

It goes on like this for another several thousand lines. Today I'll test your newer map version and see if it is still there or not.
All mazes should have a minotaur.

-Marisa Kirisame
User avatar
JackGriffin
Godlike
 
Posts: 3585
Joined: Fri Jan 14, 2011 1:53 pm
Personal rank: Hack coder

Re: Big Ugly CTF map needs feedback !!!!

Postby FraGnBraG » Tue Nov 20, 2018 4:00 pm

JackGriffin wrote:... map poured out a lot into the server ... 1000 navigation nodes searched from ...


Shit! I thought I'd fixed those :/ okay, another round of cutting will be required... damn - thing might die afterall

Note - I haven't released a newer beta yet ...

I have to fix the teh alt-paths first, so might get to that tonight...!

Thanks
User avatar
FraGnBraG
Inhuman
 
Posts: 761
Joined: Sun Jun 13, 2010 5:13 pm
Location: Canada
Personal rank: Good news everyone!

Re: Big Ugly CTF map needs feedback !!!!

Postby Swanky » Tue Nov 20, 2018 5:08 pm

Hey FNB, long time no see. How are you doing?

Regarding the map:
No big build issues this time around, luckily. Classic FNB style. Top area reminded me on Aliens the first time I saw it, felt nice.
Didn't have any issues with the pipes aside from them running on lightspeed (maybe that's an issue for other players? - Try lowering the speedvalues a bit :) ). I did encounter the xpickups mismatches, too. Didn't overwrite with your file and the map booted up quite nicely anyway - the regular health pickups were stuck in the ground, otherwise I had no further issues with this.

Some things I noticed, though:
You need to check each jumppad though, some (I think 005?) couldn't be connected.
The area around brush769 and 776 feels extremely awkward to navigate if you're coming from below since you need to do this giant snake move to get towards the flagroom.
The lifts nearby (mover5 and 15 respectively) could do with slightly less start up delay.
The topside is a bit too open though and very flat. An experienced sniper (try putting up Loque or Tamerlane up there on Godlike) or any half decent human player would rake up a lot of kills - IF you saw any bot going up there. As sektor already suggested you could take another look at the pathing, and I'd suggest putting up a few more ways to get up there in the first place, especially around the central area.
With 16 players, I ran around with speed pickups nonstop. Nice way to get around the map, but it felt abundant pretty quickly. Same with health. Will have to see how it will fare with more players but with 16 players both felt abundantly plentiful.
User avatar
Swanky
Adept
 
Posts: 280
Joined: Sun Mar 16, 2008 9:06 pm
Personal rank: Brush Commander

Re: Big Ugly CTF map needs feedback !!!!

Postby OjitroC » Tue Nov 20, 2018 10:01 pm

Briefly, I have solved my problem - I set all the jumppads in the tubes to output debug info to the log and got this
Spoiler: show
swjumppad7: A=75 IV=0 IS=0 IH=0 T=0 P=0 V=0 G=-5000 U=[kickout100] PN=[OjitroC] N=[swjumppad7] D=[swjumppad5]
swjumppad0: A=75 IV=0 IS=0 IH=0 T=0 P=0 V=0 G=-5000 U=[kickout200] PN=[OjitroC] N=[swjumppad0] D=[swjumppad86]
which I thought was odd, especially the G=-5000 (though I don't really know what that all means).

Taking a more detailed look at the map in UEd, I saw that there were two swjumppads at the top of each tuble and thought that might be the cause of my problem. I deleted one of them and reset the tags/destination URLs and now both tubes work fine for me.
User avatar
OjitroC
Inhuman
 
Posts: 919
Joined: Sat Sep 12, 2015 8:46 pm

Re: Big Ugly CTF map needs feedback !!!!

Postby FraGnBraG » Wed Nov 21, 2018 1:20 am

OjitroC wrote:Briefly, I have solved my problem - I set all the jumppads in the tubes to output debug info to the log and got this
Spoiler: show
swjumppad7: A=75 IV=0 IS=0 IH=0 T=0 P=0 V=0 G=-5000 U=[kickout100] PN=[OjitroC] N=[swjumppad7] D=[swjumppad5]
swjumppad0: A=75 IV=0 IS=0 IH=0 T=0 P=0 V=0 G=-5000 U=[kickout200] PN=[OjitroC] N=[swjumppad0] D=[swjumppad86]
which I thought was odd, especially the G=-5000 (though I don't really know what that all means).


hmm... I might have had two sets to stop bots sticking on the tube sides ... dunno - I still have to look at that :)

OjitroC wrote: Taking a more detailed look at the map in UEd, I saw that there were two swjumppads at the top of each tuble and thought that might be the cause of my problem. I deleted one of them and reset the tags/destination URLs and now both tubes work fine for me.


EDIT:
DONE! fixed - there I had a kicker pushing the player into the first set of swjumpad. Then put a second set to jump over the gap to the ledge. Turns out the first set was a bad idea and not needed because of the kicker already there. So I did the same as you, deleted the unecessary set of swjumpads and voila works great. No log errors (that I can see). good stuff! thanks man - you're in the readme :) :rock:



Hey Swanky :rock: Good to see you back again - thanks for the feedback I'll get to it in a bit - right now I have to check this weird swjumppad problem!

Are you going to whip up a map?

Rev's in this thing too (bet he'll be showing the whipper-snappers a thing or two, I'm sure of that lol!)
User avatar
FraGnBraG
Inhuman
 
Posts: 761
Joined: Sun Jun 13, 2010 5:13 pm
Location: Canada
Personal rank: Good news everyone!

Re: Big Ugly CTF map needs feedback !!!!

Postby Red_Fist » Wed Nov 21, 2018 3:26 am

I think to stop the bots sticking is you have to have friction on the walls in order for the bots to know that is has zone effects. So I reversed the friction number in accordance with the thrust and fluid friction. play with those numbers a while. but it's thinking on those lines, for instance decreasing fluid friction makes it WORSE to move through water. Increasing friction along with zone acceleration , one direction or another, it will amplify you to a splat on the ceiling. As opposed to less friction like we may naturally think.

Go find my Zonetube map, keep in mind I try to build maps while always using stock dumb customer settings, that is the challenge to outsmart the stock engine with settings to fool itself. and not use new code-actors.

anyway if you poke around those zone settings to not give a bot a chance to START to get stuck, type of thinking.

In my Zonetube map I made curved tubes so when they fly through the direction had to be perfect, so I spent hours trying to get it right. In your case you probably have straight tubes, to don't try too hard, like Swanky said, decrease the speeds of things , but along with I say mess with friction. It will work perfectly. Plus you MUST try my zonetube map for further inspiration, everyone should.
Binary Space Partitioning
Red_Fist
Godlike
 
Posts: 1404
Joined: Sun Oct 05, 2008 3:31 am

Re: Big Ugly CTF map needs feedback !!!!

Postby Swanky » Wed Nov 21, 2018 9:45 am

Don't think I will do so. Not in the short remaining, anyway. Maybe for next year's birthday or so; I do have an idea of a map layout actually.
Last edited by Swanky on Wed Nov 21, 2018 10:02 am, edited 1 time in total.
User avatar
Swanky
Adept
 
Posts: 280
Joined: Sun Mar 16, 2008 9:06 pm
Personal rank: Brush Commander

Re: Big Ugly CTF map needs feedback !!!!

Postby Barbie » Wed Nov 21, 2018 9:56 am

OjitroC wrote:
Code: Select all
swjumppad7: A=75 IV=0 IS=0 IH=0 T=0 P=0 V=0 G=-5000 U=[kickout100] PN=[OjitroC] N=[swjumppad7] D=[swjumppad5]
though I don't really know what that all means

A=angled
IV=impactspeedz
IS=VSize(impactspeedxy)
IH=impactheight
T=time*1000
P=peak
V=speed
G=grav

By having a look in the code I stumbled over this
Code: Select all
// Get gravity
grav = -Region.Zone.ZoneGravity.Z;
As far as I understood that "kicker", it needs the start end ending point and calculates a parabola as trajectory. That code line looks like the coder assumed a gravity force only in Z axe, but the tubes in that map has ZoneGravity=(X=50,Z=5000) and furthermore the start and end points are located in zones with different gravity vectors. Maybe that's the reason for the error messages "Could not calculate JumpSpeed".
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett
User avatar
Barbie
Godlike
 
Posts: 1545
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

PreviousNext

Return to Mapping

Who is online

Users browsing this forum: R3plicant and 4 guests