Masked texture

Tutorials and discussions about Mapping - Introduce your own ones!
User avatar
[NBK]DxTrEm3Fx
Experienced
Posts: 101
Joined: Wed May 09, 2012 5:56 pm
Location: Glendale, AZ

Masked texture

Post by [NBK]DxTrEm3Fx » Sun Jan 10, 2021 10:27 pm

Sorry for all of the Noob questions. This is getting pretty frustrating. I'm getting beat up by the most basic of issues. I've done 1000s of masked textures back in the day and I'm not sure if it's a photoshop issue and export-import issue. But I have a masked texture that looks fine in the editor. But when I go into the game it is no longer masked? :facepalm: :noidea :???:
https://dxfxhouse.com/maps/masked1.jpg
https://dxfxhouse.com/maps/masked2.png
https://dxfxhouse.com/maps/masked3.jpg
https://dxfxhouse.com/maps/masked4.jpg
https://dxfxhouse.com/maps/masked5.jpg

Thank you all for your help.
Dx.
Image

User avatar
EvilGrins
Godlike
Posts: 8007
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: Masked texture

Post by EvilGrins » Mon Jan 11, 2021 12:49 am

I think we were talking earlier about your map on Facebook, I'm the guy that mentioned the UTDMS.

Masking can vary depending on your graphic setup, what is visible in UnrealEd is pretty similar to what OpenGL is but not the same as D3D.

I've had similar issues...
Image
Clear before I take a screenshot but not after.
Image

What is your graphic setup?
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
[NBK]DxTrEm3Fx
Experienced
Posts: 101
Joined: Wed May 09, 2012 5:56 pm
Location: Glendale, AZ

Re: Masked texture

Post by [NBK]DxTrEm3Fx » Mon Jan 11, 2021 1:08 am

Hello Evil,
That is the issue. If I run Open GL in the game, the masking goes away. But If I run Direct3D, then it works just fine. That is a bummer, but thank you for your help.
Image

User avatar
OjitroC
Godlike
Posts: 2428
Joined: Sat Sep 12, 2015 8:46 pm

Re: Masked texture

Post by OjitroC » Mon Jan 11, 2021 1:47 am

I don't know if it is of any help (or even relevant) but OpenGL has a setting MaskedTextureHack which should be set to True and the setting SmoothMaskedTextures should be set to False. If you don't have these settings then perhaps you have an older OpenGL renderer and switching to a newer version might improve things.