Yet another Windows 10 thread: textures issue

Tutorials and discussions about Mapping - Introduce your own ones!
User avatar
EvilGrins
Godlike
Posts: 7908
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Yet another Windows 10 thread: textures issue

Post by EvilGrins » Wed Mar 31, 2021 1:58 am

Had anyone else experienced this?

To date I've never had any problems with my ut99 under Windows 10, but they've been advertising lately that a new version of Win10 was available and I finally did the upgrade yesterday... and up until today, I haven't had an issue.

I do map edits in little bits, working on dozens of maps at a time. So I popped into a golf-themed one I haven't touched in about a month and saw... well, that.

Downloaded a fresh copy of the map, figuring that maybe a texture file had been eliminated or corrupted, but the original is having the same issue.

Possibly it was using some other texture file I already had, but I can't tell which one.

This is the original map:
https://unrealarchive.org/maps/unreal-t ... dace2.html

Problem didn't exist before the upgrade. Thoughts?
You do not have the required permissions to view the files attached to this post.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
OjitroC
Godlike
Posts: 2342
Joined: Sat Sep 12, 2015 8:46 pm

Re: Yet another Windows 10 thread: textures issue

Post by OjitroC » Wed Mar 31, 2021 9:26 am

Tried that map in all three versions of UT I have and with different renderers - all with the same result - I get what you get in your screenshot. It obviously does the same in the Editor.

User avatar
EvilGrins
Godlike
Posts: 7908
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: Yet another Windows 10 thread: textures issue

Post by EvilGrins » Wed Mar 31, 2021 10:21 am

Well... I see failures to load skin textures but not much else.

Have a look:
Spoiler
Show
Log: Log file open, 03/31/21 02:18:57
Init: Name subsystem initialized
Init: Detected: Microsoft Windows NT 6.2 (Build: 9200)
Init: Version: 436
Init: Compiled: Oct 24 2000 23:40:18
Init: Command line: "D:\Unreal Anthology\UnrealTournament\Maps\CTF-UTDMT-7thHole.unr"
Init: Base directory: D:\Unreal Anthology\UnrealTournament\System\
Init: Character set: Unicode
Log: Bound to Engine.dll
Log: Bound to Core.dll
Log: Bound to Window.dll
Init: Object subsystem initialized
Init: Computer: DESKTOPRC5DBQU
Init: User: Ray
Init: Memory total: Phys=2097151K Pagef=4194303K Virt=2097024K
Init: Working set: 32000 / 159000
Init: CPU Speed=3311.187648 MHz
Init: CPU Page size=4096, Processors=4
Init: CPU Detected: PentiumPro-class processor (GenuineIntel)
Init: CPU Features: CMov FPU RDTSC PAE MMX KNI
Init: Unreal engine initialized
Log: Bound to WinDrv.dll
Init: Mouse info: 6 10 1
Init: DirectInput initialized successfully.
Init: Client initialized
Log: Bound to Render.dll
Init: Lighting subsystem initialized
Init: Rendering initialized
Log: LoadMap: Entry
Log: Bound to Fire.dll
Log: Bound to IpDrv.dll
Log: Game class is 'UTIntro'
Log: Level is Level Entry.MyLevel
Log: Bringing Level Entry.MyLevel up for play (0)...
ScriptLog: InitGame:
ScriptLog: Base Mutator is Entry.Mutator0
Log: Browse: D:\Unreal Anthology\UnrealTournament\Maps\CTF-UTDMT-7thHole.unr?Class=BotPack.TMale2?team=255?skin=SoldierSkins_DRNJ.DRNJ?Face=?OverrideClass=Botpack.CHSpectator?Voice=MultiMesh.SkaarjVoice?Name=Doppleganger
Log: LoadMap: D:\Unreal Anthology\UnrealTournament\Maps\CTF-UTDMT-7thHole.unr?Class=BotPack.TMale2?team=255?skin=SoldierSkins_DRNJ.DRNJ?Face=?OverrideClass=Botpack.CHSpectator?Voice=MultiMesh.SkaarjVoice?Name=Doppleganger
Log: Collecting garbage
Log: Purging garbage
Log: -0.0ms Unloading: Package Render
Log: Garbage: objects: 21348->21347; refs: 330378
Log: Game class is 'CTFGame'
Log: Level is Level CTF-UTDMT-7thHole.MyLevel
Log: Bringing Level CTF-UTDMT-7thHole.MyLevel up for play (0)...
ScriptLog: InitGame: ?Class=BotPack.TMale2?team=255?skin=SoldierSkins_DRNJ.DRNJ?Face=?OverrideClass=Botpack.CHSpectator?Voice=MultiMesh.SkaarjVoice?Name=Doppleganger
ScriptLog: Base Mutator is CTF-UTDMT-7thHole.DMMutator0
ScriptLog: UTDMT.UTDMT:PreBeginPlay : Creating a UTDMTMutator.
ScriptLog: Found CTF-UTDMT-7thHole.Translator0 at -5392.000000,-1376.000000,112.000000
ScriptLog: Found CTF-UTDMT-7thHole.Translator1 at 3120.000000,5616.000000,112.000000
Init: Initialized moving brush tracker for Level CTF-UTDMT-7thHole.MyLevel
Log: Bound to UWeb.dll
ScriptLog: Team 255
ScriptLog: Login: Doppleganger
Warning: Failed to load 'Texture SoldierSkins_DRNJ.DRNJ': Failed to find object 'Texture SoldierSkins_DRNJ.DRNJ'
Log: Possessed PlayerPawn: CHSpectator CTF-UTDMT-7thHole.CHSpectator0
Warning: Failed to load 'Texture Soldier_Batzarro.Batz2T_0': Failed to find object 'Texture Soldier_Batzarro.Batz2T_0'
ScriptLog: Failed to load Soldier_Batzarro.Batz2T_0 so load Soldier_Batzarro.Batz2
Warning: Failed to load 'Texture Soldier_MU.MUST2T_0': Failed to find object 'Texture Soldier_MU.MUST2T_0'
ScriptLog: Failed to load Soldier_MU.MUST2T_0 so load Soldier_MU.MUST2
Warning: Failed to load 'Texture Soldier_MU.MUST2T_0': Failed to find object 'Texture Soldier_MU.MUST2T_0'
ScriptLog: Failed to load Soldier_MU.MUST2T_0 so load Soldier_MU.MUST2
Warning: Failed to load 'Texture Q2TankSkins.tkcm1tank': Failed to find object 'Texture Q2TankSkins.tkcm1tank'
ScriptLog: Failed to load Q2TankSkins.tkcm1tank so load Q2TankSkins.tkcm1
Warning: Failed to load 'Texture Q2TankSkins.tkcm5': Failed to find object 'Texture Q2TankSkins.tkcm5'
Warning: Failed to load 'Texture Soldier_Xmen.Xmen5Wolv': Failed to find object 'Texture Soldier_Xmen.Xmen5Wolv'
Warning: Failed to load 'Texture Soldier_Xmen.xmen5Wolv': Failed to find object 'Texture Soldier_Xmen.xmen5Wolv'
Warning: Failed to load 'Texture Soldier_Btos.Btos1T_0': Failed to find object 'Texture Soldier_Btos.Btos1T_0'
ScriptLog: Failed to load Soldier_Btos.Btos1T_0 so load Soldier_Btos.Btos1
Warning: Failed to load 'Texture Soldier_Btos.Btos2T_0': Failed to find object 'Texture Soldier_Btos.Btos2T_0'
ScriptLog: Failed to load Soldier_Btos.Btos2T_0 so load Soldier_Btos.Btos2
Init: Input system initialized for WindowsViewport0
Log: Opened viewport
Log: Bound to D3DDrv.dll
Init: DirectDraw drivers detected:
Init: display (Primary Display Driver)
Init: D3D Device: Supports system memory DMA blts
Log: D3D Device 4194240K vram, 4186140K free
Init: Unreal Tournament Direct3D support - internal revision 1.9c
Init: D3D Device: szDriver=aticfx32.dll
Init: D3D Device: szDescription=AMD Radeon R7 200 Series
Init: D3D Device: wProduct=0
Init: D3D Device: wVersion=0
Init: D3D Device: wSubVersion=0
Init: D3D Device: wBuild=0
Init: D3D Device: dwVendorId=4098
Init: D3D Device: dwDeviceId=26687
Init: D3D Device: dwSubSysId=579146840
Init: D3D Device: dwRevision=0
Init: Best-match display mode: 1024x768x32 (Error=0)
Init: D3D Device: dwZbuffer depth: 32 bits.
Init: D3D Driver: wMaxTextureBlendStages=8
Init: D3D Driver: wMaxSimultaneousTextures=8
Log: D3D Driver: Supports FOURCC !
Log: D3D Driver: Supports FOURCC DXT1
Log: D3D Driver: Supports FOURCC DXT2
Log: D3D Driver: Supports FOURCC DXT3
Log: D3D Driver: Supports FOURCC DXT4
Log: D3D Driver: Supports FOURCC DXT5
Log: D3D Driver: Supports FOURCC ATI1
Log: D3D Driver: Supports FOURCC ATI2
Log: D3D Driver: Supports FOURCC RESZ
Log: D3D Driver: Supports FOURCC DF16
Log: D3D Driver: Supports FOURCC DS16
Log: D3D Driver: Supports FOURCC DF24
Log: D3D Driver: Supports FOURCC INTZ
Log: D3D Driver: Supports FOURCC NULL
Init: D3D Detected: ATI video card
Init: D3D Driver: Supports trilinear
Init: D3D Driver: Supports specular gouraud
Init: D3D Driver: Supports BLENDDIFFUSEALPHA
Init: D3D Driver: Supports LOD biasing
Init: D3D Driver: Supports Z biasing
Init: D3D Driver: Supports D3DTOP_ADDSIGNED2X
Init: D3D Driver: Supports D3DTOP_BUMPENVMAP
Init: D3D Driver: Supports D3DTOP_BUMPENVMAPLUMINANCE
Init: D3D Driver: Supports D3DTOP_DOTPRODUCT3
Init: D3D Driver: Supports D3DTOP_MODULATEALPHA_ADDCOLOR
Init: D3D Driver: Supports D3DTOP_MODULATECOLOR_ADDALPHA
Init: D3D Driver: Textures (1x1)-(16384x16384), Max aspect 8192
Init: D3D Driver: VidMem Disposition: 202 0
Log: Bound to Galaxy.dll
Init: Galaxy is using WinMM
Init: Galaxy initialized
DevAudio: Galaxy SetViewport: WindowsViewport0
Init: Game engine initialized
Log: Startup time: 4.420813 seconds
DevMusic: Load music: Music Phantom.Phantom
Log: D3D Driver: Preloaded 0K/253738K (0)
ScriptWarning: CHSpectator CTF-UTDMT-7thHole.CHSpectator0 (Function Botpack.CHSpectator.Jump:005E) Accessed None
ScriptWarning: CHSpectator CTF-UTDMT-7thHole.CHSpectator0 (Function Botpack.CHSpectator.Jump:005E) Accessed None
ScriptWarning: CHSpectator CTF-UTDMT-7thHole.CHSpectator0 (Function Botpack.CHSpectator.Jump:005E) Accessed None
ScriptWarning: CHSpectator CTF-UTDMT-7thHole.CHSpectator0 (Function Botpack.CHSpectator.Jump:005E) Accessed None
ScriptLog: Creating root window: UMenu.UMenuRootWindow
Log: appRequestExit(0)
Exit: Preparing to exit.
Log: Purging garbage
Log: Unbound to Engine.dll
Log: Unbound to Core.dll
Log: Unbound to Window.dll
Log: -0.0ms Unloading: Package Engine
Log: -0.0ms Unloading: Package Core
Exit: Game engine shut down
Log: Unbound to WinDrv.dll
Exit: Windows client shut down
Log: Unbound to Render.dll
Exit: Lighting subsystem shut down
Exit: Rendering shut down
Log: -0.0ms Unloading: Package Entry
Log: -0.0ms Unloading: Package Logo
Log: Unbound to Fire.dll
Log: -0.0ms Unloading: Package Fire
Log: -0.0ms Unloading: Package credits
Log: -0.0ms Unloading: Package Botpack
Log: -0.0ms Unloading: Package UnrealShare
Log: -0.0ms Unloading: Package UnrealI
Log: -0.0ms Unloading: Package Female2Voice
Log: -0.0ms Unloading: Package Male2Voice
Log: -0.0ms Unloading: Package Female1Voice
Log: -0.0ms Unloading: Package BossVoice
Log: -0.0ms Unloading: Package Male1Voice
Log: -0.0ms Unloading: Package UMenu
Log: -0.0ms Unloading: Package UWindow
Log: -0.0ms Unloading: Package UBrowser
Log: Unbound to IpDrv.dll
Log: -0.0ms Unloading: Package IpDrv
Log: -0.0ms Unloading: Package Announcer
Log: -0.0ms Unloading: Package CTF-UTDMT-7thHole
Log: -0.0ms Unloading: Package 7thHole
Log: -0.0ms Unloading: Package JDdeco01
Log: -0.0ms Unloading: Package genfluid
Log: -0.0ms Unloading: Package SkyBox
Log: -0.0ms Unloading: Package ShaneSky
Log: -0.0ms Unloading: Package AmbOutside
Log: -0.0ms Unloading: Package city
Log: -0.0ms Unloading: Package Detail
Log: -0.0ms Unloading: Package UTDMT
Log: -0.0ms Unloading: Package SBNaliGhostV0
Log: -0.0ms Unloading: Package AmbModern
Log: -0.0ms Unloading: Package 7th_hole
Log: -0.0ms Unloading: Package Phantom
Init: Shut down moving brush tracker for Level CTF-UTDMT-7thHole.MyLevel
DevMusic: Unregister music: Music Phantom.Phantom
Log: -0.0ms Unloading: Package UTMenu
Log: -0.0ms Unloading: Package LadderSounds
Log: Unbound to UWeb.dll
Log: -0.0ms Unloading: Package UWeb
Log: -0.0ms Unloading: Package UTServerAdmin
Log: -0.0ms Unloading: Package IpServer
Log: -0.0ms Unloading: Package LadrArrow
Log: -0.0ms Unloading: Package SoldierSkins_DRNJ
Log: -0.0ms Unloading: Package Soldier_Batzarro
Log: -0.0ms Unloading: Package indiapack
Log: -0.0ms Unloading: Package Soldier_Roach
Log: -0.0ms Unloading: Package Yosam
Log: -0.0ms Unloading: Package Soldier_MU
Log: -0.0ms Unloading: Package Excessive
Log: -0.0ms Unloading: Package MultiMesh
Log: -0.0ms Unloading: Package EpicCustomModels
Log: -0.0ms Unloading: Package UTBrowser
Log: -0.0ms Unloading: Package Q2Tank
Log: -0.0ms Unloading: Package Q2TankSkins
Log: -0.0ms Unloading: Package GearsVPs
Log: -0.0ms Unloading: Package Soldierskins_DC
Log: -0.0ms Unloading: Package ICP
Log: -0.0ms Unloading: Package Soldier_Xmen
Log: -0.0ms Unloading: Package Soldier_Btos
Log: -0.0ms Unloading: Package MercPlayerUT
Log: -0.0ms Unloading: Package MercPlayerSounds
Log: -0.0ms Unloading: Package MercPlayerSkins
Log: Unbound to D3DDrv.dll
Log: Unbound to Galaxy.dll
DevAudio: Galaxy SetViewport: NULL
Exit: Galaxy shut down
Log: -0.0ms Unloading: Package LadderFonts
Log: -0.0ms Unloading: Package UWindowFonts
Log: -0.0ms Unloading: Package AkimboArena
Log: -0.0ms Unloading: Package AlienMode
Log: -0.0ms Unloading: Package Queen
Log: -0.0ms Unloading: Package AmbAncient
Log: -0.0ms Unloading: Package CorpseMode
Log: -0.0ms Unloading: Package DMUT
Log: -0.0ms Unloading: Package ErdriksDMUT
Log: -0.0ms Unloading: Package InfilBrowser
Log: -0.0ms Unloading: Package InfMutator
Log: -0.0ms Unloading: Package InfiltrationUT
Log: -0.0ms Unloading: Package MapRandomizer
Log: -0.0ms Unloading: Package marginal
Log: -0.0ms Unloading: Package MonsterMadness
Log: -0.0ms Unloading: Package NWCoreVIII
Log: -0.0ms Unloading: Package NWUltraGoreSSEb
Log: -0.0ms Unloading: Package OldModelsMenus
Log: -0.0ms Unloading: Package OldModels
Log: -0.0ms Unloading: Package Male1Skins
Log: -0.0ms Unloading: Package Oldskool
Log: -0.0ms Unloading: Package Pinata
Log: -0.0ms Unloading: Package Sevens
Log: -0.0ms Unloading: Package U4eTMenu
Log: -0.0ms Unloading: Package U4eTC
Log: -0.0ms Unloading: Package U4eT
Log: -0.0ms Unloading: Package U4eTM
Log: -0.0ms Unloading: Package U4eFX
Log: -0.0ms Unloading: Package U4eWTexs
Log: -0.0ms Unloading: Package U4eLAnims
Log: -0.0ms Unloading: Package U4eMedigun
Log: -0.0ms Unloading: Package U4eWarp
Log: -0.0ms Unloading: Package GenWarp
Log: -0.0ms Unloading: Package U4eTCM
Log: -0.0ms Unloading: Package TGolemSkins
Log: -0.0ms Unloading: Package TZhalSkins
Log: -0.0ms Unloading: Package U4eTCM510
Log: -0.0ms Unloading: Package HHzombii
Log: -0.0ms Unloading: Package UPakMenu
Log: -0.0ms Unloading: Package XBots
Log: Garbage: objects: 41183->0; refs: 330378
Exit: Object subsystem successfully closed.
Exit: Exiting.
Uninitialized: Name subsystem shut down
Uninitialized: Memory Allocation Status
Uninitialized: Curr Memory 0.354M / 0.996M
Uninitialized: Peak Memory 89.695M / 91.512M
Uninitialized: Allocs 73 Current / 686445 Total
Uninitialized: Log file closed, 03/31/21 02:19:22
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
OjitroC
Godlike
Posts: 2342
Joined: Sat Sep 12, 2015 8:46 pm

Re: Yet another Windows 10 thread: textures issue

Post by OjitroC » Wed Mar 31, 2021 10:55 am

I've found what the problem is - it's down to file naming. The texture file with those (missing from the map in-game) tree textures is JDdeco01.utx - I have a Jddeco01.u and so probably do you.

The 'Engine' will look for a file named Jddeco01 and find it but it will find Jddeco01.u first - so won't load the tree textures from Jddeco01.utx. Because it can find that .u file which contains textures (but not the textures used in the map), the map will run.

If you want to run the map locally and see what it looks like in the Editor, you can move Jddeco01.u from your /System folder temporarily and put it in a folder off the UT path.

A more permanent solution would be to put the tree textures from Jddeco01.utx in MyLevel or to create a new and renamed texture file with the tree textures (I don't think all the textures in Jddeco01.utx are actually used in the map). This more permanent solution is only applicable if you rename the map as well - at least if you intend to distribute it.

So the issue is not to do with Windows 10 per se.

User avatar
EvilGrins
Godlike
Posts: 7908
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: Yet another Windows 10 thread: textures issue

Post by EvilGrins » Wed Mar 31, 2021 1:37 pm

Interesting... but I don't know where I got the .u file from.

Any idea what Jddeco01.u is for?
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
OjitroC
Godlike
Posts: 2342
Joined: Sat Sep 12, 2015 8:46 pm

Re: Yet another Windows 10 thread: textures issue

Post by OjitroC » Wed Mar 31, 2021 2:45 pm

EvilGrins wrote:
Wed Mar 31, 2021 1:37 pm
Any idea what Jddeco01.u is for?
Unfortunately not - there's really no way of finding out (short of looking at every map in UTPT and seeing if stuff from it is imported into the map).

It contains two decorations
jdHLantern01 - a gas lantern
jdOTractor - a tractor without a cab - not an old tractor but not that modern either

So some map based around a farm/agricultural fields possibly? Could try looking at that kind of map but not worth the effort/time.

Given that it is quite possibly only used by one map and the textures in jddeco1.utx may be used by serveral, it's probably safe to park the .u file (move it off the UT path). If you ever come across a map that lacks textures for a tractor or lamp then you can move it back to your /System file and move the jddeco1.utx file out.

[If that map worked OK a month or so ago and you have a way of identifying the maps you have downloaded since then, you can have a look through them with UTPT to see if they import stuff from Jddeco01.u - a long shot and probably not worth it]

User avatar
sektor2111
Godlike
Posts: 5218
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: Yet another Windows 10 thread: textures issue

Post by sektor2111 » Wed Mar 31, 2021 3:15 pm

Textures shown as default bubbles are located in JDDeco01.utx. If your UTX file it's different not having these referenced ones, default texture is used, either way I don't know other reasons...
For me map works normally (okay, I did not check well the rest of details... nvm...).
CTF-7th_Hole_Sshot.png
You do not have the required permissions to view the files attached to this post.

User avatar
OjitroC
Godlike
Posts: 2342
Joined: Sat Sep 12, 2015 8:46 pm

Re: Yet another Windows 10 thread: textures issue

Post by OjitroC » Wed Mar 31, 2021 3:49 pm

sektor2111 wrote:
Wed Mar 31, 2021 3:15 pm
Textures shown as default bubbles are located in JDDeco01.utx. If your UTX file it's different not having these referenced ones, default texture is used, either way I don't know other reasons...
Yes, the textures are indeed in JDDeco01.utx as I've said earlier BUT ... if you also have JDDeco01.u (which I and EG, and presumably other people, do) then the textures in the .utx aren't loaded as the .u file with the same name is read first. I've explained ths at length above .. and proved it to be the case as removing JDDeco01.u from the /System folder means that the textures are loaded and the map appears as it should.

User avatar
sektor2111
Godlike
Posts: 5218
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: Yet another Windows 10 thread: textures issue

Post by sektor2111 » Wed Mar 31, 2021 4:30 pm

Ah, yes, I do not have the U file messing up with packages... so U files goes in front of UTX - resulting once again that files like Engine.utx which some maps archives are having packed aren't good at anything...

User avatar
OjitroC
Godlike
Posts: 2342
Joined: Sat Sep 12, 2015 8:46 pm

Re: Yet another Windows 10 thread: textures issue

Post by OjitroC » Wed Mar 31, 2021 4:55 pm

So the lessons from this are
1 Give packages a unique name and not one used by ANY other UT package; and
2 If you see the default bubble textures in a map, first check that you don't have a package in your /System folder that shares a name with a texture package required by the map - something I had forgotten but this case has reminded me to do that.

User avatar
EvilGrins
Godlike
Posts: 7908
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: Yet another Windows 10 thread: textures issue

Post by EvilGrins » Wed Mar 31, 2021 10:00 pm

sektor2111 wrote:
Wed Mar 31, 2021 3:15 pm
For me map works normally
Working fine for me again too, now, and I'll be sending it your way for an assessment soon as I'm done with a few things.
You do not have the required permissions to view the files attached to this post.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758