Crackling audio

Tutorials and discussions about Mapping - Introduce your own ones!
User avatar
jmartin
Experienced
Posts: 96
Joined: Tue Mar 23, 2021 11:38 pm

Crackling audio

Post by jmartin » Sun Jul 03, 2022 11:57 pm

I noticed that when play-testing a map in the editor, about half of the time the audio is distorted, and sounds buzzing or "crackling".

Normally this is not a problem unless you are adjusting the settings for an Ambient or Dynamic audio actor, which then becomes slightly irritating.

Anyone else experience the same issue?

Thanks.

Also noticed, sometimes the Trees are masked... sometimes they're not. WUWT?
You do not have the required permissions to view the files attached to this post.

User avatar
papercoffee
Godlike
Posts: 10141
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.

Re: Crackling audio

Post by papercoffee » Mon Jul 04, 2022 3:29 am

haven't experienced that sound problem ...but that masked and not masked textures rings a bell, what renderer do you use?

User avatar
jmartin
Experienced
Posts: 96
Joined: Tue Mar 23, 2021 11:38 pm

Re: Crackling audio

Post by jmartin » Mon Jul 04, 2022 10:55 pm

Direct3D, although software rendering seems to handle masked textures better, but then everything else looks worse.

User avatar
papercoffee
Godlike
Posts: 10141
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.

Re: Crackling audio

Post by papercoffee » Tue Jul 05, 2022 12:09 am

Have you updated your renderer or is this still vanilla?
Same goes for the sound, is it still Galaxy or some newer driver?
Is this happening in the game as well?

User avatar
jmartin
Experienced
Posts: 96
Joined: Tue Mar 23, 2021 11:38 pm

Re: Crackling audio

Post by jmartin » Tue Jul 05, 2022 2:05 am

Yes, all vanilla and Galaxy 3D audio.
Happens in the game as well as play-testing through the editor. But it's intermittent.
Exact same map, exact same conditions. Results are variable, which is just weird.

** Just noticed the same topic here.

https://steamcommunity.com/app/13240/di ... 603741199/

Apparently a new patch and ALaudio dll solves the problem.

User avatar
Dr.Flay
Godlike
Posts: 3332
Joined: Thu Aug 04, 2011 9:26 pm
Personal rank: Chaos Evangelist
Location: Kernow, UK

Re: Crackling audio

Post by Dr.Flay » Tue Jul 05, 2022 6:54 am

It is worth using updated renderers as they fix longstanding bugs, especially with newer hardware.
They are available separately at oldunreal and in the 469 patch.

Worth noting that it is worth changing the main config so that windowed mode uses the same video renderer as you use to play in.
This will allow UEd to display previews for High Resolution and S3TC compressed textures eg. the ones on CD 2 or newer.
Also the lighting and colours are easier to get right when they both match.
Software, GL and D3D have different presets so out of the box look very different.
You may want to switch off anti-aliasing for the renderer or the wire-frame views can get laggy with lots of stuff in frame.

User avatar
jmartin
Experienced
Posts: 96
Joined: Tue Mar 23, 2021 11:38 pm

Re: Crackling audio

Post by jmartin » Fri Jul 08, 2022 11:30 pm

Thanks Paper Coffee and Dr. Flay for the help, I'll check into it asap.

Also just wanted to add the "Import Sound" issue.
I noticed that when importing sound (not music) UnrealEd doesn't like convoluted path names.

For example if I try to import a wave file from my thumb drive, it doesn't work.

However if I import the exact same file from C:\ or C:\tmp, it works fine.

UT seems to be very picky on this issue, more so than textures or music imports.
Not sure if anyone else has experienced this?

Thanks again.

User avatar
UnrealGGecko
Godlike
Posts: 2682
Joined: Wed Feb 01, 2012 11:26 am
Personal rank: GEx the Gecko
Location: Kaunas, Lithuania

Re: Crackling audio

Post by UnrealGGecko » Sat Jul 09, 2022 1:07 am

UEd just doesn't like any spaces in the path name.