lift problems, weird bug

Tutorials and discussions about Mapping - Introduce your own ones!
User avatar
NIGHTCRAWLER
Novice
Posts: 12
Joined: Tue Mar 18, 2008 3:20 pm
Personal rank: HARDcOrEGAMER
Location: Canada

lift problems, weird bug

Post by NIGHTCRAWLER » Tue Mar 18, 2008 3:55 pm

hey guys, i am having problems getting lifts to work. i used the unrealwiki to help me out but i cant get them to work. i can see the lifts but they don't work?,
another problem i am having is that in some places where i made lift's and this one staircase, players cant walk there theres like an invisible cylinder arround it.
u can jump on them to, unrealed dosent show anething is there and evan after i delete the lifts and that staircase the cylinders are there. any :help: is greatly appricieated

things have tried:
deleting the 2 lifts and 1 staircase
looking for holes in the map
changing textures(just to see what would happen)
looking in the wiki(as far as i searched no results)
if this game ever dies, i go with it

User avatar
Feralidragon
Godlike
Posts: 5391
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: lift problems, weird bug

Post by Feralidragon » Tue Mar 18, 2008 4:10 pm

What do you mean "they don't work"? They don't move? That's it?

Another thing, that invisible wall or cylinder, I thing that's the lift (mover) problem.
I think you did the lift shape with the 2D editor from Ued or just edited another existing one, am I right?
If so, I know what the problem is, and I figured it out myself, it's a weird problem, but I can solve it, no worry. :tu:

So answer to my questions above, to solve your problem. :mrgreen:

User avatar
NIGHTCRAWLER
Novice
Posts: 12
Joined: Tue Mar 18, 2008 3:20 pm
Personal rank: HARDcOrEGAMER
Location: Canada

Re: lift problems, weird bug

Post by NIGHTCRAWLER » Tue Mar 18, 2008 4:34 pm

yes they don't move i made a cube then made it a lift but i dident edit it with 2d shape editor tho
if this game ever dies, i go with it

User avatar
Feralidragon
Godlike
Posts: 5391
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: lift problems, weird bug

Post by Feralidragon » Tue Mar 18, 2008 4:49 pm

If you didn't edit another mover, and made a new one by 2D shape editor neither, then the collision thing I do not know what may happened. For that, give me your map to see better :tu:

About mover working thing, what type of mover did you use? A normal one (just Mover), or another one like ElevatorMover, MixMover or so?

User avatar
NIGHTCRAWLER
Novice
Posts: 12
Joined: Tue Mar 18, 2008 3:20 pm
Personal rank: HARDcOrEGAMER
Location: Canada

Re: lift problems, weird bug

Post by NIGHTCRAWLER » Tue Mar 18, 2008 5:15 pm

i thinhk i used a elavator mover, i deleted the lifts in a earlier session but i put 3 redemers in their place the cylinders are still there. from a top view the first one is in the upper left corner, se second in the lower left corner and the third(staircase in the center right. sorry for the major inconvenience. and btw i might have done the lifts with the 2d shape editor, i just don't thik i did, and ty verry much

is there another way i can send u the map .unr files are not allowed
if this game ever dies, i go with it

User avatar
Feralidragon
Godlike
Posts: 5391
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: lift problems, weird bug

Post by Feralidragon » Tue Mar 18, 2008 5:24 pm

You can zip the file, I guess...
If you still can't, then change the extension .unr to .txt and send.

Then I change the extension again to .unr, and then I can open your map :tu:

But I can only take a look to your map tonight, sorry... :noidea

User avatar
NIGHTCRAWLER
Novice
Posts: 12
Joined: Tue Mar 18, 2008 3:20 pm
Personal rank: HARDcOrEGAMER
Location: Canada

Re: lift problems, weird bug

Post by NIGHTCRAWLER » Tue Mar 18, 2008 5:38 pm

ok. i 7z zipped it it's a free compression tool u can find easy on google. in the meantime i wouldent mind hearing your fix for the 2d shape editor that might work. and ul need the ShaneChurch.utx file i can't send too big
You do not have the required permissions to view the files attached to this post.
if this game ever dies, i go with it

User avatar
Feralidragon
Godlike
Posts: 5391
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: lift problems, weird bug

Post by Feralidragon » Tue Mar 18, 2008 5:44 pm

Don't mind about the utx file, I have that one too :tu:

And about the 2D shape editor, I will make a tutorial later (today) how to solve the collision things, so no worry.
I just don't make the tutorial right now, because I'm not on my computer, so I haven't UT installed, and some screenshots are well recommended in tutorials, but tonight I sure you that it will be there, I promisse 8)

User avatar
NIGHTCRAWLER
Novice
Posts: 12
Joined: Tue Mar 18, 2008 3:20 pm
Personal rank: HARDcOrEGAMER
Location: Canada

Re: lift problems, weird bug

Post by NIGHTCRAWLER » Tue Mar 18, 2008 5:47 pm

ty verry much, :gj: :D :rock: :thuup:
if this game ever dies, i go with it

User avatar
Creavion
Godlike
Posts: 4497
Joined: Sun Feb 17, 2008 7:23 pm
Personal rank: About to be non-act.
Location: Germany, Lower Saxony

Re: lift problems, weird bug

Post by Creavion » Tue Mar 18, 2008 5:48 pm

One thing to note: ShaneChurch.utx is a Retail package of UT, you don`t need to upload it with your map. ;)
About to be non-active
My very last UT map project: CTF-FacePalm (tropical CTF-Face remake)
Why do I leave? click here
What I want to do next: Joining an UDK team (uncertain however) and improve 3D modelling and texture editing skills
Thanks to those who visibly supported me until/at the end!
My reactivated account on indiedb.com.

User avatar
Feralidragon
Godlike
Posts: 5391
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: lift problems, weird bug

Post by Feralidragon » Tue Mar 18, 2008 9:36 pm

I already saw your map, and I have to give you the congratulations of the well placed spots for the snipers :tu: , but look for Brush137 (it's nothing about the lifts issue, it's just a little note), this Brush is not well built on the Grid, even if I set the Grid by 1 unit (and not the default 16 units). Try to build the brushes well built on the grid, by setting it's dimensions like 256.0000; 128.0000; 14.00000; but not like you did or scaled: 512.1452; 213.785 for example. This little note avoids many of BSP Holes problems, as HOMs too and some collision messing too.

Your map has now a lift working well and without the collision issue, and I will describe how to solve this on my tutorial about movers and stuff. :tu:

There's your map with a working lift, so you to able to make the other 2 :wink:
DM-CityStreetsBlahBETA.zip
EDIT: The tutorial I promissed is already there, on Mapping category. Take a look if you want to :wink:
You do not have the required permissions to view the files attached to this post.

User avatar
NIGHTCRAWLER
Novice
Posts: 12
Joined: Tue Mar 18, 2008 3:20 pm
Personal rank: HARDcOrEGAMER
Location: Canada

Re: lift problems, weird bug

Post by NIGHTCRAWLER » Wed Mar 19, 2008 8:28 pm

super sweet thank you :thuup: :tele2:
if this game ever dies, i go with it