Mute Music

Search and find cool Voicepacks, Sounds and Music or show us your own ones!
Post Reply
ghee
Novice
Posts: 8
Joined: Mon Sep 02, 2019 12:17 pm

Mute Music

Post by ghee » Tue Oct 15, 2019 12:20 pm

Hi, i tried turning the music all the way to zero in the preferences but the music persists

I set MusicVolume=0 and UseDigitalMusic=False

under [Audio.GenericAudioSubsystem] and [ALAudio.ALAudioSubsystem] in UnrealTournament.ini

and yet the music still persists.

Is there a way to mute the music once and for all?

Thank you

User avatar
OjitroC
Godlike
Posts: 1113
Joined: Sat Sep 12, 2015 8:46 pm

Re: Mute Music

Post by OjitroC » Tue Oct 15, 2019 3:01 pm

What are the settings under [Galaxy.GalaxyAudioSubsystem] in your UT.ini? MusicVolume should be =0.

ghee
Novice
Posts: 8
Joined: Mon Sep 02, 2019 12:17 pm

Re: Mute Music

Post by ghee » Tue Oct 15, 2019 6:04 pm

by UT.ini you mean UnrealTournament.ini? I don't see a UT.ini anywhere.

There is [Galaxy.GalaxyAudioSubsystem] in Default.ini and i just set that to 0 but yet the music still persists. Any other ideas?

User avatar
OjitroC
Godlike
Posts: 1113
Joined: Sat Sep 12, 2015 8:46 pm

Re: Mute Music

Post by OjitroC » Tue Oct 15, 2019 7:06 pm

ghee wrote:
Tue Oct 15, 2019 6:04 pm
by UT.ini you mean UnrealTournament.ini? I don't see a UT.ini anywhere.
Yes, I meant UnrealTournament.ini - apologies, I should have written it out in full.

In your UnrealTournament.ini, under [Engine.Engine], what is the AudioDevice? If it's Galaxy.GalaxyAudioSubsystem, then have a look further down in the ini for the heading [Galaxy.GalaxyAudioSubsystem] and ensure that MusicVolume=0.

Possibly your UnrealTournament.ini is write-protected as setting the Music Volume to 0 in Preferences in-game should result in MusicVolume=0 under [Galaxy.GalaxyAudioSubsystem] in your UnrealTournament.ini.

ghee
Novice
Posts: 8
Joined: Mon Sep 02, 2019 12:17 pm

Re: Mute Music

Post by ghee » Tue Oct 15, 2019 7:37 pm

AudioDevice=Audio.GenericAudioSubsystem under [Engine.Engine]

MusicVolume=0 under
[Audio.GenericAudioSubsystem]

yet music still persists :(

I changed the file permission on UT.ini to 644 and chown User, still no luck

User avatar
EvilGrins
Godlike
Posts: 6438
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: Mute Music

Post by EvilGrins » Tue Oct 15, 2019 10:00 pm

There are 2 possibilities:
1) Volume on your speakers is cranked way up!

2) Is this happening only on 1 specific map?

Reason I ask is that some mappers include the music as a sound, so it's not recognized under music settings.

The music you hear may be a sound, like gunfire or footsteps or wind or any number of things.

Try turning the overall volume all the way down, if this is for 1 map. Just to test.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Image Image Image Image

ghee
Novice
Posts: 8
Joined: Mon Sep 02, 2019 12:17 pm

Re: Mute Music

Post by ghee » Tue Oct 15, 2019 11:37 pm

thanks for the suggestion but i have the music turns off in the preferences in a Mac OS instance of UT99 where the same maps and main menu has no music.

This new install of UT99 is on LInux, and the music persists. If i go into preferences, the music turns off for a few minutes, then turns itself back on, and if i go into preferences again, it turns off for a few minutes before it turns on yet again.

User avatar
papercoffee
Godlike
Posts: 9403
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.
Contact:

Re: Mute Music

Post by papercoffee » Wed Oct 16, 2019 12:02 am

writing permissions

ghee
Novice
Posts: 8
Joined: Mon Sep 02, 2019 12:17 pm

Re: Mute Music

Post by ghee » Wed Oct 16, 2019 7:49 am

could you please elaborate on that? I set the file permissions to 644 and chown to the user. write persmissions shouldn't be the case now unless there is something I am missing?

User avatar
OjitroC
Godlike
Posts: 1113
Joined: Sat Sep 12, 2015 8:46 pm

Re: Mute Music

Post by OjitroC » Wed Oct 16, 2019 8:20 am

ghee wrote:
Wed Oct 16, 2019 7:49 am
could you please elaborate on that? I set the file permissions to 644 and chown to the user. write persmissions shouldn't be the case now unless there is something I am missing?
You can check if that works by making a change to your UnrealTournament.ini and then seeing if the LastModified/Saved date/time is altered (and/or starting the game, turning off the music under Preferences and exiting the game immediately, then checking on the LastModified/Saved date/time of your UnrealTournament.ini).

Have you tried changing the AudioDevice under [Engine.Engine] and seeing what happens?

User avatar
EvilGrins
Godlike
Posts: 6438
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: Mute Music

Post by EvilGrins » Wed Oct 16, 2019 9:42 am

I have what may be a very low-tech but obvious solution.

Disconnect your speakers.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Image Image Image Image

User avatar
sektor2111
Godlike
Posts: 4168
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: Mute Music

Post by sektor2111 » Wed Oct 16, 2019 7:22 pm

He was talking about MUSIC not about turning off Sounds.

ghee
Novice
Posts: 8
Joined: Mon Sep 02, 2019 12:17 pm

Re: Mute Music

Post by ghee » Thu Oct 17, 2019 12:01 am

OjitroC wrote:
Wed Oct 16, 2019 8:20 am
\You can check if that works by making a change to your UnrealTournament.ini and then seeing if the LastModified/Saved date/time is altered (and/or starting the game, turning off the music under Preferences and exiting the game immediately, then checking on the LastModified/Saved date/time of your UnrealTournament.ini).

Have you tried changing the AudioDevice under [Engine.Engine] and seeing what happens?
how do i go about cehcking the LastModified/Saved date/time?
my [Engine.Engine] has AudioDevice=Audio.GenericAudioSubsystem and MusicVolume=0 under [Audio.GenericAudioSubsystem]

but this has yet to do the trick? Am I missing something here? I appreciate everyone for their input and being engaged in this thread.

User avatar
OjitroC
Godlike
Posts: 1113
Joined: Sat Sep 12, 2015 8:46 pm

Re: Mute Music

Post by OjitroC » Thu Oct 17, 2019 10:47 am

ghee wrote:
Thu Oct 17, 2019 12:01 am
my [Engine.Engine] has AudioDevice=Audio.GenericAudioSubsystem ...
Change that to ALAudio.ALAudioSubsystem and see if it makes a difference. Also you can check in your UnrealTournament/System folder for any Galaxy files (Galaxy.u, .int and .dll) and see if you can use that.
ghee wrote:
Thu Oct 17, 2019 12:01 am
how do i go about checking the LastModified/Saved date/time?
I know nothing about Linux but I assume there is a 'program' similar to Finder in MacOS that will show you the directory/folder 'tree' and the contents of each directory/folder. Using that, go to your UnrealTournament/System folder, find the file UnrealTournament.ini and again I presume that there will be a way to get info on that file like the size and the date/time it was last modified and/or saved.

Post Reply