horrible tearing OR stuck at 30 fps

Discussions about UT99

horrible tearing OR stuck at 30 fps

Postby Levee44 » Tue Jan 16, 2018 4:04 pm

Hello!

I hope someone really clever can help me with this issue I'm having.

I'm using the latest version of UT with the latest OpenGL renderer. I don't use any third-party stuff (like textures etc.) except for the 436 patch and the renderer.

The problem is the following:
The refresh rate of my notebook LCD is 60 Hz and SwapInterval is set to '1' (i.e. VSync is on), so the game runs at 60 fps. Despite this, however, there is terrible screen tearing, especially around blinking lights, where even artifacts occur. I had the same problem with a few other games, e.g. Doom 3 vanilla and Quake 2, but there I could solve the problem by limiting the max fps to 55. For some reason, these games require a frame rate lower than the screen refresh rate to function properly on my PC.
However, this solution doesn't work with UT. I can limit the max fps to 55 and 'timedemo 1' reports that it is limited, but the screen tearing occurs just the same. I tried all kinds of possible combinations with driver settings and they don't make a difference.
The only solution is to set the SwapInterval to '2' (it has to be an integer), but that means limiting the game to 30 fps.

Setting a fake or null refresh rate in the .ini file doesn't work. I also tried to add a custom resolution with 110 Hz in Intel settings (hoping the screen itself would simply reject it instead of going into flames), but I can't; I get a maximum bandwidth error message.

The issue doesn't occur in Direct3D, but all D3D renderers I've been able to find have inferior graphics (e.g. no two-layer detail texturing) and for some reason antialiasing doesn't work at all under D3D in this game on my GPU, so I really don't want to use those.

Is there any way to make UT believe that the refresh rate is bigger than it really is?

My Computer is a Dell 7559 laptop with Windows 10 Home
CPU: 6th Gen. Intel C i5-6300HQ Quad C 2.3 GHz (6M Cache, up to 3.2 GHz)
RAM: 8GB Single Channel DDR3L 1600MHz (8GBx1)
HDD: Seagate 5400rpm 64MB SATA ST1000LM014
GPU: NVIDIA GeForce GTX 960M 4GB GDDR5 (+ intergrated Intel HD Graphics 530)

Thank you!
Levee44
 
Posts: 2
Joined: Tue Jan 16, 2018 3:24 pm

Re: horrible tearing OR stuck at 30 fps

Postby OjitroC » Tue Jan 16, 2018 4:26 pm

This happens on any/every map?

What versions of OpenGL and D3D are you using?
User avatar
OjitroC
Inhuman
 
Posts: 802
Joined: Sat Sep 12, 2015 8:46 pm

Re: horrible tearing OR stuck at 30 fps

Postby Pileyrei » Tue Jan 16, 2018 5:02 pm

Not sure if this is helpful or not. Forgive me if not!
Copied from tweak your graphics document: https://www.unrealsurvivors.com/viewtopic.php?f=13&t=17

Try changing/checking some of these settings

[OpenGLDrv.OpenGLRenderDevice]
ZRangeHack=True
NoAATiles=True
NumAASamples=4 // Level of anti-aliasing, valid values are 0, 2, 4 and 8.
UseAA=True //Enable anti-aliasing.
MaskedTextureHack=True
SmoothMaskedTextures=False
SceneNodeHack=True
FrameRateLimit=62 // Do not go over 100 or you’ll get some inconstant game speeds.
SwapInterval=0 // 0 means Vsync off, 1 means Vsync on (will cause mouse imput lag).
UseFragmentProgram=True
UseMultiDrawArrays=True
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=True
UseTexPool=True
UseTexIdPool=True
UseSSE2=True
UseSSE=True
BufferTileQuads=True
SinglePassDetail=False
SinglePassFog=True
ColorizeDetailTextures=False
DetailClipping=False
DetailMax=2
RefreshRate=75 // Set maximum refresh rate your display supports.
MaxTMUnits=0
NoFiltering=False
MaxAnisotropy=16 // Level of anisotrophic filtering.
Use16BitTextures=False
UseS3TC=True // Enable higher resolution S3TC textures.
UseAlphaPalette=True
UseTrilinear=True
UsePrecache=True
ShareLists=False
UsePalette=True
UseMultiTexture=True
UseBGRATextures=True
UseZTrick=False
MaxLogTextureSize=12
MinLogTextureSize=0
OneXBlending=False
GammaCorrectScreenshots=False
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.000000
LODBias=-1.000000 // Use negative values to sharpen textures, positive to blur them.
DetailTextures=True
DescFlags=0
Description=ATI Radeon HD 4800 Series // Add your GPU description if you want to.
HighDetailActors=True
Coronas=True
ShinySurfaces=True
VolumetricLighting=True
http://www.unrealsurvivors.com

Image

Our Servers
Image
Image



Donate to UT99.org!
Pileyrei
Masterful
 
Posts: 602
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Re: horrible tearing OR stuck at 30 fps

Postby Levee44 » Tue Jan 16, 2018 5:32 pm

OjitroC wrote:This happens on any/every map?

What versions of OpenGL and D3D are you using?


It happens on every map. I don't know how to check the version of the renderers, but I tried D3D10 again, and it seems both detail texturing and antialiasing are working fine.

I realized, however, that in the OpenGL renderer, the cause of the problem is that the FrameRateLimit setting doesn't work. The game will report the FrameRateLimit fps, but is actually running at monitor frequency.

Thank you all for answering!
Levee44
 
Posts: 2
Joined: Tue Jan 16, 2018 3:24 pm

Re: horrible tearing OR stuck at 30 fps

Postby Qwerty » Wed Jan 17, 2018 7:22 pm

on my laptop sometimes my framerate is locked. To quickly fix this type preferences in console then exit out of the preferences box and boom my FPS jump back to high hundreds. also make sure vsync is off.
http://www.vulpinemission.com
Image ROCKET-X8 Server
Image MONSTERHUNT w/ NALI WEAPONS 3 + RX8
Image BUNNYTRACK NY
Image SIEGE ULTIMATE
Qwerty
Masterful
 
Posts: 630
Joined: Wed Mar 12, 2008 7:14 pm
Location: New York
Personal rank: I.T Master

Re: horrible tearing OR stuck at 30 fps

Postby Chamberly » Wed Jan 17, 2018 9:52 pm

Sometimes trying out other settings that should work with your graphic card do better.

Feel free to try out some of these. https://ooper.000webhostapp.com/ut/inis/
Image
Image
irc.globalgamers.net #uscript
http://irc.lc/globalgamers/uscript
Image
User avatar
Chamberly
Godlike
 
Posts: 1607
Joined: Sat Sep 17, 2011 4:32 pm
Location: TN, USA
Personal rank: Dame. Vandora

Re: horrible tearing OR stuck at 30 fps

Postby iSenSe » Mon Feb 12, 2018 8:32 am

tried all kinds of possible combinations with driver settings and they don't make a difference.
The only solution is to set the SwapInterval to '2' (it has to be an integer), but that means limiting the game to 30 fps.



Have you also checked that the VSync settings in your UT are not overrided by the nVidia Control Panel / ATI Catalyst Control Center?
Problem is mostly caused through the driver; VSync and AA settings are overrided, and what you will set in the UT.ini has no effect at all.
Driver is always leading/overriding.

Had this issue for a long time.
Appeared that in my nVidia control panel i had to set vsync settings to ''adaptive'', so it will check the application/game settings and apply those.
When i changed this, my tearing was finally gone.
Every time when i switched on VSync, the tearing was gone, but i had terrible key-input-lag, and a gliding mouse.



[OpenGL]
SwapInterval=0
UseVsync=False

[Direct3d9]
SwapInterval=0

Driver VSYNC = Adaptive

Should be good!
Refreshrates at 60 or higher in case you have a better screen ;)
Image
Image

For many of us it's just a dream.
They are guided by the mainstream.
You need some balls, some self-esteem?
Come join us at the substream!

https://www.ClassicUT99.com
User avatar
iSenSe
Average
 
Posts: 67
Joined: Mon Aug 31, 2015 12:58 pm


Return to General Discussions

Who is online

Users browsing this forum: No registered users and 0 guests