Still experiencing the speed-up bug

Get some cool tips about how to tweak your UT graphic, gameplay, and much more!
User avatar
brazzjazz
Average
Posts: 44
Joined: Sat Feb 13, 2010 12:51 pm
Location: Germany

Still experiencing the speed-up bug

Post by brazzjazz » Sat Feb 13, 2010 1:22 pm

Hi everyone!

Yesterday I returned to my UT99, since it still fascinates me, more than any of its successors. I got my UT running again, except for one thing: the fact that UT99 runs very fast and with varying speed. I experience this only with VSync disabled. However, I can't turn it on because then I experience a slight but annoying mouse lag. In another thread,
http://www.ut99.org/forum/viewtopic.php ... hilit=fast
this speed-up problem has already been discussed. However, I didn't get the problem fixed by using the newest DLLs. Perhaps it worked for the other one because the D3D8Drv.dll has again VSync enabled. The speed-up works in a way that UT runs faster when the polygon count decreases (in small corridors for example). This small how-to
http://fingel.com/ut/howtos/utonlinux.html
is among other things dedicated to this problem, however only under Linux.
Also AMD's Cool 'n' Quiet has been said to cause the issue, however I just turned it off in the BIOS and the speed-up bug still exists. It really rather looks like the CPU is always at full throttle which would explain why it's faster in simple surroundings.

Any other workaround?

Thanks!

CPU: AMD Athlon64 3500+
Graphics: Ati Radeon X800 XT

gopostal

Re: Still experiencing the speed-up bug

Post by gopostal » Sat Feb 13, 2010 3:21 pm

This will suck but delete your user.ini and unrealtournament.ini and let it generate a new default one for both. The reason is that your processor is polled for it's speed when you installed and that value is added into the game's setup. Even if you disable speed stepping or cool-n-quiet, the game still won't know your processor speed is different until it "forgets" that bit of data. If the default ini's don't do it, try a quick reinstall to another folder with the speed stepping disabled to see if it clears the issue. I'll bet you the first will clear you up and if not the second will. Good luck and glad to see you back in the game!

User avatar
Sergeant Todd
Adept
Posts: 407
Joined: Mon Mar 03, 2008 2:09 am
Personal rank: Retired Jedi
Location: Ocho Rios Jamaica
Contact:

Re: Still experiencing the speed-up bug

Post by Sergeant Todd » Sat Feb 13, 2010 3:46 pm

gopostal wrote:This will suck but delete your user.ini and unrealtournament.ini and let it generate a new default one for both. The reason is that your processor is polled for it's speed when you installed and that value is added into the game's setup. Even if you disable speed stepping or cool-n-quiet, the game still won't know your processor speed is different until it "forgets" that bit of data. If the default ini's don't do it, try a quick reinstall to another folder with the speed stepping disabled to see if it clears the issue. I'll bet you the first will clear you up and if not the second will. Good luck and glad to see you back in the game!
Phraggonía, when it's running OK again, make a copy of your user.ini and unrealtournament.ini, and put them somewhere other than the UT directory. :D
Sergeant Todd
---------------

"I miss Olmos & BG, as a matter of frak'd!"

User avatar
brazzjazz
Average
Posts: 44
Joined: Sat Feb 13, 2010 12:51 pm
Location: Germany

Re: Still experiencing the speed-up bug

Post by brazzjazz » Sat Feb 13, 2010 7:33 pm

1. I did as you told me and deleted both INIs and restarted the game - no improvement.
2. Then I went into the BIOS, disabled Cool 'n' Quiet, booted again, started UT again without INIs - no improvement.
3. Then I used a copy of my original UT folder and ran UT there without INIs - no improvement.

I don't know whether the third one was really the same as a new installation - unfortunately I don't have the install CD with me right now, neither know I whether UT does some more CPU analysis in the install process than just without the INIs.

I do have to say however that I installed the game with my current CPU so UT had already the chance to detect my CPU speed?

UT99.org

Re: Still experiencing the speed-up bug

Post by UT99.org » Sat Feb 13, 2010 8:12 pm

medor wrote:It come from your processor.

For your d3d8 you must add in ur UT.ini
[D3D8Drv.D3D8RenderDevice]
UseVSync=False
SwapInterval=0
ZRangeHack=False
NoAATiles=False
NumAASamples=0
UseAA=False
RequestHighResolutionZ=True
UseSoftwareVertexProcessing=False
UsePureDevice=True
UseTripleBuffering=False
MaskedTextureHack=False
SmoothMaskedTextures=False
FrameRateLimit=150
UseVertexProgram=True
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=False
UseTexPool=True
UseTexIdPool=True
UseSSE2=True
UseSSE=True
BufferTileQuads=True
BufferClippedActorTris=True
SinglePassDetail=False
SinglePassFog=False
ColorizeDetailTextures=False
DetailClipping=False
UseDetailAlpha=True
DetailMax=0
RefreshRate=0
MaxTMUnits=0
NoFiltering=False
MaxAnisotropy=0
Use565Textures=False
Use16BitTextures=False
UseS3TC=False
UseAlphaPalette=False
UseTrilinear=False
UsePrecache=False
UsePalette=False
UseMultiTexture=True
MaxLogTextureSize=8
MinLogTextureSize=0
MaxLogVOverU=8
MaxLogUOverV=8
OneXBlending=True
GammaCorrectScreenshots=False
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.100000
LODBias=0.000000
DetailTextures=False
DescFlags=0
Description=
HighDetailActors=False
Coronas=False
ShinySurfaces=False
VolumetricLighting=False
If u whant an UT ready with this ...you have UnrealTournament-V3 with d3d9 or opengl .

Have you search a patch for ur processor ? http://www.amd.com/index.html

gopostal

Re: Still experiencing the speed-up bug

Post by gopostal » Sat Feb 13, 2010 8:53 pm

To answer you, yes it does actually use values in places other than the two ini's when it installs. Some values are saved as registry entries, etc. so that's why a reinstall is a last resort but sometimes what it takes to fix a corrupted UT installation.

User avatar
brazzjazz
Average
Posts: 44
Joined: Sat Feb 13, 2010 12:51 pm
Location: Germany

Re: Still experiencing the speed-up bug

Post by brazzjazz » Sat Feb 13, 2010 9:21 pm

FrameRateLimit=150 worked! :) With VSync (= max 60 fps) enabled I still had mouse lag, if it's still there it's much smaller now! Thanks a lot to all!
Last edited by brazzjazz on Sun Feb 14, 2010 2:22 am, edited 1 time in total.

UT99.org

Re: Still experiencing the speed-up bug

Post by UT99.org » Sat Feb 13, 2010 10:43 pm

medor wrote:For beast play change to in
[WinDrv.WindowsClient]
MinDesiredFrameRate=30.000000 set it to 60.000000 or hight if your screened is set up hight like 75.0000000 or more.

minimum to
MinDesiredFrameRate=60.000000

User avatar
Lee_Stricklin
Adept
Posts: 321
Joined: Tue Mar 11, 2008 4:49 am
Personal rank: XFire: leestricklin
Location: Midwest
Contact:

Re: Still experiencing the speed-up bug

Post by Lee_Stricklin » Wed Feb 17, 2010 8:07 am

Here's the easy way to fix it:
http://www.ut-files.com/index.php?dir=U ... UT_Fix.zip
Just replace your exe with this one. If you want to run Unreal/Return to Na Pali though you'll have to grab a new renderer (like D3D9 or the latest OpenGL) and set the fps limit below 200 as well as fire the game up on one core. If running on Windows you'll have to do the set affinity thing, if running in WINE (since the Linux and Mac clients are useless) then you can just add "taskset -c 0" in front of the command line to the game's launcher.
Use this link to get rid of the skating glitch server-side.

http://www.unrealtexture.com/UT/Website ... ckages.htm

User avatar
Raynor
Adept
Posts: 419
Joined: Sun Jan 27, 2008 5:09 pm

Re: Still experiencing the speed-up bug

Post by Raynor » Sun Mar 07, 2010 8:35 pm

I would recommand using even lower FrameRateLimit, because anything over 100 seems to freak out particle effects and animated textures when playing offline and sometimes even online. For example when player is wearing shield belt, its glowing animation is way too fast, so are some fire etc. animations. In my opinion values somewhere 62...90 seem to be sweet spot.

bl!nk
Novice
Posts: 4
Joined: Wed Apr 14, 2010 11:31 pm

Re: Still experiencing the speed-up bug

Post by bl!nk » Thu Apr 15, 2010 12:02 am

Chiming in with a similar problem. I bought the steam version and the D3d renderer causes speed problems, making the game slow down and speed up all the time (on a laptop btw). Changing the processor affinity and disabling speedstep/power management in the BIOS did nothing. I've been forced to use the software renderer, which works fine despite looking a bit poo. I had the same problems with Deus Ex (also unreal engine), but managed to find a custom replacement exe file that uses openGL.

SO my question is: is there a similar custom UT99 exe file? I'd rather not hack about with the ini files unless I really have to, since I don't really know what i'm doing. :help:

Thanks!

User avatar
rohitggarg
Adept
Posts: 400
Joined: Wed Mar 12, 2008 7:18 am
Personal rank: The name is Bu||et
Location: India
Contact:

Re: Still experiencing the speed-up bug

Post by rohitggarg » Thu Apr 15, 2010 5:27 am

Dude, i found out that only disabling the speedstep doesn't do the trick.. Your OS also has a power management feature which has got three options for battery power. I had to set it to high performance to get rid of that filthy lag. But after setting that, I was able to run UT like i wanted it to (all settings to the top and blazing resolution).

BTW i got core 2 duo laptop wid win7 x64
Regards,
Rohit

CATCH ME IF YOU CAN.............
Image

My website : http://www.appointmentagent.com

bl!nk
Novice
Posts: 4
Joined: Wed Apr 14, 2010 11:31 pm

Re: Still experiencing the speed-up bug

Post by bl!nk » Tue Apr 20, 2010 7:50 pm

Tried that, no good. Thanks anyway:)

I'm running the same processor and OS as you, what graphics card are you using?

User avatar
rohitggarg
Adept
Posts: 400
Joined: Wed Mar 12, 2008 7:18 am
Personal rank: The name is Bu||et
Location: India
Contact:

Re: Still experiencing the speed-up bug

Post by rohitggarg » Wed Apr 21, 2010 9:59 am

Intel 4000MHD and i must say its something i love for multimedia :). BTW i got a dell 1545 just in case u waana know more....
Regards,
Rohit

CATCH ME IF YOU CAN.............
Image

My website : http://www.appointmentagent.com

AlchemistX
Novice
Posts: 3
Joined: Sat Dec 17, 2011 6:14 pm

Re: Still experiencing the speed-up bug

Post by AlchemistX » Sat Dec 17, 2011 6:28 pm

I'll suggest using the latest OpenGL-Drv 3.6 Game rendering method. Download the files from here [http://www.cwdohnal.com/utglr/] and use it as your game rendering device. Hopefully that'll solve the problem , worked for me. I play ut in windows 7 64 bit :)

Post Reply