TUTORIAL: Unreal Tournament Audio & Visuals Tweaking Guide

Get some cool tips about how to tweak your UT graphic, gameplay, and much more!
Post Reply
shankman
Novice
Posts: 3
Joined: Mon Sep 08, 2008 12:30 pm

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by shankman » Mon Sep 08, 2008 12:34 pm

ty 4 the info

WindWalker
Posts: 1
Joined: Thu May 15, 2008 12:47 am

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by WindWalker » Tue Sep 16, 2008 1:12 am

Very nice tutorial!

Forty
Posts: 2
Joined: Tue Sep 23, 2008 2:56 pm

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by Forty » Wed Sep 24, 2008 3:52 am

Very nice tutorial, took only a few minutes and the game looks better than ever! Thanks man!

Logan
Posts: 2
Joined: Thu Sep 25, 2008 2:36 pm

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by Logan » Fri Sep 26, 2008 10:58 am

Thanks for the nice tutorial, my UT runs really nice now on mine and my brother Quad cores.

Only i always had this problem because of SwapInterval=0, it's nice to hit but when i move the mouse i can see the horizontal line of the refresh rate. I don't know if it's normal or not.

Any ideas ?
Last edited by Logan on Fri Sep 26, 2008 5:25 pm, edited 1 time in total.

User avatar
Raynor
Adept
Posts: 419
Joined: Sun Jan 27, 2008 5:09 pm

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by Raynor » Fri Sep 26, 2008 3:18 pm

Logan wrote:Thanks for the nice tutorial, my UT runs really nice now on my and my brother Quad cores.

Only i always had this problem because of SwapInterval=0, it's nice to hit but when i move the mouse i can see the horizontal line of the refresh rate. I don't know if it's normal ou not.

Any ideas ?
Hi Logan,

Could you please elaborate that issue? Is that like image tearing or something else? First thing your should try is to set proper refresh rate (native or highest your display can support) and check that your FrameRateLimit does not exceed 200, best is to stay somewhere 180 since I've noticed with value 200 maximum frames can still go little bit over 200 (~210), but I don't think it's the main cause, just additional info. I've experienced smilar issue long time ago when I was using lower refresh rate than my desktop's refresh rate.

Logan
Posts: 2
Joined: Thu Sep 25, 2008 2:36 pm

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by Logan » Fri Sep 26, 2008 5:34 pm

Well i can't tell much more, when i move the mouse up and down i can see some lines, like when you record with a camera a monitor, you can see lines that you don't see normaly looking to the monitor.

About the refresh rate, i've set it to 85 in game since it's same on windows. The frameratelimite is set to 85 aswell.

To my brother it worked to put the refresh rate at 75 and the frameratelimit to 85 since he has a TFT.

*EDIT*

About the S3TC textures, when i replace my normal ones by them i can't see the movements of the players while playing.

User avatar
Raynor
Adept
Posts: 419
Joined: Sun Jan 27, 2008 5:09 pm

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by Raynor » Fri Sep 26, 2008 6:45 pm

Logan wrote:Well i can't tell much more, when i move the mouse up and down i can see some lines, like when you record with a camera a monitor, you can see lines that you don't see normaly looking to the monitor.

About the refresh rate, i've set it to 85 in game since it's same on windows. The frameratelimite is set to 85 aswell.

To my brother it worked to put the refresh rate at 75 and the frameratelimit to 85 since he has a TFT.

*EDIT*

About the S3TC textures, when i replace my normal ones by them i can't see the movements of the players while playing.
Try higher frameratelimit like 170, this might resolve your issue.
What concerns about missing player animations please refer to first post of this thread. You need to download attached S3TC textures fix and use it as described.
Good luck.

Syphon
Posts: 1
Joined: Tue Nov 04, 2008 12:10 am
Personal rank: [GoC]

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by Syphon » Tue Nov 04, 2008 12:18 am

I have the gliding players problem on servers that use the textures from the 2nd cd (I did not install those textures myself). I hope the fix will cover this problem.

Lodeep
Posts: 2
Joined: Fri Nov 28, 2008 2:16 am

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by Lodeep » Fri Nov 28, 2008 2:19 am

This is a nice tutorial thxz big time :rock:

User avatar
Burd!K
Posts: 2
Joined: Fri Dec 05, 2008 4:10 pm
Personal rank: UT and CoD Master
Contact:

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by Burd!K » Fri Dec 05, 2008 4:25 pm

:gj: great guide, dude! I'm tweaking graphics in all games I'm playing. *In a whisper* i tweaked it even in Quake 3 *_*
Image
Image

David_OSU
Novice
Posts: 24
Joined: Tue Jan 06, 2009 8:18 pm

SmoothMaskedTextures

Post by David_OSU » Tue Jan 06, 2009 8:41 pm

I posted this to the graphics tutorial on the home page, but I think it makes more sense here in the Forum (I'm new to the site, so I'm still finding my way around):

For highest quality with OpenGL, set SmoothMaskedTextures=True (not False as shown in the tutorial). This smooths the edges of masked textures which helps them blend into the image better, rather than looking like fake cutouts. The rendering hardware doesn’t anti-alias the edges of masked textures, but this edge smoothing looks like anti-aliased edges. Note, this setting only smooths the edges of masked textures, not the whole texture (the inner parts of the texture will not be blurred). AFAIK, the edges are smoothed by adding an alpha layer at the very edge of the mask over a few pixels.

David_OSU
Novice
Posts: 24
Joined: Tue Jan 06, 2009 8:18 pm

OneXBlending

Post by David_OSU » Tue Jan 06, 2009 8:46 pm

Another setting that may be incorrect in the tutorial. At least on my hardware (ATI Radeon 9700), the image quality looks slightly better with OneXBlending=True using the OpenGL renderer. I loaded up a lot of maps with OneXBlending set both ways, and the lighting just looks better with OneXBlending set to True. In particular, the effect of lightmaps seems diminished when OneXBlending is set to False.

However, this particular setting may be hardware-dependent (and renderer dependent), so it is probably good to play with this one and set it the way you like.

iNFiN1TY
Posts: 1
Joined: Thu Jan 08, 2009 11:37 am
Personal rank: GodLike

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by iNFiN1TY » Thu Jan 08, 2009 11:53 am

Thanks, going to use that d3d9 one instead of 8 i got atm, and the high textures thingy..

User avatar
Shoulon
Novice
Posts: 10
Joined: Thu Feb 05, 2009 6:54 pm
Personal rank: Skilled

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by Shoulon » Thu Feb 05, 2009 8:01 pm

I Didin't get to make a Before picture, but i'm shure you can just go play the level to see the difference. SO far Iv'e noticed that the Floor texture is new, the entire Tower Building looks Very much more detailed. ( I haven't fully checked out UT with the new tweaks but this is what I noticed instantly.)

Map - Facing Worlds -- Capture the Flag

Image

I'll Post more if Requested.
Image

User avatar
Raynor
Adept
Posts: 419
Joined: Sun Jan 27, 2008 5:09 pm

Re: TUTORIAL: Tweak your UT graphics to the maximum

Post by Raynor » Sun Feb 08, 2009 1:42 pm

I see you're using UTRP textures and your Earth texture is still old low res one. Use the one from UT CD2 (XbpFX.utx) to get higher resolution Earth texture.

Post Reply