Need some help with sounds & skins

Get some cool tips about how to tweak your UT graphic, gameplay, and much more!
Post Reply
User avatar
Zeppy
Novice
Posts: 25
Joined: Thu Nov 26, 2015 11:53 am

Need some help with sounds & skins

Post by Zeppy » Thu Nov 26, 2015 12:08 pm

I wasn't sure which section to put this in but I'll put it here anyway, moderators can move it to the correct section.

First the textures.
I tried editing some skins to put on weapons, I edited all on photoshop and try adding new textures as skins. I import the edited textures, save them but when I try to add them to a weapon/item, it doesn't show when I test them ingame, i just get original skins, also sometimes when I try compiling the scripts, I get an error "can't find texturepackage.texturename" even when I try adding the packages to the umake still get the same error.

Now the sounds.
I imported some sounds, also saved the .aux package, but when I try firing for example, there's no sound.

would appreciate any help.
Image

User avatar
editor Dave
Inhuman
Posts: 902
Joined: Mon Mar 10, 2008 6:40 pm
Personal rank: Slave of SP Mapping
Location: Germany/Bavaria

Re: Need some help with sounds & skins

Post by editor Dave » Thu Nov 26, 2015 2:59 pm

First of all, welcome to ut99.org!

For your sound problem we might need more info, for example what you tried to attach the sound to the weapon, if you can play the sound in the editor, the length of the sound, etc.

Concerning your skin problem you probably didn't consider the MultiSkins option in the display section of the item's properties. If your item has several skin textures, you don't replace the texture under "Skin" but "MultiSkins". There you put in the required textures in the right order and you'll notice the display will change! [Well, this is the way to do it by changing the default properties. If you want to implement the skins by code, the expert coders will be here in no time ^^ It doesn't matter how you do it, anyway, as far as I'm concerned.]
Image
10-Year Anniversary on Jun 08, 2019.

User avatar
Zeppy
Novice
Posts: 25
Joined: Thu Nov 26, 2015 11:53 am

Re: Need some help with sounds & skins

Post by Zeppy » Thu Nov 26, 2015 3:49 pm

I'm working on two flakcannon mods
my first one is I'm trying to use the ut2k4Flak sounds, both normal and alt fire (used audacity since you can't really convert the weapon sounds from ut2k4)
my other one is the one im trying to get the skin onto I'm using the unreali flak and it has only 1 skin but i tried putting the edited flak skin in multiskin, I export the file as pcx, edit with photoshop, save and import it as bmp, i of course make it indexed
I can't seem to open the texture package I saved when I restart my unrealed.
Image

User avatar
editor Dave
Inhuman
Posts: 902
Joined: Mon Mar 10, 2008 6:40 pm
Personal rank: Slave of SP Mapping
Location: Germany/Bavaria

Re: Need some help with sounds & skins

Post by editor Dave » Thu Nov 26, 2015 5:30 pm

There's no reason to import the texture as .bmp as it only takes more space without changing the outcome. Better import the skin as .pcx. I just checked out the U1 Flak. Indeed, it only has one skin, but you can only change it under "MultiSkins" if you put your modified texture in the second line [1].

If I change the sounds of the Flak with regular sounds from Unreal/UT it works, so it must be your audio files that are not imported correctly. Can you hear the sounds via the sound browser of UnrealED? If you don't, could you upload one of the sounds so we can check what's wrong?
Image
10-Year Anniversary on Jun 08, 2019.

User avatar
Zeppy
Novice
Posts: 25
Joined: Thu Nov 26, 2015 11:53 am

Re: Need some help with sounds & skins

Post by Zeppy » Fri Nov 27, 2015 8:31 am

I'll send you the sound package. (check PM).
The sound plays fine in UnrealEd but when I try putting it in the weapon I get no sound, I tried saving the .u package after adding in the sounds but when I restart my editor, the sounds are back to none, i tried setting the sounds ingame with console command set flakcannon firesound ut2k4flakcannon.ut2k4flakcannonfire, that didn't work so I don't know whats up with that.
Image

User avatar
editor Dave
Inhuman
Posts: 902
Joined: Mon Mar 10, 2008 6:40 pm
Personal rank: Slave of SP Mapping
Location: Germany/Bavaria

Re: Need some help with sounds & skins

Post by editor Dave » Sat Nov 28, 2015 7:08 pm

So I looked into this and it seems your sounds are alright overall. It may be a problem with how the Flak's sound play is programmed, because I noticed the following: If you shoot the primary fire and there are no obstacles in the way, the sound will be played normally, but it will stop as soon as one projectile hits something. I've got no issues with the secondary fire, except sometimes the sound looped (for whatever reason). I'm not sure how to fix the primary fire's sound. Maybe you have tochange the code even. Or has someone else experienced this issue when modifying the U1 Flak?

I uploaded a picture to show you what needs to be done if you want to change the skin. As you can see, if you insert a new texture in the second line of MultiSkins, the display will change accordingly.
Attachments
FlakSkin.jpg
Image
10-Year Anniversary on Jun 08, 2019.

Post Reply