Redirect broken after installing xc_engine

Post Reply
nuxx
Novice
Posts: 11
Joined: Sat Dec 09, 2017 7:40 pm

Redirect broken after installing xc_engine

Post by nuxx » Sun Jun 16, 2019 9:19 pm

I've installed Xc engine on my server, no crashes so far.. However the redirect is broken

Image

[XC_IpDrv.XC_TcpNetDriver]
ConnectionLimit=128
LogPortUnreach=False
AllowPlayerPortUnreach=False
DownloadManagers=XC_IpDrv.XC_HTTPDownload
DownloadManagers=IpDrv.HTTPDownload
DownloadManagers=XC_Core.XC_ChannelDownload
MaxDownloadSize=0
AllowDownloads=True
LanServerMaxTickRate=50
NetServerMaxTickRate=65
MaxClientRate=25000
ServerTravelPause=4.000000
SpawnPrioritySeconds=1.000000
RelevantTimeout=6.000000
KeepAliveTime=0.000000
InitialConnectTimeout=25.000000
ConnectionTimeout=10.000000

Original

[IpDrv.HTTPDownload]
RedirectToURL=https://cwfiles3.clanwarz.com/fastfiles ... tFilesOut/
ProxyServerHost=
ProxyServerPort=3128
UseCompression=True

I added the following

[XC_Core.XC_ChannelDownload]
RedirectToURL=https://cwfiles3.clanwarz.com/fastfiles ... tFilesOut/
ProxyServerHost=
ProxyServerPort=3128
UseCompression=True

Didn't fix it however

User avatar
Hook
Masterful
Posts: 747
Joined: Tue Apr 22, 2008 11:21 pm
Personal rank: UT99 Promoter/Admin
Location: Minnesota USA
Contact:

Re: Redirect broken after installing xc_engine

Post by Hook » Sun Jun 16, 2019 9:41 pm

Possibly any spaces in ini file?
Select text and check for spaces. (at end of lines of text etc)

Possible typos?

This kind of stuff causes more errors than people think.
=Hook=(Member# 626)
Active Forums: http://hooksutplace.freeforums.net
UT99 Server -> CROSSBONES Missile Madness {CMM}

* Newest Versions of: PRO-Redeemers | PRO-SNIPER-Redeemers | PRO-SEEKER-Redeemers <-(the Original)
and Now with FOOD FIGHT and Frying Pan arena !!!
IP: 68.232.181.236:7777
{CMH} CROSSBONES Monster Hunt (MH) by Mars007 (The Original) - IP: 108.61.238.93:7777

nuxx
Novice
Posts: 11
Joined: Sat Dec 09, 2017 7:40 pm

Re: Redirect broken after installing xc_engine

Post by nuxx » Sun Jun 16, 2019 10:02 pm

looks all good, even with the .uz files in the redirect folder it's still not working.

-MERGED-

I've turned off redirect for now and it's working fine, server is fast enough.

User avatar
papercoffee
Godlike
Posts: 9735
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.
Contact:

Re: Redirect broken after installing xc_engine

Post by papercoffee » Sun Jun 16, 2019 11:31 pm

It might be that you haven't read my comment in the other thread.
papercoffee wrote: Please avoid double posts within a 24 hour time limit.
If no one other has answered after you please edit your former post to add more informations

Higor
Godlike
Posts: 1821
Joined: Sun Mar 04, 2012 6:47 pm

Re: Redirect broken after installing xc_engine

Post by Higor » Mon Jun 17, 2019 1:57 am

You may:

Remove the following

Code: Select all

DownloadManagers=XC_IpDrv.XC_HTTPDownload
Or add the following

Code: Select all

[XC_IpDrv.XC_HTTPDownload]
RedirectToURL=https://cwfiles3.clanwarz.com/fastfiles/145.239.139.111_7777/UtFilesOut/
ProxyServerHost=
ProxyServerPort=3128
UseCompression=True
ImageImage
Image unreal://23.111.157.138:7777
Image unreal://46.228.199.205:7788

Post Reply