Error

Post Reply
Insanext
Posts: 2
Joined: Thu May 21, 2020 8:50 am
Personal rank: n00b

Error

Post by Insanext » Fri May 22, 2020 3:25 am

Hello, I followed the steps to install XC_ENGINE but when I open the game I get this error

Image

I fixed it changed this line in ut.ini:
GameEngine=XC_Engine.XC_GameEngine

for this:
EditorEngine=Editor.EditorEngine

but leaving it like this I should assume that the xc_engine is not installed.
any idea?

ty

User avatar
Deepu
Skilled
Posts: 210
Joined: Mon Nov 11, 2013 7:56 am
Personal rank: Average
Location: India
Contact:

Re: Error

Post by Deepu » Fri May 22, 2020 4:06 am

Are you using new patch? XC_ is not supported with new patch, I think

User avatar
sektor2111
Godlike
Posts: 4433
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: Error

Post by sektor2111 » Fri May 22, 2020 6:19 am

GameEngine it's not the same thing as EditorEngine.

XC_Engine (probably until v24b) doesn't work in UT 469 - at least not at this time.

For previous versions there are more changes needed in ini file, including settings for XC_IpDrv and having Engine section declared as
[XC_Engine.XC_GameEngine] instead of [Engine.GameEngine]. Then declaring download managers, variables are needed in all sections.

Insanext
Posts: 2
Joined: Thu May 21, 2020 8:50 am
Personal rank: n00b

Re: Error

Post by Insanext » Fri May 22, 2020 4:58 pm

sektor2111 wrote:
Fri May 22, 2020 6:19 am
GameEngine it's not the same thing as EditorEngine.

XC_Engine (probably until v24b) doesn't work in UT 469 - at least not at this time.

For previous versions there are more changes needed in ini file, including settings for XC_IpDrv and having Engine section declared as
[XC_Engine.XC_GameEngine] instead of [Engine.GameEngine]. Then declaring download managers, variables are needed in all sections.
The version of my ut is 451 and xc_engine is the 24 version.

What else do I have to add in the .ini file settings?

User avatar
Chamberly
Godlike
Posts: 1853
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA
Contact:

Re: Error

Post by Chamberly » Fri May 22, 2020 7:26 pm

Did you get the right XC_Core version?
Image
Image
Image

User avatar
sektor2111
Godlike
Posts: 4433
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: Error

Post by sektor2111 » Fri May 22, 2020 7:41 pm

Since the XC_Engine compilation strategy was changed, more precisely since version 22 I have had all kinds of problems. Now I have a version of UT 451b but it works with version XC 21. The errors that I saw are practically illegible, there are messages about system libraries, there were changes that did not help me at all.

Post Reply