Page 35 of 35

Re: FerBotz (new AI, XCGE release 20)

Posted: Wed Feb 14, 2018 7:44 am
by esnesi
Deepak O V wrote:Use Suppress=ScriptWarning
Thanks, i know this suppresses everything though.
We probably still need debug information for the future probably.

I should rephrase my question; how to suppress certain output from this baby :)

Will tweak 'em upcoming weeks.
Can finally tingle with this now :)

Re: FerBotz (new AI, XCGE release 20)

Posted: Wed Feb 14, 2018 2:56 pm
by Deepu
IDK much more, otherwise go to fix your accessed nones with editing each mods...

Re: FerBotz (new AI, XCGE release 20)

Posted: Wed Feb 14, 2018 6:39 pm
by Chamberly
Deepak O V wrote:Use Suppress=ScriptWarning
Please keep in mind, it's best to not ever use this because you are not really fixing the main cause of the issue, you are only hiding it.

Things can be fixed, but never a good idea to always hide it and let it never be fixed because it can build up a lot of issue in the background. ;)

Re: FerBotz (new AI, XCGE release 20)

Posted: Thu Feb 15, 2018 3:09 am
by Deepu
Yes I know, for example
local pawn p;
if (pawn != none)
Eg: code;

Re: FerBotz (new AI, XCGE release 20)

Posted: Thu Apr 02, 2020 11:32 am
by abomination
Is there anywhere in any logs that I might be able to identify what is causing Botz to be invisible? I'm running FerBotz_cl_4 with XC_Engine 24 and I noticed yesterday that the botz spawn and are like ghosts. Their skin/model does not appear at all until they are dead.

I tried removing a recent package I added and rolling back my BotzDefault.ini to what it was but I'm not having any luck. :noidea

Re: FerBotz (new AI, XCGE release 20)

Posted: Thu Apr 02, 2020 1:35 pm
by Chamberly
abomination wrote:
Thu Apr 02, 2020 11:32 am
Is there anywhere in any logs that I might be able to identify what is causing Botz to be invisible? I'm running FerBotz_cl_4 with XC_Engine 24 and I noticed yesterday that the botz spawn and are like ghosts. Their skin/model does not appear at all until they are dead.

I tried removing a recent package I added and rolling back my BotzDefault.ini to what it was but I'm not having any luck. :noidea
Check the ferbotz ini or somewhere it may be assigned a skin that's not found and it appear to be invisible maybe so maybe set it to default skin will do?

Re: FerBotz (new AI, XCGE release 20)

Posted: Thu Apr 02, 2020 5:47 pm
by EvilGrins
abomination wrote:
Thu Apr 02, 2020 11:32 am
Is there anywhere in any logs that I might be able to identify what is causing Botz to be invisible? I'm running FerBotz_cl_4 with XC_Engine 24 and I noticed yesterday that the botz spawn and are like ghosts. Their skin/model does not appear at all until they are dead.
That is not unique to this; I don't use FerBotz. I get that periodically when not running any mutators at all, it's a memory glitch... only happens to me when I'm running a lot of bots.

Gotta admit, it gives them an edge in Last Man Standing... although the other bots can see them and still shoot them so really only an advantage over human players.

Re: FerBotz (new AI, XCGE release 20)

Posted: Thu Apr 02, 2020 8:38 pm
by abomination
Chamberly wrote:
Thu Apr 02, 2020 1:35 pm
abomination wrote:
Thu Apr 02, 2020 11:32 am
Is there anywhere in any logs that I might be able to identify what is causing Botz to be invisible? I'm running FerBotz_cl_4 with XC_Engine 24 and I noticed yesterday that the botz spawn and are like ghosts. Their skin/model does not appear at all until they are dead.

I tried removing a recent package I added and rolling back my BotzDefault.ini to what it was but I'm not having any luck. :noidea
Check the ferbotz ini or somewhere it may be assigned a skin that's not found and it appear to be invisible maybe so maybe set it to default skin will do?
All Botz regardless of skin are invisible. I went back to a known good ini and it didn't change it.

I'll keep tinkering with it.
EvilGrins wrote:
Thu Apr 02, 2020 5:47 pm
abomination wrote:
Thu Apr 02, 2020 11:32 am
Is there anywhere in any logs that I might be able to identify what is causing Botz to be invisible? I'm running FerBotz_cl_4 with XC_Engine 24 and I noticed yesterday that the botz spawn and are like ghosts. Their skin/model does not appear at all until they are dead.
That is not unique to this; I don't use FerBotz. I get that periodically when not running any mutators at all, it's a memory glitch... only happens to me when I'm running a lot of bots.

Gotta admit, it gives them an edge in Last Man Standing... although the other bots can see them and still shoot them so really only an advantage over human players.
I'm using CacusMapVote to toggle mutators/game types and the only one I have Botz enabled for just fills the game up to four players, so a max of 3 at a time.
It sure does give them an edge. How sad is it that it took me 2-3 minutes to figure out that I wasn't just not seeing the bot that was demolishing me but it was invisible?

Re: FerBotz (new AI, XCGE release 20)

Posted: Fri Apr 03, 2020 6:21 am
by sektor2111
Any other package out of stock used/forced by mutator must be part of ServerPackages or else no one can see/hear those. If I'm reading back this stuff can read skins loaded and then... they must be in ServerPackages - including parts of mutator itself - at least these are default rules.

Re: FerBotz (new AI, XCGE release 20)

Posted: Thu Oct 08, 2020 10:03 pm
by Acoma
hey
couldnt get ferbotz 20 working in 469a, even with the latest xc engine installed, every time i installed it and opened preferences the ferbotz tab would return a could not load error in all fields
i assume you would update it in the future but in the meantime ferbotz 18 works fine in 469a as long as you use the uscript version (thank god :loool: )

i also figured out how to use ferbotz alongside loathesome's latest xbots mutator as well as restore their individual stats by dumb luck
all you have to do is go into botzdefault.ini and edit bUseDummyPawns to true then comment out the behavior config like this: /bHumanMove=False
/bSuperAim=False
lastly set botzconfig.ini to read only so the mutator doesnt reset it ingame and voila, now you can use 10 pages of uniquely configured bots without them acting stupid :rock:

Re: FerBotz (new AI, XCGE release 20)

Posted: Wed Nov 04, 2020 10:46 pm
by TaglesMalsto
Acoma wrote:
Thu Oct 08, 2020 10:03 pm
hey
couldnt get ferbotz 20 working in 469a, even with the latest xc engine installed, every time i installed it and opened preferences the ferbotz tab would return a could not load error in all fields
i assume you would update it in the future but in the meantime ferbotz 18 works fine in 469a as long as you use the uscript version (thank god :loool: )

i also figured out how to use ferbotz alongside loathesome's latest xbots mutator as well as restore their individual stats by dumb luck
all you have to do is go into botzdefault.ini and edit bUseDummyPawns to true then comment out the behavior config like this: /bHumanMove=False
/bSuperAim=False
lastly set botzconfig.ini to read only so the mutator doesnt reset it ingame and voila, now you can use 10 pages of uniquely configured bots without them acting stupid :rock:
Is it possible to use on local Botmatch? :?: