[Release] ACE v1.0f

Re: [Release] ACE v1.0f

Postby Letylove49 » Mon May 21, 2018 10:42 pm

thanks for fixing of the time-out issue.
<[MHA]>Letylove49 aka Shado170
Letylove49
Novice
 
Posts: 23
Joined: Tue Feb 28, 2012 7:47 pm
Location: Retired
Personal rank: <[MHA] >Admin

Re: [Release] ACE v1.0f

Postby Se7eN » Thu May 24, 2018 4:09 am

madrixis wrote:Its failing on multihome Linux boxes:

With multihome:
ACE: DEBUG: Default IPv4 WAN NIC = venet0
ACE: DEBUG: Default IPv6 WAN NIC =
ACE: DEBUG: Enabling bListen on NIC venet0:0 (MY_IP) because it is specified in MULTIHOME.
[ACEv10f]: DEBUG: ACE found the following network card: lo
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: 127.0.0.1 - Subnet: - Internet Access: False
[ACEv10f]: DEBUG: - Can listen on this interface? False
[ACEv10f]: DEBUG: ACE found the following network card: venet0
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: 127.0.0.1 - Subnet: - Internet Access: True
[ACEv10f]: DEBUG: - Can listen on this interface? False
[ACEv10f]: DEBUG: ACE found the following network card: venet0:0
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: MY_IP - Subnet: - Internet Access: True
[ACEv10f]: DEBUG: - Can listen on this interface? True
[ACEv10f]: DEBUG: ACE found the following network card: lo
[ACEv10f]: DEBUG: - IPv6 Properties -> Address: :: - Subnet: - Internet Access: False
[ACEv10f]: DEBUG: - Can listen on this interface? False
[ACEv10f]: DEBUG: NICHelper recommends this ListenIP: MY_IP
readlink(/proc/self/exe) = /data/ut-server/System/ucc-bin
Path to the PlayerManager: /data/ut-server/System/PlayerManager/ACEv10f_M
ACE: ERROR - PlayerManager Connection Failed - Timed Out
[ACEv10f]: ERROR: ACE could not spawn the PlayerManager.
[ACEv10f]: ERROR: ACE is now disabled.
ACE: ERROR - PlayerManager Connection Shutting Down!



And without Multihome:

ACE: DEBUG: Default IPv4 WAN NIC = venet0
ACE: DEBUG: Default IPv6 WAN NIC =
[ACEv10f]: DEBUG: ACE found the following network card: lo
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: 127.0.0.1 - Subnet: - Internet Access: False
[ACEv10f]: DEBUG: - Can listen on this interface? True
[ACEv10f]: DEBUG: ACE found the following network card: venet0
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: 127.0.0.1 - Subnet: - Internet Access: True
[ACEv10f]: DEBUG: - Can listen on this interface? True
[ACEv10f]: DEBUG: ACE found the following network card: venet0:0
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: MY_IP - Subnet: - Internet Access: False
[ACEv10f]: DEBUG: - Can listen on this interface? True
[ACEv10f]: DEBUG: ACE found the following network card: lo
[ACEv10f]: DEBUG: - IPv6 Properties -> Address: :: - Subnet: - Internet Access: False
[ACEv10f]: DEBUG: - Can listen on this interface? True
[ACEv10f]: DEBUG: NICHelper recommends listening on all interfaces
readlink(/proc/self/exe) = /data/ut-server/System/ucc-bin
Path to the PlayerManager: /data/ut-server/System/PlayerManager/ACEv10f_M
PlayerManager Uplink Complete!


I'm also getting the "PlayerManager Connection Failed" issue, and it also seems to be related to multihome:

ACE: ERROR - PlayerManager Connection Failed
[ACEv10f]: ERROR: ACE could not spawn the PlayerManager.
[ACEv10f]: ERROR: ACE is now disabled.
ACE: ERROR - PlayerManager Connection Shutting Down!


My server is on GameServers and they force us to use "multihome=@SERVERIP port=@SERVERPORT -nohomedir" in the server's command line. I told them that others with multihome share the same problem, and that with multihome off, ACE worked. Unfortunately, it seems they depend on it. I inquired if I could be switched to a Winblows box and they said they didn't offer any for UT99.

That (multihome) has to stay in the command line, otherwise your server will not work and other clients' services could be impacted as well.

I am sorry, but we do not offer this game on Windows.

Sincerely,

Brendan Kiel
"Dr. Worm[GS]"


Stuck between either changing hosts or waiting for a fix as my only solution, I thought of downgrading to the closest release before 1.0f - however all the downloads I've been able to find, require a password in order to extract the files. After hours of searching online, I finally found this:

http://forums.ut-files.com/post15445.html

ACEv09c is private

I asked AnthraXs who asked me not to make it public so i ave save it and set a password.


Any help is appreciated :)

:help:
Se7eN
Novice
 
Posts: 5
Joined: Thu May 16, 2013 1:27 pm

Re: [Release] ACE v1.0f

Postby anth » Thu May 24, 2018 8:48 pm

A simple update for the server-side .so/.dll file will probably suffice to fix this. I'll try to upload a fix this weekend. Are there any other pressing issues that need to be fixed in the mean time?
anth
Skilled
 
Posts: 160
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.0f

Postby Se7eN » Thu May 24, 2018 9:22 pm

A simple update for the server-side .so/.dll file will probably suffice to fix this. I'll try to upload a fix this weekend.


There goes my hero, watch him as he goes
/airguitar
Se7eN
Novice
 
Posts: 5
Joined: Thu May 16, 2013 1:27 pm

Re: [Release] ACE v1.0f

Postby anth » Thu May 31, 2018 8:47 pm

I've sent the v1.0g package to some people for testing. Changes in this release include:

Code: Select all
v1.0g:
* [FIXED] Splash logo not appearing in TO
* [FIXED] False positive kicks for system dlls in WINE 2.0
* [FIXED] Autoconfig now properly recognizes all TOST files
* [FIXED] False positive detections of package patches in certain packages (e.g., s_SWAT, BotPack)
* [CHANGED] Made the GameServer<->PlayerManager connection mechanism more robust. This should fix timeout issues with -MULTIHOME (needs testing!!)
anth
Skilled
 
Posts: 160
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.0f

Postby Se7eN » Mon Jun 04, 2018 5:40 pm

May I have the new version to test on my server?
Se7eN
Novice
 
Posts: 5
Joined: Thu May 16, 2013 1:27 pm

Re: [Release] ACE v1.0f

Postby Qwerty » Mon Jun 04, 2018 8:27 pm

Se7eN wrote:May I have the new version to test on my server?


+1
http://www.vulpinemission.com
Image ROCKET-X8 Server
Image MONSTERHUNT w/ NALI WEAPONS 3 + RX8
Image BUNNYTRACK NY
Image SNIPER DEATHMATCH
Image ROSEBUM ROCKET-X RB
Qwerty
Masterful
 
Posts: 656
Joined: Wed Mar 12, 2008 7:14 pm
Location: New York
Personal rank: I.T Master

Re: [Release] ACE v1.0f

Postby forge » Sun Jun 10, 2018 8:56 pm

i know that at some point the game starts to get faster, but is it possible to increase the fps cap further?
right now its capped at 180, right? eventhough some seem to get 200 somehow (older windows?)
so i guess 200 is fine too? or even a bit higher?
just asking :wink:
forge
 
Posts: 1
Joined: Sun Jun 10, 2018 8:39 pm

Re: [Release] ACE v1.0f

Postby Qwerty » Mon Jun 11, 2018 1:43 am

forge wrote:i know that at some point the game starts to get faster, but is it possible to increase the fps cap further?
right now its capped at 180, right? eventhough some seem to get 200 somehow (older windows?)
so i guess 200 is fine too? or even a bit higher?
just asking :wink:


If I'm not mistaken your question has nothing to do with ACE. 200FPS is the max regardless. Anything above that causes weird game issues.
http://www.vulpinemission.com
Image ROCKET-X8 Server
Image MONSTERHUNT w/ NALI WEAPONS 3 + RX8
Image BUNNYTRACK NY
Image SNIPER DEATHMATCH
Image ROSEBUM ROCKET-X RB
Qwerty
Masterful
 
Posts: 656
Joined: Wed Mar 12, 2008 7:14 pm
Location: New York
Personal rank: I.T Master

Re: [Release] ACE v1.0f

Postby Qwerty » Mon Jun 11, 2018 2:05 am

looks like some maps still kicking. This happened to multiple players on the same map.

[ACEv10f]: KickReason.....: Unexpected Package Loaded
[ACEv10f]: PackageName....: CTF-MarsFigherJetsCraterX2
[ACEv10f]: PackagePath....: ../Cache\36F40A9C46A2E6FB540F55B6D796C943.uxx
[ACEv10f]: PackageSize....: 2744342 bytes
[ACEv10f]: PackageHash....: 38D9122BB52A184C679907455663A80F
[ACEv10f]: PackageVer.....: Unknown File
http://www.vulpinemission.com
Image ROCKET-X8 Server
Image MONSTERHUNT w/ NALI WEAPONS 3 + RX8
Image BUNNYTRACK NY
Image SNIPER DEATHMATCH
Image ROSEBUM ROCKET-X RB
Qwerty
Masterful
 
Posts: 656
Joined: Wed Mar 12, 2008 7:14 pm
Location: New York
Personal rank: I.T Master

Re: [Release] ACE v1.0f

Postby anth » Mon Jun 11, 2018 5:43 am

Qwerty wrote:looks like some maps still kicking. This happened to multiple players on the same map.

[ACEv10f]: KickReason.....: Unexpected Package Loaded
[ACEv10f]: PackageName....: CTF-MarsFigherJetsCraterX2
[ACEv10f]: PackagePath....: ../Cache\36F40A9C46A2E6FB540F55B6D796C943.uxx
[ACEv10f]: PackageSize....: 2744342 bytes
[ACEv10f]: PackageHash....: 38D9122BB52A184C679907455663A80F
[ACEv10f]: PackageVer.....: Unknown File


This issue was fixed in an updated version of PackageHelper v1.3. I bundled it with one of the latest versions of ACE (might have been v1.0f?). Don't forget to unzip/overwrite all files!
anth
Skilled
 
Posts: 160
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.0f

Postby anth » Mon Jun 11, 2018 5:44 am

there were some hiccups while testing v1.0g. I fixed them and will release v1.0h soon.

Change log:

Code: Select all
v1.0h:
* [FIXED] ACE breaking the HUDMutator chain in some game types
* [FIXED] Map switches taking a long time when the server is handling a lot of traffic

v1.0g:
* [FIXED] Splash logo not appearing in TO
* [FIXED] False positive kicks for system dlls in WINE 2.0
* [FIXED] Autoconfig now properly recognizes all TOST files
* [FIXED] False positive detections of package patches in certain packages (e.g., s_SWAT, BotPack)
* [CHANGED] Made the GameServer<->PlayerManager connection mechanism more robust. This should fix timeout issues with -MULTIHOME (needs testing!!)

anth
Skilled
 
Posts: 160
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.0f

Postby Qwerty » Mon Jun 11, 2018 3:12 pm

anth wrote:
Qwerty wrote:looks like some maps still kicking. This happened to multiple players on the same map.

[ACEv10f]: KickReason.....: Unexpected Package Loaded
[ACEv10f]: PackageName....: CTF-MarsFigherJetsCraterX2
[ACEv10f]: PackagePath....: ../Cache\36F40A9C46A2E6FB540F55B6D796C943.uxx
[ACEv10f]: PackageSize....: 2744342 bytes
[ACEv10f]: PackageHash....: 38D9122BB52A184C679907455663A80F
[ACEv10f]: PackageVer.....: Unknown File


This issue was fixed in an updated version of PackageHelper v1.3. I bundled it with one of the latest versions of ACE (might have been v1.0f?). Don't forget to unzip/overwrite all files!


yeah the update fixed all the maps we reported initially. This one still kicking though. I will test on my own if I ever get time. :loool:
http://www.vulpinemission.com
Image ROCKET-X8 Server
Image MONSTERHUNT w/ NALI WEAPONS 3 + RX8
Image BUNNYTRACK NY
Image SNIPER DEATHMATCH
Image ROSEBUM ROCKET-X RB
Qwerty
Masterful
 
Posts: 656
Joined: Wed Mar 12, 2008 7:14 pm
Location: New York
Personal rank: I.T Master

Re: [Release] ACE v1.0f

Postby UT Sniper (SJA94) » Sat Mar 09, 2019 11:26 pm

How do you stop the latest ACE forcing 167fps with highperftoggle off?

I have mine set up to 195fps limit, and it feels great, but as soon as I go into the servers that run the new ACE it forces my fps to 167 no matter what I set it to and it's makes the game fell horrible. This is not an XC_Engine problem, it's an ACE problem because it does it with or without XC_Engine installed. This is without highperftoggle on.
Find the Latest player inis https://ooper.000webhostapp.com/ut/newinis/ (2019 version)
My latest UT themed game Spawn Killer 4 Game
User avatar
UT Sniper (SJA94)
Adept
 
Posts: 407
Joined: Thu Jun 24, 2010 10:35 pm
Location: England
Personal rank: noob programmer

Previous

Return to Anti-Cheat Releases

Who is online

Users browsing this forum: No registered users and 1 guest