[Release] ACE v1.1b

[Release] ACE v1.1b

Postby anth » Wed Jun 19, 2019 10:31 am

*** INTRODUCTION ***

Hello everyone. Here's another update to ACE. This release includes a relatively large amount of changes so I bumped the major version number from v1.0 to v1.1. This also means this release comes with a new IACE package, so if you have any ACE plugin mods, you may have to recompile them.

There will be another minor release soon to fix the remaining issues with the latest Windows 10 build. The release after that will include updated native protection, timer fixes for smoother gameplay, and possibly support for some new games

This is the list of changes:

    v1.1b:
    * [FIXED] Filelist updater no longer working on some platforms
    * [FIXED] Updated UScript call stack scanner to properly track state code
    * [FIXED] False positive kicks for some system dlls caused by changes in the
    Visual C++ code generation back-end
    * [FIXED] Game server freezing during mapswitches
    * [FIXED] False positive kicks for corrupted ddraw.dll files caused by Windows
    10's D3DX to D3D12 mapping layer
    * [FIXED] AutoConfig no longer discards UPackages that are still in the UEngine
    PackageMap
    * [ADDED] New UScript protection feature: mods now need to be whitelisted to
    access vector and rotator variables in a playerpawn class. This feature
    replaces and improves a UScript protection routine I tested in v1.0d but
    removed in v1.0e because it broke many legitimate mods (e.g., XConsole)
    * [ADDED] FileList definitions for the latest Kentie D3D Renderers
    * [CHANGED] Various performance fixes
    * [CHANGED] The client frame rate is now capped at 200fps (up from 180)
    * [CHANGED] Developers can now override the class used to spawn and render the
    ACE splash logo by modifying the BadgeNotifyClass option in the ACEActor
    class.

A full list of changes will be made available at:
http://utgl.unrealadmin.org/ACE/changes.txt

*** INSTALLATION ***

If you are currently running NPLoader v1.7 (which comes with ACE v1.1+), the installation is fairly straightforward: just unzip the package in your server's root folder and reboot the server.
If you are not running NPLoader v1.7, then please refer to the INSTALL.txt document included in the package.

*** CONFIGURATION ***

Please refer to the SETTINGS.txt document included in the package.

*** KNOWN ISSUES ***

Installation Issues: Some other testers have reported issues installing the server files. Most of these are caused by outdated system libraries. Please note that you will need glibc 2.15 or later on Linux. Linux distributions released before 2012 might have older versions of glibc.

A second problem seems to occur for certain admins running x86_64 Linux servers. These admins might see the following error message:
Code:

Code: Select all
Path to the PlayerManager: /data/ut-server/System/PlayerManager/ACEv11b_M
ACE: ERROR - Communication with PlayerManager failed - poll errno: 4 Interrupted system call
ACE: ERROR - PlayerManager Connection Failed
[ACEv11b]: ERROR: ACE could not spawn the PlayerManager.
[ACEv11b]: ERROR: ACE is now disabled.
ACE: ERROR - PlayerManager Connection Shutting Down!

This is most likely caused by a corrupted PlayerManager file. Please make sure that you upload the files in binary mode rather than text mode!

Kick logs that say "Not kicking because bStrictSystemLibraryChecks is set to false": This is not technically an issue. ACE v1.0+ has some very aggressive detection routines that detect a lot of legitimate external programs (e.g., Fraps, Display Drivers, Sound drivers, virus scanners...) because they do terrible things to your system DLLs. If you see this kick status, just ignore the log. The player will not be kicked.
Attachments
ACEv11b.zip
(2.96 MiB) Downloaded 160 times
User avatar
anth
Skilled
 
Posts: 179
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.1b

Postby Deepu » Wed Jun 19, 2019 2:39 pm

:tu:
Deepu
Skilled
 
Posts: 163
Joined: Mon Nov 11, 2013 7:56 am
Location: India
Personal rank: Average

Re: [Release] ACE v1.1b

Postby [rev]rato.skt » Thu Jun 20, 2019 3:52 am

Thanks guy, :gj: :gj: :gj: i go test in brasil :)

i test in linux emulated in WINE, dont work for me!
NPLoaderLL_v17 is loaded but ace no load... look my log.
is installed on 168.227.251.200 1 Classic

ScriptLog: +--------------------------------------+
ScriptLog: | ACE for Unreal Tournament |
ScriptLog: | v11b |
ScriptLog: | (c) 2009-2019 - AnthraX |
ScriptLog: +--------------------------------------+
Log: ACE: Path to the PlayerManager: Z:/home/unreal/server-win/System/PlayerManager/ACEv11b_M.dll - Internal IP: 0.0.0.0:7779
Log: ACE: ERROR - PlayerManager Connection Failed - Timed Out - Tried connecting on: 0.0.0.0:54423
ScriptLog: [ACEv11b]: ERROR: ACE could not spawn the PlayerManager.
ScriptLog: [ACEv11b]: ERROR: ACE is now disabled.
Log: ACE: ERROR - PlayerManager Connection Shutting Down!
ScriptLog: +--------------------------------------+
ScriptLog: | ACE EventHandler |
ScriptLog: | v11b |
ScriptLog: | (c) 2009-2016 - AnthraX |
ScriptLog: +--------------------------------------+
Last edited by [rev]rato.skt on Sat Jun 22, 2019 6:59 pm, edited 1 time in total.
Brazilian Server:
168.227.251.200 1 Classic
168.227.251.201 2 Custom
User avatar
[rev]rato.skt
Skilled
 
Posts: 165
Joined: Mon Aug 16, 2010 1:09 pm

Re: [Release] ACE v1.1b

Postby eVASSASIN » Thu Jun 20, 2019 6:12 pm

Awesome! Thanks for all the hard work and dedication to the UT99 community it's greatly appreciated!! Installed on dangerous grounds NFO server smooth and no issues so far. :rock:

eV.ASSASIN
+~*-(-_-)-*~+ [-Dangerous Grounds-]+~*-(-_-)-*~+~
Server address: dg.game.nfoservers.com:7777
eVASSASIN
 
Posts: 1
Joined: Thu Jun 20, 2019 1:10 am

Re: [Release] ACE v1.1b

Postby 3itch_fi » Fri Jun 21, 2019 12:24 pm

Tactical Ops community thanks for your efforts.

One question raised of updating from previous version to new 1.1b.

After upgrade my server .ini still had this section:
[ACEv10h_S.ACEActor]

and under that there is: AutoConfigPackage=ACEv10_AutoConfig

Did I assume correctly that both of these need to be change to point ACEv11b?
In settings.txt file it says ACEv10_AutoConfig.
Image
3itch_fi
Novice
 
Posts: 4
Joined: Fri Jun 21, 2019 11:44 am

Re: [Release] ACE v1.1b

Postby Deepu » Sat Jun 22, 2019 6:02 pm

Getting some issue with this ACE. When you do suicide, it gives 2 die sounds and effects, when I restored to old version of ACE there is no issues...
Deepu
Skilled
 
Posts: 163
Joined: Mon Nov 11, 2013 7:56 am
Location: India
Personal rank: Average

Re: [Release] ACE v1.1b

Postby 3itch_fi » Sat Jun 22, 2019 10:22 pm

In tactical ops following minor bugs have been noticed.
1. When you drop/throw gun it throws 2 guns instead of just 1. It's like you would press "throw weapons" twice.
2. In spectator / behindview mode guns animations are misplaced.
https://ibb.co/2NpHNHr
Image
3itch_fi
Novice
 
Posts: 4
Joined: Fri Jun 21, 2019 11:44 am

Re: [Release] ACE v1.1b

Postby Deepu » Sun Jun 23, 2019 2:51 am

Me too also in UT...
Deepu
Skilled
 
Posts: 163
Joined: Mon Nov 11, 2013 7:56 am
Location: India
Personal rank: Average

Re: [Release] ACE v1.1b

Postby anth » Mon Jun 24, 2019 5:29 pm

3itch_fi wrote:Tactical Ops community thanks for your efforts.

One question raised of updating from previous version to new 1.1b.

After upgrade my server .ini still had this section:
[ACEv10h_S.ACEActor]

and under that there is: AutoConfigPackage=ACEv10_AutoConfig

Did I assume correctly that both of these need to be change to point ACEv11b?
In settings.txt file it says ACEv10_AutoConfig.


No, you do not have to touch the ACEv10h_S.ACEActor settings at all.

AutoConfigPackage=ACEv11_AutoConfig is what you should have in your ACEv11b_S.ACEActor section. The readme did indeed say ACEv10_AutoConfig, which was a typo.
User avatar
anth
Skilled
 
Posts: 179
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.1b

Postby anth » Mon Jun 24, 2019 5:30 pm

Deepu wrote:Getting some issue with this ACE. When you do suicide, it gives 2 die sounds and effects, when I restored to old version of ACE there is no issues...


Which client and server versions of UT are you using? Does this happen every time or only when recording a demo?
User avatar
anth
Skilled
 
Posts: 179
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.1b

Postby anth » Mon Jun 24, 2019 5:31 pm

3itch_fi wrote:In tactical ops following minor bugs have been noticed.
1. When you drop/throw gun it throws 2 guns instead of just 1. It's like you would press "throw weapons" twice.
2. In spectator / behindview mode guns animations are misplaced.
https://ibb.co/2NpHNHr


I cannot reproduce the first issue in TO 3.50. Are you running 3.40?

I will look into the second issue soon...
User avatar
anth
Skilled
 
Posts: 179
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.1b

Postby Deepu » Mon Jun 24, 2019 5:50 pm

anth wrote:
Deepu wrote:Getting some issue with this ACE. When you do suicide, it gives 2 die sounds and effects, when I restored to old version of ACE there is no issues...


Which client and server versions of UT are you using? Does this happen every time or only when recording a demo?

It look like some rendering problem with this ace build, Server version is 451 & client version is 436. See this issue is not happening with your old version of ACE v1.0h!
Deepu
Skilled
 
Posts: 163
Joined: Mon Nov 11, 2013 7:56 am
Location: India
Personal rank: Average

Re: [Release] ACE v1.1b

Postby 3itch_fi » Mon Jun 24, 2019 10:13 pm

anth wrote:
3itch_fi wrote:In tactical ops following minor bugs have been noticed.
1. When you drop/throw gun it throws 2 guns instead of just 1. It's like you would press "throw weapons" twice.
2. In spectator / behindview mode guns animations are misplaced.
https://ibb.co/2NpHNHr


I cannot reproduce the first issue in TO 3.50. Are you running 3.40?

I will look into the second issue soon...


Hi, forgot to mention the version. I'm running TO 3.4
Image
3itch_fi
Novice
 
Posts: 4
Joined: Fri Jun 21, 2019 11:44 am

Re: [Release] ACE v1.1b

Postby Chamberly » Tue Jun 25, 2019 8:24 am

Deepu wrote:
anth wrote:
Deepu wrote:Getting some issue with this ACE. When you do suicide, it gives 2 die sounds and effects, when I restored to old version of ACE there is no issues...


Which client and server versions of UT are you using? Does this happen every time or only when recording a demo?

It look like some rendering problem with this ace build, Server version is 451 & client version is 436. See this issue is not happening with your old version of ACE v1.0h!


I remember this did happen before but I don't quite remember what version it was. I think it have to be double checked if it does it in vanilla mode.

Edit: It did happen to one of my Windows UT Server. I tested it locally some days ago and didn't notice it yet, I'll double check on it though.
Last edited by Chamberly on Tue Jun 25, 2019 5:29 pm, edited 1 time in total.
Image
Image
Image
User avatar
Chamberly
Godlike
 
Posts: 1669
Joined: Sat Sep 17, 2011 4:32 pm
Location: TN, USA
Personal rank: Dame. Vandora

Re: [Release] ACE v1.1b

Postby Deepu » Tue Jun 25, 2019 10:07 am

Yes look like double check!!!
Deepu
Skilled
 
Posts: 163
Joined: Mon Nov 11, 2013 7:56 am
Location: India
Personal rank: Average


Return to Anti-Cheat Releases

Who is online

Users browsing this forum: SC]-[WARTZ_{HoF} and 1 guest