[Release] ACE v1.0f

[Release] ACE v1.0f

Postby anth » Mon Jan 22, 2018 6:47 pm

*** UPDATE3 ***

Reuploaded again to fix false positive detections on certain maps.

*** UPDATE2 ***

I reuploaded the package again to include a fix for timeout issues some people were seeing on servers running behind NAT firewalls. Once again, this updated package can be installed on top of the previous one, as it does not include any client-side changes.

*** UPDATE ***

I reuploaded the package to include a fix for the timeout issues some people were seeing on certain maps. This updated package can be installed on top of the previous one, as it does not include any client-side changes.

*** INTRODUCTION ***

Hello everyone. I thought I'd drop a new version of ACE here to get this section started. The most notable changes since v1.0e are:

    * [FIXED] Timeout issues on servers with 32+ network interfaces
    * [FIXED] General protection fault during map switches on the client side
    * [ADDED] Support for a lot of new skins (e.g., the official UT v400 hi-res skins), renderers (e.g., OldUnreal XOpenGLDrv), mods

A full list of changes is available at:
http://utgl.unrealadmin.org/ACE/changes.txt

*** INSTALLATION ***

If you are currently running NPLoader v1.7 (which comes with ACE v1.0+), the installation is fairly straightforward: just unzip the package in your server's root folder and reboot the server.
If you are not running NPLoader v1.7, then please refer to the INSTALL.txt document included in the package.

*** CONFIGURATION ***

Please refer to the SETTINGS.txt document included in the package.

*** KNOWN ISSUES ***

Installation Issues: Some other testers have reported issues installing the server files. Most of these are caused by outdated system libraries. Please note that you will need glibc 2.15 or later on Linux. Linux distributions released before 2012 might have older versions of glibc.

A second problem seems to occur for certain admins running x86_64 Linux servers. These admins might see the following error message:
Code:

Code: Select all
Path to the PlayerManager: /data/ut-server/System/PlayerManager/ACEv10f_M
ACE: ERROR - Communication with PlayerManager failed - poll errno: 4 Interrupted system call
ACE: ERROR - PlayerManager Connection Failed
[ACEv10f]: ERROR: ACE could not spawn the PlayerManager.
[ACEv10f]: ERROR: ACE is now disabled.
ACE: ERROR - PlayerManager Connection Shutting Down!

This is most likely caused by a corrupted PlayerManager file. Please make sure that you upload the files in binary mode rather than text mode!

Timeouts during check spawn: Although ACE v1.0f likely fixes this issue, I cannot rule it out completely. You can enable extra logging in the server log to help figure out why these occur by adding these settings to the server ini file:

Code: Select all
[ACEv10f_S.ACENICHelper]
bDebug=1

Kick logs that say "Not kicking because bStrictSystemLibraryChecks is set to false": This is not technically an issue. ACE v1.0 has some very aggressive detection routines that detect a lot of legitimate external programs (e.g., Fraps, Display Drivers, Sound drivers, virus scanners...) because they do terrible things to your system DLLs. If you see this kick status, just ignore the log. The player will not be kicked.
Attachments
ACEv10f.zip
SHA-1: 59460a7eb59d093b5e02a91f9dafc386980386d1
MD5: cfb112c849e900a09cbf11d746a70867
(2.71 MiB) Downloaded 128 times
Last edited by anth on Sun Jan 28, 2018 8:39 pm, edited 5 times in total.
anth
Skilled
 
Posts: 157
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.0f

Postby Pileyrei » Mon Jan 22, 2018 8:02 pm

Wow - thank you Anth!

Downloaded and will install on my recently wiped server.

Had a real battle installing Ace 10e so hopefully this will be good.
Will report back :highfive:
http://www.unrealsurvivors.com

Image

Our Servers
Image
Image



Donate to UT99.org!
Pileyrei
Masterful
 
Posts: 602
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Re: [Release] ACE v1.0f

Postby Raynor » Mon Jan 22, 2018 9:40 pm

How's wine compatibility?
I do not follow every release, but unfortunately there's still number of (outdated?) servers that kick wine users because of kernel32.dll error.
User avatar
Raynor
Adept
 
Posts: 415
Joined: Sun Jan 27, 2008 5:09 pm

Re: [Release] ACE v1.0f

Postby anth » Mon Jan 22, 2018 10:08 pm

I do not test every single release with WINE, but it is supposed to work... There have definitely been releases where WINE compatibility was broken though.
anth
Skilled
 
Posts: 157
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.0f

Postby Aldebaran » Mon Jan 22, 2018 10:46 pm

Great to have a ACE discussion here! I tried ACE some time ago and had these timeouts too, also setting a forced WAN IP did not work. So I will give it a new chance soon...

Qwerty posted in this thread page maps that seem not to work with ACE because of special weapons included into the maps:
http://www.unrealadmin.org/forums/showt ... 41&page=13
I use to play some of these maps too, so is this fixed or is there a workaround for these maps?
Aldebaran
Masterful
 
Posts: 525
Joined: Thu Jan 28, 2016 7:30 pm

Re: [Release] ACE v1.0f

Postby [rev]rato.skt » Mon Jan 22, 2018 11:22 pm

thanks for the gift, i go test :rock: :rock:
Brazilian Server:
1.utbr.org:2017 all classic + combogib
1.utbr.org:2222 custom bt, jb, ra, siege others
1.utbr.org:8888 1on1
1.utbr.org:5555 nali weaponws 3
User avatar
[rev]rato.skt
Experienced
 
Posts: 146
Joined: Mon Aug 16, 2010 1:09 pm

Re: [Release] ACE v1.0f

Postby Chamberly » Mon Jan 22, 2018 11:27 pm

Aldebaran wrote:Great to have a ACE discussion here! I tried ACE some time ago and had these timeouts too, also setting a forced WAN IP did not work. So I will give it a new chance soon...

Qwerty posted in this thread page maps that seem not to work with ACE because of special weapons included into the maps:
http://www.unrealadmin.org/forums/showt ... 41&page=13
I use to play some of these maps too, so is this fixed or is there a workaround for these maps?


It looked like he already have it taken care of unless it is still an issue?
"we have NFoservers but its a VDS ACE works great now that we fixed the map issues."

I'm guessing the maps is flooded with actors, and too much info is sending from the server to the client that might've caused the lagging timeout, but will be worse for those with higher pings.
Image
Image
irc.globalgamers.net #uscript
http://irc.lc/globalgamers/uscript
Image
User avatar
Chamberly
Godlike
 
Posts: 1607
Joined: Sat Sep 17, 2011 4:32 pm
Location: TN, USA
Personal rank: Dame. Vandora

Re: [Release] ACE v1.0f

Postby Qwerty » Tue Jan 23, 2018 1:47 am

Chamberly wrote:
Aldebaran wrote:Great to have a ACE discussion here! I tried ACE some time ago and had these timeouts too, also setting a forced WAN IP did not work. So I will give it a new chance soon...

Qwerty posted in this thread page maps that seem not to work with ACE because of special weapons included into the maps:
http://www.unrealadmin.org/forums/showt ... 41&page=13
I use to play some of these maps too, so is this fixed or is there a workaround for these maps?


It looked like he already have it taken care of unless it is still an issue?
"we have NFoservers but its a VDS ACE works great now that we fixed the map issues."

I'm guessing the maps is flooded with actors, and too much info is sending from the server to the client that might've caused the lagging timeout, but will be worse for those with higher pings.


Our resident coder Mar took car of it, but I will see if he can comment on it. I cant seem to find the PM he sent regarding the fix.

-MERGED-

anth wrote:*** INTRODUCTION ***
* [FIXED] General protection fault during map switches on the client side


sweet this was our last big issue!


Edit by papercoffee


Edit: Works great on our Rocket-X server! I will test on our DM server shortly
Last edited by Qwerty on Tue Jan 23, 2018 9:52 pm, edited 2 times in total.
http://www.vulpinemission.com
Image ROCKET-X8 Server
Image MONSTERHUNT w/ NALI WEAPONS 3 + RX8
Image BUNNYTRACK NY
Image SIEGE ULTIMATE
Qwerty
Masterful
 
Posts: 632
Joined: Wed Mar 12, 2008 7:14 pm
Location: New York
Personal rank: I.T Master

Re: [Release] ACE v1.0f

Postby papercoffee » Tue Jan 23, 2018 2:29 am

Even so we have now content here which is usually expected at UA... we still don't allow double posts. :mrgreen:
User avatar
papercoffee
Site Staff
 
Posts: 8546
Joined: Wed Jul 15, 2009 11:36 am
Location: Cologne, the city with the big cathedral.
Personal rank: coffee addicted !!!

Re: [Release] ACE v1.0f

Postby Aldebaran » Tue Jan 23, 2018 12:23 pm

Querty wrote:I will see if he can comment on it

Thank you, I overlooked your answer in the UA thread. So this issue seem to be solved.
Aldebaran
Masterful
 
Posts: 525
Joined: Thu Jan 28, 2016 7:30 pm

Re: [Release] ACE v1.0f

Postby $carface » Wed Jan 24, 2018 12:45 pm

Tested it today...uploaded everything in binary mode.

Code: Select all
Log: ACE: Path to the PlayerManager: C:/servers/uksiege/System/PlayerManager/ACEv10f_M.dll - Internal IP: 66.150.121.123:7779
Log: ACE: ERROR - PlayerManager Connection Failed - Timed Out
ScriptLog: [ACEv10f]: ERROR: ACE could not spawn the PlayerManager.
ScriptLog: [ACEv10f]: ERROR: ACE is now disabled.
Log: ACE: ERROR - PlayerManager Connection Shutting Down!
$carface
Skilled
 
Posts: 201
Joined: Sat Jul 23, 2011 10:58 pm

Re: [Release] ACE v1.0f

Postby iSenSe » Wed Jan 24, 2018 8:53 pm

Works flawlessly, didnt face any major problems yet.
Many thanks for your continuing time and effort to keep this up2date!

Noticed 1 thing on our server (issue tested with multiple players and versions of UT)

When the client is downloading the packages the first time, server shows the ACE installation prompt like it should :);
Image

However this prompt is visible for 0.1 ms and after that our server gives:
''Connection Failed'' (black screen)

When I press escape, i can see the prompt, and install it, but need to reconnect again off course.

But was asking myself how this could happen with this version (did not have this issue with the previous versions)
Prompt should be staying active off course.

I've checked the log;
Code: Select all
ScriptLog: [NPLoaderv17] Loading failed for player: `esnesi (Reason: Installation of new mods required)
NetComeGo: Close XC_TcpipConnection2 01/24/18 20:13:39

Seems like a normal disconnect i would assume.

Might be something with XC. (core7 v20)
Thought this might be useful for posting :)

I need to test without XC yet.
Last edited by iSenSe on Thu Jan 25, 2018 8:27 pm, edited 3 times in total.
Image
Image

For many of us it's just a dream.
They are guided by the mainstream.
You need some balls, some self-esteem?
Come join us at the substream!

https://www.ClassicUT99.com
User avatar
iSenSe
Average
 
Posts: 67
Joined: Mon Aug 31, 2015 12:58 pm

Re: [Release] ACE v1.0f

Postby Chamberly » Wed Jan 24, 2018 9:22 pm

Do be aware that there was an issue with XConsole that prevented it to be installed client/user side. Have to update for the full info on this one.
Image
Image
irc.globalgamers.net #uscript
http://irc.lc/globalgamers/uscript
Image
User avatar
Chamberly
Godlike
 
Posts: 1607
Joined: Sat Sep 17, 2011 4:32 pm
Location: TN, USA
Personal rank: Dame. Vandora

Re: [Release] ACE v1.0f

Postby Higor » Tue Feb 27, 2018 12:08 am

I like servers with read-only inis, I also like them with upgraded binaries.
This piece of code will solve ppl like me a lot of problems when it comes to ACE installation without reboots.

Code: Select all
native(1718) final function bool AddToPackageMap( optional string PkgName);
native(1719) final function bool IsInPackageMap( optional string PkgName, optional bool bServerPackagesOnly); //Second parameter doesn't exist in 227!
function ExecThisBeforeFirstTick()
{
   if ( int(ConsoleCommand("Get ini:Engine.Engine.GameEngine XC_Version")) >= 11 )
   {
      AddToPackageMap(); //Adds package I reside in
      AddToPackageMap("MyCustomMod"); //Adds this package
   }
}
Higor
Godlike
 
Posts: 1608
Joined: Sun Mar 04, 2012 6:47 pm

Re: [Release] ACE v1.0f

Postby madrixis » Thu Mar 01, 2018 9:59 am

Its failing on multihome Linux boxes:

With multihome:
ACE: DEBUG: Default IPv4 WAN NIC = venet0
ACE: DEBUG: Default IPv6 WAN NIC =
ACE: DEBUG: Enabling bListen on NIC venet0:0 (MY_IP) because it is specified in MULTIHOME.
[ACEv10f]: DEBUG: ACE found the following network card: lo
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: 127.0.0.1 - Subnet: - Internet Access: False
[ACEv10f]: DEBUG: - Can listen on this interface? False
[ACEv10f]: DEBUG: ACE found the following network card: venet0
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: 127.0.0.1 - Subnet: - Internet Access: True
[ACEv10f]: DEBUG: - Can listen on this interface? False
[ACEv10f]: DEBUG: ACE found the following network card: venet0:0
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: MY_IP - Subnet: - Internet Access: True
[ACEv10f]: DEBUG: - Can listen on this interface? True
[ACEv10f]: DEBUG: ACE found the following network card: lo
[ACEv10f]: DEBUG: - IPv6 Properties -> Address: :: - Subnet: - Internet Access: False
[ACEv10f]: DEBUG: - Can listen on this interface? False
[ACEv10f]: DEBUG: NICHelper recommends this ListenIP: MY_IP
readlink(/proc/self/exe) = /data/ut-server/System/ucc-bin
Path to the PlayerManager: /data/ut-server/System/PlayerManager/ACEv10f_M
ACE: ERROR - PlayerManager Connection Failed - Timed Out
[ACEv10f]: ERROR: ACE could not spawn the PlayerManager.
[ACEv10f]: ERROR: ACE is now disabled.
ACE: ERROR - PlayerManager Connection Shutting Down!



And without Multihome:

ACE: DEBUG: Default IPv4 WAN NIC = venet0
ACE: DEBUG: Default IPv6 WAN NIC =
[ACEv10f]: DEBUG: ACE found the following network card: lo
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: 127.0.0.1 - Subnet: - Internet Access: False
[ACEv10f]: DEBUG: - Can listen on this interface? True
[ACEv10f]: DEBUG: ACE found the following network card: venet0
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: 127.0.0.1 - Subnet: - Internet Access: True
[ACEv10f]: DEBUG: - Can listen on this interface? True
[ACEv10f]: DEBUG: ACE found the following network card: venet0:0
[ACEv10f]: DEBUG: - IPv4 Properties -> Address: MY_IP - Subnet: - Internet Access: False
[ACEv10f]: DEBUG: - Can listen on this interface? True
[ACEv10f]: DEBUG: ACE found the following network card: lo
[ACEv10f]: DEBUG: - IPv6 Properties -> Address: :: - Subnet: - Internet Access: False
[ACEv10f]: DEBUG: - Can listen on this interface? True
[ACEv10f]: DEBUG: NICHelper recommends listening on all interfaces
readlink(/proc/self/exe) = /data/ut-server/System/ucc-bin
Path to the PlayerManager: /data/ut-server/System/PlayerManager/ACEv10f_M
PlayerManager Uplink Complete!
madrixis
 
Posts: 2
Joined: Thu Mar 01, 2018 9:55 am

Next

Return to Anti-Cheat Releases

Who is online

Users browsing this forum: No registered users and 1 guest