[Release] ACE v1.2e

User avatar
anth
Skilled
Posts: 235
Joined: Thu May 13, 2010 2:23 am

[Release] ACE v1.2e

Post by anth » Thu Sep 24, 2020 11:28 am

*** WARNING ***

ACE v1.2e will not work on UT v436-451 Linux servers or TO Linux servers!

*** INTRODUCTION ***

Hello everyone. This version of ACE fixes a couple of issues, adds some protection, and is compatible with v469a servers. Some of you may already have a preview of ACE v1.2e running on your servers, but I still recommend that you upgrade to the official release version since I fixed some Linux server stability issues just yesterday.

**Please note that this release comes with a new version of NPLoader. You WILL have to update your server.ini file.**

This is the full list of changes since the previous public release (ACE v1.1f):
  • v1.2e:
    * [CHANGED] Made changes in the networking code to eliminate timeouts for people using certain firewalls or NAT routers
    * [FIXED] The crosshair no longer disappears when switching between servers running ACE v1.2 and servers running earlier versions of ACE
    * [FIXED] Various stability improvements for Linux servers

    v1.2d:
    * [FIXED] The SplashLogo code in previous versions of ACE triggered an engine bug that caused UGameEngine::Draw crashes. This should now be fixed
    * [FIXED] Some settings were not saving correctly for 469 clients
    * [FIXED] Crashes in player logging code on Linux servers
    * [CHANGED] Tweaked the netcode to significantly reduce the chances of timeout kicks
    * [ADDED] "mutate ace crosshairsmoothingtoggle" command to make the crosshair sharper at high resolutions

    v1.2c:
    * [FIXED] Eliminated a memory leak that caused crashes after getting a connection error
    * [FIXED] False positive detections in UPackages that use dynamic arrays
    * [CHANGED] Detections that do not cause player kicks will no longer be logged unless the bVerboseLogging option under [ACEv12c_S.ACEActor] is set to true.

    v1.2b:
    * [CHANGED] Disabled the soundfix for 469 Clients
    * [CHANGED] Reinstated the 200 fps limit for 432-451 Clients
    * [FIXED] 432-451 can no longer go above the frameratelimit

    v1.2a:
    * [ADDED] Wine 5 and Proton 5 compatibility
    * [CHANGED] ACE no longer supports the v400-451 Linux servers.
    * [CHANGED] Merged the PlayerManager code into the GameServer dll/so file
A full list of changes will be made available at:
http://utgl.unrealadmin.org/ACE/changes.txt

*** INSTALLATION ***

Please follow the instructions in the INSTALL.txt document included in the package.

*** CONFIGURATION ***

Please refer to the SETTINGS.txt document included in the package.

*** KNOWN ISSUES ***

Installation Issues: Some other testers have reported issues installing the server files. Most of these are caused by outdated system libraries. Please note that you will need glibc 2.15 or later on Linux. Linux distributions released before 2012 might have older versions of glibc.
Attachments
ACEv12e_UT_TO.zip
$ sha1sum ACEv12e_UT_TO.zip
0bbf13841458ed2a133e94821d20df00eede992a ACEv12e_UT_TO.zip
$ sha512sum ACEv12e_UT_TO.zip
78ac574e7ebd7c4c0f161f96748c01efdc96309aab9320164b8e7bc26a032774b2137fe22e5518f665a7112d4279a6ee1c880642934746a91d579211af6d8702 ACEv12e_UT_TO.zip
(2.55 MiB) Downloaded 97 times
Last edited by anth on Fri Oct 02, 2020 8:31 am, edited 1 time in total.

Hertz
Novice
Posts: 3
Joined: Sun May 10, 2020 10:50 am

Re: [Release] ACE v1.2e

Post by Hertz » Mon Sep 28, 2020 9:38 pm

Thanks!! :tu: :tu: :!: :!: :!:

gargul2
Novice
Posts: 25
Joined: Wed Sep 30, 2020 9:16 am

Re: [Release] ACE v1.2e

Post by gargul2 » Wed Sep 30, 2020 3:58 pm

There is a nasty bug here with ACE 1.2x & ATBHighScores

After joining to the server as a cilent, the ACE 1.2x installation dialog shows up but then suddenly quickly dissappears after 1 sec just in the moment when ATBHighScores table is showing up on the left side of the screen, they appear almost in the same moment, however they don't obstruct each other, yet they still interfere somehow.

ACE 1.1f is unaffected, the bug begun to happen only after upgrading a server from ACE v1.1f to ACE v1.2e

To see ACE installation dialog again, an Esc or Tilde key is required to be pressed, that gets a player back to UT99 Main Menu along with the ACE Installation dialog visible again so the installation can be contiuned.

The bug causes problems for some newcomers / unexperienced players, as they are unaware of the workaround and thus they end with the ACE installation unfinished, what further leads them to be disconnected after 60 secs. They sometimes complain in the chat in a spectator mode, that they can't play and can only spectate. So this bug throws away some newcomers / unexperienced players from playing on a server, which is THE WORST THING any server owner wanted ever to happen.

I tried things which didn't work:
- moving ACE ServerActors & ServerPackages UT.ini entries above / below ATBHighScores entries
- bShowLogo=True to bShowLogo=False but it didn't help neither

Only disabling ATBHighScores, but I'm not going to disable it.

There is a small GIF video I recorded: https://ibb.co/yY4qfL2 - you have to click "Otwórz GIF" (Open GIF) to play.

To reproduce the bug you may visit some 1.2e servers for ex.:

Image

To see that the bug doesn't happen on ACE 1.1f you may visit some ACE 1.1f servers:

Image

User avatar
[rev]rato.skt
Adept
Posts: 306
Joined: Mon Aug 16, 2010 1:09 pm

Re: [Release] ACE v1.2e

Post by [rev]rato.skt » Thu Oct 01, 2020 3:44 am

Hi,

i get this erro, not work in my server linux...

Critical: UClass::Bind
Critical: (Class PackageHelper_v15.PHActor)
Critical: ULinkerLoad::CreateExport
Critical: (PHActor 11138)
Critical: ULinkerLoad::Create
Critical: UObject::StaticLoadObject
Critical: (Core.Class PackageHelper_v15.PHActor NULL)
Exit: Exiting.
Uninitialized: Name subsystem shut down
Uninitialized: Log file closed, Thu Oct 1 02:41:44 2020

Code: Select all

Log: Log file open, Thu Oct  1 02:41:39 2020
Init: Name subsystem initialized
Init: Version: 451
Init: Compiled: May  6 2003 22:27:59
Init: Command line: DM-Deck16][.unr ini=/home/utcustom/serverfiles/System/ut99server.ini
Init: Base directory: 
Init: Character set: ANSI
Log: Bound to Editor.so
Log: Bound to Core.so
Log: Bound to Engine.so
Init: Object subsystem initialized
Init: CPU Speed=2200.070249 MHz
Log: Executing Class Engine.ServerCommandlet
Init: Unreal engine initialized
Log: Browse: DM-Deck16][.unr?Name=Player?Class=Botpack.TMale2?team=0?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello
Log: LoadMap: DM-Deck16][.unr?Name=Player?Class=Botpack.TMale2?team=0?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello
Log: Bound to Fire.so
Log: Case-insensitive search: Botpack -> ../System/BotPack.u
Log: Bound to IpDrv.so
Log: Case-insensitive search: Ambancient -> ../Sounds/AmbAncient.uax
Log: Case-insensitive search: hubeffects -> ../Textures/HubEffects.utx
Log: Case-insensitive search: genfluid -> ../Textures/GenFluid.utx
Log: Collecting garbage
Log: Purging garbage
Log: Garbage: objects: 16896->16895; refs: 236001
Log: Game class is 'DeathMatchPlus'
Init: Sockets: Socket queue 262144 / 262144
Init: Sockets: I am madrugaserver-2 (10.158.0.10)
Log: Server Package: SoldierSkins
Log: Case-insensitive search: SoldierSkins -> ../Textures/Soldierskins.utx
Log: Server Package: CommandoSkins
Log: Server Package: FCommandoSkins
Log: Server Package: SGirlSkins
Log: Server Package: BossSkins
Log: Server Package: Botpack
Log: Case-insensitive search: Botpack -> ../System/BotPack.u
Log: Server Package: MultiMesh
Log: Server Package: EpicCustomModels
Log: Server Package: TCowMeshSkins
Log: Server Package: TNaliMeshSkins
Log: Server Package: SkeletalChars
Log: Server Package: BrasilTauntV1
Log: Server Package: MVE2a
Log: Server Package: NexgenCC
Log: Server Package: Nexgen112N
Log: Server Package: NexgenPlayerLookup112N
Log: Server Package: NexgenClientsideExtensions112NMHA
Log: Server Package: NexgenPlus100N
Log: Server Package: NexgenSSB
Log: Server Package: NoInvisibility
Log: Server Package: NoUDamage
Log: Server Package: KWNet48v7
Log: Bound to UWeb.so
Log: Server Package: SBU3
Log: Server Package: SmartSB101m
Log: Server Package: SmartDmAssets
Log: Server Package: CountryFlags32b
Log: Server Package: CountryFlags3
Log: Server Package: IpToCountry_AOL
Log: Server Package: UTSAccuBeta4_2
Log: Spawning: IpDrv.UdpBeacon
Log: Spawning: IpServer.UdpServerQuery
Log: Spawning: IpServer.UdpServerUplink
Log: Spawning: NPLoader_v19b.NPLActor
Log: Spawning: ipToCountry.LinkActor
Log: Spawning: Nexgen112N.NexgenActor
Log: Spawning: UTStatsBeta4_2.UTStatsSA
Log: Spawning: NodeUTStats.NodeUTStatsServerActor
Log: Spawning: NexgenServersideExtensions.NSEMain
Log: Spawning: NexgenPlayerLookup112N.NexgenPlayerLookup
Log: Spawning: NexgenPlus100N.NXPMain
Log: Spawning: SmartSB101n.SmartSBServerActor
Log: Level is Level DM-Deck16][.MyLevel
Log: Bringing Level DM-Deck16][.MyLevel up for play (80)...
ScriptLog: InitGame: ?Name=Player?Class=Botpack.TMale2?team=0?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello
ScriptLog: Base Mutator is DM-Deck16][.DMMutator0
ScriptLog: UdpServerQuery(crt): Port 7778 successfully bound.
Log: Resolving utmaster.epicgames.com...
NSC: [NSC-SYS] Starting Nexgen Server Controller...
NSC: [NSC-SYS] Server crash/reboot detected, executing Nexgen boot sequence...
ScriptLog: ProcessServerTravel: AS-Frigate?Name=Player?Class=Botpack.TMale2?Team=0?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?Game=Botpack.Assault?mutator=SmartSB101n.SmartSB,MVES.MapVote
Critical: appError called:
Critical: Can't bind to native class PackageHelper_v15.PHActor
Exit: Executing UObject::StaticShutdownAfterError
Critical: UClass::Bind
Critical: (Class PackageHelper_v15.PHActor)
Critical: ULinkerLoad::CreateExport
Critical: (PHActor 11138)
Critical: ULinkerLoad::Create
Critical: UObject::StaticLoadObject
Critical: (Core.Class PackageHelper_v15.PHActor NULL)
Exit: Exiting.
Uninitialized: Name subsystem shut down
Uninitialized: Log file closed, Thu Oct  1 02:41:44 2020

Brazilian Server:
Classic madruga.utbr.tk:7777
Duel x1.utbr.tk:6666
Custom custom.utbr.tk:7777
UT2004 2004.utbr.tk:5555

User avatar
Sp0ngeb0b
Adept
Posts: 368
Joined: Wed Feb 13, 2008 9:16 pm
Location: Cologne
Contact:

Re: [Release] ACE v1.2e

Post by Sp0ngeb0b » Thu Oct 01, 2020 12:06 pm

The first line of this thread explains your error:
anth wrote:
Thu Sep 24, 2020 11:28 am
*** WARNING ***

ACE v1.2e will not work on v436-451 or TO servers that run Linux!
Website, Forum & UTStats

Image
******************************************************************************
Nexgen Server Controller || My plugins & mods on GitHub
******************************************************************************

User avatar
[rev]rato.skt
Adept
Posts: 306
Joined: Mon Aug 16, 2010 1:09 pm

Re: [Release] ACE v1.2e

Post by [rev]rato.skt » Thu Oct 01, 2020 12:33 pm

Thanks, i dont see :oops:
Brazilian Server:
Classic madruga.utbr.tk:7777
Duel x1.utbr.tk:6666
Custom custom.utbr.tk:7777
UT2004 2004.utbr.tk:5555

User avatar
Fraxter
Novice
Posts: 14
Joined: Wed Jul 01, 2020 5:44 pm
Location: Hvalsoe, Zealand, Denmark.

Re: [Release] ACE v1.2e

Post by Fraxter » Thu Oct 01, 2020 8:51 pm

anth wrote:
Thu Sep 24, 2020 11:28 am
ACE v1.2e will not work on v436-451 or TO servers that run Linux!
How does that translate into if I run a v451 windows server? I see it isolated as it will not work on 436-451 at all and then TO servers on linux OS. So I need to run v469 beta to use this version or is it meaning linux servers in general not TO alone not working with this version?

User avatar
anth
Skilled
Posts: 235
Joined: Thu May 13, 2010 2:23 am

Re: [Release] ACE v1.2e

Post by anth » Fri Oct 02, 2020 8:32 am

Fraxter wrote:
Thu Oct 01, 2020 8:51 pm
anth wrote:
Thu Sep 24, 2020 11:28 am
ACE v1.2e will not work on v436-451 or TO servers that run Linux!
How does that translate into if I run a v451 windows server? I see it isolated as it will not work on 436-451 at all and then TO servers on linux OS. So I need to run v469 beta to use this version or is it meaning linux servers in general not TO alone not working with this version?
v451 Windows servers are fine. I've edited the top post to clarify

gargul2
Novice
Posts: 25
Joined: Wed Sep 30, 2020 9:16 am

Re: [Release] ACE v1.2e

Post by gargul2 » Fri Oct 02, 2020 9:00 am

Another of ACE related issues is: timeouts for some players, they were present in ACE 1.1f and they are still here in ACE 1.2e as well, despite the fact that in ACE change log, every second ACE release has some timeout (and crash by the way) issues fixed since the beginning of ACE being developed, timeouts are still here, I wonder whether timeouts issues are caused by ACE or by server or by client:
[ACEv12e]: +------------------------------------------------------------------------------+
[ACEv12e]: | Kick Reasons |
[ACEv12e]: +------------------------------------------------------------------------------+
[ACEv12e]: KickReason.....: Timeout during Periodic Check
[ACEv12e]: +------------------------------------------------------------------------------+
By the way another thing is that ACE change log lacks mentioning about NPLoader 1.8b & 1.9b in change log file:
-------------------------------------------------------------------------------
NPLoader Changes
-------------------------------------------------------------------------------

v1.6b:
I wonder whether it is because:
- some NPLoader 1.8b changes are mentioned in ACE changes already (and in case of NPLoader 1.9b there are no major changes other than compatibility with ACE 1.2x)
- or the changes are secret,
- or the changes are just missing in the change log file
Last edited by gargul2 on Mon Oct 12, 2020 10:31 am, edited 1 time in total.

User avatar
[rev]rato.skt
Adept
Posts: 306
Joined: Mon Aug 16, 2010 1:09 pm

Re: [Release] ACE v1.2e

Post by [rev]rato.skt » Sun Oct 11, 2020 11:45 pm

I get this erro...
relics.u is an original ut package... :noidea

this erro even with ace fully loaded

in other versions I did not have this problem ..

Image

[ACEv12e]: KickReason.....: Unknown Package Loaded
[ACEv12e]: PackageName....: relics
[ACEv12e]: PackagePath....: ../System/Relics.u
[ACEv12e]: PackageSize....: 453755 bytes
[ACEv12e]: PackageHash....: 8C45B948D85A5606680B8CC0565984B9
[ACEv12e]: PackageVer.....: Unknown File

[ACEv12e]: +------------------------------------------------------------------------------+
[ACEv12e]: | Kick Reasons |
[ACEv12e]: +------------------------------------------------------------------------------+
[ACEv12e]: KickReason.....: Timeout during Periodic Check
[ACEv12e]: +------------------------------------------------------------------------------+

[ACEv12e]: [g3*MaraWzLasers]: Player Kicked
[ACEv12e]: [g3*MaraWzLasers]: Kick Message 0: You have been kicked because of a timeout during the ACE checks.
[ACEv12e]: [g3*MaraWzLasers]: Kick Message 1: This is usually caused by severe connection problems.
[ACEv12e]: [g3*MaraWzLasers]: Kick Message 2: Try shutting down all programs that use a lot of bandwidth, memory or CPU time.
Brazilian Server:
Classic madruga.utbr.tk:7777
Duel x1.utbr.tk:6666
Custom custom.utbr.tk:7777
UT2004 2004.utbr.tk:5555

gargul2
Novice
Posts: 25
Joined: Wed Sep 30, 2020 9:16 am

Re: [Release] ACE v1.2e

Post by gargul2 » Mon Oct 12, 2020 10:23 am

Anth has been informed about this file version already almost a year ago HERE, but he refused whitelisting this file. Also the thread I linked is more suitable for reporting blocked ACE files, while the current thread is more focused on the issues related to the ACE itself.
in other versions I did not have this problem ..
This version of the file was never whitelisted on ACE whielist, it seems you have a different copy of game this time, which comes with a different version of the file, I wonder where did you get your game copy from and what game / language version it is. If you prove the file is a valid UT99 file, there is a better chance that anth will whitelist it.

RocketJedi
Inhuman
Posts: 803
Joined: Wed Mar 12, 2008 7:14 pm
Personal rank: I.T Master
Location: New York
Contact:

Re: [Release] ACE v1.2e

Post by RocketJedi » Mon Oct 12, 2020 4:35 pm

gargul2 wrote:
Wed Sep 30, 2020 3:58 pm
There is a nasty bug here with ACE 1.2x & ATBHighScores

After joining to the server as a cilent, the ACE 1.2x installation dialog shows up but then suddenly quickly dissappears after 1 sec just in the moment when ATBHighScores table is showing up on the left side of the screen, they appear almost in the same moment, however they don't obstruct each other, yet they still interfere somehow.

ACE 1.1f is unaffected, the bug begun to happen only after upgrading a server from ACE v1.1f to ACE v1.2e

To see ACE installation dialog again, an Esc or Tilde key is required to be pressed, that gets a player back to UT99 Main Menu along with the ACE Installation dialog visible again so the installation can be contiuned.

The bug causes problems for some newcomers / unexperienced players, as they are unaware of the workaround and thus they end with the ACE installation unfinished, what further leads them to be disconnected after 60 secs. They sometimes complain in the chat in a spectator mode, that they can't play and can only spectate. So this bug throws away some newcomers / unexperienced players from playing on a server, which is THE WORST THING any server owner wanted ever to happen.

I tried things which didn't work:
- moving ACE ServerActors & ServerPackages UT.ini entries above / below ATBHighScores entries
- bShowLogo=True to bShowLogo=False but it didn't help neither

Only disabling ATBHighScores, but I'm not going to disable it.

There is a small GIF video I recorded: https://ibb.co/yY4qfL2 - you have to click "Otwórz GIF" (Open GIF) to play.

To reproduce the bug you may visit some 1.2e servers for ex.:

Image

To see that the bug doesn't happen on ACE 1.1f you may visit some ACE 1.1f servers:

Image
edit nm i had a different issue. I Am also unable to join your server be cause you "de" in server packages.
Last edited by RocketJedi on Mon Oct 12, 2020 5:19 pm, edited 2 times in total.
https://www.vulpinemission.com
Image ROCKET-X8 Server
Image MONSTERHUNT w/ NALI WEAPONS 3 + RX8
Image BUNNYTRACK NY
Image SNIPER DEATHMATCH
Image InstaGib + ComboGib + Jailbreak
Image ROSEBUM ROCKET-X RB

User avatar
[rev]rato.skt
Adept
Posts: 306
Joined: Mon Aug 16, 2010 1:09 pm

Re: [Release] ACE v1.2e

Post by [rev]rato.skt » Mon Oct 12, 2020 4:54 pm

Hi,

I just tested on the same VM in linux, server 451 with ace 11f I had no errors, no kick... :sad2:
Brazilian Server:
Classic madruga.utbr.tk:7777
Duel x1.utbr.tk:6666
Custom custom.utbr.tk:7777
UT2004 2004.utbr.tk:5555

gargul2
Novice
Posts: 25
Joined: Wed Sep 30, 2020 9:16 am

Re: [Release] ACE v1.2e

Post by gargul2 » Mon Oct 12, 2020 5:34 pm

RocketJedi wrote:edit nm i had a different issue.
You will not get the ACE 1.2e & ATBHighScore Board issue anymore on this server, coz the server has fallback to ACE 1.1f until the issue is fixed...
RocketJedi wrote:I Am also unable to join your server be cause you "de" in server packages.
I think this is not a server issue, probably this is a client side issue, there was already an email from a player with an identical issue:
PLAYER wrote:Hello John,

I hope this email finds you well. I have just reinstalled Unreal Tournament 99 after 20 years. :) Have been installing all the patches and trying to get it up and running.

When I attempt to connect to your server, it says the server refused to send 'de'. Now, I do have the de umod in my UT system folder, so I'm not sure why it needs it again.

I was wonder if by chance I could please ask for your guidance? I would love to get in on some CTF facing worlds action!

Thanks so much
--
REPLY wrote:Hey,
most probably your de.u file differs from the one present on the server,
that's why your client tries to download the original file from the server,
but the file cannot be downloaded from the server
because the file is a default / vanilla ut99 file
which should be present in a client side after default game installation,
so there is no reason to keep this file as a downloadable file on the server,
so you have to get the proper file yourself,
most probably
either your ut99 version is too old and need to be patched to at least v432 patch,
or the file is corrupted / modified somehow
or you have some unusual ut99 game copy,
so try installing other game copy to get the proper de.u file
PLAYER wrote:It works now! Thank you!
========================================================================================================
[rev]rato.skt wrote:Hi, I just tested on the same VM in linux, server 451 with ace 11f I had no errors, no kick...
Kinda odd, not sure what to say.

gargul2
Novice
Posts: 25
Joined: Wed Sep 30, 2020 9:16 am

Re: [Release] ACE v1.2e

Post by gargul2 » Mon Oct 12, 2020 6:19 pm

Apart from occasional timeouts for some players:
gargul2 wrote:[ACEv12e]: +------------------------------------------------------------------------------+
[ACEv12e]: | Kick Reasons |
[ACEv12e]: +------------------------------------------------------------------------------+
[ACEv12e]: KickReason.....: Timeout during Periodic Check
[ACEv12e]: +------------------------------------------------------------------------------+
Just right now I've got kicked from my own server as well, it's not the first time, it happens occasionaly, from time to time, it also happens for other players as well:
[ACEv11f]: You have been kicked because of a timeout during the ACE checks.
[ACEv11f]: This is usually caused by severe connection problems.
[ACEv11f]: Try shutting down all programs that use a lot of bandwidth, memory or CPU time.
lolz

Post Reply