★ Smart Scoreboard 101t ★ [UPDATED 21/11/20]

Search, find and discuss about Mutators!
User avatar
[rev]rato.skt
Adept
Posts: 306
Joined: Mon Aug 16, 2010 1:09 pm

Re: ★ Smart Scoreboard 101m ★

Post by [rev]rato.skt » Mon Sep 21, 2020 3:47 am

hi,
i use openGL last version..

Image
Brazilian Server:
Classic madruga.utbr.tk:7777
Duel x1.utbr.tk:6666
Custom custom.utbr.tk:7777
UT2004 2004.utbr.tk:5555

User avatar
Que
Skilled
Posts: 233
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...
Contact:

Re: ★ Smart Scoreboard 101m ★

Post by Que » Mon Sep 21, 2020 3:53 am

Last edited by Que on Mon Sep 21, 2020 4:13 am, edited 2 times in total.
>>> PSYCHOSERVERS <<< Address: 116.251.192.212 Port: 7760

User avatar
[rev]rato.skt
Adept
Posts: 306
Joined: Mon Aug 16, 2010 1:09 pm

Re: ★ Smart Scoreboard 101m ★

Post by [rev]rato.skt » Mon Sep 21, 2020 4:11 am

Que wrote:
Mon Sep 21, 2020 3:53 am
http://www.cwdohnal.com/utglr/utglr37.zip

this version?

Image
Yes!! :noidea :noidea
Brazilian Server:
Classic madruga.utbr.tk:7777
Duel x1.utbr.tk:6666
Custom custom.utbr.tk:7777
UT2004 2004.utbr.tk:5555

ProAsm
Experienced
Posts: 124
Joined: Sun Sep 29, 2013 7:12 am

Re: ★ Smart Scoreboard 101m ★

Post by ProAsm » Mon Sep 21, 2020 8:47 am

The black background appears with graphic cards that do not support OpenGL or they are using the wrong GameRenderDevice

[Engine.Engine]
GameRenderDevice=D3D9Drv.D3D9RenderDevice = Black background.

GameRenderDevice=D3DDrv.D3DRenderDevice = Clear background

or if your graphic card supports OpenGL

GameRenderDevice=OpenGLDrv.OpenGLRenderDevice

I will force transparency in next version.

ProAsm
Experienced
Posts: 124
Joined: Sun Sep 29, 2013 7:12 am

Re: ★ Smart Scoreboard 101m ★

Post by ProAsm » Mon Sep 21, 2020 9:29 am

[rev]rato.skt wrote:
Mon Sep 21, 2020 3:47 am
hi,
i use openGL last version..

Image
If your graphics card does not support OpenGL it will go to Software Rendering which it looks like.
Try:
GameRenderDevice=D3DDrv.D3DRenderDevice

rdy2bz
Novice
Posts: 14
Joined: Thu Nov 26, 2015 11:42 am

Re: ★ Smart Scoreboard 101m ★

Post by rdy2bz » Wed Sep 23, 2020 10:38 am

I upgraded ut to v469a from the previous august beta.
And I upgraded to SSB101m from k, just replacing all 'k' with 'm' in all the three relevant ini files.
No further changes. That's what I get, both top right and bottom left icons are screwed up:
ut469assb101m.jpg

ProAsm
Experienced
Posts: 124
Joined: Sun Sep 29, 2013 7:12 am

Re: ★ Smart Scoreboard 101m ★

Post by ProAsm » Wed Sep 23, 2020 4:49 pm

I have no idea why you get this except for the new 469 font scaling.
Is the 1280x720 the resolution you play with or is that just the screenshot.
Also please make sure your override font scaling in the UT Menu is not checked.
fontscal.png
fontscal.png (3.54 KiB) Viewed 122 times

rdy2bz
Novice
Posts: 14
Joined: Thu Nov 26, 2015 11:42 am

Re: ★ Smart Scoreboard 101m ★

Post by rdy2bz » Wed Sep 23, 2020 5:00 pm

I play with FullHD, I just rescaled the screenshot to reduce size.
Here's a full sized screenshot with all the options. Font scaling seems to not be the issue. I tried disabling all other mutators except SSB but that didn't help:
ut469assb101mfull.jpg

ProAsm
Experienced
Posts: 124
Joined: Sun Sep 29, 2013 7:12 am

Re: ★ Smart Scoreboard 101m ★

Post by ProAsm » Wed Sep 23, 2020 7:05 pm

Ok, this is very interesting and would like to get to the bottom of the problem, because if I cannot replicate the problem on my computers then I canot fix it :)
A few questions.
What make and model graphics card you using.
Are you using a windows PC ?
What is you GameRenderDevice device set at, check in your UT.ini file under [Engine.Engine]

Also the pic what you are showing I'm sure cannot exist.
Nowhere in UT's HUD that I know of is the DOLL on the left hand side of the Armor/Health ?
hud1.jpg
hud1.jpg (23.77 KiB) Viewed 114 times
hud2.jpg
hud2.jpg (15.74 KiB) Viewed 114 times

rdy2bz
Novice
Posts: 14
Joined: Thu Nov 26, 2015 11:42 am

Re: ★ Smart Scoreboard 101m ★

Post by rdy2bz » Wed Sep 23, 2020 7:56 pm

I guess I figured it out: it seems to be connected to Wormbo's enhanced item patch from here.
It seems that the UI "remembers" the location of the player icon. I've played with enhanced items forever. Once I unloaded the mutator, the icon remained on the left side. I had to disable and enable the "Show Player Status" in the HUD section to reset the icon placement to the right, just as you have shown in the screenshots.

So, plain UT looks like this:
ut99v469_nomut.jpg
When I now enable SSB, the player icon looks correct, although on the bottom left there's sill text overlapping:
ut99v469_ssbonly.jpg
Once I add the Enhanced Player Item, the player icon moves to the left and the placement of the additional SSB time is broken:
ut99v469_ssb+ei.jpg
On a side note: the misplaced time box as well as the overlapping text seem to be connected to the "Status Size" slider that controls the height of the player icon:
iconut99v469assb101m.gif
The last one is a gif, so make sure to open it full screen to play. You see, that there is no status size value that corrects both errors. When the time box is correctly placed, there's still some overlapping on the bottom. When the bottom is correct, the time box is already too far left.

rdy2bz
Novice
Posts: 14
Joined: Thu Nov 26, 2015 11:42 am

Re: ★ Smart Scoreboard 101m ★

Post by rdy2bz » Wed Sep 23, 2020 8:49 pm

Another small bug report:
In all the UTR maps both the timer box and the additional stats are completely missing. I reckon that has to do with XPickups which all of those maps use. Is there a way for you to fix this?

ProAsm
Experienced
Posts: 124
Joined: Sun Sep 29, 2013 7:12 am

Re: ★ Smart Scoreboard 101m ★

Post by ProAsm » Wed Sep 23, 2020 8:57 pm

The part that had me most baffled was the time at the top.
In UT those Armor/Health/Timer boxes are exactly 128 pixels wide and 64 pixels high (scaled), so when we place them we place them Horizontal width minus 140 pixels.
So that leaves 12 pixels on the right so how on earth the timer get to be shifted is anyone's guess :)
Also I never use the UT menu options, I tick everything on then use the + and - keys to shift the HUD around.
In that way we code the sequence and you know what comes next to place the icons etc as there is no other way of know where things are.
set1.jpg
set1.jpg (27.72 KiB) Viewed 98 times

rdy2bz
Novice
Posts: 14
Joined: Thu Nov 26, 2015 11:42 am

Re: ★ Smart Scoreboard 101m ★

Post by rdy2bz » Wed Sep 23, 2020 9:37 pm

So Wormbo found some clever but dirty hack to move the player icon around. Nice :lol:

Now that I can actually see the new status items, I wonder what they actually should show. I expected that they either show the amount of picked up items (for the boots) or the remaining time (for the amplifier) or something.

So I tried it offline with bots and my setup from above (with enhanced items) on Linux and UT v469a. As you can see, I picked up the belt, the boots and the amp.
But both the boot item and the amp item still show "0". And although I have 135 armor, the item only shows 89. It showed 99 when I freshly pick up the belt, so I guess that's kind of the status of the body armor?
ssb101m-icons.jpg

ProAsm
Experienced
Posts: 124
Joined: Sun Sep 29, 2013 7:12 am

Re: ★ Smart Scoreboard 101m ★

Post by ProAsm » Thu Sep 24, 2020 9:05 am

rdy2bz wrote:
Wed Sep 23, 2020 8:49 pm
Another small bug report:
In all the UTR maps both the timer box and the additional stats are completely missing. I reckon that has to do with XPickups which all of those maps use. Is there a way for you to fix this?
Normal when someone changes the way a default class works, like XPickups, there is nothing one can do about it.
If you can post a direct workable link to XPickups I'll have a look see if I can do something.

ProAsm
Experienced
Posts: 124
Joined: Sun Sep 29, 2013 7:12 am

Re: ★ Smart Scoreboard 101m ★

Post by ProAsm » Thu Sep 24, 2020 9:21 am

rdy2bz wrote:
Wed Sep 23, 2020 9:37 pm
So Wormbo found some clever but dirty hack to move the player icon around. Nice :lol:

Now that I can actually see the new status items, I wonder what they actually should show. I expected that they either show the amount of picked up items (for the boots) or the remaining time (for the amplifier) or something.

So I tried it offline with bots and my setup from above (with enhanced items) on Linux and UT v469a. As you can see, I picked up the belt, the boots and the amp.
But both the boot item and the amp item still show "0". And although I have 135 armor, the item only shows 89. It showed 99 when I freshly pick up the belt, so I guess that's kind of the status of the body armor?
The powerups should show you exactly what it is.
The Invisiblity is a count down timer from 100 to 0
The Amplifier is a count down timer from 25 to 0
The Boots shows the jumps you have left from 3 to 0
The Armor is the percentage left. 100% = 150 etc.
SSB101m has an error here as it shows differently depending whether you picked up armor or thighpads first.
This has been fixed in 101n

Looks like your version of UT is maybe different.
All coding is done for the free version of UT99 version downloadable from EpicGames.

I wonder if there is anyone else around that's having similar problems ?
ssb6.jpg

Post Reply