Trans Throws low after zoom

Search, find and discuss about Mutators!
-=CoN=-Strych9
Average
Posts: 34
Joined: Wed Jun 19, 2013 2:17 am

Trans Throws low after zoom

Post by -=CoN=-Strych9 » Mon Nov 30, 2015 11:15 pm

I have a custom single shot gun and a custom sniper rifle. I have noticed that on the single shot gun sometimes after zooming the trans throws really low like it is coming out of your feet and you have to zoom all the way in and back out and it will work correctly after that. I was just wondering if anyone had seen that and if so maybe some suggestions to fix it. It does not do it all the time but enough to be annoying.

Thank you,

S9

UTX
Skilled
Posts: 214
Joined: Fri Aug 28, 2015 3:39 am

Re: Trans Throws low after zoom

Post by UTX » Wed Dec 02, 2015 1:46 am

Single shot gun? Trans? I think people are not replying because they don't know what you're talking about, try rephrasing what you're trying to say and perhaps add a screenshot so we know what you're saying.

-=CoN=-Strych9
Average
Posts: 34
Joined: Wed Jun 19, 2013 2:17 am

Re: Trans Throws low after zoom

Post by -=CoN=-Strych9 » Wed Dec 02, 2015 3:52 am

Well not sure how to elaborate more other than it is a single shot sniper rifle. Trans is the translocator. Really can't take a screen shot since the translocator is coming from below the view.

User avatar
Wormbo
Adept
Posts: 258
Joined: Sat Aug 24, 2013 6:04 pm

Re: Trans Throws low after zoom

Post by Wormbo » Wed Dec 02, 2015 6:34 am

That "elaboration" still doesn't shine any light on how that single shot sniper rifle works, so it won't help you generate better answers.

User avatar
Chamberly
Godlike
Posts: 1963
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA

Re: Trans Throws low after zoom

Post by Chamberly » Wed Dec 02, 2015 6:45 am

Bolt action gun right?

I'm probably gonna take a guess... would it be some kind of animation not fully complete, and hang halfway (beside the xloc/trans animation but according to where the offset of the disc to go)? Like sometimes it would be coming out from above the norm as well?

How would it goes for adding check and print in the log about how is it completing upon switch, to see if it doing something else? Just an idea.
Image
Image
Image Edit: Why does my sig not work anymore?

-=CoN=-Strych9
Average
Posts: 34
Joined: Wed Jun 19, 2013 2:17 am

Re: Trans Throws low after zoom

Post by -=CoN=-Strych9 » Wed Dec 02, 2015 3:15 pm

Thanks Chamberly! That is what I was thinking. I just have not had time to really look at it. Just wanted see what other thought.

User avatar
UTPe
Masterful
Posts: 510
Joined: Sun Jul 12, 2009 7:10 pm
Personal rank: Dude
Location: Trieste, Italy

Re: Trans Throws low after zoom

Post by UTPe » Wed Dec 02, 2015 7:35 pm

-=CoN=-Strych9 wrote:I have noticed that on the single shot gun sometimes after zooming the trans throws really low like it is coming out of your feet and you have to zoom all the way in and back out and it will work correctly after that.
Hi Matt,
(much) time ago I thought to be the only one to have this issue with sniper custom rifles and to have, someway, a faulty copy of the game (broken packages, etc). Only later, I understood the problem was about the weapon itself. I asked for infos around but no one told me anything about it.
The first time I really noticed this problem was during NBK Camping Cup 2011 when teams played with a custom sniper rifle by NBK (one mutator for modded rifle + xloc). ISC camping rifle, which is based on NBK camping rifle, has the same problem so I guess every custom rifle based on NBK rifle (as far as I know, for example, EST rifle) should show the same behaviour. I can't remember now if I noticed this issue elsewhere.

-=CoN=-Strych9 wrote:maybe some suggestions to fix it. It does not do it all the time but enough to be annoying.
Unfortunately, I don't have any suggetions to correct this problem. Decompiling rifle code is pretty easy but I would not know what to fix.
Can't say if this problem is related to some types of custom rifles or, generally speaking, to the customization of the standard ut99 sniper rifle. It would be interesting to understand if the problem arises also when 2 separate mutators (for rifle and xloc) are used.
True, this problem can be really annoying during gameplay. It looks like the only solution to avoid this issue is unzooming before changing weapon and using xloc (but it's not always obvious when under enemy fire :?)

cheers,
Pietro
Personal map database: http://ut99maps.gamezoo.org

"These are the days that we will return to one day in the future only in memories." (The Midnight)

-=CoN=-Strych9
Average
Posts: 34
Joined: Wed Jun 19, 2013 2:17 am

Re: Trans Throws low after zoom

Post by -=CoN=-Strych9 » Wed Dec 02, 2015 8:55 pm

Pietro,

Good to see you again. My gun is not based on the NBK rifle but I am sure all the custom rifles have some similarities. The one I see it on most of all is my bolt action rifle. I also started seeing it on the FN C-oPs bolt action too. The code on my rifles have not changed in years and I used to not have the problem but it seems as the years have gone on I started seeing it more and more. But yes you are correct zooming in and out does a reset and the trans throws correct again.

I am hoping to find some time soon to sit down and look at it, but wanted to throw it out there for ideas first.

Take care and talk to you soon,

Matt

User avatar
Chamberly
Godlike
Posts: 1963
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA

Re: Trans Throws low after zoom

Post by Chamberly » Thu Dec 03, 2015 1:41 am

Sounds kind of interesting. Zoomed in and then switch to the trans which changed the offset (position) to shoot the trans? Maybe a reset from zoom to unzoom to alter that settings by a code... and I would think that would either be implemented by the rifle just incase the change of a trans. A security check would be good on that...

I also remember even using the trans alone in the xloc server, the trans does still have a weird offset some other times until I disconnect/reconnect or suicide I think.

I'm not sure if it's the trans... or the rifle... ;)
Image
Image
Image Edit: Why does my sig not work anymore?

User avatar
Barbie
Godlike
Posts: 2390
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: Trans Throws low after zoom

Post by Barbie » Thu Dec 03, 2015 4:05 am

What about posting the code of the sniper? Maybe one of us will notice the mistake in code.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

max***
Novice
Posts: 10
Joined: Sun Apr 22, 2012 8:31 pm

Re: Trans Throws low after zoom

Post by max*** » Thu Dec 03, 2015 9:23 am

U all are noobs :P
S9 i will show u.

User avatar
Chamberly
Godlike
Posts: 1963
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA

Re: Trans Throws low after zoom

Post by Chamberly » Thu Dec 03, 2015 9:46 am

Then why not show us all about the fix?
Image
Image
Image Edit: Why does my sig not work anymore?

User avatar
papercoffee
Godlike
Posts: 10133
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.

Re: Trans Throws low after zoom

Post by papercoffee » Thu Dec 03, 2015 4:15 pm

max*** wrote:U all are noobs :P
S9 i will show u.
lame.
Chamberly wrote:Then why not show us all about the fix?
^This
Share the fix with the community.

User avatar
UTPe
Masterful
Posts: 510
Joined: Sun Jul 12, 2009 7:10 pm
Personal rank: Dude
Location: Trieste, Italy

Re: Trans Throws low after zoom

Post by UTPe » Thu Dec 03, 2015 9:01 pm

well,
before, I had an interesting conversation on ICU forum chat with Doomed about this bug.
He already knew this issue but he told me also other people don't have this problem when they use the same custom rifles. He suggested me to remove weapon hand from HUD and test the xloc behaviour. Ok, I tested ISC camping rifle without displaying weapon (rifle/xloc), it worked fine and I did not notice any bug, xloc throws correct also after zoom.
What can be said ? at least for ISC rifle (maybe this behaviour can be extended to other custom rifles), the bug arises only when Weapon Hand is visible (see values in Preferences > Game tab: Left, Center, Right).
The bug reported by Strych9 obviously remains, it's coded somewhere in the rifle but maybe can be avoided by using the "Hidden" value of Weapon Hand property. Anyway, it would be nice to fix this problem someday.

I would like to thank Doomed from ICU clan for his suggestion :tu:

cheers,
Pietro


PS:
maxi, maybe you're right when you say we are "noobs" :pfff: because "only" noobs (really ?) play with weapon hand visible :mrgreen: but I'm an old fart who still needs to display weapon hand to see which item/weapon is active in that moment: please be patient...like Ivan says, I'm an old man :lol2:
Personal map database: http://ut99maps.gamezoo.org

"These are the days that we will return to one day in the future only in memories." (The Midnight)

User avatar
Chamberly
Godlike
Posts: 1963
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA

Re: Trans Throws low after zoom

Post by Chamberly » Thu Dec 03, 2015 9:38 pm

That is an interesting report, thank you UTPe!
Image
Image
Image Edit: Why does my sig not work anymore?