Characters move slow - v432

Discussions about UT99
Post Reply
cafyon
Posts: 1
Joined: Wed May 23, 2018 9:45 am

Characters move slow - v432

Post by cafyon » Wed May 23, 2018 10:06 am

Hi,

From time to time I setup/install, play, then uninstall UT on various pcs in years.

I installed UT again a couple of weeks ago. v432. I was playing multiplayer without online session. All characters are computer except mine/player. It was working fine until a couple of days ago. However, a couple of days ago, I opened UT and at the start of game ALL characters including me/player were moving SLOW, even in running mode, which is default for me. And it's the same since then, moving SLOW. :???:
Also, any movable object, loading rocket launcher for alternate fire, flight of rocket missiles after firing, jumping, thrown pod's motion etc. all are SLOW for all characters.
Edit: Gameplay is smooth but slow wrt player. Sound has no problems.

I tried some not all different game styles, CTF, Domination etc. with some not all built-in maps, but it's the same. ALL characters, moving objects move SLOW.
I don't know how to express this fault in other words. The motion of player, characters, objects is SLOW.

Edit: UT currently running on:
HP 6510b notebook
intel mobile GM965 Express chipset
Core 2 Duo T8100 2.1GHz
4 GB RAM
Onboard/i865 gfx
MS Windows 8.1 64bit
Kaspersky Total Security since pc first set up


Any ideas?

:help:

User avatar
UnrealGGecko
Godlike
Posts: 2250
Joined: Wed Feb 01, 2012 11:26 am
Personal rank: GEx the Gecko
Location: Kaunas, Lithuania
Contact:

Re: Characters move slow - v432

Post by UnrealGGecko » Wed May 23, 2018 11:21 am

On Practice Session when picking your map, check the tabs out on that little window, there is a game speed slider there (not at home so can't say how that tab is called).

Also try updating to v436? :noidea
http://www.moddb.com/games/unreal-tourn ... s-no-delta

User avatar
Barbie
Godlike
Posts: 1727
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: Characters move slow - v432

Post by Barbie » Wed May 23, 2018 3:58 pm

cafyon wrote:The motion of player, characters, objects is SLOW.
Open console and type

Code: Select all

slomo 1.1
1.1 means 110% for hardcore mode - use 1.0 for normal gamespeed.
(What is SLOMO?)
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett

User avatar
EvilGrins
Godlike
Posts: 6434
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA
Contact:

Re: Characters move slow - v432

Post by EvilGrins » Wed May 23, 2018 11:58 pm

I've had this problem a lot, before I got Windows 10. Not every time, but frequently.

Only way I ever found to deal with it was to close UT, start it up again, and that usually did it. Sometimes I'd have to do it a few times, over and over.

Never did figure out what was causing it.

For what it's worth:
Hitman wrote:Problem: Unreal, UT and old Unreal-engine games run 'erratically' - the game speeds up and slows down at random, seemingly independent of the framerate. And this is most common for AMD-cores

Cause: This is caused by the way the Unreal engine calculates time, which is a little archaic has a number of issues with modern hardware - primarily because it is based on the CPUs clock speed, which on modern CPUs is automatically varied to save power, but it also has issues when the framerate is particularly high.

Quick Fix: Sorry, you're out of luck - this can be caused by a range of issues, so go through the solution step-by-step and see which ones actually fix the problem.

Solutions: Try the following in order - generally the first few tend to fix the problem for most people, and the latter are more extreme measures for problematic systems (dual-core laptops running Vista are particularly awkward).

* If you have an AMD multi-core processor, install the AMD Dual-Core Optimizer (5th down). This is needed because of a bug with some AMD processors which means that the timers on the CPU cores aren't synchronised with each other.

* UT has a built-in flag you can use to tell it the CPUs clock speed if it doesn't detect the speed correctly (it shows the detected speed in UT.log). Create a shortcut to UnrealTournament.exe and add ' -cpuspeed=X' to the end - without the quotes, and replacing X with you CPUs clock speed in Mhz.

* As stated above, UT has issues with very high framerates (200+), you need to put a limit on it. The best way to do this is to install one of Chris Dohnal's updated renderers (OpenGL, D3D8 or D3D9) - this is worth doing anyway. Try OpenGL first, and if you have issues use D3D9 or 8.
o Copy the .dll (and .int if present) to UT\System
o Run the game in safe mode (create a shortcut to UnrealTournament.exe and add ' -safe' to the end)
o When it asks to select a render device, click on 'show all' at the bottom and select the appropriate device
o After the game starts up, open the console (normally the ~ key if I remember correctly), go to Render Devices > OpenGL (or D3Dx as appropriate), find the FrameRateLimit entry and set the value to 200.
o While you're there, find the SwapInterval entry and set it to 0 - see the section on VSync for an explanation.
Alternatively you can edit your UnrealTournament.ini directly to make these changes but you're on your own doing this, unless I update this guide that is.

* The next step is to disable the CPU's power saving features before running UT. There are a number of ways to go about this depending on which operating system you use, so I'll list the easiest first.
o On Windows XP, go to Control Panel > Power Options, and in the Power Schemes tab select 'Always On'. This can be done automatically in a batch file, as explained by Blitzschlag on the Infiltration forums.
o In Windows Vista, go to Control Panel > Power Options and select the 'High Performance' profile.
o In a modern Linux distro e.g. Ubuntu, the easiest thing to do is to use the EMIFreq applet - simply select either 'Performance' or a fixed speed.
Failing this there are three ways to go about this, none perfect but all fairly fool-proof.
o The first, and in my opinion the easiest, is to run a CPU-hungry process in the background. Prime95 is a good one to use as it defaults to running in the background, so won't interfere with UT at all.
+ Download Prime95 from the link above and extract it to any location
+ Run the application, and if nothing happens go to Options > Torture Test
+ Select 'Small FFTs' as it uses the least amount of memory
+ To start off, tell it to run only one thread - no need to waste any more power than is needed
+ Click OK and leave it to it
o The second is to use a 3rd-party utility to manually set the CPU speed. These tend to vary in effectiveness though - I use RMClock on Windows XP but don't know if it supports Vista yet. Feel free to suggest any others.
o The third is a little more involved, but if you aren't worried about power-saving you'll only have to do it once. Disabling power saving in the BIOS is a fairly fail-safe method, but the exact option to look for can vary depending on the CPU and BIOS type. Either way, you'll usually find the settings in something like Advanced Options or CPU Features. For AMD processors, look for Cool & Quiet and disable it. For Intel CPUs look for something like EIST Function, Thermal Control and C1E Function.

* VSync (or Vertical Synchronisation) is a bit of a contentious issue - some people claim that enabling it solves the problem, while in my experience it can hinder things - try it both ways (0=off, 1=on). In a nutshell, it forces the video card to synchronise the swapping of buffers (i.e. outputting the picture) with each refresh of the monitor, in order to prevent 'tearing' effects where the monitor displays the upper part of one frame and the lower part of the next. On most modern flat panel monitors this is 60Hz, giving at most 60 updates per second, and in my experience a 60fps limit doesn't put enough load on a modern CPU to make it run at full clock speed all the time, meaning power saving will cut in and mess up the game speed.

Written by Crowze
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Image Image Image Image

User avatar
Feralidragon
Godlike
Posts: 5118
Joined: Wed Feb 27, 2008 6:24 pm
Personal rank: Work In Progress
Location: Liandri

Re: Characters move slow - v432

Post by Feralidragon » Thu May 24, 2018 7:41 pm

The very first things to do in cases like this before trying anything else is:
1 - Update the game to v436 at the very least;
2 - Update the renderer to one of these: http://www.cwdohnal.com/utglr/

These 2 steps alone solve all problems for 80% of the players.
For the remaining unlucky 20%, there's all the stuff about CPU patching, enabling VSync, disabling some Windows issues, compatibility mode, etc, or just following this guide overall: viewtopic.php?t=373

User avatar
esnesi
Adept
Posts: 472
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: on it!

Re: Characters move slow - v432

Post by esnesi » Wed Oct 03, 2018 2:20 pm

Sorry that my reaction does not fit in with the rest above me.

Iam assuming your UT runs at multiple processors on your laptop.
To check this, follow these steps:

1) Open UT
2) Alt-Tab back to windows
3) Open Task-Manager (CTRL+SHIFT+ESC)
3) Rightclick your UnrealTournament.exe and select ''show details''
4) Rightclick your UnrealTournament.exe again and select ''set affinity''.

You will probably see that all your CPU's are checked.

UT needs to run on 1 CPU on laptops (dont ask me why, Hitman his quote above exlains)
(when you set this in task-manager, its not remembered)

Solution = multicorecpu fix
http://unrealtournament.99.free.fr/utfi ... oreFix.zip

DONT REPLACE YOUR UnrealTournament.exe with this file BUT
RENAME your current file to: ''unrealtournamentold.exe''
Then place the exe in the zip in your system folder.

When you start up UT now, and alt-tab back to windows, you will see that its running at 1 cpu.
Problems should be gone. :gj:

User avatar
rjmno1
Masterful
Posts: 605
Joined: Fri Aug 12, 2011 9:38 pm
Personal rank: masterfull

Re: Characters move slow - v432

Post by rjmno1 » Wed Oct 03, 2018 2:47 pm

yes update the game to v 436 wich you can download from the internet.
Look at the tips and tricks section of this forum and update your game to 436 and to the opengl videocard setting with the s3tc textures (if you have the goty edition of the game).
If you have a fast videocard you can also download more detailed textures from the retuxture website also founded on the same tip turtual and tips section of this forum.

viewtopic.php?f=6&t=373

happy editing download and reading, and installing :tu:
unreal tournament 99
®
Image
Image
ImageImage

User avatar
UnrealGGecko
Godlike
Posts: 2250
Joined: Wed Feb 01, 2012 11:26 am
Personal rank: GEx the Gecko
Location: Kaunas, Lithuania
Contact:

Re: Characters move slow - v432

Post by UnrealGGecko » Wed Oct 03, 2018 3:01 pm

Uhhh guys? Last post was on May :mrgreen:

User avatar
esnesi
Adept
Posts: 472
Joined: Mon Aug 31, 2015 12:58 pm
Personal rank: on it!

Re: Characters move slow - v432

Post by esnesi » Wed Oct 03, 2018 3:23 pm

arghh!
urge.to.help.bleep!
sorry!
hopefully the OP still sees it :)
#thinkshenailedit

Post Reply