Can't change brightness of the game (Solved)

Discussions about UT99
Terraniux
Masterful
Posts: 705
Joined: Mon Jan 05, 2009 8:08 pm
Personal rank: Banished member

Can't change brightness of the game (Solved)

Post by Terraniux » Thu Feb 13, 2020 6:39 pm

Hi there.

I had to reinstall my computer recently and did install the game again. It's way too dark! Some parts of certain maps are completely black.
Everything works well, except that I can not change the brightness of the game. Hitting f10/f11 is not doing anything, and sliding the brightnes -level -bar manually is not working either.

It does work in Software Rendering though, but not in OpenGl something, and als0 not in Direct3D. I can't play in software rendering, it's way too pixelated for me. :ironic:
Before the installation I did not have problems. I tried some different numbers in UnrealTournament.ini but not sure if I entered them correctly.

Other games are running fine, and have not this problem...

Any clues? Help would be appreciated.


Edit: got it working now. Hooray!
Last edited by Terraniux on Sat Feb 15, 2020 12:31 pm, edited 1 time in total.
This member can only post when permitted.

User avatar
EvilGrins
Godlike
Posts: 7518
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: Can't change brightness of the game

Post by EvilGrins » Thu Feb 13, 2020 8:36 pm

There was a recent thread over on Hermskii's forum about something similar...
David wrote:
Tue Feb 04, 2020 10:46 am
EvilGrins wrote:
Tue Feb 04, 2020 3:55 am
David wrote:
Tue Feb 04, 2020 2:05 am
Well, I got UT running after uninstalling it and re-installing it. But the screen appears darker. I have the brightness all the way up. Any suggestions?
Brighten your monitor's settings. It's gotta have a knob on it somewhere for that.
My monitor brightness is already at 100.
Your situation seems different, as switching to OpenGL fixed his problem.

I had a similar issue a few years ago but it turned out the issue was with my monitor and not the game.

Maybe you need a new graphics card?
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

Terraniux
Masterful
Posts: 705
Joined: Mon Jan 05, 2009 8:08 pm
Personal rank: Banished member

Re: Can't change brightness of the game

Post by Terraniux » Thu Feb 13, 2020 9:02 pm

EvilGrins wrote:
Thu Feb 13, 2020 8:36 pm
There was a recent thread over on Hermskii's forum about something similar...
David wrote:
Tue Feb 04, 2020 10:46 am
EvilGrins wrote:
Tue Feb 04, 2020 3:55 am
David wrote:
Tue Feb 04, 2020 2:05 am
Well, I got UT running after uninstalling it and re-installing it. But the screen appears darker. I have the brightness all the way up. Any suggestions?
Brighten your monitor's settings. It's gotta have a knob on it somewhere for that.
My monitor brightness is already at 100.
Your situation seems different, as switching to OpenGL fixed his problem.

I had a similar issue a few years ago but it turned out the issue was with my monitor and not the game.

Maybe you need a new graphics card?
I use tne game graphic card before and after the re-installation of my computer.
Could it be driver-related? As I update my driver frequently. :???:

I never had this problem before, that's what makes it so strange.
This member can only post when permitted.

User avatar
anth
Skilled
Posts: 235
Joined: Thu May 13, 2010 2:23 am

Re: Can't change brightness of the game

Post by anth » Thu Feb 13, 2020 9:30 pm

The method OpenGLDrv used to change the display brightness no longer works on Windows 10. If you are indeed using Windows 10, then I recommend switching to D3D9Drv.

User avatar
Que
Skilled
Posts: 242
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

Re: Can't change brightness of the game

Post by Que » Fri Feb 14, 2020 1:11 am

Wow that sucks "Windows 10" is a pig.
Are we able to fix this somehow because OpenGL is a necessity :/

Maybe old unreal drivers help sort the problem?
https://www.oldunreal.com/patch/OMP-UT-V0.2.zip

Terraniux
Masterful
Posts: 705
Joined: Mon Jan 05, 2009 8:08 pm
Personal rank: Banished member

Re: Can't change brightness of the game

Post by Terraniux » Fri Feb 14, 2020 7:22 pm

anth wrote:
Thu Feb 13, 2020 9:30 pm
The method OpenGLDrv used to change the display brightness no longer works on Windows 10. If you are indeed using Windows 10, then I recommend switching to D3D9Drv.
How do I do that, without interfering with other games?

Here is my dxdiag:

I have Ryzen 5 3600 6 core 3,6 ghz. 16 ram ddr4

rx580 8gb and windows 10 uptodate.

The patch link is not working
You do not have the required permissions to view the files attached to this post.
This member can only post when permitted.

User avatar
anth
Skilled
Posts: 235
Joined: Thu May 13, 2010 2:23 am

Re: Can't change brightness of the game

Post by anth » Fri Feb 14, 2020 8:15 pm

Here's the link for D3D9Drv: http://www.cwdohnal.com/utglr/utd3d9r13.zip

Unzip into your game's system folder, then open the UnrealTournament.ini file.

Look for the "[Engine.Engine]" section and locate the GameRenderDevice, WindowedRenderDevice and RenderDevice lines. Change each renderdevice to D3D9Drv.D3D9RenderDevice (e.g., GameRenderDevice=D3D9Drv.D3D9RenderDevice).

Now, scroll down to the bottom of the file and add:

[D3D9Drv.D3D9RenderDevice]
SwapInterval=0
GammaOffset=0.2

Use larger gammaoffset values for higher brightness.

Terraniux
Masterful
Posts: 705
Joined: Mon Jan 05, 2009 8:08 pm
Personal rank: Banished member

Re: Can't change brightness of the game

Post by Terraniux » Fri Feb 14, 2020 9:25 pm

I did what you asked me to, now the game won't start . Giving me errors starting up. I did make a back up of the .ini though. gladly. When replacing it,( old to the replaced one) the games starts fine

Is it this horror windows 10 causing this?
This member can only post when permitted.

User avatar
EvilGrins
Godlike
Posts: 7518
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: Can't change brightness of the game

Post by EvilGrins » Fri Feb 14, 2020 9:46 pm

It's weird that Windows10 causes everyone so much problems.

Was worried about that myself when I upgraded, but it's never negatively impacted my UT. You've seen the screenshots, everything looks great.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758

User avatar
Que
Skilled
Posts: 242
Joined: Mon Dec 09, 2019 5:49 am
Personal rank: ...

Re: Can't change brightness of the game

Post by Que » Fri Feb 14, 2020 11:24 pm

aCIkkkY52Q.png
8kCaCljsMm.png
You do not have the required permissions to view the files attached to this post.

Terraniux
Masterful
Posts: 705
Joined: Mon Jan 05, 2009 8:08 pm
Personal rank: Banished member

Re: Can't change brightness of the game

Post by Terraniux » Sat Feb 15, 2020 12:31 pm

I got it working now! Hooray. I think I made the mistake by fist editing the ini file then adjusting the video driver.
Starting over with the clean ini file then switching to dx9 in the options menu got it working for me !

Big thanks! I can play UT normal again now! :tu: :highfive:
This member can only post when permitted.

zabijaka87
Posts: 1
Joined: Wed Aug 05, 2020 4:06 pm

Re: Can't change brightness of the game (Solved)

Post by zabijaka87 » Wed Aug 05, 2020 4:14 pm

Here's the link for D3D9Drv: http://www.cwdohnal.com/utglr/utd3d9r13.zip

Unzip into your game's system folder, then open the UnrealTournament.ini file.

Look for the "[Engine.Engine]" section and locate the GameRenderDevice, WindowedRenderDevice and RenderDevice lines. Change each renderdevice to D3D9Drv.D3D9RenderDevice (e.g., GameRenderDevice=D3D9Drv.D3D9RenderDevice).

Now, scroll down to the bottom of the file and add:

[D3D9Drv.D3D9RenderDevice]
SwapInterval=0
GammaOffset=0.2

Use larger gammaoffset values for higher brightness.
Worked for me but now everything is running with ultra speed so I had to go back to previous settings T_T Any idea how to deal with this superspeed issue ?