bot path testing

Discussions about UT99
Post Reply
hee
Average
Posts: 74
Joined: Wed Jan 16, 2019 2:11 am

bot path testing

Post by hee » Sat Aug 15, 2020 5:36 pm

Thanks to the advice from Sektor2111 I was able to get the bot paths working. The exit lift-center lifts triplets were key in traversing difficult terrain.
For example, in one place there was just a small ledge that a small jump was required to get up to. The bots would go down but not up. I placed a lift center at the edge of the ledge and two lift exits, one on top and one on the bottom. The bots could then jump up. I also used the lift triplet to get them to do a big jump across a chasm.
The jump spot also worked, but only if the teleporter was allowed. They always used the teleporter, even for tiny jumps.

One issue was testing as I didn't have a special editor, but I found a good method. I started the game with a bot on my team. To test a path I would lead the bot to the beginning of the path and order him to hold the position. Then I would go to the other end of the path (out of his sight) and tell him to cover me. If the path was broken, he would not come. I then came back along the path in increments (knowing about where the nodes were supposed to be) and when he would finally come, I knew the problem was with the node I had just passed.

This had to be done, even if the editor gave all paths as blue.

With capture the flag the main test was to order them to capture the flag. If they could, then it proved that the whole path was good both ways, but if they couldn't, I used the above method to isolate the problem.

User avatar
OjitroC
Godlike
Posts: 1876
Joined: Sat Sep 12, 2015 8:46 pm

Re: bot path testing

Post by OjitroC » Sat Aug 15, 2020 8:19 pm

hee wrote:
Sat Aug 15, 2020 5:36 pm
Thanks to the advice from Sektor2111 I was able to get the bot paths working. The exit lift-center lifts triplets were key in traversing difficult terrain.
For example, in one place there was just a small ledge that a small jump was required to get up to. The bots would go down but not up. I placed a lift center at the edge of the ledge and two lift exits, one on top and one on the bottom. The bots could then jump up. I also used the lift triplet to get them to do a big jump across a chasm.
The jump spot also worked, but only if the teleporter was allowed. They always used the teleporter, even for tiny jumps.
Good to hear you've got the pathing working OK. :) This description would certainly be more useful if accompanied by some screenshots to illustrate the solultions.

Post Reply