mouse accelleration/lag

Discussions about UT99

mouse accelleration/lag

Postby Rita G. » Sat Oct 29, 2011 3:44 am

just installed my old copy of ut goty and wondering if anyone has any new info on this awful mouse lag/accel problem. i googled around and found nothing new; just the same old stuff that doesn't work.
i'm wondering if the current optical mice have something to do with it. when i bought the game (around 10 yrs. ago) it worked very well with a ball mouse.
Rita G.
Novice
 
Posts: 7
Joined: Sat Oct 29, 2011 3:25 am

Re: mouse accelleration/lag

Postby MrLoathsome » Sat Oct 29, 2011 7:50 am

With some of the new optical mice, you have to set the speed much lower in UT than with the older mice.

Less than 1 even in some cases. Try 0.80 for starters.
blarg
MrLoathsome
Inhuman
 
Posts: 958
Joined: Wed Mar 31, 2010 9:02 pm
Location: MrLoathsome fell out of the world!
Personal rank: I am quite rank.

Re: mouse accelleration/lag

Postby UT99.org » Sat Oct 29, 2011 2:06 pm

medor wrote:http://unrealtournament.99.free.fr/utfiles/index.php?dir=Utilities/mouse/
UT99.org
 

Re: mouse accelleration/lag

Postby papercoffee » Sat Oct 29, 2011 6:29 pm

meDATAor strikes again...
User avatar
papercoffee
Site Staff
 
Posts: 9098
Joined: Wed Jul 15, 2009 11:36 am
Location: Cologne, the city with the big cathedral.
Personal rank: coffee addicted !!!

Re: mouse accelleration/lag

Postby UT99.org » Sat Oct 29, 2011 9:57 pm

medor wrote::loool:
papercoffee wrote:meDATAor strikes again...
UT99.org
 

Re: mouse accelleration/lag

Postby maximdymok » Mon Oct 31, 2011 7:37 am

Hmm, i was just about to post a thread about this..
Well, im already using the mouse fix from the link medor gave..
but im still getting mouse lags... or more like delays - the mouse feels really smooth to move and seems to have a bit of a delay before the stuff on screen moves after you move the mouse. Basically, i didn't have this problem while using the OpenGL renderer, but now i tried D3D and i get much better FPS with it [playing on a netbook here], but i have this weird mouse delay thing. Tried fiddling with the settings in Input tab, but none help. Any tips from you guys? Using a Logitech G5.
maximdymok
Experienced
 
Posts: 84
Joined: Mon May 30, 2011 5:28 am

Re: mouse accelleration/lag

Postby UT99.org » Mon Oct 31, 2011 8:29 am

medor wrote:ok it's the basic set UT d3d
use d3d9 with add this in UT.ini http://unrealtournament.99.free.fr/utfi ... o_Renders/

Code: Select all
[D3D9Drv.D3D9RenderDevice]
UseVSync=False
SwapInterval=0
ZRangeHack=False
NoAATiles=False
NumAASamples=0
UseAA=False
RequestHighResolutionZ=True
UseSoftwareVertexProcessing=False
UsePureDevice=True
UseTripleBuffering=False
MaskedTextureHack=False
SmoothMaskedTextures=False
FrameRateLimit=190
UseVertexProgram=True
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=False
UseTexPool=True
UseTexIdPool=True
UseSSE2=True
UseSSE=True
BufferTileQuads=True
BufferClippedActorTris=True
SinglePassDetail=False
SinglePassFog=False
ColorizeDetailTextures=False
DetailClipping=False
UseDetailAlpha=True
DetailMax=0
RefreshRate=0
MaxTMUnits=0
NoFiltering=False
MaxAnisotropy=0
Use565Textures=False
Use16BitTextures=False
UseS3TC=False
UseAlphaPalette=False
UseTrilinear=False
UsePrecache=False
UsePalette=False
UseMultiTexture=True
MaxLogTextureSize=8
MinLogTextureSize=0
MaxLogVOverU=8
MaxLogUOverV=8
OneXBlending=True
GammaCorrectScreenshots=False
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.100000
LODBias=0.000000
DetailTextures=False
DescFlags=0
Description=
HighDetailActors=False
Coronas=False
ShinySurfaces=False
VolumetricLighting=False


if you have a bad pc

Code: Select all
[D3D9Drv.D3D9RenderDevice]
FrameRateLimit=190
UseVSync=False
SwapInterval=0
ZRangeHack=False
NoAATiles=False
NumAASamples=0
UseAA=False
RequestHighResolutionZ=True
UseSoftwareVertexProcessing=False
UsePureDevice=True
UseTripleBuffering=False
MaskedTextureHack=False
SmoothMaskedTextures=False
FrameRateLimit=150
UseVertexProgram=True
TexDXT1ToDXT3=False
DynamicTexIdRecycleLevel=100
CacheStaticMaps=False
UseTexPool=True
UseTexIdPool=True
UseSSE2=True
UseSSE=True
BufferTileQuads=True
BufferClippedActorTris=True
SinglePassDetail=False
SinglePassFog=False
ColorizeDetailTextures=False
DetailClipping=False
UseDetailAlpha=True
DetailMax=0
RefreshRate=0
MaxTMUnits=0
NoFiltering=False
MaxAnisotropy=0
Use565Textures=False
Use16BitTextures=False
UseS3TC=False
UseAlphaPalette=False
UseTrilinear=False
UsePrecache=False
UsePalette=False
UseMultiTexture=True
MaxLogTextureSize=8
MinLogTextureSize=0
MaxLogVOverU=8
MaxLogUOverV=8
OneXBlending=True
GammaCorrectScreenshots=False
GammaOffsetBlue=0.000000
GammaOffsetGreen=0.000000
GammaOffsetRed=0.000000
GammaOffset=0.100000
LODBias=0.000000
DetailTextures=False
DescFlags=0
Description=
HighDetailActors=False
Coronas=False
ShinySurfaces=False
VolumetricLighting=False


Yoy can also use this settings for d3d.
UT99.org
 

Re: mouse accelleration/lag

Postby maximdymok » Mon Oct 31, 2011 1:05 pm

Big thanks dude! That fixed it for me. Game runs at 60 FPS and no mouse lag!!
maximdymok
Experienced
 
Posts: 84
Joined: Mon May 30, 2011 5:28 am

Re: mouse accelleration/lag

Postby Raynor » Mon Oct 31, 2011 9:33 pm

Disable Mouse smoothing, VSync (SwapInterval=0) and enable Direct imput, no need for any additional "fixes".
User avatar
Raynor
Adept
 
Posts: 417
Joined: Sun Jan 27, 2008 5:09 pm

Re: mouse accelleration/lag

Postby Rita G. » Fri Nov 04, 2011 9:10 pm

how does one disable VSync (SwapInterval=0)?
Rita G.
Novice
 
Posts: 7
Joined: Sat Oct 29, 2011 3:25 am

Re: mouse accelleration/lag

Postby >@tack!< » Fri Nov 04, 2011 9:34 pm

I just got a HD monitor/tv and i have this problem too, disabling VSync fixed it but now i get screentearing or w.e. its called, is there no other way :(?
User avatar
>@tack!<
Adept
 
Posts: 338
Joined: Sat Apr 17, 2010 4:51 pm
Personal rank: lol?

Re: mouse accelleration/lag

Postby Rita G. » Fri Nov 04, 2011 10:02 pm

>@tack!< wrote:I just got a HD monitor/tv and i have this problem too, disabling VSync fixed it but now i get screentearing or w.e. its called, is there no other way :(?


how did you disable vsync?
Rita G.
Novice
 
Posts: 7
Joined: Sat Oct 29, 2011 3:25 am

Re: mouse accelleration/lag

Postby >@tack!< » Fri Nov 04, 2011 10:04 pm

Go to your ini and under the renderer you use set swapintervals 0
User avatar
>@tack!<
Adept
 
Posts: 338
Joined: Sat Apr 17, 2010 4:51 pm
Personal rank: lol?

Re: mouse accelleration/lag

Postby Rita G. » Fri Nov 04, 2011 10:45 pm

>@tack!< wrote:Go to your ini and under the renderer you use set swapintervals 0


can someone please explain where this is?
Rita G.
Novice
 
Posts: 7
Joined: Sat Oct 29, 2011 3:25 am

Re: mouse accelleration/lag

Postby UT99.org » Fri Nov 04, 2011 11:04 pm

medor wrote:In render setting
UseVSync=False
SwapInterval=0

For DirectInput it's under
[WinDrv.WindowsClient]
UseDirectInput=False

Easy way try my ini UT http://unrealtournament.99.free.fr/utfi ... Config.rar with hight and warconfig settings (video improved or video minimal)

You can also have the complete UT with set opengl ... http://unrealtournament.99.free.fr/foru ... hp?f=4&t=7
UT99.org
 

Next

Return to General Discussions

Who is online

Users browsing this forum: No registered users and 1 guest