Cross hair problem

Get some cool tips about how to tweak your UT graphic, gameplay, and much more!
Pileyrei
Masterful
Posts: 700
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Cross hair problem

Post by Pileyrei » Mon Jan 16, 2017 5:37 pm

Hi all

I use OpenGL. For some reason I have a white/grey cross next to my cross hair?!
Looks like I have two cross hairs!

Very annoying. Anyone seen this and how to fix please?

Piley

EDIT: Changed cross hairs and its gone?!
So weird. All fine now.

Would be good to know why it happened.
Image

Our Server
Image

[donate][/donate]
Donate to UT99.org!

User avatar
Chamberly
Godlike
Posts: 1723
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA
Contact:

Re: Cross hair problem

Post by Chamberly » Mon Jan 16, 2017 6:12 pm

Are you doing any editing on some things or making some changes?
Image
Image
Image

Pileyrei
Masterful
Posts: 700
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Re: Cross hair problem

Post by Pileyrei » Mon Jan 16, 2017 7:01 pm

No sir!

I'll try to reproduce it again and post a screenie :)
Image

Our Server
Image

[donate][/donate]
Donate to UT99.org!

User avatar
FXANBSS
Skilled
Posts: 228
Joined: Thu Dec 26, 2013 7:03 pm

Re: Cross hair problem

Post by FXANBSS » Mon Jan 16, 2017 8:38 pm

Oh, that extra cross hair... i also use OpenGL and it does appear, mostly it happens when i switch Fullscreen to Windowed mode (and viceversa) and do specific things, sometimes it appears as a mouse pointer if you do it in a different way.

Oh, you cannot take an screenshot of it because it doesn't appear, so i have taken a photo of it with my phone...
Image
Image

User avatar
Chamberly
Godlike
Posts: 1723
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA
Contact:

Re: Cross hair problem

Post by Chamberly » Mon Jan 16, 2017 9:21 pm

Oh that...

I'm sure it have something to do with some kind of settings. I remember swapping some inis and someone had it enabled. I don't know which though.
Image
Image
Image

User avatar
sektor2111
Godlike
Posts: 4108
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: Cross hair problem

Post by sektor2111 » Mon Jan 16, 2017 9:22 pm

Some times at travel between Levels cross-hair is gone and an arrow cursor type shows up or when I'm switching through Windowed and full screen. I'm using to press Escape at travel when arrow is showing up and whatever UWindow is closing and Cross-hair returns, even after a click on UT's Window followed by Escape.

Another times when I switch through apps and UT a double arrow/cursor shows up bugging me, switching multiple times randomly, everything returns to normal, other times I have to stop UT and restart it... Too much I.T. around I'm guessing... :mrgreen:

Pileyrei
Masterful
Posts: 700
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Re: Cross hair problem

Post by Pileyrei » Tue Jan 17, 2017 9:42 am

Yes that's the problem I mean. Not just me then :)

Its annoying and messes with my already poor aim, especially on iCTF PUGS :shock:
Image

Our Server
Image

[donate][/donate]
Donate to UT99.org!

User avatar
rjmno1
Masterful
Posts: 587
Joined: Fri Aug 12, 2011 9:38 pm
Personal rank: masterfull

Re: Cross hair problem

Post by rjmno1 » Wed Jan 18, 2017 12:37 am

Yeah i sometimes have the same problem especialy when i,m going online with internet explorer while i was playing ut99.
Then when i come back i see the mouse pointer when i play ut 99 very chort by the crosshair.
Sometimes i have a double crosshair also.
I think its a bug.
unreal tournament 99
®
Image
Image
ImageImage

User avatar
Chamberly
Godlike
Posts: 1723
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA
Contact:

Re: Cross hair problem

Post by Chamberly » Wed Jan 18, 2017 2:21 am

I'm always F12'ing (Windowed mode/Full screen mode) my game to multi-task... and I don't have any arrow issue so I should find out about this setting and tell you all how to turn it off.

Best thing I can do to probably find it sooner is you to send me your UT.ini so I can compare with mine and find it to turn it off. Delete any sensitive info (pw, client ID #s, etc.) if you want to, I don't bother with these.
Image
Image
Image

User avatar
sektor2111
Godlike
Posts: 4108
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: Cross hair problem

Post by sektor2111 » Wed Jan 18, 2017 8:01 am

My ini is not something that secret (server doesn't run in public all time, so my keys are useless for the rest)... however I believe it depends on Windows OS type display/refresh/drivers config, and UT/Refresh/resolution/etc. By switching screens this way probably not everything works as should and then... little force by switching and ESC-ing seems to solve these issues. Sometimes it shows like a cross when I order "preferences" and/or console with log - has temporary the same effects. For me these are not major issues as long as I don't have annoying crashes breaking me from some party. Editor in exchange is a bitch, If that would be human probably it would be already burned in ass by myself as annoying as it is. A simple wrong mouse move and is crashing, I got reflexes in saving a map at each 15 seconds.

User avatar
papercoffee
Godlike
Posts: 9329
Joined: Wed Jul 15, 2009 11:36 am
Personal rank: coffee addicted !!!
Location: Cologne, the city with the big cathedral.
Contact:

Re: Cross hair problem

Post by papercoffee » Fri Jan 20, 2017 1:51 pm

sektor2111 wrote:I got reflexes in saving a map at each 15 seconds.
And I got the Editor to auto save every 5 minutes (or shorter if needed) :ironic:

User avatar
rjmno1
Masterful
Posts: 587
Joined: Fri Aug 12, 2011 9:38 pm
Personal rank: masterfull

Re: Cross hair problem

Post by rjmno1 » Sun Jan 22, 2017 11:27 pm

mine ut.ini looks like this see atachement.
Attachments
UnrealTournament.rar
unrealtournament.ini
(5.54 KiB) Downloaded 60 times
unreal tournament 99
®
Image
Image
ImageImage

User avatar
sektor2111
Godlike
Posts: 4108
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: Cross hair problem

Post by sektor2111 » Mon Jan 23, 2017 12:14 am

This is useless:
UT.ini wrote: ListFactories[1]=UBrowser.UBrowserGSpyFact,MasterServerAddress=master0.gamespy.com,MasterServerTCPPort=28900,Region=0,GameName=ut
unless you have hacked Hosts file for getting different results. GameSpy is dead, bro... for months... :sleep:
And If I'm not mistaking you need bFallbackFactories=False in order to to not have restored original useless masters if memory doesn't cheat me - check out more info at 333networks etc...
Bah, that's why you cannot see servers all time, you can't count only on Epic, they are using to get some sleep randomly...

User avatar
Chamberly
Godlike
Posts: 1723
Joined: Sat Sep 17, 2011 4:32 pm
Personal rank: Dame. Vandora
Location: TN, USA
Contact:

Re: Cross hair problem

Post by Chamberly » Mon Jan 23, 2017 7:23 am

I see I am now infected by the cross hair problem. Now time to debug. :loool:

Edit:
This is strange. You are using OpenGL and I'm using D3D9. I think something else is infecting the virus of the arrow...

Something might be related but not sure. https://www.reddit.com/r/unrealtourname ... on_screen/
Doesn't make a difference for me.

I wonder if it was a window update that caused this. On a unrelated issue but slightly related, one of the previous Windows update really screwed up the movement in the game whereas you was moving then decided to stop, BUT, your character kept moving and you have to do whatever to spam the keys to stop it and sometimes it doesn't stop. Until the next update came along and fixed that. I think this was back in 2013.
Image
Image
Image

User avatar
OjitroC
Godlike
Posts: 1085
Joined: Sat Sep 12, 2015 8:46 pm

Re: Cross hair problem

Post by OjitroC » Mon Jan 23, 2017 7:27 pm

It's not just a Windows issue - I get it with my Mac when it goes to sleep when UT is full screen though I get the mouse pointer rather than another cross hair - I minimise it (which puts UT into a smaller window) and then maximise it and the cursor/pointer disappears and it's back to normal.

Post Reply