Server wont start

Discussions about Servers
Pileyrei
Masterful
Posts: 745
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Server wont start

Post by Pileyrei »

Hi all

Happy New Year! :rock:

Installed MH2 Gold on a server and now it wont start up:

appError called:
ReadFile beyond EOF 7+1/7
Executing UObject::StaticShutdownAfterError
Signal: SIGIOT [iot trap]
Aborting.
Exiting.
Name subsystem shut down

Removed MH files and it still wont start up.

Hmm. I have a support ticket open with the host but wanted to ask here too in case anyone had seen this problem before.

Piley
Image

Our Server
Image

[donate][/donate]
Donate to UT99.org!
User avatar
Hitman
Adept
Posts: 280
Joined: Mon Aug 16, 2010 11:01 am
Location: Sweden

Re: Server wont start

Post by Hitman »

This is linux i guess so i am clueless, might help if we got the log
Pileyrei
Masterful
Posts: 745
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Re: Server wont start

Post by Pileyrei »

Hi Hitman

Yes its Linux.
We don't have root access so the host adds/removes files.

Below is from the log, the rset of the log has no errors.

This only happened after installing MH2 Gold :(

Init: Unreal engine initialized
Log: Browse: MH-Arden?Name=Flash?Class=BotPack.TMale2?team=1?skin=SoldierSkins.Gard?Face=SoldierSkins.Drake?OverrideClass=?Voice=BotPack.VoiceMaleTwo?game=MonsterHunt.MonsterHunt?mutator=ServerSpam.ServerSpam,MapVoteLA13.BDBMapVote
Log: LoadMap: MH-Arden?Name=Flash?Class=BotPack.TMale2?team=1?skin=SoldierSkins.Gard?Face=SoldierSkins.Drake?OverrideClass=?Voice=BotPack.VoiceMaleTwo?game=MonsterHunt.MonsterHunt?mutator=ServerSpam.ServerSpam,MapVoteLA13.BDBMapVote
Log: Bound to Fire.so
Log: Case-insensitive search: Botpack -> ../System/BotPack.u
Log: Bound to IpDrv.so
Critical: appError called:
Critical: ReadFile beyond EOF 7+1/7
Exit: Executing UObject::StaticShutdownAfterError
Exit: Exiting.
Uninitialized: Name subsystem shut down
Uninitialized: Log file closed, Sun Jan 1 12:24:28 2017
Image

Our Server
Image

[donate][/donate]
Donate to UT99.org!
User avatar
sektor2111
Godlike
Posts: 6397
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: Server wont start

Post by sektor2111 »

Try to upload MH file again. If file went screwed during whatever ftp transfer server will not start ever. Try to not do nothing while you upload files.
User avatar
Barbie
Godlike
Posts: 2770
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: Server wont start

Post by Barbie »

I also guess corrupt files.
Later you may run into the place-holder-files-problem, discussed for example in thread function GetSoundDuration -> SIGSEGV.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett
Pileyrei
Masterful
Posts: 745
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Re: Server wont start

Post by Pileyrei »

Thanks for the replies. I know the files were deleted after the failed install so don't understand why it doesn't start up now.
I'll see what their tech support guys come up with and try uploading the files again as suggested/if necessary.

Thanks for the help :)

EDIT: Bit in bold is now fixed. Missing redirect files.

appError called:
ReadFile beyond EOF 7+1/7
Executing UObject::StaticShutdownAfterError
Signal: SIGIOT [iot trap]

The main error now is:

ReadFile beyond EOF 7+1/7

On other servers the EOF value is different.

I'm at the mercy of tec support from the host.
Image

Our Server
Image

[donate][/donate]
Donate to UT99.org!
Letylove49
Adept
Posts: 277
Joined: Tue Feb 28, 2012 7:47 pm
Location: suisse

Re: Server wont start

Post by Letylove49 »

Hi Pileyrei

Check your setting this must be like that:

ServerActors=MonsterHunt2Gold.LinkActor
ServerActors=MonsterHunt2Gold.ServerAdds
ServerPackages=MonsterHunt
ServerPackages=MonsterHunt2Gold

GameClass="MonsterHunt2Gold.MonsterHunt",

,Mutators="
MonsterHunt2Gold.IP2Country,
MonsterHunt2Gold.Stats,
MonsterHunt2Gold.MH2PlayerLog,
MonsterHunt2Gold.RelicDefense,
MonsterHunt2Gold.RelicSpeed,
MonsterHunt2Gold.RelicStrength,
MonsterHunt2Gold.RelicDeath,
MonsterHunt2Gold.RelicInvulnerable,
MonsterHunt2Gold.RelicRadiation,
MonsterHunt2Gold.ShutUp"
Image



Letylove49 aka Alicia
Aldebaran
Masterful
Posts: 672
Joined: Thu Jan 28, 2016 7:30 pm

Re: Server wont start

Post by Aldebaran »

Pileyrei wrote:ReadFile beyond EOF 7+1/7
Perhaps you have forgotten a sign/apostrophe or something in your config file.
Looks like the syntax in one place there is not ok.

EOF=End of file, the program wants to read more data from it as exists.
User avatar
sektor2111
Godlike
Posts: 6397
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: Server wont start

Post by sektor2111 »

Letylove49 wrote: Check your setting this must be like that
...
ServerPackages=MonsterHunt
ServerPackages=MonsterHunt2Gold
Nope this is NOT a MUST BE, Game-type is being added automated in Packages-Map by Engine and then MonsterHunt.u is being called by map itself, btw... I'm not using any of such file in packages and I run 2 MH games in a single server with no issues at this point.
Secondary note:
If any mutator integrated in Game-Type do needs to be in packages, it will work as well due to main package called by engine.
At this moment I run around 6 custom game-types and none of them is declared in ServerPackages only external needs (skins and audio things).
Pileyrei
Masterful
Posts: 745
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Re: Server wont start

Post by Pileyrei »

Thank you Lety and everyone else for the replies so far, it really helps.

I have checked my ini and the settings are good. Nothing missing.

But I think I found a possible problem, see the bold bit below from the log. The gametype is wrong. Needs to be MonsterHunt2Gold.MonsterHunt.

Log: Log file open, Mon Jan 2 08:06:57 2017
Init: Name subsystem initialized
Init: Version: 440
Init: Compiled: Feb 15 2003 20:40:12
Init: Command line: MH-Arden?game=MonsterHunt.MonsterHunt?mutator=MapVoteLA13.BDBMapVote,ServerSpam.ServerSpam -multihome *IPREMOVED* ini=/usr/local/games/ut-server/System/7960/UnrealTournament.ini log=logs/server.log
Log: Browse: MH-Arden?Name=Flash?Class=BotPack.TMale2?team=1?skin=SoldierSkins.Gard?Face=SoldierSkins.Drake?OverrideClass=?Voice=BotPack.VoiceMaleTwo?game=MonsterHunt.MonsterHunt?mutator=MapVoteLA13.BDBMapVote,ServerSpam.ServerSpam
Log: LoadMap: MH-Arden?Name=Flash?Class=BotPack.TMale2?team=1?skin=SoldierSkins.Gard?Face=SoldierSkins.Drake?OverrideClass=?Voice=BotPack.VoiceMaleTwo?game=MonsterHunt.MonsterHunt?mutator=MapVoteLA13.BDBMapVote,ServerSpam.ServerSpam
Log: Bound to Fire.so
Log: Case-insensitive search: Botpack -> ../System/BotPack.u
Log: Bound to IpDrv.so
Critical: appError called:
Critical: ReadFile beyond EOF 7+1/7
Exit: Executing UObject::StaticShutdownAfterError
Exit: Exiting.
Uninitialized: Name subsystem shut down
Uninitialized: Log file closed, Mon Jan 2 08:07:02 2017

I will ask the host to change as I don't have that access :(

Doesn't explain why the other 15 servers remain down and wont start, even though they removed or MH gold files from them.

Thank you again and please keep your thoughts coming!
Progress!

Piley
Image

Our Server
Image

[donate][/donate]
Donate to UT99.org!
Pileyrei
Masterful
Posts: 745
Joined: Tue May 05, 2009 3:10 pm
Personal rank: UT Survivor

Re: Server wont start

Post by Pileyrei »

Servers all back up again after support removed some the old MH files.

Phew!

Thanks for the help in this thread.
Image

Our Server
Image

[donate][/donate]
Donate to UT99.org!