"Connection Failed" in UT99

Discussions about Servers
Bach
Novice
Posts: 6
Joined: Sun Feb 05, 2017 7:21 am

"Connection Failed" in UT99

Post by Bach »

I have UT99 running on Windows 2000 SP4 inside VirtualBox (virtual machine software) on my Mac. Runs almost perfectly in single player mode with the highest settings (just some slight audio lag I can't get rid of).

I can't join any servers however. Every one I click says "Connection Failed". It'll list all the servers and show how many people are connected to each and it'll log me into the IRC channel, but I can't seem to join multiplayer games. Suggestions?
User avatar
Barbie
Godlike
Posts: 2770
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: "Connection Failed" in UT99

Post by Barbie »

As usual the content of the log file may help. You'll find it in the SYSTEM folder of your UT installation; its name is UnrealTorunament.log.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett
Bach
Novice
Posts: 6
Joined: Sun Feb 05, 2017 7:21 am

Re: "Connection Failed" in UT99

Post by Bach »

Here it is recording me trying a few random different servers.

Code: Select all

Log: Loading: Package UTMenu
Log: Loading: Package LadderSounds
Log: Loading: Package UTServerAdmin
Log: Bound to UWeb.dll
Log: Loading: Package UWeb
Log: Loading: Package IpServer
Log: Loading: Package LadrArrow
ScriptLog: Team 255
ScriptLog: Login: Bach
Log: Loading: Package SoldierSkins
Log: Possessed PlayerPawn: TMale2 CityIntro.TMale0
Init: Input system initialized for WindowsViewport0
Log: Opened viewport
Log: Bound to SoftDrv.dll
Log: Setting 1280x960x16
Log: DirectDraw: Triple buffer, 1280x960, Stride=0
Log: DirectDraw: Rate=0
Log: Bound to Galaxy.dll
Init: Galaxy is using DirectSound
Init: Galaxy initialized
DevAudio: Galaxy SetViewport: WindowsViewport0
Init: Game engine initialized
Log: Startup time: 1.085820 seconds
DevMusic: Load music: Music Uttitle.Uttitle
Log: Loading: Package LadderFonts
Log: URL: Adding default option Name=Bach
Log: URL: Adding default option Class=Botpack.TMale2
Log: URL: Adding default option team=255
Log: URL: Adding default option skin=SoldierSkins.blkt
Log: URL: Adding default option Face=SoldierSkins.Othello
Log: URL: Adding default option Voice=BotPack.VoiceMaleTwo
Log: Browse: Index.unr?entry?Name=Bach?Class=Botpack.TMale2?team=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?Voice=BotPack.VoiceMaleTwo
Log: Failed; returning to Entry
Init: Shut down moving brush tracker for Level CityIntro.MyLevel
Log: Spawning new actor for Viewport WindowsViewport0
ScriptLog: Team 255
ScriptLog: Login: Bach
Log: Possessed PlayerPawn: TMale2 Entry.TMale1
DevAudio: Galaxy SetViewport: WindowsViewport0
ScriptLog: Creating root window: UMenu.UMenuRootWindow
Log: Loading: Package UWindowFonts
Log: Loading: Package utmenu23
DevMusic: Unregister music: Music Uttitle.Uttitle
DevMusic: Load music: Music utmenu23.utmenu23
Log: Loading: Package UTBrowser
Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
Log: Resolving unreal.epicgames.com...
Log: Resolved unreal.epicgames.com (199.255.40.174)
Init: WinSock: I am windows (10.0.2.15)
Log: Resolving unreal.epicgames.com...
Log: Resolved unreal.epicgames.com (199.255.40.174)
Log: Resolving unreal.epicgames.com...
Log: Resolved unreal.epicgames.com (199.255.40.174)
ScriptLog: UBrowserGSpyLink: Master Server is unreal.epicgames.com:28900
Log: Resolving unreal.epicgames.com...
Log: Resolved unreal.epicgames.com (199.255.40.174)
ScriptLog: Timed out in master server protocol.  Waiting for \ in state 4
ScriptLog: Ping Timeout from 213.230.216.2.  Attempt 1
ScriptLog: Ping Timeout from 169.38.68.45.  Attempt 1
ScriptLog: Ping Timeout from 155.133.46.223.  Attempt 1
ScriptLog: Ping Timeout from 145.130.219.44.  Attempt 1
ScriptLog: Ping Timeout from 193.33.176.49.  Attempt 1
ScriptLog: Ping Timeout from 169.38.68.45 Giving Up
ScriptLog: Ping Timeout from 145.130.219.44 Giving Up
Warning: Failed to load 'DM-DieHard': Can't find file for package 'DM-DieHard'
Warning: Failed to load 'Texture DM-DieHard.Screenshot': Can't find file for package 'DM-DieHard'
Log: URL: Adding default option Name=Bach
Log: URL: Adding default option Class=Botpack.TMale2
Log: URL: Adding default option team=255
Log: URL: Adding default option skin=SoldierSkins.blkt
Log: URL: Adding default option Face=SoldierSkins.Othello
Log: URL: Adding default option Voice=BotPack.VoiceMaleTwo
Log: Browse: 195.154.136.56/Index.unr?Name=Bach?Class=Botpack.TMale2?team=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?Voice=BotPack.VoiceMaleTwo
Init: WinSock: Socket queue 32768 / 32768
DevNet: Game client on port 0, rate 20000
DevNet: PendingLevel received: UPGRADE MINVER=400 VER=436
Log: Pending connect to '195.154.136.56/Index.unr?Name=Bach?Class=Botpack.TMale2?team=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?Voice=BotPack.VoiceMaleTwo' failed; Connection failed
NetComeGo: Close TcpipConnection0 02/04/17 22:56:04
Exit: WinSock shut down
Log: Resolving irc.gameslink.net...
Log: Resolved irc.gameslink.net (207.192.72.43)
ScriptLog: UBrowserIRCLink: Server is irc.gameslink.net:6667
Warning: Failed to load 'DM-Deck8][': Can't find file for package 'DM-Deck8]['
Warning: Failed to load 'Texture DM-Deck8][.Screenshot': Can't find file for package 'DM-Deck8]['
Log: URL: Adding default option Name=Bach
Log: URL: Adding default option Class=Botpack.TMale2
Log: URL: Adding default option team=255
Log: URL: Adding default option skin=SoldierSkins.blkt
Log: URL: Adding default option Face=SoldierSkins.Othello
Log: URL: Adding default option Voice=BotPack.VoiceMaleTwo
Log: Browse: 77.163.218.201:7788/Index.unr?Name=Bach?Class=Botpack.TMale2?team=255?skin=SoldierSkins.blkt?Face=SoldierSkins.Othello?Voice=BotPack.VoiceMaleTwo
Init: WinSock: Socket queue 32768 / 32768
DevNet: Game client on port 0, rate 20000
DevNet: PendingLevel received: UPGRADE MINVER=400 VER=436
Log: Pending connect to '77.1
User avatar
Barbie
Godlike
Posts: 2770
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: "Connection Failed" in UT99

Post by Barbie »

Maybe a network problem or a block by server. Can you ping a server from 1) your host OS (Mac) and 2) from your VM (Win2000)? What kind of network connection have you chosen in VirtualBox?
(How to ping)
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett
User avatar
Raynor
Adept
Posts: 426
Joined: Sun Jan 27, 2008 5:09 pm

Re: "Connection Failed" in UT99

Post by Raynor »

Just curious why not use wine to run UT instead. Performance would be better and with complete 3D acceleration package.
Aldebaran
Masterful
Posts: 672
Joined: Thu Jan 28, 2016 7:30 pm

Re: "Connection Failed" in UT99

Post by Aldebaran »

What version of UT99 do you use? Perhaps you have to upgrade to v4.36. You can find it on the right side of menu.
Will the maps (you don't have already) be downloaded before the "Connection failed" appears?
When yes it could be a file permission problem with the cached files or the Cache directory don't work properly.
User avatar
sektor2111
Godlike
Posts: 6397
Joined: Sun May 09, 2010 6:15 pm
Location: On the roof.

Re: "Connection Failed" in UT99

Post by sektor2111 »

For sure there is a Net Configuration problem given logs:

Code: Select all

Timed out in master server protocol.  Waiting for \ in state 4
Like traffic is blocked by a firewall or a wrong configuration
Then

Code: Select all

ScriptLog: Ping Timeout from 213.230.216.2.  Attempt 1
ScriptLog: Ping Timeout from 169.38.68.45.  Attempt 1
ScriptLog: Ping Timeout from 155.133.46.223.  Attempt 1
ScriptLog: Ping Timeout from 145.130.219.44.  Attempt 1
ScriptLog: Ping Timeout from 193.33.176.49.  Attempt 1
more timeouts like connection is "One-Way".
IP "10.0.2.15", eh... some port forwarding might be required...
Bach
Novice
Posts: 6
Joined: Sun Feb 05, 2017 7:21 am

Re: "Connection Failed" in UT99

Post by Bach »

Raynor wrote:Just curious why not use wine to run UT instead. Performance would be better and with complete 3D acceleration package.
So I took your suggestion this morning and installed UT with Wine and it seems to work fine. It even solved my multiplayer issue!

The screen was flickering for some reason so I switched to "software rendering" and the flickering went away.

I knew about Wine but I didn't know it could work with games. I'm not really a gamer. It's been probably 10 years since I've played a game. As a teenager I used to play Unreal and Unreal Tournament a lot and I was feeling nostalgic this week so I decided to try running it again. Using a virtual machine was the first thing that came to mind and apart from the multiplayer issue, it was running decently. The biggest problem I had with Virtual Box was I couldn't run UT on my MacBook Pro's Retina display. It only worked on an external display. Wine works fine on my built in display thankfully.

Thanks!
User avatar
Barbie
Godlike
Posts: 2770
Joined: Fri Sep 25, 2015 9:01 pm
Location: moved without proper hashing

Re: "Connection Failed" in UT99

Post by Barbie »

sektor2111 wrote:IP "10.0.2.15", eh... some port forwarding might be required...
Port forwarding is needed only if new incoming connections should be handled. For outgoing connections (this is the case for an UT client) a router doing NAT automatically sends incoming packets of an established connection to the client that has opened it. Of course the firewall settings of all participated traffic handlers must allow it for that port and protocol.

Maybe his network is doing multiple NAT (router and VirtualBox) - that's why I asked for VirtualBox' network settings.
"Multiple exclamation marks," he went on, shaking his head, "are a sure sign of a diseased mind." --Terry Pratchett
User avatar
Raynor
Adept
Posts: 426
Joined: Sun Jan 27, 2008 5:09 pm

Re: "Connection Failed" in UT99

Post by Raynor »

Bach wrote:
Raynor wrote:Just curious why not use wine to run UT instead. Performance would be better and with complete 3D acceleration package.
So I took your suggestion this morning and installed UT with Wine and it seems to work fine. It even solved my multiplayer issue!

The screen was flickering for some reason so I switched to "software rendering" and the flickering went away.

I knew about Wine but I didn't know it could work with games. I'm not really a gamer. It's been probably 10 years since I've played a game. As a teenager I used to play Unreal and Unreal Tournament a lot and I was feeling nostalgic this week so I decided to try running it again. Using a virtual machine was the first thing that came to mind and apart from the multiplayer issue, it was running decently. The biggest problem I had with Virtual Box was I couldn't run UT on my MacBook Pro's Retina display. It only worked on an external display. Wine works fine on my built in display thankfully.

Thanks!
UT works perfectly under Wine, in fact I get better performance on GNU/Linux than I was getting on Win7 :ironic:
You could try using updated OpenGL renderer, because stock UT renderer is pretty outdated and has problems on modern systems.
Bach
Novice
Posts: 6
Joined: Sun Feb 05, 2017 7:21 am

Re: "Connection Failed" in UT99

Post by Bach »

Raynor wrote: UT works perfectly under Wine, in fact I get better performance on GNU/Linux than I was getting on Win7 :ironic:
You could try using updated OpenGL renderer, because stock UT renderer is pretty outdated and has problems on modern systems.
Got an OpenGl patch for Unreal Gold from here: http://www.unrealtexture.com/Unreal/Web ... OpenGL.htm

Installing it fixed a weird line across my screen and let me run the game in 2560x1600 which I believe is my screen's native resolution. My younger self would be so jealous. Growing up I had to play these games on a Pentium II Gateway machine with Windows 98. I think I could only do 800x600 back then. :shock:
User avatar
EvilGrins
Godlike
Posts: 9630
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: "Connection Failed" in UT99

Post by EvilGrins »

[quote="Raynor"]Just curious why not use wine to run UT instead.[/quote]
Image
Because then all the Skaarj & Nali would be stumbling around drunk.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758