XVehicles (Network play) (VCTF, VMH, Greed for UT99)

Need some nice Mods? Here, you are right!

How you play in XVehicles?

Multiplayer and local play
8
31%
Only Multiplayer
9
35%
Only local play
7
27%
Not play
2
8%
 
Total votes: 26

Buggie
Godlike
Posts: 2784
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

Here example how it work.


You can also try change game language to English and try again.   
Auto merged new post submitted 5 hours 12 minutes later
Here command work on Italian UT as well:

I not found Hungarian among official translations. So I guess you use translation done in destructive way.
This mean your UT broken. Try update UT to latest patch (469d now).
After you can participate in translate project and translate game to Hungarian as well.
Jake19
Average
Posts: 44
Joined: Wed Dec 13, 2017 1:57 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Jake19 »

Buggie wrote: Wed Apr 10, 2024 5:10 am Here example how it work.


You can also try change game language to English and try again.   
Auto merged new post submitted 5 hours 12 minutes later
Here command work on Italian UT as well:

I not found Hungarian among official translations. So I guess you use translation done in destructive way.
This mean your UT broken. Try update UT to latest patch (469d now).
After you can participate in translate project and translate game to Hungarian as well.
UT is also updated to latest version (469d) i already updated everything to latest version, so i don't know what else.

PS: This is where i found and downloaded the hungarian translate http://vkk.hu/magyar_ut/
Buggie
Godlike
Posts: 2784
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

Try use English. Try join to XV server and use here.
Jake19
Average
Posts: 44
Joined: Wed Dec 13, 2017 1:57 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Jake19 »

Buggie wrote: Wed Apr 10, 2024 12:04 pm Try use English. Try join to XV server and use here.
I installed an fresh english version of the game, patched it to the latest 469d version, installed XVehicles latest version, i started practice, entered a map, typed !xv in the chat and nothing happened, i really don't know what the problem is, i have no idea what else to do, is there anything else this mod requires to work?
Buggie
Godlike
Posts: 2784
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

No. It must work. Try enter to server and say "!xv" on it.
unreal://85.214.243.170:7277
Jake19
Average
Posts: 44
Joined: Wed Dec 13, 2017 1:57 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Jake19 »

Buggie wrote: Sun Apr 14, 2024 12:40 am No. It must work. Try enter to server and say "!xv" on it.
unreal://85.214.243.170:7277
It worked on the server, so it's server-only and not for SP?
Buggie
Godlike
Posts: 2784
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

It must work in SP. And it work. i rec videos above in SP (local session - practice mode). And it work for me.
Idk why it not work for you. Look like there exists some difference about your setup.

You can run next commands:
1. Start SP game.
2. Run in console utrace.
3. Say in chat "!xv".
4. Run in console again utrace.
5. Close UT.
6. Add to archive UnrealTornament.log and send to me.

I will try look what happen here and why it not work for you.
You need be really fast for steps 2 3 4, or it produce really huge log file.
Jake19
Average
Posts: 44
Joined: Wed Dec 13, 2017 1:57 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Jake19 »

Buggie wrote: Sun Apr 14, 2024 5:01 pm It must work in SP. And it work. i rec videos above in SP (local session - practice mode). And it work for me.
Idk why it not work for you. Look like there exists some difference about your setup.

You can run next commands:
1. Start SP game.
2. Run in console utrace.
3. Say in chat "!xv".
4. Run in console again utrace.
5. Close UT.
6. Add to archive UnrealTornament.log and send to me.

I will try look what happen here and why it not work for you.
You need be really fast for steps 2 3 4, or it produce really huge log file.
Sent you a PM with the log file.
Buggie
Godlike
Posts: 2784
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

?Game=Botpack.DeathMatchPlus?Mutator=?Name=xxx?Class=BotPack.TMale1?team=255?skin=CommandoSkins.goth?Face=CommandoSkins.Grail?Voice=BotPack.VoiceMaleOne

You not load any mutators. You simple not load any XV stuff. So chat command can't do anything, because XV not loaded.
You need use XV mutators, when you start map. You need press mutators button, and add mutators.
And do this every time or select checkbox "always use this mutators list".
Jake19
Average
Posts: 44
Joined: Wed Dec 13, 2017 1:57 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Jake19 »

Buggie wrote: Sun Apr 14, 2024 7:32 pm ?Game=Botpack.DeathMatchPlus?Mutator=?Name=xxx?Class=BotPack.TMale1?team=255?skin=CommandoSkins.goth?Face=CommandoSkins.Grail?Voice=BotPack.VoiceMaleOne

You not load any mutators. You simple not load any XV stuff. So chat command can't do anything, because XV not loaded.
You need use XV mutators, when you start map. You need press mutators button, and add mutators.
And do this every time or select checkbox "always use this mutators list".
But i used XV mutators with hungarian version, but it didn't worked even then so.
Buggie
Godlike
Posts: 2784
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

You need make logs when you use Mutators. And send to me, if it not work.
Jake19
Average
Posts: 44
Joined: Wed Dec 13, 2017 1:57 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Jake19 »

Buggie wrote: Sun Apr 14, 2024 8:20 pm You need make logs when you use Mutators. And send to me, if it not work.
Sent you another log file with the mutators i used.
Buggie
Godlike
Posts: 2784
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

Try not add XVehiclesHUD into mutator list. Also you not need add both XVehiclesCTF and XVehiclesMH. First need for CTF, second one for MH.
And start play on map with vehicles. DM-Zeto not contain vehicles.
Or summon some, before call chat command.
Jake19
Average
Posts: 44
Joined: Wed Dec 13, 2017 1:57 pm

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Jake19 »

Buggie wrote: Mon Apr 15, 2024 12:02 am Try not add XVehiclesHUD into mutator list. Also you not need add both XVehiclesCTF and XVehiclesMH. First need for CTF, second one for MH.
And start play on map with vehicles. DM-Zeto not contain vehicles.
Or summon some, before call chat command.
It worked, i spawned a manta, after that i typed "!xv" in the chat, and it worked, although manta not fited perfectley in DM-Zeto, but now the command works, i didn't even know that vehicles must be summoned first or a map with vehicles from XVehicles needed and the "!xv" command will only work this way, i had no idea about it.

PS: Is there a way to make it so the command works without vehicles being needed to summon first or without maps that contain vehicles?
Buggie
Godlike
Posts: 2784
Joined: Sat Mar 21, 2020 5:32 am

Re: XVehicles (Network play) (VCTF, VMH for UT99)

Post by Buggie »

Yea. I plan do that for next release.