This is going to sound a little weird...

Search and find cool skins and models, or introduce your own ones!
User avatar
EvilGrins
Godlike
Posts: 9958
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

This is going to sound a little weird...

Post by EvilGrins »

Some models & skins are designed to only be used by players and can't be used by bots. Some are the opposite, but they're much more rare.
Spoiler
EvilGrins wrote: Sun Feb 23, 2014 3:33 am
papercoffee wrote:
Radi wrote:OMG that is sick xD in positive mean ;p hehe Gingerbread looks funny, Im curious what Paper might look as model xD
maybe pretty flatish ...I can provide a model sheet so my Logo/avatar would look like the actual thing. :mrgreen:
I wonder how the straightjacket will look like on a model.
Again, I'm at work so can't confirm it... but I'm pretty sure this is that model · http://www.atomicgamer.com/files/75543/gbm-zip

Gingerbread Man has a weird glitch, it's designed to be used for bots. Everytime i've seen a real person try to use it, the skins on the model don't work. It's just the shape with a bunch of gray all over it.
Other day I pitched "energetic skins" and I posted a screenshot of my using one in the player setup... but the moment I put it on a bot, it defaulted to a the ut99 default skins in the selection window.

Which was weird as when I put it on Sktroopers bots it worked fine.

Anybody seen this kind of thing? Know any ways around it?
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758
User avatar
OjitroC
Godlike
Posts: 3717
Joined: Sat Sep 12, 2015 8:46 pm

Re: This is going to sound a little weird...

Post by OjitroC »

EvilGrins wrote: Thu Jun 13, 2024 2:35 am ..but the moment I put it on a bot, it defaulted to a the ut99 default skins in the selection window.

Which was weird as when I put it on Sktroopers bots it worked fine.
What does the UT log say in both instances?

The GBM is a skeletal model and it may be that there is an error in the code for the skeletal TournamentPlayer - it is certainly different to that for a Bot and this may be the reason why the skin is OK on the latter but not the former.
User avatar
EvilGrins
Godlike
Posts: 9958
Joined: Thu Jun 30, 2011 8:12 pm
Personal rank: God of Fudge
Location: Palo Alto, CA

Re: This is going to sound a little weird...

Post by EvilGrins »

OjitroC wrote: Thu Jun 13, 2024 3:29 pmWhat does the UT log say in both instances?
I wasn't aware it would say anything. Thought it only logged in gameplay, not setting up bots.
http://unreal-games.livejournal.com/
Image
medor wrote:Replace Skaarj with EvilGrins :mrgreen:
Smilies · viewtopic.php?f=8&t=13758
User avatar
OjitroC
Godlike
Posts: 3717
Joined: Sat Sep 12, 2015 8:46 pm

Re: This is going to sound a little weird...

Post by OjitroC »

Much is logged, not just 'events' during games. The Player set up is certainly logged and I would assume the bot set up is also logged.

You may need to remove the 'comment out' for DevLoad if that is suppressed by default (delete the ; at the beginning of the line and save) - search for that in your UnrealTournament.ini. DevLoad will tell you what packages are loaded at every stage from starting up Unreal Tournament onwards.