UT99 Server (web server issue)

Discussions about Servers
darkmenace
Novice
Posts: 4
Joined: Thu Aug 02, 2012 1:03 pm

UT99 Server (web server issue)

Post by darkmenace »

Hi all

I have setup a private UT99 game server for a few friends, it's running on port 9876. Let's assume my internet IP is currently 219.92.254.31. My PC's local LAN ip is 192.168.1.5.

When I enter http://219.92.254.31:9876/ServerAdmin it redirects me to http://192.168.1.5:9876, I get prompted for my login and password I set in UT and can get in to administer the game.

When my friends try to access http://219.92.254.31:9876/ServerAdmin from the internet, it also tries to resolve to 192.168.1.5 but obviously cannot because they are not on my LAN.

I have port 9876 TCP/UDP port forwarded on my router. I have been to a couple of online port scanner sites and checked my ip 219.92.254.31 port 9876 and it says its open, as it should.

This leads me to believe the issue is with my unrealtournament.ini file where the server settings and other game settings are stored. When I fire up UCC.exe one of the lines that comes up is WinSock: I am JT-PC (192.168.1.5). I am wondering whether that line should be saying "Winsock: I am JT-PC (219.92.254.31)" and if so, how I tell UT to run the server on that IP, rather than my LAN ip? Note, people can actually connect to my internet ip to play games, but I want a couple of my friends to be able to admin the game as well through the web interface.

Hope this makes sense. If anyone knows how to make the webserver run on my external IP address, rather than auto detecting my LAN address, please let me know.

Thanks
DM
User avatar
Wises
Godlike
Posts: 1089
Joined: Sun Sep 07, 2008 10:59 am
Personal rank: ...

Re: UT99 Server (web server issue)

Post by Wises »

dragonbe.be wrote: Default port config

7777 UDP/IP: Game port
7778 UDP/IP: Query port
7779 UDP/IP: Query port
7780 UDP/IP: GameSpy query port
7781 UDP/IP: GameSpy query port
27900 TCP/IP: UT Master Server Browser
80 TCP/IP: WebAdmin Graphical User Interface

If your server is behind a router/firewall with NAT enabled, don't forget to set the "ServerName" to your external IP:
[UWeb.WebServer]
ServerName=XXX.XXX.XXX.XXX (e.g. 195.130.132.82)

try also using instead superwebadmin , Default port 5000

Then <yourip>:5000 to access it...

remember to forward all relevant ports;
UT99.org

Re: UT99 Server (web server issue)

Post by UT99.org »

medor wrote:For friend use ip public for connect

and for you the intern ip.
open ut go to the table lan and double clic on the server
darkmenace
Novice
Posts: 4
Joined: Thu Aug 02, 2012 1:03 pm

Re: UT99 Server (web server issue)

Post by darkmenace »

Wises wrote:
dragonbe.be wrote: ServerName=XXX.XXX.XXX.XXX (e.g. 195.130.132.82)
That was the missing line I was looking for. Couldn't find that in any documentation I read online. Thanks man :)